Hi,
> I agree, stubbs were removed.
Thanks.
What is going to be done about the debug infrastructure in the ehea
driver? The entry and exit traces really need to go, and any other debug
you think is important to users needs to go into debugfs or something
similar.
I see a similar issue in the e
Anton Blanchard wrote:
Hi,
--- linux-2.6.18-rc4-orig/drivers/net/ehea/ehea_ethtool.c 1969-12-31
+static void netdev_get_pauseparam(struct net_device *dev,
+ struct ethtool_pauseparam *pauseparam)
+{
+ printk("get pauseparam\n");
+}
Ther
Hi,
> --- linux-2.6.18-rc4-orig/drivers/net/ehea/ehea_ethtool.c 1969-12-31
> +static void netdev_get_pauseparam(struct net_device *dev,
> + struct ethtool_pauseparam *pauseparam)
> +{
> + printk("get pauseparam\n");
> +}
There are a number of stubbed out e
Mikey,
first of all thanks a lot for the effort you invested to review our code.
We're quite happy about the improvements we made due to your comments.
See our answers below.
Kind regards
Thomas
Michael Neuling wrote:
Please add comments to make the code more readable, especially at the
star
Hi,
+#define EHEA_EQE_SM_MECH_NUMBER EHEA_BMASK_IBM(48, 55)
+#define EHEA_EQE_SM_PORT_NUMBER EHEA_BMASK_IBM(56, 63)
+
+struct ehea_eqe {
+ u64 entry;
+};
ehea_ege.. what is that and why a struct if only 1 item? Comments
please.
There are send / receive queue elements (ehea_swqe
On Fri, 11 August 2006 09:28:26 +0200, Thomas Klein wrote:
> Michael Neuling wrote:
> +static inline u32 map_swqe_size(u8 swqe_enc_size)
> +static inline u32|map_rwqe_size(u8 rwqe_enc_size)
> >
> Agreed. Functions were replaced by a single map_wqe_size() function.
Just a general thing, t
Michael Neuling wrote:
+static inline u32 map_swqe_size(u8 swqe_enc_size)
+{
+ return 128 << swqe_enc_size;
+}^
+ |
+static inline u32|map_rwqe_size(u8 rwqe_enc_size)
+{|
+ return 128 << rwqe_enc_size;
> > > +static inline u32 map_swqe_size(u8 swqe_enc_size)
> > > +{
> > > + return 128 << swqe_enc_size;
> > > +} ^
> > > + |
> > > +static inline u32|map_rwqe_size(u8 rwqe_enc_size)
> > > +{ |
> > > + return 128 << rwqe_enc_size;
>
> > +static inline u32 map_swqe_size(u8 swqe_enc_size)
> > +{
> > + return 128 << swqe_enc_size;
> > +}^
> > + |
> > +static inline u32|map_rwqe_size(u8 rwqe_enc_size)
> > +{|
> > + return 128 << rwqe_enc_size;
^
> > +}
Please add comments to make the code more readable, especially at the
start of functions/structures to describe what they do. A large readme
at the start of ehea_main.c which gave an overview of the driver design
would be really useful.
Comments inline below...
> +static void *ipz_qpageit_get_i
Signed-off-by: Jan-Bernd Themann <[EMAIL PROTECTED]>
drivers/net/ehea/ehea_ethtool.c | 325
drivers/net/ehea/ehea_qmr.c | 798
drivers/net/ehea/ehea_qmr.h | 381 +++
3 files changed, 1504 insertions(+)
--- l
Signed-off-by: Jan-Bernd Themann <[EMAIL PROTECTED]>
drivers/net/ehea/ehea_ethtool.c | 325 ++
drivers/net/ehea/ehea_qmr.c | 719
drivers/net/ehea/ehea_qmr.h | 390 +
3 files changed, 1434 insertions(+)
-
12 matches
Mail list logo