On Tue, 2017-04-11 at 20:03 -0400, David Miller wrote:
> > From: Benjamin Herrenschmidt
> Date: Wed, 12 Apr 2017 09:36:05 +1000
>
> > I should call the helper when I don't recognize the protocol type in
> > the IP header, not just when the main skb protocol type is not IP.
>
> That's correct.
>
From: Benjamin Herrenschmidt
Date: Wed, 12 Apr 2017 09:36:05 +1000
> I should call the helper when I don't recognize the protocol type in
> the IP header, not just when the main skb protocol type is not IP.
That's correct.
> BTW. I'm not too familiar with how encapsulation works these days. I
>
On Wed, 2017-04-12 at 08:06 +1000, Benjamin Herrenschmidt wrote:
> On Tue, 2017-04-11 at 11:27 -0400, David Miller wrote:
> > > I'll fix it in a next spin if Dave wants it that way but
> > > otherwise
> > > I'm keen to leave it as it is.
> >
> > Please fix this and respin.
> >
> > Meanwhile get t
On Tue, 2017-04-11 at 11:27 -0400, David Miller wrote:
> > I'll fix it in a next spin if Dave wants it that way but otherwise
> > I'm keen to leave it as it is.
>
> Please fix this and respin.
>
> Meanwhile get the coding style rules changed if you disagree with
> them. A patch series review is
From: Benjamin Herrenschmidt
Date: Tue, 11 Apr 2017 21:13:45 +1000
> On Tue, 2017-04-11 at 13:57 +0300, Sergei Shtylyov wrote:
>> Need {} here as well since the 1st branch has it -- see
>> Documentation/process/coding-style.rst (the end of the section 3).
>
> Adding {} in that specific stat
On Tue, 2017-04-11 at 21:13 +1000, Benjamin Herrenschmidt wrote:
> On Tue, 2017-04-11 at 13:57 +0300, Sergei Shtylyov wrote:
> > Need {} here as well since the 1st branch has it -- see
> > Documentation/process/coding-style.rst (the end of the section 3).
>
> Adding {} in that specific statem
On Tue, 2017-04-11 at 13:57 +0300, Sergei Shtylyov wrote:
> Need {} here as well since the 1st branch has it -- see
> Documentation/process/coding-style.rst (the end of the section 3).
Adding {} in that specific statements just makes things more
cluttered and less readable.
I can find a ton
Hello!
On 4/11/2017 4:04 AM, Benjamin Herrenschmidt wrote:
The documentation describes NETIF_F_IP_CSUM as deprecated
so let's switch to NETIF_F_HW_CSUM and use the helper to
handle unhandled protocols.
Signed-off-by: Benjamin Herrenschmidt
---
drivers/net/ethernet/faraday/ftgmac100.c | 7 +++
The documentation describes NETIF_F_IP_CSUM as deprecated
so let's switch to NETIF_F_HW_CSUM and use the helper to
handle unhandled protocols.
Signed-off-by: Benjamin Herrenschmidt
---
drivers/net/ethernet/faraday/ftgmac100.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --g