Hello james,
Thank you for your review.
I'll check your mails and fix my patch.
James Morris wrote:
On Fri, 13 Jan 2006, Kazunori Miyazawa wrote:
[it's better to send patches inline, so they can be reviewed inline with
proper quoting etc.]
I'm sorry and I agree. But my MUA changes a signl
Hello Herbert,
Thank you for your comments.
Herbert Xu wrote:
On Fri, Jan 13, 2006 at 08:17:49PM +0900, Kazunori Miyazawa wrote:
Anyway this is for 2.6.15. please review and apply it.
Signed-off-by: Kazunori MIYAZAWA <[EMAIL PROTECTED]>
Thanks for the patch Miyazawa-san!
Just a quick tho
Why do you have this magic number for the blocksize, and limit the code to
this value?
int crypto_alloc_xcbc_block(struct crypto_tfm *tfm)
+{
+ struct xcbc_ops *ops;
+
+ BUG_ON(!crypto_tfm_alg_blocksize(tfm));
+ if (crypto_tfm_alg_blocksize(tfm) != 16)
+ return 0;
+
+ ops = (struct xcbc_ops*)kmalloc(sizeof(*ops) +
+ + crypto_tfm_alg_blocksize(tfm), GFP_KERNEL);
+
Don't cast the return of kmalloc().
+void crypto_free_xcbc_block(struct crypto_tfm *tfm)
+{
+ if (tfm->crt_cipher.cit_xcbc_block)
+ kfree(
On Fri, 13 Jan 2006, Kazunori Miyazawa wrote:
[it's better to send patches inline, so they can be reviewed inline with
proper quoting etc.]
+#ifdef CONFIG_CRYPTO_XCBC
+ ret = crypto_alloc_xcbc_block(tfm);
+#endif
}
...
+#ifdef CONFIG_CRYPTO_XCBC
+int crypto_alloc_xcbc_bl
On Fri, Jan 13, 2006 at 08:17:49PM +0900, Kazunori Miyazawa wrote:
>
> Anyway this is for 2.6.15. please review and apply it.
>
> Signed-off-by: Kazunori MIYAZAWA <[EMAIL PROTECTED]>
Thanks for the patch Miyazawa-san!
Just a quick thought: HMAC is a bit of a misfit in the crypto directory.
It's
Hello David and Herbert,
This patch introduces AES-XCBC-MAC.
I will send a glue for IPsec in another mail.
BTW, I could not fix the issue of single space line
so that I attach the patch. My thunderbird erases the line :-<
Anyway this is for 2.6.15. please review and apply it.
Signed-off-by: Ka