[PATCH 14/20] net/ipv4/cipso_ipv4.c: use LIST_HEAD instead of LIST_HEAD_INIT

2007-12-06 Thread Denis Cheng
single list_head variable initialized with LIST_HEAD_INIT could almost always can be replaced with LIST_HEAD declaration, this shrinks the code and looks better. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/ipv4/cipso_ipv4.c |2 +- 1 files changed, 1 insertions(+), 1 del

[PATCH 13/20] net/core/dev.c: use LIST_HEAD instead of LIST_HEAD_INIT

2007-12-06 Thread Denis Cheng
single list_head variable initialized with LIST_HEAD_INIT could almost always can be replaced with LIST_HEAD declaration, this shrinks the code and looks better. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/core/dev.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-)

[PATCH] [net/ipv4]: fib_seq_show function adjustment to get a more sensable output of /proc/net/route

2007-10-22 Thread Denis Cheng
0 0 00FF0 0 0 eth00101A8C000030 0 0 0 0 0 Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/ipv4/fib_hash.c | 15 +++ 1 files changed, 7 insertions(+),

[PATCH 2/2] drivers/net/: all drivers/net/ cleanup with ARRAY_SIZE

2007-09-02 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- drivers/net/apne.c |2 +- drivers/net/arm/am79c961a.c|2 +- drivers/net/atarilance.c |2 +- drivers/net/atl1/atl1_hw.c |2 +- drivers/net/

[PATCH 1/2] net/: all net/ cleanup with ARRAY_SIZE

2007-09-02 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/atm/proc.c |2 +- net/decnet/dn_dev.c |2 +- net/ipv4/af_inet.c |2 +- 3 files changed, 3 insertions(+), 3 deletions(-) diff --git a/net/atm/proc.c b/net/atm/proc.c index 99fc1fe..a3e52ff 100644 --- a/net/atm/proc.c

[PATCH] net/ipv4/af_inet.c: use ARRAY_SIZE macro from kernel.h instead

2007-09-01 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/ipv4/af_inet.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/net/ipv4/af_inet.c b/net/ipv4/af_inet.c index e681034..d5e8b67 100644 --- a/net/ipv4/af_inet.c +++ b/net/ipv4/af_inet.c @@ -939,7 +939,7 @@ static

[PATCH 3/3] netlink: use a statically allocated nl_table instead

2007-09-01 Thread Denis Cheng
if the table is always fixed size with MAX_LINKS entries, why not use a statically allocated table straightforwardly? Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/netlink/af_netlink.c | 11 ++- 1 files changed, 2 insertions(+), 9 deletions(-) diff --git a/net/n

[PATCH 2/3] netlink: the temp variable name max is ambiguous

2007-09-01 Thread Denis Cheng
with the macro max provided by , so changed its name to a more proper one: limit Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/netlink/af_netlink.c | 12 ++-- 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/net/netlink/af_netlink.c b/net/netlink/af_net

[PATCH 1/3] netlink: use the macro min(x,y) provided by instead

2007-09-01 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/netlink/af_netlink.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/net/netlink/af_netlink.c b/net/netlink/af_netlink.c index 5681ce3..8bb14e3 100644 --- a/net/netlink/af_netlink.c +++ b/net/netlink/af_net

[PATCH] netlink: use container_of instead

2007-08-28 Thread Denis Cheng
this could make future redesign of struct netlink_sock easier. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/netlink/af_netlink.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/net/netlink/af_netlink.c b/net/netlink/af_netlink.c index 5681ce3..a78d962

[PATCH] net/sched: mark "NET_CLS_RSVP6 depends on IPV6"

2007-07-31 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/sched/Kconfig |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/net/sched/Kconfig b/net/sched/Kconfig index 8a74cac..5d3749c 100644 --- a/net/sched/Kconfig +++ b/net/sched/Kconfig @@ -300,6 +300,7 @@ config NET_CL

[PATCH 2/2] nbd: change a parameter's type to remove a memcpy call

2007-07-19 Thread Denis Cheng
ransformed accordingly. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- drivers/block/nbd.c |7 ++- 1 files changed, 2 insertions(+), 5 deletions(-) diff --git a/drivers/block/nbd.c b/drivers/block/nbd.c index 86639c0..a4d8508 100644 --- a/drivers/block/nbd.c +++ b/drivers/block/

[PATCH 1/2] nbd: use list_for_each_entry_safe to make it more consolidated and readable

2007-07-19 Thread Denis Cheng
Thus the traverse of the loop may delete nodes, use the safe version. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- drivers/block/nbd.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/block/nbd.c b/drivers/block/nbd.c index c129510..86639c0 100644

[PATCH 2/2] net/core: some functions' definition order adjustment for readability

2007-07-18 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/core/dev.c | 407 1 files changed, 201 insertions(+), 206 deletions(-) diff --git a/net/core/dev.c b/net/core/dev.c index 16842af..ee567dd 100644 --- a/net/core/dev.c +++ b/ne

[PATCH 1/2] net/core: merge the content of dev_mcast.c into dev.c

2007-07-18 Thread Denis Cheng
- removed three function declarations from header file to mark them static, - reduced one file Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- this one is just merging by concatenating, and I'll try to adjust some function definitions' order to make it more readable.

[PATCH] [drivers/net/cxgb3] removed several unneeded zero initilization

2007-07-18 Thread Denis Cheng
Cc: [EMAIL PROTECTED] Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- drivers/net/cxgb3/cxgb3_main.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/net/cxgb3/cxgb3_main.c b/drivers/net/cxgb3/cxgb3_main.c index 6fd1e52..45711f9 100644 --- a/drive

[PATCH 3/3] [net/core] move __dev_addr_discard adjacent to dev_addr_discard for readability

2007-07-17 Thread Denis Cheng
Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/core/dev.c | 28 ++-- 1 files changed, 14 insertions(+), 14 deletions(-) diff --git a/net/core/dev.c b/net/core/dev.c index 17c9cbd..6357f54 100644 --- a/net/core/dev.c +++ b/net/core/dev.c @@ -2715,20 +

[PATCH 1/3] [net/core] move dev_mc_discard from dev_mcast.c to dev.c

2007-07-17 Thread Denis Cheng
), they should merged into one to eliminate duplicates in acquiring and releasing the dev->_xmit_lock, this would be done in my following patch. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- include/linux/netdevice.h |2 -- net/core/dev.c| 14 +-

[PATCH 2/3] [net/core] merge dev_unicast_discard and dev_mc_discard into one

2007-07-17 Thread Denis Cheng
this two functions could share the dev->_xmit_lock acquired context. Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/core/dev.c | 16 1 files changed, 4 insertions(+), 12 deletions(-) diff --git a/net/core/dev.c b/net/core/dev.c index 3ba63aa..17c9cbd 100644

[PATCH] since the definition of dst_discard_in and dst_discard_out are the same,

2007-06-01 Thread Denis Cheng
they should merged into one Signed-off-by: Denis Cheng <[EMAIL PROTECTED]> --- net/core/dst.c | 17 - 1 files changed, 4 insertions(+), 13 deletions(-) diff --git a/net/core/dst.c b/net/core/dst.c index 764bccb..c6a0587 100644 --- a/net/core/dst.c +++ b/net/core