From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 32
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index dd19cf8dbcc1..c312ad4046d
From: Maciej Żenczykowski
(the parameter in question is mark)
Signed-off-by: Maciej Żenczykowski
---
include/net/ip6_route.h | 3 +--
net/ipv6/ndisc.c| 2 +-
net/ipv6/route.c| 4 +---
3 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/include/net/ip6_route.h b/inclu
From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 17 -
1 file changed, 8 insertions(+), 9 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index e50525a95a09..dd19cf8dbcc1 100644
--- a/ne
From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 23 ---
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index c312ad4046d1..be5f7a15bc38 100644
From: Maciej Żenczykowski
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index be5f7a15bc38..6311a7fc5f63 100644
--- a/net/ipv6/route.c
+++ b/net/ipv6/route.c
@@ -4823,7 +4823,7 @@
From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 19 +--
1 file changed, 9 insertions(+), 10 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index d28f83e01593..6f252fa914c2 100644
--- a
From: Maciej Żenczykowski
Signed-off-by: Maciej Żenczykowski
---
net/ipv4/route.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/net/ipv4/route.c b/net/ipv4/route.c
index 02482b71498b..048919713f4e 100644
--- a/net/ipv4/route.c
+++ b/net/ipv4/route.c
@@ -2780,7 +2780,7 @@
From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv4/route.c | 21 +
1 file changed, 9 insertions(+), 12 deletions(-)
diff --git a/net/ipv4/route.c b/net/ipv4/route.c
index dce2ed66ebe1..02482b71498b 100644
---
From: Maciej Żenczykowski
(allows for better compiler optimization)
Signed-off-by: Maciej Żenczykowski
---
net/ipv6/route.c | 17 -
1 file changed, 8 insertions(+), 9 deletions(-)
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
index 6f252fa914c2..dff80697c033 100644
--- a/ne
we can save container_of computation and return dst directly,
since dst is always first member of struct rt6_info
Add a BUILD_BUG_ON() to catch any change that could break this
assertion.
Signed-off-by: Li RongQing
---
include/net/ip6_route.h | 4 +++-
net/ipv6/route.c| 6 +++---
2 file
we can save container_of computation and return dst directly,
since dst is always first member of struct rtable, and any
breaking will be caught by BUILD_BUG_ON in route.h
include/net/route.h:BUILD_BUG_ON(offsetof(struct rtable, dst) != 0);
Signed-off-by: Li RongQing
---
net/core/dst_ca
From: Roopa Prabhu
While at it also add missing text for proxy in the man page.
Signed-off-by: Roopa Prabhu
---
ip/ipneigh.c| 1 +
man/man8/ip-neighbour.8 | 11 ++-
2 files changed, 11 insertions(+), 1 deletion(-)
diff --git a/ip/ipneigh.c b/ip/ipneigh.c
index 5747152..16
Presently, for non-zero copy case, separate pages are allocated for
storing plaintext and encrypted text of records. These pages are stored
in sg_plaintext_data and sg_encrypted_data scatterlists inside record
structure. Further, sg_plaintext_data & sg_encrypted_data are passed
to cryptoapis for re
Hello Daniel, Jon
Thank you very much for review.
>That is a bit of a problem, since Apache v2 is not compatible with GPLv2.
>If the license of the document cannot be changed, I don't think we can
>accept it into the kernel tree.
Thank you for sharing information, Jon. I will check the rst file
On Fri, Sep 28, 2018 at 9:30 AM Vasundhara Volam
wrote:
> This patch adds support for ignore_ari generic permanent mode
> devlink parameter. This parameter is disabled by default. It can be
> enabled using devlink param commands.
>
> ignore_ari - If enabled, device ignores ARI(Alternate Routing ID
The phy_mii_ioctl can be used to write a value into the MII_ADVERTISE
register in the PHY. Since this changes the state of the PHY, we need
to make the same change to phydev->advertising. Add a helper which can
convert the register value to a linkmode.
Signed-off-by: Andrew Lunn
Reviewed-by: Flor
Add a helper to convert the local advertising to an LCL capabilities,
which is then used to resolve pause flow control settings.
Signed-off-by: Andrew Lunn
Reviewed-by: Florian Fainelli
Reviewed-by: Maxime Chevallier
---
drivers/net/dsa/mt7530.c | 6 +-
drivers/net/et
Add helpers which take a linkmode rather than a u32 ethtool for
advertising settings.
Signed-off-by: Andrew Lunn
Reviewed-by: Florian Fainelli
Reviewed-by: Maxime Chevallier
---
include/linux/mii.h | 50 +
1 file changed, 50 insertions(+)
diff --git
Add phydev_info() and make use of it within the phy drivers and core
code.
Signed-off-by: Andrew Lunn
---
drivers/net/phy/dp83640.c| 11 ++-
drivers/net/phy/phy_device.c | 4 ++--
include/linux/phy.h | 3 +++
3 files changed, 11 insertions(+), 7 deletions(-)
diff --git a/
This is one step in allowing phylib to make use of link_mode bitmaps,
instead of u32 for supported and advertised features. Convert the phy
drivers to use bitmaps to indicates the features they support.
Build bitmap equivalents of the u32 values at runtime, and have the
drivers point to the approp
The macro PHY_GBIT_FEAUTRES needs to change into a bitmap in order to
support link_modes. Remove its use from xgde by replacing it with its
definition.
Probably, the current behavior is wrong. It probably should be
ANDing not assigning.
Signed-off-by: Andrew Lunn
---
v2
Remove unneeded ()
---
d
Not all new style LINK_MODE bits can be converted into old style
SUPPORTED bits. We need to warn when such a conversion is attempted.
Add a helper for this.
Convert all pr_warn() calls to phydev_warn() where possible.
Signed-off-by: Andrew Lunn
Reviewed-by: Maxime Chevallier
---
v2:
Make use of
phylink has some useful helpers to working with linkmode bitmaps.
Move them to there own header so other code can use them.
Signed-off-by: Andrew Lunn
Acked-by: Florian Fainelli
Reviewed-by: Maxime Chevallier
---
v2: It was suggested to make include/linux/ethernet-phy and move
some of the heade
These patches contain some further cleanup and helpers, and the first
real patch towards using linkmode bitmaps in phylink.
The macro magic in the RFC version has been replaced with run time
initialisation.
Andrew Lunn (8):
net: phy: Move linkmode helpers to somewhere public
net: phy: Add phy
Fix the patch for the mv88e6xxx.h header file in MAINTAINERS
Reported-by: Joe Perches
Signed-off-by: Andrew Lunn
---
MAINTAINERS | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index 15565de091af..12d1da4a9653 100644
--- a/MAINTAINERS
+++ b/MAINTAIN
From: Hans de Goede
Date: Wed, 26 Sep 2018 22:12:39 +0200
> Disable the clk during suspend to save power. Note that tp->clk may be
> NULL, the clk core functions handle this without problems.
>
> Reviewed-by: Andy Shevchenko
> Tested-by: Carlo Caione
> Signed-off-by: Hans de Goede
Applied.
From: Johannes Berg
Date: Wed, 26 Sep 2018 22:19:42 +0200
> From: Johannes Berg
>
> Fix a simple typo: attribuets -> attributes
>
> Signed-off-by: Johannes Berg
Applied.
From: Shahed Shaikh
Date: Wed, 26 Sep 2018 12:41:10 -0700
> In regular NIC transmission flow, driver always configures MAC using
> Tx queue zero descriptor as a part of MAC learning flow.
> But with multi Tx queue supported NIC, regular transmission can occur on
> any non-zero Tx queue and from t
From: Yifeng Sun
Date: Wed, 26 Sep 2018 11:40:14 -0700
> This patch fixes the bug that all datapath and vport ops are returning
> wrong values (OVS_FLOW_CMD_NEW or OVS_DP_CMD_NEW) in their replies.
>
> Signed-off-by: Yifeng Sun
Applied.
From: Vakul Garg
Date: Wed, 26 Sep 2018 16:22:08 +0530
> Structure 'tls_rec' contains sg_aead_in and sg_aead_out which point
> to a aad_space and then chain scatterlists sg_plaintext_data,
> sg_encrypted_data respectively. Rather than using chained scatterlists
> for plaintext and encrypted data
From: Stefan Schmidt
Date: Fri, 28 Sep 2018 12:20:42 +0200
> An update from ieee802154 for your *net* tree.
>
> Some cleanup patches throughout the drivers from the Huawei tag team
> Yue Haibing and Zhong Jiang.
> Xue is replacing some magic numbers with defines in his mcr20a driver.
Applied, t
From: Yuchung Cheng
Date: Fri, 28 Sep 2018 13:09:02 -0700
> Previously TCP initial receive buffer is ~87KB by default and
> the initial receive window is ~29KB (20 MSS). This patch changes
> the two numbers to 128KB and ~64KB (rounding down to the multiples
> of MSS) respectively. The patch also
From: David Ahern
Add rtnl_addrlbldump_req for address label dumps using the proper
ifaddrlblmsg as the header. Convert existing RTM_GETADDRALBEL dumps
to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/ipaddrlabel.c | 4 ++--
lib/libnetlink.c | 17
From: David Ahern
Add rtnl_routedump_req for route dumps using the proper rtmsg
as the header. Convert existing RTM_GETROUTE dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/ipmroute.c| 2 +-
ip/iproute.c | 4 ++--
lib/libnetlink.c | 16 +++
From: David Ahern
Add rtnl_netconfdump_req for netconf dumps using the proper netconfmsg
as the header. Convert existing RTM_GETNETCONF dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/ipnetconf.c | 3 +--
lib/libnetlink.c | 16
3 fil
From: David Ahern
Add rtnl_mdbdump_req for mdb dumps using the proper br_port_msg as
the header. Convert existing RTM_GETMDB dumps to use it.
Signed-off-by: David Ahern
---
bridge/mdb.c | 2 +-
include/libnetlink.h | 2 ++
lib/libnetlink.c | 17 +
3 files changed,
From: David Ahern
Add rtnl_neightbldump_req for neighbor table dumps using the proper ndtmsg
as the header. Convert existing RTM_GETNEIGHTBL dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/ipntable.c| 2 +-
lib/libnetlink.c | 16
3
From: David Ahern
Add rtnl_neighdump_req for neighbor dumps using the proper ndmsg
as the header. Convert existing rtnl_wilddump_request for RTM_GETNEIGH
to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
lib/libnetlink.c | 16
misc/arpd.c |
From: David Ahern
Add rtnl_ruledump_req for fib fule dumps using the proper fib_rule_hdr
as the header. Convert existing RTM_GETRULE dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/iprule.c | 2 +-
lib/libnetlink.c | 17 +
3 files
From: David Ahern
Add rtnl_addrdump_req for address dumps using the proper ifaddrmsg
as the header. Convert existing RTM_GETADDR dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 4
ip/ipaddress.c | 6 +++---
lib/libnetlink.c | 16
3 files
From: David Ahern
Rename rtnl_wilddump_req_filter to rtnl_linkdump_req_filter,
rtnl_wilddump_request to rtnl_linkdump_request and
rtnl_wilddump_req_filter_fn to rtnl_linkdump_req_filter_fn.
In all cases drop the type argument which at this point is only
RTM_GETLINK and hardcode in the functions.
From: David Ahern
Add rtnl_nsiddump_req for namespace id dumps using the proper rtgenmsg
as the header. Convert existing RTM_GETNSID dumps to use it.
Signed-off-by: David Ahern
---
include/libnetlink.h | 2 ++
ip/ipnetns.c | 2 +-
lib/libnetlink.c | 16
3 files c
From: David Ahern
rtnl_wilddump_stats_req_filter only takes RTM_GETSTATS as the type argument
so rename to rtnl_statsdump_req_filter for consistency with other request
functions and hardcode the type argument.
Signed-off-by: David Ahern
---
bridge/vlan.c| 8 ++--
include/libnetlink
From: David Ahern
iproute2 currently uses ifinfomsg as the header for all dumps using the
wilddump headers. This is wrong as each message type actually has its own
header type. While the kernel has traditionally let it go as it for the
most part only uses the family entry, the use of kernel side
When we use raw socket as the vhost backend, a packet from virito with
gso offloading information, cannot be sent out in later validaton at
xmit path, as we did not set correct skb->protocol which is further used
for looking up the gso function.
To fix this, we set this field according to virito h
As Michal remaind, we should allow to clear ttl inherit. Then we will
have three states:
1. set the flag, and do ttl inherit.
2. do not set the flag, use configured ttl value, or default ttl (0) if
not set.
3. disable ttl inherit, use previous configured ttl value, or default ttl (0).
Fixes: 5
On Sat, Sep 29, 2018 at 01:46:19AM +0200, Michal Kubecek wrote:
> Is it desirable to switch to a flag? If I read geneve_changelink() and
> geneve_nl2info() correctly, it allows you to set the ttl_inherit flag
> for an existing device but doesn't allow you to clear it. With NLA_U8,
> you could disti
On Fri, Sep 28, 2018 at 9:57 AM David Ahern wrote:
>
> On 9/25/18 3:15 PM, Roopa Prabhu wrote:
> > From: Roopa Prabhu
> >
> > Signed-off-by: Roopa Prabhu
> > ---
> > ip/ipneigh.c | 2 ++
> > 1 file changed, 2 insertions(+)
> >
>
> applied to iproute2-next.
>
> And then I noticed you did not upd
> -Original Message-
> From: Stephen Hemminger
> Sent: Saturday, September 29, 2018 8:53 AM
> To: netdev@vger.kernel.org
> Cc: Stephen Hemminger ; Haiyang Zhang
> ; Eric Dumazet
> Subject: [PATCH] hv_netvsc: remove ndo_poll_controller
>
> Similar to other patches from ERic.
>
> As di
Fri, Sep 28, 2018 at 08:28:23AM CEST, vasundhara-v.vo...@broadcom.com wrote:
>This patch adds a new file to add information about configuration
>parameters that are supported by bnxt_en driver via devlink.
>
>Cc: "David S. Miller"
>Cc: Jonathan Corbet
>Cc: linux-...@vger.kernel.org
>Cc: Jiri Pirk
On Sat, 29 Sep 2018 14:52:56 +0200
Stephen Hemminger wrote:
> Similar to other patches from ERic.
>
> As diagnosed by Song Liu, ndo_poll_controller() can
> be very dangerous on loaded hosts, since the cpu
> calling ndo_poll_controller() might steal all NAPI
> contexts (for all RX/TX queues of th
Similar to other patches from ERic.
As diagnosed by Song Liu, ndo_poll_controller() can
be very dangerous on loaded hosts, since the cpu
calling ndo_poll_controller() might steal all NAPI
contexts (for all RX/TX queues of the NIC). This capture
can last for unlimited amount of time, since one
cpu
This patch series adds AF_XDP support socionext netsec driver
In addition the new dma allocation scheme offers a 10% boost on Rx
pps rate using 64b packets
- patch [1/2]: Use a different allocation scheme for Rx DMA buffers to
prepare the driver for AF_XDP support
- patch [2/2]: Add XDP support
Add basic XDP support. The interface only supports 1 Tx queue for now
so locking is introduced on the Tx queue if XDP is enabled to make sure
.ndo_start_xmit and .ndo_xdp_xmit won't corrupt Tx ring
Signed-off-by: Ilias Apalodimas
---
drivers/net/ethernet/socionext/netsec.c | 345
Current driver dynamically allocates an skb and maps it as DMA rx buffer.
A following patch introduces XDP functionality, so we need a
different allocation scheme. Buffers are allocated dynamically and
mapped into hardware. During the Rx operation the driver uses
build_skb() to produce the necessar
The MAINTAINERS file contained the wrong file name of the driver.
Fixes: 14fceff4771e ("net: dsa: Add Lantiq / Intel DSA driver for vrx200")
Reported-by: Joe Perches
Signed-off-by: Hauke Mehrtens
---
MAINTAINERS | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/MAINTAINERS b/M
Hi David Ahern,
On Fri, Sep 28, 2018 at 11:59:37AM -0600, David Ahern wrote:
> On 9/27/18 7:09 PM, Hangbin Liu wrote:
> > Phil pointed out that there is a mismatch between vxlan and geneve ttl
> > inherit. We should define it as a flag and use nla_put_flag to export this
> > opiton.
> >
> > Fixes:
On Sat, Sep 29, 2018 at 01:46:19AM +0200, Michal Kubecek wrote:
> On Fri, Sep 28, 2018 at 09:09:58AM +0800, Hangbin Liu wrote:
> > Phil pointed out that there is a mismatch between vxlan and geneve ttl
> > inherit. We should define it as a flag and use nla_put_flag to export this
> > opiton.
> >
>
On Fri, Sep 28, 2018 at 11:56:10AM -0600, David Ahern wrote:
> On 9/28/18 6:38 AM, Hangbin Liu wrote:
> > On Fri, Sep 28, 2018 at 12:37:00PM +0200, Phil Sutter wrote:
> >> On Fri, Sep 28, 2018 at 09:08:26AM +0800, Hangbin Liu wrote:
> >>> Phil pointed out that there is a mismatch between vxlan and
59 matches
Mail list logo