On 3/11/18 10:03 AM, Colin King wrote:
From: Colin Ian King
Functions rds_info_from_znotifier and rds_message_zcopy_from_user are
local to the source and do not need to be in global scope, so make them
static.
Cleans up sparse warnins:
net/rds/message.c:70:27: warning: symbol 'rds_info_from_zn
On 3/11/18 9:27 AM, Colin King wrote:
From: Colin Ian King
Variable sg_off is assigned a value but it is never read, hence it is
redundant and can be removed.
Cleans up clang warning:
net/rds/message.c:373:2: warning: Value stored to 'sg_off' is never read
Signed-off-by: Colin Ian King
---
On 3/12/2018 4:48 AM, David Miller wrote:
> Ok, queued up.
thank you
hi, I have a question need your help.
I get failure "libbpf: incorrect bpf_call opcode" when running below two
cases on v4.16-rc3:
-
test_l4lb_all();
const char *file2 = "./test_l4lb_noinline.o";
test_xdp_noinline();
-
and from the file test_libbpf.
On Thu, 08 Mar 2018 11:02:29 -0800
Alexander Duyck wrote:
> From: Alexander Duyck
>
> This patch is meant to add some basic functionality to support for SR-IOV
> on devices when the VFs are not managed by some other entity in the device
> other than the kernel.
>
> A new sysfs value called sri
From: Thomas Falcon
Date: Fri, 9 Mar 2018 13:23:56 -0600
> + /* For some backing devices, mishandling of small packets
> + * can result in a loss of connection or TX stall. Device
> + * architects recommend that no packet should be smaller
> + * than the minimum MTU value prov
From: Peng Li
Date: Sat, 10 Mar 2018 11:29:21 +0800
> This patchset fixes some bugs for HNS3 driver:
> [Patch 1/12 - Patch 8/12] fix various bugs for PF driver.
> [Patch 9/12 - Patch 12/12] fix issues when change the us mac address of
> PF/VF device to an existent one in the mac_vlan table.
Seri
From: zhangliping
Date: Fri, 9 Mar 2018 10:08:50 +0800
> From: zhangliping
>
> Max delat_t should be the full_bucket/rate instead of the full_bucket.
> Also report EINVAL if the rate is zero.
>
> Fixes: 96fbc13d7e77 ("openvswitch: Add meter infrastructure")
> Cc: Andy Zhou
> Signed-off-by: z
From: Or Gerlitz
Date: Sun, 11 Mar 2018 11:16:44 +0200
> On 3/7/2018 6:23 PM, David Miller wrote:
>> From: Paul Blakey
>> Date: Wed, 7 Mar 2018 16:00:11 +0200
>>
>>> On our mlx5 driver fs_core.c, we use the rhltable interface to store
>>> flow groups. We noticed that sometimes we get a warning
From: Shannon Nelson
Date: Thu, 8 Mar 2018 16:17:23 -0800
> Adding a macvlan device on top of a lowerdev that supports
> the xfrm offloads fails with a new regression:
> # ip link add link ens1f0 mv0 type macvlan
> RTNETLINK answers: Operation not permitted
>
> Tracing down the failure show
From: Ido Schimmel
Date: Sun, 11 Mar 2018 09:57:21 +0200
> First patch adds a new test for VLAN-unaware bridges.
>
> Next two patches make the tests fail in case they are missing interfaces
> or dependencies.
>
> Last patch allows one to create the veth interfaces even without the
> optional co
On 3/11/18 12:45 AM, Ido Schimmel wrote:
> From: Petr Machata
>
> In order to abstract away access to the
> ipv6.sysctl.multipath_hash_policy variable, which is not available on
> systems compiled without IPv6 support, introduce a wrapper function
> ip6_multipath_hash_policy() that falls back to
On 3/11/18 12:57 AM, Ido Schimmel wrote:
> Some users want to be able to run the tests without a configuration file
> which is useful when one needs to test both virtual and physical
> interfaces on the same machine.
>
> Move the defines that set the type of interface to create and whether to
> cr
On 3/11/18 12:57 AM, Ido Schimmel wrote:
> Returning 0 gives a false sense of success when the required modules did
> not even manage to be initialized and register the required net devices.
>
> Signed-off-by: Ido Schimmel
> Reviewed-by: Jiri Pirko
> ---
> tools/testing/selftests/net/forwarding
On 3/11/18 12:57 AM, Ido Schimmel wrote:
> Similar to the VLAN-aware bridge test, test the VLAN-unaware bridge and
> make sure that ping, FDB learning and flooding work as expected.
>
> Signed-off-by: Ido Schimmel
> Reviewed-by: Jiri Pirko
> ---
> .../net/forwarding/bridge_vlan_unaware.sh
On 3/11/18 12:57 AM, Ido Schimmel wrote:
> We already return an error when some dependencies (e.g., 'jq') are
> missing so lets be consistent and do that for all.
>
> Signed-off-by: Ido Schimmel
> Reviewed-by: Jiri Pirko
> ---
> tools/testing/selftests/net/forwarding/lib.sh | 2 +-
> 1 file cha
On 03/11/2018 08:43 PM, Tobin C. Harding wrote:
The kernel would like to have all stack VLA usage removed[1]. rsi uses
a VLA based on 'blksize'. Elsewhere in the SDIO code maximum block size
is defined using a magic number. We can use a pre-processor defined
constant and declare the array to m
On 3/8/18 7:02 PM, Stephen Hemminger wrote:
> From: Stephen Hemminger
>
> Some more JSON support and report better error if kernel
> is configured without multicast.
>
> Stephen Hemminger (3):
> ipmaddr: json and color support
> ipmroute: convert to output JSON
> ipmroute: better error mes
On 3/7/18 1:40 AM, Serhey Popovych wrote:
> This is main routine to parse ip-link(8) configuration parameters.
>
> Move all code related to command line parsing and validation to it from
> iptables_modify(). As benefit we reduce number of arguments as well as
> checking for most of weired cases in
The kernel would like to have all stack VLA usage removed[1]. rsi uses
a VLA based on 'blksize'. Elsewhere in the SDIO code maximum block size
is defined using a magic number. We can use a pre-processor defined
constant and declare the array to maximum size. We add a check before
accessing the
On 2018/3/10 4:41, Greg Kurz wrote:
> If it was interrupted by a signal, the 9p client may need to send some
> more requests to the server for cleanup before returning to userspace.
>
> To avoid such a last minute request to be interrupted right away, the
> client memorizes if a signal is pending,
On 03/11/2018 05:21 PM, Pablo Neira Ayuso wrote:
On Sun, Mar 11, 2018 at 05:12:09PM -0500, Gustavo A. R. Silva wrote:
Hi Pablo,
On 03/11/2018 05:04 PM, Pablo Neira Ayuso wrote:
On Tue, Mar 06, 2018 at 12:47:55PM -0600, Gustavo A. R. Silva wrote:
In preparation to enabling -Wvla, remove VLA
Hi Pablo,
On 03/11/2018 05:04 PM, Pablo Neira Ayuso wrote:
On Tue, Mar 06, 2018 at 12:47:55PM -0600, Gustavo A. R. Silva wrote:
In preparation to enabling -Wvla, remove VLA and replace it
with dynamic memory allocation.
Looks good but...
Signed-off-by: Gustavo A. R. Silva
---
net/netfilt
On 3/10/2018 10:33 PM, SF Markus Elfring wrote:
From: Markus Elfring
Date: Sat, 10 Mar 2018 22:18:45 +0100
Add a jump target so that a bit of exception handling can be better reused
at the end of this function.
This issue was detected by using the Coccinelle software.
You call this an issue?
On Fri, Mar 09, 2018 at 01:10:30PM -0800, Linus Torvalds wrote:
> On Fri, Mar 9, 2018 at 12:05 PM, Kees Cook wrote:
> > When max() is used in stack array size calculations from literal values
> > (e.g. "char foo[max(sizeof(struct1), sizeof(struct2))]", the compiler
> > thinks this is a dynamic cal
If 'kzalloc' fails, we must free some memory before returning.
Fixes: 67f8b1dcb9ee ("net/mlx4_en: Refactor the XDP forwarding rings scheme")
Signed-off-by: Christophe JAILLET
---
drivers/net/ethernet/mellanox/mlx4/en_netdev.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dr
On Sun, Mar 11, 2018 at 2:34 PM, Eric Biggers wrote:
> On Wed, Feb 14, 2018 at 02:45:05PM +0100, 'Dmitry Vyukov' via syzkaller-bugs
> wrote:
>> On Wed, Dec 6, 2017 at 1:50 PM, Dmitry Vyukov wrote:
>> > On Fri, Oct 27, 2017 at 11:18 PM, Cong Wang
>> > wrote:
>> >> On Thu, Oct 26, 2017 at 11:00
Arushi Singhal wrote:
> On Mon, Mar 12, 2018 at 2:17 AM, Pablo Neira Ayuso
> wrote:
>
> > Hi Joe,
> >
> > On Sun, Mar 11, 2018 at 12:52:41PM -0700, Joe Perches wrote:
> > > On Mon, 2018-03-12 at 01:11 +0530, Arushi Singhal wrote:
> > > > Using pr_() is more concise than
> > > > printk(KERN_).
>
On Mon, Mar 12, 2018 at 03:56:15AM +0530, Arushi Singhal wrote:
> On Mon, Mar 12, 2018 at 2:17 AM, Pablo Neira Ayuso
> wrote:
>
> > Hi Joe,
> >
> > On Sun, Mar 11, 2018 at 12:52:41PM -0700, Joe Perches wrote:
> > > On Mon, 2018-03-12 at 01:11 +0530, Arushi Singhal wrote:
> > > > Using pr_() is mo
On Sun, Mar 11, 2018 at 05:12:09PM -0500, Gustavo A. R. Silva wrote:
> Hi Pablo,
>
> On 03/11/2018 05:04 PM, Pablo Neira Ayuso wrote:
> > On Tue, Mar 06, 2018 at 12:47:55PM -0600, Gustavo A. R. Silva wrote:
> > > In preparation to enabling -Wvla, remove VLA and replace it
> > > with dynamic memory
On Tue, Mar 06, 2018 at 12:47:55PM -0600, Gustavo A. R. Silva wrote:
> In preparation to enabling -Wvla, remove VLA and replace it
> with dynamic memory allocation.
Looks good but...
> Signed-off-by: Gustavo A. R. Silva
> ---
> net/netfilter/nfnetlink_cttimeout.c | 12 ++--
> 1 file cha
On Sat, Mar 10, 2018 at 02:08:43PM +, Luis R. Rodriguez wrote:
> The alternative to this would be a simple equivalent of
> try_then_request_module()
> for UMH modules: try_umhm_then_request_umh_module() or whatever. So just as I
> argued earlier over UMH limitations, this is not the end of the
On Wed, Feb 14, 2018 at 02:45:05PM +0100, 'Dmitry Vyukov' via syzkaller-bugs
wrote:
> On Wed, Dec 6, 2017 at 1:50 PM, Dmitry Vyukov wrote:
> > On Fri, Oct 27, 2017 at 11:18 PM, Cong Wang
> > wrote:
> >> On Thu, Oct 26, 2017 at 11:00 PM, Dmitry Vyukov wrote:
> >>> On Thu, Oct 26, 2017 at 7:58 P
Avoid a VLA[1] by using a real constant expression instead of a variable.
The compiler should be able to optimize the original code and avoid using
an actual VLA. Anyway this change is useful because it will avoid a false
positive with -Wvla, it might also help the compiler generating better
code.
Avoid VLA[1] by using an already allocated buffer passed
by the caller.
[1] https://lkml.org/lkml/2018/3/7/621
Signed-off-by: Salvatore Mesoraca
---
net/rds/connection.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/net/rds/connection.c b/net/rds/connection.c
index f80
Avoid VLA[1] by using an already allocated buffer passed
by the caller.
[1] https://lkml.org/lkml/2018/3/7/621
Signed-off-by: Salvatore Mesoraca
---
net/rds/connection.c | 2 +-
net/rds/ib.c | 3 +++
net/rds/rds.h| 1 +
3 files changed, 5 insertions(+), 1 deletion(-)
diff --git
Also,
Alexei you never answered my questions out aliases with the umh modules.
Long term this important to consider.
Luis
On Fri, Mar 09, 2018 at 12:37:06PM +0200, Kalle Valo wrote:
> "Tobin C. Harding" writes:
>
> > The kernel would like to have all stack VLA usage removed[1]. rsi uses
> > a VLA based on 'blksize'. Elsewhere in the SDIO code maximum block size
> > is defined using a magic number. We can use a pr
Hi Joe,
On Sun, Mar 11, 2018 at 12:52:41PM -0700, Joe Perches wrote:
> On Mon, 2018-03-12 at 01:11 +0530, Arushi Singhal wrote:
> > Using pr_() is more concise than
> > printk(KERN_).
> > Replace printks having a log level with the appropriate
> > pr_*() macros.
> >
> > Signed-off-by: Arushi Sing
On 02/27/2018 02:23 AM, Al Viro wrote:
> On Tue, Feb 27, 2018 at 12:57:21AM +, Al Viro wrote:
>> On Tue, Feb 27, 2018 at 01:41:11AM +0100, Mickaël Salaün wrote:
>>> The function current_nameidata_security(struct inode *) can be used to
>>> retrieve a blob's pointer address tied to the inode be
On Mon, 2018-03-12 at 01:11 +0530, Arushi Singhal wrote:
> Using pr_() is more concise than
> printk(KERN_).
> Replace printks having a log level with the appropriate
> pr_*() macros.
>
> Signed-off-by: Arushi Singhal
> ---
> changes in v2
> *in v1 printk() were replaced with netdev_*()
> net/n
Using pr_() is more concise than
printk(KERN_).
Replace printks having a log level with the appropriate
pr_*() macros.
Signed-off-by: Arushi Singhal
---
changes in v2
*in v1 printk() were replaced with netdev_*()
net/netfilter/nf_conntrack_acct.c | 2 +-
net/netfilter/nf_conntrack_ecache.c
Hi Dave,
I stumbled across a reproducible kernel panic while playing around with
busy_poll on a Linux 4.9.86 kernel. There's an unfortunate interaction
between init_dummy_netdev, which doesn't bother to fill in netdev_ops, and
sk_busy_loop, which assumes netdev_ops is a valid pointer.
To reproduc
init_dummy_netdev() leaves its netdev_ops pointer zeroed. This leads
to a NULL pointer dereference when sk_busy_loop fires against an iwlwifi
wireless adapter and checks napi->dev->netdev_ops->ndo_busy_poll.
Avoid this by ensuring that napi->dev is not a dummy device before
dereferencing napi dev'
On Sun, Mar 11, 2018 at 4:05 AM, Ingo Molnar wrote:
>
> BTW., while I fully agree with everything you said, it's not entirely correct
> to
> claim that if a C compiler can generate VLA code it is necessarily able to
> parse
> and evaluate constant array sizes "just fine".
>
> Constant expression
On (03/11/18 18:03), Colin King wrote:
> From: Colin Ian King
>
> Functions rds_info_from_znotifier and rds_message_zcopy_from_user are
> local to the source and do not need to be in global scope, so make them
> static.
the rds_message_zcopy_from_user warning was already flagged by kbuild-robot
From: Colin Ian King
Functions rds_info_from_znotifier and rds_message_zcopy_from_user are
local to the source and do not need to be in global scope, so make them
static.
Cleans up sparse warnins:
net/rds/message.c:70:27: warning: symbol 'rds_info_from_znotifier' was
not declared. Should it be s
From: Colin Ian King
Functions lan743x_csr_read and lan743x_csr_read are local to the source
and do not need to be in global scope, so make them static.
Cleans up sparse warning:
drivers/net/ethernet/microchip/lan743x_main.c:56:5: warning: symbol
lan743x_csr_read' was not declared. Should it be
On (03/11/18 17:27), Colin King wrote:
> Variable sg_off is assigned a value but it is never read, hence it is
> redundant and can be removed.
>
Acked-by: Sowmini Varadhan
From: Colin Ian King
Function lan743x_phy_init assigns pointer 'netdev' but this is never read
and hence it can be removed. The return error code handling can also be
cleaned up to remove the variable 'ret'.
Function lan743x_phy_link_status_change assigns pointer 'phy' twice and
this is never re
Introduce -X/--exact switch to disable human-friendly printing of
datarates. With the switch, data is not presented as MBps/Kbps.
Changes in v2:
- change variable name into to show_human_readable
Introduce -X/--exact switch to disable human-friendly printing
of datarates. With the switch, data is not presented as MBps/Kbps.
Signed-off-by: Tomasz Torcz
---
misc/ss.c | 12 ++--
1 file changed, 10 insertions(+), 2 deletions(-)
diff --git a/misc/ss.c b/misc/ss.c
index e087bef7.
From: Colin Ian King
Variable sg_off is assigned a value but it is never read, hence it is
redundant and can be removed.
Cleans up clang warning:
net/rds/message.c:373:2: warning: Value stored to 'sg_off' is never read
Signed-off-by: Colin Ian King
---
net/rds/message.c | 2 --
1 file changed
On 06/03/2018 10:16 PM, Sarah Newman wrote:
On 03/06/2018 08:13 AM, Tariq Toukan wrote:
I have a general question about the process.
I don't totally get what branch this patch is targeted to.
It touches critical areas in datapath and should go through regression tests
before it is accepted t
Currently the link state is initialized to "up" when the phy_device is
being created. This is not consistent with the phy state being
initialized to PHY_DOWN.
Usually this doen't do any harm because the link state is updated
once the PHY reaches state PHY_AN. However e.g. if a LAN port isn't
used
* Linus Torvalds wrote:
> So an error message like
>
>warning: ISO C90 requires array sizes to be constant-expressions
>
> would be technically correct and useful from a portability angle. It
> tells you when you're doing something non-portable, and should be
> automatically enabled with "
On 3/7/2018 6:23 PM, David Miller wrote:
> From: Paul Blakey
> Date: Wed, 7 Mar 2018 16:00:11 +0200
>
>> On our mlx5 driver fs_core.c, we use the rhltable interface to store
>> flow groups. We noticed that sometimes we get a warning that flow group isn't
>> found at removal. This rare case was c
57 matches
Mail list logo