On Fri, Feb 10, 2017 at 03:19:53AM -0800, Selvin Xavier wrote:
> Makefile and Kconfig changes for enabling bnxt_re compilation
>
> v3: Adds list of MAINTAINERS of bnxt_re driver. Removes bnxt_re_debugfs.c
> from Makefile as this file is no longer present
>
> Signed-off-by: Devesh Sharma
> Sign
On 2/11/17 9:47 PM, Tejun Heo wrote:
On Fri, Feb 10, 2017 at 08:28:24PM -0800, Alexei Starovoitov wrote:
If BPF_F_ALLOW_OVERRIDE flag is used in BPF_PROG_ATTACH command
to the given cgroup the descendent cgroup will be able to override
effective bpf program that was inherited from this cgroup.
B
On Fri, Feb 10, 2017 at 08:28:24PM -0800, Alexei Starovoitov wrote:
> If BPF_F_ALLOW_OVERRIDE flag is used in BPF_PROG_ATTACH command
> to the given cgroup the descendent cgroup will be able to override
> effective bpf program that was inherited from this cgroup.
> By default it's not passed, there
On Sat, Feb 11, 2017 at 08:37:06PM +0100, Christian Lamparter wrote:
> I think if you follow through with this argument. You have the problem of:
> How to handle EFAULT from skb_copy_datagram_* (and all it's "wrappers")?
>
> Because on one hand, the iovec could be partially bad. I remember that
From: Scott Peterson
This patch reduces the size of struct i40e_rx_buffer by one pointer,
and makes the i40e driver a little more consistent with the igb driver
in terms of packets that span buffers.
We do this by moving the skb field from struct i40e_rx_buffer to
struct i40e_ring. We pass the s
From: Mitch Williams
The function i40e_client_prepare() can never return an error. So make it
void and quit checking its return value.
Change-ID: I9ff311e2324dde329eb68648efb2c94aaff856db
Signed-off-by: Mitch Williams
Tested-by: Andrew Bowers
Signed-off-by: Jeff Kirsher
---
drivers/net/ether
From: Henry Tieman
Ethtool support needs to save more PHY information. The
added information includes FEC capabilities and 25G link
types. Without this change it is possible to lose 25G or
FEC settings by using ethtool.
Change-ID: Ie42255b1e901ffbf9583b8c46466a54894114280
Signed-off-by: Henry Ti
From: Scott Peterson
Reorganize the i40e_pull_tail() logic, doing it in i40e_add_rx_frag()
where it's cheaper. The igb driver does this the same way.
Also renames i40e_page_is_reserved() to reflect what it actually
tests.
Change-ID: Icd9cc507aae1fcdc02308b3a09034111b4c24071
Signed-off-by: Scot
From: Bimmy Pujari
Signed-off-by: Bimmy Pujari
Tested-by: Andrew Bowers
Signed-off-by: Jeff Kirsher
---
drivers/net/ethernet/intel/i40e/i40e_main.c | 2 +-
drivers/net/ethernet/intel/i40evf/i40evf_main.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/et
From: Scott Peterson
On packet RX, we perform a DMA sync for CPU before passing the
packet up. Here we limit that sync to the actual length of the
incoming packet, rather than always syncing the entire buffer.
Change-ID: I626aaf6c37275a8ce9e81efcaa773f327b331487
Signed-off-by: Scott Peterson
T
From: Jacob Keller
The original comment implies that the only location where the raw_packet
buffer will be freed is in i40e_clean_tx_ring() which is incorrect. In
fact this isn't even the normal case. Update the comment explaining
where the memory is freed.
Change-ID: Ie0defc35ed1c3af183f81fdc60
From: Jacob Keller
We can avoid the minor bit of work by calling check params after we
check for the client instance, since we're about to return early in
cases where we do not have a client.
Change-ID: I56f8ea2ba48d4f571fa331c9ace50819a022fa1c
Signed-off-by: Jacob Keller
Tested-by: Andrew Bowe
From: Jacob Keller
The intent of this message was to indicate to a user that we might have
missed a timestamp event for a valid packet. The original method of
detecting the missed events relied on waiting until all 4 registers were
filled.
A recent commit d55458c0cd7a5 ("i40e: replace PTP Rx tim
From: Sudheer Mogilappagari
Currently i40e_bus_info has PCI device and function info only and log
messages print device number as bus number. Added field to provide bus
number info and modified log statements to print bus, device and
function information.
Change-ID: I811617cee2714cc0d6bade8d369f
From: Jacob Keller
Fix a bug where we modified the mac_filter_hash while outside a lock,
when handling addition of broadcast filters.
Normally, we add filters to firmware by batching the additions into
lists and issuing 1 update for every few filters. Broadcast filters are
handled differently, b
From: Henry Tieman
Store the FEC status bits from the link up event into the
hw_link_info structure.
Change-ID: I9a7b256f6dfb0dce89c2f503075d0d383526832e
Signed-off-by: Henry Tieman
Tested-by: Andrew Bowers
Signed-off-by: Jeff Kirsher
---
drivers/net/ethernet/intel/i40e/i40e_common.c | 2 ++
This series contains updates to i40e and i40evf only.
Jake makes a minor change to prevent a minor bit of work, if it is not
necessary. In the case where we do not have a client, there is no need
to check the client params, so move the check till after we have ensured
we have a client. Correct a
From: Mitch Williams
The iWarp client cannot continue until this operation has been completed
by the PF driver. Sleep (with timeout) until the reply from the PF
driver has been received.
Change-ID: I5dc41b857bba32d0218b7ce167b5da122dadf349
Signed-off-by: Mitch Williams
Tested-by: Andrew Bowers
From: Jacob Keller
Refactor how we add new filters to firmware to avoid a race condition
that can occur due to removing filters from the hash temporarily.
To understand the race condition, suppose that you have a number of MAC
filters, but have not yet added any VLANs. Now, add two VLANs in rapi
This patch fixes two trivial whitespace messages (ERROR/WARNING).
Fixes trailing whitespace ERROR and fixes space before tabs WARNING.
Signed-off-by: Tobin C. Harding
---
include/linux/idr.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/idr.h b/include/lin
Current implementation of __dev_alloc_name uses a custom bitmap of
a single page to iterate network device id's and allocate an
unused id. This is seemingly the same task that the IDA does. Also the
current implementation leads to a upper limit of 8 * PAGE_SIZE on the
number of network id's (for ea
Current implementation of __dev_alloc_name uses a custom bitmap of
a single page to iterate network device id's and allocate an unused id.
This leads to a upper limit of 8 * PAGE_SIZE network device id's (for
each name format i.e eth0).
This patch uses the kernel's IDA as a replacement to the page
From: Eric Dumazet
Date: Fri, 10 Feb 2017 10:31:49 -0800
> From: Eric Dumazet
>
> Dmitry reported uses after free in qdisc code [1]
>
> The problem here is that ops->init() can return an error.
>
> qdisc_create_dflt() then call ops->destroy(),
> while qdisc_create() does _not_ call it.
>
> F
From: walter harms
Date: Sat, 11 Feb 2017 11:53:09 +0100
>
>
> Am 11.02.2017 00:01, schrieb Ralf Baechle:
>> When looking at Thomas' mkiss fix 7ba1b6890387 ("NET: mkiss: Fix panic")
>> I noticed that the mkiss SIOCSIFENCAPS ioctl was also doing a slightly
>> strange assignment
>>
>>
From: Ivan Khoronzhuk
Date: Sat, 11 Feb 2017 03:49:57 +0200
> If skb_padto failed the skb has been dropped already, so it was
> consumed, but it doesn't mean it was sent, thus no need to update
> queue tx time, etc. So, return NET_XMIT_DROP as more appropriate.
>
> Signed-off-by: Ivan Khoronzhuk
From: Roopa Prabhu
Date: Fri, 10 Feb 2017 21:38:36 -0800
> From: Roopa Prabhu
>
> This patch drops the vni zero check for COLLECT_METADATA mode.
> It is not really needed, vni zero is a valid vni.
>
> Fixes: 3ad7a4b141eb ("vxlan: support fdb and learning in COLLECT_METADATA
> mode"
> Reported
From: Nathan Fontenot
Date: Fri, 10 Feb 2017 13:45:05 -0500
> Initialize condition variables prior to invoking any work that can
> mark them complete. This resolves a race in the ibmvnic driver where
> the driver faults trying to complete an uninitialized condition
> variable.
>
> Signed-off-by:
From: Nathan Fontenot
Date: Fri, 10 Feb 2017 13:29:06 -0500
> The failure path in ibmvnic_open() mistakenly makes a second call
> to napi_enable instead of calling napi_disable. This can result
> in a BUG_ON for any queues that were enabled in the previous call
> to napi_enable.
>
> Signed-off-b
From: Edward Cree
Date: Fri, 10 Feb 2017 17:34:59 +
> Fixes: a0ee35414837 ("sfc: process RX event inner checksum flags")
> Reported-by: Colin Ian King
> Signed-off-by: Edward Cree
Applied.
From: Stephen Hemminger
Date: Fri, 10 Feb 2017 16:22:08 -0800
> On Fri, 10 Feb 2017 09:38:20 -0800
> Shannon Nelson wrote:
>
>> +static void vsw_get_ethtool_stats(struct net_device *dev,
>> + struct ethtool_stats *estats, u64 *data)
>> +{
>> +int i = 0;
>> +
>>
From: Sainath Grandhi
Date: Fri, 10 Feb 2017 16:03:45 -0800
> Tap character devices can be implemented on other virtual interfaces like
> ipvlan, similar to macvtap. Source code for tap functionality in macvtap
> can be re-used for this purpose.
>
> This patch series splits macvtap source into t
On Sat, Feb 11, 2017 at 8:15 PM, Bruce Fields wrote:
> On Sat, Feb 11, 2017 at 07:31:42AM -0500, Jeff Layton wrote:
>> The basic idea here is that nfsv4 sessions have a "resting state" of 0.
>> We want to keep them around, but if they go "dead" then we we'll tear
>> them down if they aren't active
On Sat, Feb 11, 2017 at 07:31:42AM -0500, Jeff Layton wrote:
> The basic idea here is that nfsv4 sessions have a "resting state" of 0.
> We want to keep them around, but if they go "dead" then we we'll tear
> them down if they aren't actively in use at the time. So, we still free
> the thing when t
Le 02/11/17 à 14:45, Christian Lamparter a écrit :
> Hello,
>
> I'm sorry for the delay.
>
> On Sunday, February 5, 2017 2:44:54 PM CET Florian Fainelli wrote:
>> Le 02/05/17 à 14:25, Christian Lamparter a écrit :
>>> From: Christian Lamparter
>>>
>>> This patch adds glue-code that allows the EM
Hello,
I'm sorry for the delay.
On Sunday, February 5, 2017 2:44:54 PM CET Florian Fainelli wrote:
> Le 02/05/17 à 14:25, Christian Lamparter a écrit :
> > From: Christian Lamparter
> >
> > This patch adds glue-code that allows the EMAC driver to interface
> > with the existing dt-supported PHY
This is needed to force a rebuild of bpf.o when one of its dependencies
(e.g. uapi/linux/bpf.h) is updated.
Add a phony target.
Signed-off-by: Mickaël Salaün
Cc: Alexei Starovoitov
Cc: Daniel Borkmann
Cc: David S. Miller
Cc: Wang Nan
---
tools/testing/selftests/bpf/Makefile | 15 +++
On 10 February 2017 at 21:38, Roopa Prabhu wrote:
> From: Roopa Prabhu
>
> This patch drops the vni zero check for COLLECT_METADATA mode.
> It is not really needed, vni zero is a valid vni.
>
> Fixes: 3ad7a4b141eb ("vxlan: support fdb and learning in COLLECT_METADATA
> mode"
> Reported-by: Joe S
On Friday, February 10, 2017 9:45:13 PM CET Al Viro wrote:
> On Tue, Aug 09, 2016 at 03:58:36PM +0100, Al Viro wrote:
>
> > Actually returning to the original behaviour would be "restore ->msg_iter
> > if we tried skb_copy_and_csum_datagram() and failed for any reason". Which
> > would be bloody
Remove a useless ifdef __NR_bpf as requested by Wang Nan.
Inline one-line static functions as it was in the bpf_sys.h file.
Signed-off-by: Mickaël Salaün
Cc: Alexei Starovoitov
Cc: Daniel Borkmann
Cc: David S. Miller
Cc: Wang Nan
Link: https://lkml.kernel.org/r/828ab1ff-4dcf-53ff-c97b-074adb
The function glock_hash_walk walks the rhashtable by hand. This
is broken because if it catches the hash table in the middle of
a rehash, then it will miss entries.
This patch replaces the manual walk by using the rhashtable walk
interface.
Fixes: 88ffbf3e037e ("GFS2: Use resizable hash table fo
Hi:
v2 -
Added Ack to patch 2.
Fixed RCU annotation in code path executed by rehasher by using
rht_dereference_bucket.
v1 -
This series tackles the problem of table allocation failures during
insertion. The issue is that we cannot vmalloc during insertion.
This series deals with this by introd
On Wed, Feb 08, 2017 at 01:26:42PM -0500, David Miller wrote:
> rhashtable is indeed getting quite complex, but I understand your
> motivation for doing this work.
>
> I also agree that only true OOM situations should cause insertion
> failures.
>
> Given the delicate nature of change rhashtable
This patch adds code that handles GFP_ATOMIC kmalloc failure on
insertion. As we cannot use vmalloc, we solve it by making our
hash table nested. That is, we allocate single pages at each level
and reach our desired table size by nesting them.
When a nested table is created, only a single page i
There are two problems with the function tipc_sk_reinit. Firstly
it's doing a manual walk over an rhashtable. This is broken as
an rhashtable can be resized and if you manually walk over it
during a resize then you may miss entries.
Secondly it's missing memory barriers as previously the code us
On Sat, Feb 11, 2017 at 5:33 AM, Mintz, Yuval wrote:
>> +/**
>> + * struct ethtool_fecparam - Ethernet forward error correction(fec)
>> +parameters
>> + * @cmd: Command number = %ETHTOOL_GFECPARAM or
>> %ETHTOOL_SFECPARAM
>> + * @active_fec: FEC mode which is active on porte
>> + * @fec: Bitmask o
On 02/09/2017 02:12 PM, Julia Lawall wrote:
Remove unneeded semicolon.
Generated by: scripts/coccinelle/misc/semicolon.cocci
CC: Larry Finger
Signed-off-by: Julia Lawall
Signed-off-by: Fengguang Wu
Acked-by: Larry Finger
Thanks,
Larry
---
halbtc8821a2ant.c |2 +-
1 file changed,
On Thu, Feb 9, 2017 at 9:09 PM, Larry Finger wrote:
> On 02/09/2017 01:43 PM, Bjorn Helgaas wrote:
>>
>> [+cc rtl8192ce folks in case they've seen this]
>>
>> On Thu, Feb 09, 2017 at 03:45:01PM +0100, rupert THURNER wrote:
>>>
>>> hi,
>>>
>>> not technical expert enough, i just wanted to give a sh
On 02/11/2017 05:28 AM, Alexei Starovoitov wrote:
If BPF_F_ALLOW_OVERRIDE flag is used in BPF_PROG_ATTACH command
to the given cgroup the descendent cgroup will be able to override
effective bpf program that was inherited from this cgroup.
By default it's not passed, therefore override is disallo
On Sat, 2017-02-11 at 09:01 -0500, David Windsor wrote:
> On Sat, Feb 11, 2017 at 7:31 AM, Jeff Layton wrote:
> > On Sat, 2017-02-11 at 01:42 -0500, David Windsor wrote:
> > >
> > >
> > > > Signed-off-by: David Windsor
> > > > ---
> > > > fs/nfsd/nfs4state.c | 6 +++---
> > > > 1 file changed,
On Sat, Feb 11, 2017 at 7:31 AM, Jeff Layton wrote:
> On Sat, 2017-02-11 at 01:42 -0500, David Windsor wrote:
>>
>>
>> > Signed-off-by: David Windsor
>> > ---
>> > fs/nfsd/nfs4state.c | 6 +++---
>> > 1 file changed, 3 insertions(+), 3 deletions(-)
>> >
>> > diff --git a/fs/nfsd/nfs4state.c b/f
> +/**
> + * struct ethtool_fecparam - Ethernet forward error correction(fec)
> +parameters
> + * @cmd: Command number = %ETHTOOL_GFECPARAM or
> %ETHTOOL_SFECPARAM
> + * @active_fec: FEC mode which is active on porte
> + * @fec: Bitmask of supported/configured FEC modes
> + * @rsvd: Reserved for fu
Hello,
On Fri, 3 Feb 2017, Steffen Klassert wrote:
> On Thu, Feb 02, 2017 at 01:04:34AM +0200, Julian Anastasov wrote:
> >
> > For now I installed common handler, just like
> > xfrm_neigh_lookup. BTW this function has problem from
> > commit f894cbf847c9, it looks like dst is wrongl
On Sat, 2017-02-11 at 01:42 -0500, David Windsor wrote:
>
>
> > Signed-off-by: David Windsor
> > ---
> > fs/nfsd/nfs4state.c | 6 +++---
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> >
> > diff --git a/fs/nfsd/nfs4state.c b/fs/nfsd/nfs4state.c
> > index a0dee8a..b0f3010 100644
> > ---
After the dst->pending_confirm flag was removed, we do not
need anymore to provide dst arg to dst_neigh_output.
So, rename it to neigh_output as before commit 5110effee8fd
("net: Do delayed neigh confirmation.").
Signed-off-by: Julian Anastasov
---
drivers/net/vrf.c | 4 ++--
include/net/
On Sat, Feb 11, 2017 at 09:58:10AM +0100, Richard Cochran wrote:
> If I am not mistaken, then you can skip the cases val==2 and val==3,
> because they are equivalent to val==4 and 6.
I took a stab at this, and you can see the result, below. My version
has lower average error than yours in the int
Am 11.02.2017 00:01, schrieb Ralf Baechle:
> When looking at Thomas' mkiss fix 7ba1b6890387 ("NET: mkiss: Fix panic")
> I noticed that the mkiss SIOCSIFENCAPS ioctl was also doing a slightly
> strange assignment
>
>dev->hard_header_len = AX25_KISS_HEADER_LEN +
>
On Tue, Feb 07, 2017 at 10:43:13PM -0800, Sudarsana Kalluru wrote:
> +/* Adjust the HW clock by a rate given in parts-per-billion (ppb) units.
> + * FW/HW accepts the adjustment value in terms of 3 parameters:
> + * Drift period - adjustment happens once in certain number of nano
> seconds.
> +
57 matches
Mail list logo