HI Netdev team,
Greetings. We have been monitoring the vrf device approach for l3
isolation from cumulus networks and we are currently interested in validating
it. We have following questions on them and hoping to get answers from
you/concerned team.
1. As per the linux documentation,
Hello,
Does anyone can say what's the difference between smc911 and smsc911 ?
On reading the first comments in each file it seems that there is
overlapping between them:
smc911x.c
* This is a driver for SMSC's LAN911{5,6,7,8} single-chip Ethernet devices.
smsc911x.c
===
* Su
From: Pablo Neira Ayuso
Date: Fri, 22 Apr 2016 15:39:31 +0200
> The following patchset contains Netfilter updates for your net-next
> tree, mostly from Florian Westphal to sort out the lack of sufficient
> validation in x_tables and connlabel preparation patches to add
> nf_tables support. They a
On Sat, 2016-04-23 at 20:12 -0400, David Miller wrote:
> Eric, please double check my merge work for net/ipv4/udp.c
>
> In net we fixed a soreuseport bug that added a hlist_nulls_add_tail_rcu()
> call to net/ipv4/udp.c
>
> And in net-next you converted UDP sockets away from nulls lists.
>
> Ther
On Sat, 2016-04-23 at 23:23 +0300, Or Gerlitz wrote:
> On Sat, Apr 23, 2016 at 9:35 PM, Eric Dumazet wrote:
> > From: Eric Dumazet
> >
> > When multiple skb are TX-completed in a row, we might incorrectly keep
> > a timestamp of a prior skb and cause extra work.
> >
> > Fixes: ec693d47010e8 ("net
From: Nicolas Dichtel
Date: Fri, 22 Apr 2016 17:31:15 +0200
> This is the continuation of the work done to align netlink attributes
> when these attributes contain some 64-bit fields.
>
> David, if the third patch is too big (or maybe the series), I can split it.
> Just tell me what you prefer.
Eric, please double check my merge work for net/ipv4/udp.c
In net we fixed a soreuseport bug that added a hlist_nulls_add_tail_rcu()
call to net/ipv4/udp.c
And in net-next you converted UDP sockets away from nulls lists.
Therefore I had to add a hlist_add_tail_rcu() implementation to
linux/rcul
Sat, Apr 23, 2016 at 11:21:45PM IDT, sae...@dev.mellanox.co.il wrote:
>On Sat, Apr 23, 2016 at 7:00 PM, Ido Schimmel wrote:
>> mutt suggests I sent you the following patches a while ago:
>>
>> net/mlx5e: Set port administrative status in ndo_{open, close}
>> net/mlx5e: Initialize port administrati
On Saturday 23 April 2016 23:43:20 Michael Heimpold wrote:
> diff --git a/drivers/net/ethernet/microchip/enc28j60.c
> b/drivers/net/ethernet/microchip/enc28j60.c
> index b723622..49635d7 100644
> --- a/drivers/net/ethernet/microchip/enc28j60.c
> +++ b/drivers/net/ethernet/microchip/enc28j60.c
> @@
macvtap_device_event(NETDEV_UNREGISTER) should check vlan->minor to
determine if it is being invoked in the context of a macvtap_newlink
that failed, for example in this code sequence:
macvtap_newlink
macvlan_common_newlink
register_netdevice
call_netdevice_notifiers(NETDEV_REGISTER, d
If macvlan_common_newlink fails in register_netdevice after macvlan_init
then it decrements port->count twice, first in macvlan_uninit (from
register_netdevice or rollback_registered) and then again in
macvlan_common_newlink.
A similar problem may exist in the ipvlan driver.
This patch consolidates
This series of two patches adds the following improvements to the driver:
1) Rework the central SPI read function so that it is compatible with
SPI masters which only support half duplex transfers.
2) Add a device tree binding for the driver.
Michael Heimpold (2):
net: ethernet: enc28j60: s
The following patch adds the required match table for device tree support
(and while at, fix the indent).
Also add the corresponding binding documentation file.
Signed-off-by: Michael Heimpold
---
.../devicetree/bindings/net/microchip-enc28j60.txt | 49 ++
drivers/net/ethern
The current spi_read_buf function fails on SPI host masters which
are only half-duplex capable. Splitting the Tx and Rx part solves
this issue.
Tested on Raspberry Pi (full duplex) and I2SE Duckbill (half duplex).
Signed-off-by: Michael Heimpold
---
drivers/net/ethernet/microchip/enc28j60.c | 1
On Sun, Apr 24, 2016 at 12:24 AM, Saeed Mahameed
wrote:
> On Sat, Apr 23, 2016 at 11:28 PM, Or Gerlitz wrote:
>> On Sat, Apr 23, 2016 at 11:21 PM, Saeed Mahameed
>> wrote:
>>> On Sat, Apr 23, 2016 at 7:00 PM, Ido Schimmel wrote:
>>
Also, why is this directed at net-next?
>>
>>> it is kind
On Sat, Apr 23, 2016 at 11:28 PM, Or Gerlitz wrote:
> On Sat, Apr 23, 2016 at 11:21 PM, Saeed Mahameed
> wrote:
>> On Sat, Apr 23, 2016 at 7:00 PM, Ido Schimmel wrote:
>
>>> Also, why is this directed at net-next?
>
>> it is kind of new behavior, and not a bug fix.
>
> Saeed,
>
> We should be ai
On Sat, Apr 23, 2016 at 11:21 PM, Saeed Mahameed
wrote:
> On Sat, Apr 23, 2016 at 7:00 PM, Ido Schimmel wrote:
>> Also, why is this directed at net-next?
> it is kind of new behavior, and not a bug fix.
Saeed,
We should be aiming to patch the driver around this issue with
something that goes
On Sat, Apr 23, 2016 at 9:35 PM, Eric Dumazet wrote:
> From: Eric Dumazet
>
> When multiple skb are TX-completed in a row, we might incorrectly keep
> a timestamp of a prior skb and cause extra work.
>
> Fixes: ec693d47010e8 ("net/mlx4_en: Add HW timestamping (TS) support")
> Signed-off-by: Eric
On Sat, Apr 23, 2016 at 7:00 PM, Ido Schimmel wrote:
> mutt suggests I sent you the following patches a while ago:
>
> net/mlx5e: Set port administrative status in ndo_{open, close}
> net/mlx5e: Initialize port administrative status to down
>
> So I'm curious as to why you didn't follow up on them
Add structures for identifiers, locators, and an ila address which
is composed of a locator and identifier and in6_addr can be cast to
it. This includes a three bit type field and enums for the types defined
in ILA I-D.
In ILA lwt don't allow user to set a translation for a non-ILA
address (type o
This patch set updates ILA to support draft-herbert-nvo3-ila-02. The
primary addition is support checksum neutral ILA translation.
This allows address to be performed and still keep any transport
layer checksums that include the addresses in their pseudo header to
still be correct without the trans
Support checksum neutral ILA as described in the ILA draft. The low
order 16 bits of the identifier are used to contain the checksum
adjustment value.
The csum-mode parameter is added to described checksum processing. There
are three values:
- adjust transport checksum (previous behavior)
- do c
Change model of xlat to be used only for input where lookup is done on
the locator part of an address (comparing to locator_match as key
in rhashtable). This is needed for checksum neutral translation
which obfuscates the low order 16 bits of the identifier. It also
permits hosts to be in muliple I
From: Eric Dumazet
When multiple skb are TX-completed in a row, we might incorrectly keep
a timestamp of a prior skb and cause extra work.
Fixes: ec693d47010e8 ("net/mlx4_en: Add HW timestamping (TS) support")
Signed-off-by: Eric Dumazet
Willem de Bruijn
---
drivers/net/ethernet/mellanox/mlx4
Hi,
On 04/23/2016 07:05 PM, Alexander Aring wrote:
...
>
> if this is really needed, then nla_put_u64/be64/etc need to be changed also,
Okay, I found PATCH 3/9 do it for be64, but what's about u64?
- Alex
I was reviewing the H.323 conntrack helper in the kernel when I came
across what appears to be an off-by-one error in the DecodeQ931
function. The MessageType field of the Q931 record is assigned and p
is incremented, but the corresponding decrement to sz is missing,
leading the sz variable to be o
Hi,
On 04/22/2016 06:51 PM, Eric Dumazet wrote:
> On Fri, 2016-04-22 at 17:31 +0200, Nicolas Dichtel wrote:
>> nla_data() is now aligned on a 64-bit area.
>>
>> Signed-off-by: Nicolas Dichtel
>> ---
>> include/net/netlink.h | 8 +---
>> include/net/nl802154.h| 6 ++
>> net/iee
Hi,
Fri, Apr 22, 2016 at 10:00:47PM IDT, sae...@mellanox.com wrote:
>From: Eran Ben Elisha
>
>Disable link up when initializing the HCA. Link up/down will be changed
>using (Ports Administrative and Operational Status Register) PAOS
>commands.
>
>If link layer is Ethernet, up/down the link in ndo
Signed-off-by: Ivan Babrou
---
drivers/net/Kconfig | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/net/Kconfig b/drivers/net/Kconfig
index 2a1ba62b..bd86a23 100644
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
@@ -62,9 +62,8 @@ config DUMMY
this de
This patch added the operation for initing cmd. In addition that,
added some functions for initing eq table and selecting cmd mode
in next stages.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_cmd.c| 92 +
drivers/in
This patch registers IB device and unregister IB device when removed.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_main.c | 48 +++
1 file changed, 48 insertions(+)
diff --git a/drivers/infiniband/hw/hns/hns_roce_main.
This patch mainly added the initial bare main driver. it
could get the relative configure information of net node.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_device.h | 49
drivers/infiniband/hw/hns/hns_roce_main.c | 182
This patch mainly added RoCE engine reset process in RoCE driver.
it is necessary when RoCE was loaded and removed.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_device.h | 7
drivers/infiniband/hw/hns/hns_roce_hw_v1.c | 54 +
The HiSilicon Network Substem is a long term evolution IP which is
supposed to be used in HiSilicon ICT SoCs. HNS (HiSilicon Network
Sybsystem) also has a hardware support of performing RDMA with
RoCEE.
The driver for HiSilicon RoCEE(RoCE Engine) is a platform driver and will
support mulitple versi
This patch was mainly for implemention of memory region.
Memory Registration provides mechanisms that allow Consumers
to describe a set of virtually contiguous memory locations or
a set of physically contiguous memory locations.
MR operations includes as follows:
1. get dma MR in kernel mode
This patch mainly configured some profile resoure. for exmaple,
vendor_id, hardware version, and some data structure sizes so on.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_common.h | 25 +
drivers/infiniband/hw/hns/hns_roce_device.h | 5
This patch was implemention for queue pair operations. QP Consists
of a Send Work Queue and a Receive Work Queue. Send and receive
queues are always created as a pair and remain that way throughout
their lifetime. A Queue Pair is identified by its Queue Pair Number.
QP operations implemention as fo
This patch adds related DTS binding document for HiSilicon RoCE driver.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
.../bindings/infiniband/hisilicon-hns-roce.txt | 107 +
1 file changed, 107 insertions(+)
create mode 100644
Documentation/devicetree/bindi
This patch added the verbs to operate PD. It mainly includes
the functions of allocating PD and deallocating PD.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_device.h | 17
drivers/infiniband/hw/hns/hns_roce_main.c | 8 +++-
drivers/in
This patch mainly initialized the RoCE engine. It is absolutely
necessary to run RoCE function. It mainly includes that configure
DMAE user, init doorbell and raq operations, enable port.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_common.h | 107
This patch mainly set mtu and gid resource. These resource
will be used to set up network transmission in nodes.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_common.h | 16
drivers/infiniband/hw/hns/hns_roce_device.h | 14
drivers/infi
This patch add Kconfig and Makefile for building RoCE module.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/Kconfig | 1 +
drivers/infiniband/hw/Makefile | 1 +
drivers/infiniband/hw/hns/Kconfig | 10 ++
drivers/infiniband/hw/hns/Makefile |
This patch added event queue support for RoCE driver. it is used
for RoCE interrupt. RoCE includes 32 synchronous event irqs, 1
asynchronous event irq and 1 common overflow irq.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_cmd.c| 22 +
driver
This patch mainly added the function module which netif notify
registered the protocol stack. It includes interface functions
as follows:
1. The executive called interface of RoCE when the netlink
event that registered protocol stack was generated
2. The executive called interface of
This patch mainly registered some relative verbs for the kernel.
These operation funtions will be called by user. For example:
1. modify device
2. query device
3. query_port
4. modify_port
and so on.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw
This patch mainly setup hca for RoCE. it will do a series of
initial works as follows:
1. init uar table, allocate uar resource
2. init pd table
3. init cq table
4. init mr table
5. init qp table
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/inf
This patch was implemention for Completion Queue(CQ) operations.
A CQ can be used to multiplex work completions from multiple work
queues across queue pairs on the same HCA. CQ as the notification
mechanism for Work Request completions.
CQ operations implemention as follows:
1. create CQ. CQ ar
This patch mainly added icm support for RoCE. It inits the icm
which managers the relative memory blocks for RoCE. the data
structures of RoCE will be located in it. for example, CQ table,
QP table and MTPT table so on.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniban
This patch added maintainers for RoCE driver.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
MAINTAINERS | 8
1 file changed, 8 insertions(+)
diff --git a/MAINTAINERS b/MAINTAINERS
index 61a323a..cb45b6f 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -10012,6 +10012,14 @@ W:
This patch was for implemention of address handle operation.
It includes three verbs that create ah, query ah and destory
ah. They is completed independently by RoCE driver.
Signed-off-by: Lijun Ou
Signed-off-by: Wei Hu(Xavier)
---
drivers/infiniband/hw/hns/hns_roce_ah.c | 109 +
It added reset function for RoCE driver. RoCE is a feature of hns.
In hip06 SoC, in RoCE reset process, it's needed to configure dsaf
channel reset, port and sl map info. Reset function of RoCE is
located in dsaf module, we only call it in RoCE driver when needed.
Signed-off-by: Lijun Ou
Signed-o
The first argument of pci_free_consistent has type struct pci_dev *, so use
NULL instead of 0.
The semantic patch that performs this transformation is as follows:
(http://coccinelle.lip6.fr/)
//
@@
@@
pci_free_consistent(
- 0
+ NULL
, ...)
//
Signed-off-by: Julia Lawall
---
drivers/net/et
Add the subctrl reset offset for dsaf, this property is used to reset
xge/ge ports for different dsaf. If this attribute is not present,
default value 0 will be used.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
change log:
PATCH v2:
- put DT bindings in separate patches.
PATC
From: Daode Huang
As debug ports are moved from service dsaf to debug dsaf,
the interrupts offset should start from 0, So this patch
re-defines the offset index of debug ports.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
drivers/net/ethernet/hisilicon/hns/hns_dsaf_rcb.c | 8 +--
This patch adds a new dsaf mode named "single-port" mode for debug port.
This mode only contains one debug port. This patch also changes the
method of distinguishing the port type.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
drivers/net/ethernet/hisilicon/hns/hns_ae_adapt.c |
Because debug dsaf port was separated from service dsaf port, this patch
updates the related information of DT binding.
Signed-off-by: Yisen Zhuang
---
.../devicetree/bindings/net/hisilicon-hns-dsaf.txt | 59 ++
1 file changed, 49 insertions(+), 10 deletions(-)
diff --git a
The reset offset for each port in a dsaf is different. The current code is
not so readability. This patch adds configuration named port-rst-offset to
make the code simple and more readability. If this attribute doesn't exist,
default value of this attribute is equal to its port index.
Signed-off-b
From: Daode Huang
This patch tunes the header file by the alphabetical order.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
drivers/net/ethernet/hisilicon/hns/hns_dsaf_mac.c | 12 ++--
drivers/net/ethernet/hisilicon/hns/hns_dsaf_main.c | 12 ++--
drivers/net/ethe
Because debug dsaf port was separated from service dsaf port, this patch
updates the related configurations of hns dts, changes it to match with
the new binding files. This also removes enet nodes which don't exist in
d02 board.
Signed-off-by: Yisen Zhuang
---
arch/arm64/boot/dts/hisilicon/hip05
This patch adds description for port-idx-in-ae attribute.
Signed-off-by: Yisen Zhuang
---
.../devicetree/bindings/net/hisilicon-hns-nic.txt | 30 +-
1 file changed, 29 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/net/hisilicon-hns-nic.txt
b/D
There are two kinds of dsaf device in hns, one is for service ports,
contains crossbar in it, can work under different mode. Another is for
debug port, only can work under single port mode. The current code only
declares a dsaf device for both service ports and debug ports.It is not so
readability.
This patch parse port-idx-in-ae in enet node. In NIC mode of DSAF, all 6
PHYs of service DSAF are taken as ethernet ports to the CPU. The
port-idx-in-ae can be 0 to 5. Here is the diagram:
+-+---+
|CPU |
+-+-+-+---+-+-+-+-+-+-+
There are two kinds of dsaf device in hns, one is for service ports,
contains crossbar in it, can work under different mode. Another is for
debug port, only can work under "single-port" mode. The current code only
declared a dsaf device for both service ports and debug ports. This patch
separate it
This patch adds attribute cpld_ctrl for dsaf port node, parses the syscon
for mac_cb from dts, and changes the method of access the cpld related
registers through syscon.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
change log:
PATCH v2:
- put DT bindings in separate patches.
This patch provides the read/write function for dsaf to
access the registers through syscon methods.
Signed-off-by: Daode Huang
Signed-off-by: Yisen Zhuang
---
drivers/net/ethernet/hisilicon/hns/hns_dsaf_reg.h | 14 ++
1 file changed, 14 insertions(+)
diff --git a/drivers/net/ether
Port mode offset for each dsaf port is different. The current code is not
so readability. This patch adds configuration named port-mode-offset to
make the code simple and more readability. If port-mode-offset isn't
exists, default value 0 will be used.
Signed-off-by: Daode Huang
Signed-off-by: Yi
66 matches
Mail list logo