Re: ESFQ (or SFQ updates) mainline status?

2008-01-19 Thread Stephen Hemminger
On Fri, 04 Jan 2008 11:21:15 -0800 Jeff Gustafson <[EMAIL PROTECTED]> wrote: > Hi all, > I have a question about the status of the spiffy updates to SFQ. I > *really* like the ESFQ idea. I appears to be exactly what I'm looking > for. From what I can tell from this mailing list, SFQ is ge

Re: [Bugme-new] [Bug 9778] New: unregister_netdevice: waiting for [device] to become free

2008-01-19 Thread Andrew Morton
On Sat, 19 Jan 2008 12:20:28 -0800 (PST) [EMAIL PROTECTED] wrote: > http://bugzilla.kernel.org/show_bug.cgi?id=9778 > >Summary: unregister_netdevice: waiting for [device] to become > free >Product: Networking >Version: 2.5 > KernelVersi

Re: [PATCH] [IrDA] af_irda memory leak fixes

2008-01-19 Thread Jesper Juhl
On 18/01/2008, Samuel Ortiz <[EMAIL PROTECTED]> wrote: > Hi Dave, > > Here goes an IrDA patch against your latest net-2.6 tree. > > This patch fixes some af_irda memory leaks. > It also checks for irias_new_obect() return value. > > Signed-off-by: Jesper Juhl <[EMAIL PROTECTED]> > Signed-off-by: Sa

[PATCH 12/14] Move usbnet.h and rndis_host.h to include/linux/usb

2008-01-19 Thread Jussi Kivilinna
Move headers usbnet.h and rndis_host.h to include/linux/usb and fix includes for drivers/net/usb modules. Headers are moved because rndis_wext will be outside drivers/net/usb in drivers/net/wireless and yet need these headers. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/us

[PATCH 13/14] [rndis_host] blacklist known wireless RNDIS devices

2008-01-19 Thread Jussi Kivilinna
Blacklist known wireless RNDIS devices that will be handled by rndis_wext module. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 104 ++ 1 files changed, 104 insertions(+), 0 deletions(-) diff --git a/drivers/net/us

[PATCH 11/14] [rndis_host] Add rndis_link_change function pointer to 'struct rndis_data'.

2008-01-19 Thread Jussi Kivilinna
Callback to signal link state changes to rndis_wext. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 24 drivers/net/usb/usbnet.h |3 +++ 2 files changed, 23 insertions(+), 4 deletions(-) diff --git a/drivers/net/usb/rndis

[PATCH 10/14] [rndis_host] Add rndis_early_init function pointer to 'struct rndis_data'.

2008-01-19 Thread Jussi Kivilinna
Function pointer is for rndis minidrivers that need to do work on device right after RNDIS_INIT. For example setting device specific configuration parameters with OID_GEN_RNDIS_CONFIG_PARAMETER. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c |6 ++ dr

[PATCH 09/14] [usbnet] add driver_priv pointer to 'struct usbnet'

2008-01-19 Thread Jussi Kivilinna
Add a private data pointer to usbnet for rndis_wext module to use. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/usbnet.h |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/drivers/net/usb/usbnet.h b/drivers/net/usb/usbnet.h index 29ab92e..0b4bf09 1

[PATCH 07/14] [rndis_host] Split up rndis_host.c

2008-01-19 Thread Jussi Kivilinna
Split up rndis_host.c into rndis_host.h and rndis_base.c. This is done so that rndis_wext can reuse common parts with rndis_host. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 223 -- drivers/net/usb/rndis_host.h | 248

[PATCH 08/14] [rndis_host] export functions

2008-01-19 Thread Jussi Kivilinna
Export rndis_host functions and also rename rndis_bind() to generic_rndis_bind() for modules using rndis_host as base. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 20 +--- drivers/net/usb/rndis_host.h |9 + 2 files changed,

[PATCH 05/14] [rndis_host] Fix rndis packet filter flags.

2008-01-19 Thread Jussi Kivilinna
RNDIS packet filter flags are not exactly the same as CDC flags so we cannot reuse them. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> Signed-off-by: Bjorge Dijkstra <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 23 ++- 1 files changed, 22 insertions(+), 1 del

[PATCH 06/14] [usbnet] Use wlan device name for RNDIS wireless devices

2008-01-19 Thread Jussi Kivilinna
Use wlan device name for RNDIS wireless devices. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> Signed-off-by: Bjorge Dijkstra <[EMAIL PROTECTED]> --- drivers/net/usb/usbnet.c |3 +++ drivers/net/usb/usbnet.h |2 ++ 2 files changed, 5 insertions(+), 0 deletions(-) diff --git a/drive

[PATCH 02/14] [cdc_ether] Hardwire CDC descriptors when missing

2008-01-19 Thread Jussi Kivilinna
From: Bjorge Dijkstra <[EMAIL PROTECTED]> Just as ActiveSync devices, some regular RNDIS devices also lack the CDC descriptors (e.g. devices based on BCM4320 WLAN chip). This patch hardwires the CDC descriptors for all RNDIS style devices when they are missing. Signed-off-by: Bjorge Dijkstra <[EM

[PATCH 03/14] [rndis_host] Use 1KB buffer in rndis_unbind

2008-01-19 Thread Jussi Kivilinna
rndis_command requires the caller to pass in a buffer of at least 1KB. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> Signed-off-by: Bjorge Dijkstra <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/net/usb/

[PATCH 04/14] [rndis_host] Halt device if rndis_bind fails.

2008-01-19 Thread Jussi Kivilinna
When bind fails after device was initialized, shutdown device properly by sending RNDIS_MSG_HALT. Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> Signed-off-by: Bjorge Dijkstra <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c | 12 +--- 1 files changed, 9 insertions(+), 3 deleti

[PATCH 00/14] RFC: Driver for Wireless RNDIS USB devices.

2008-01-19 Thread Jussi Kivilinna
Hello, This is second try on wireless RNDIS patchset started by Bjorge Dijkstra. Since Bjorge has disappeared, I claim maintainership of rndis_wext and this patchset until he returns. This patchset adds support for various 802.11 USB devices based on Broadcom 4320 chip. Chip uses RNDIS to communi

[PATCH 01/14] Fix sparse warning: returning void-valued expression

2008-01-19 Thread Jussi Kivilinna
From: Bjorge Dijkstra <[EMAIL PROTECTED]> rndis_unbind and usbnet_cdc_unbind don't return anything. Signed-off-by: Bjorge Dijkstra <[EMAIL PROTECTED]> Signed-off-by: Jussi Kivilinna <[EMAIL PROTECTED]> --- drivers/net/usb/rndis_host.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-)

Re: Packetlost when "tc qdisc del dev eth0 root"

2008-01-19 Thread Jarek Poplawski
Patrick McHardy wrote, On 01/16/2008 06:12 AM: > [EMAIL PROTECTED] wrote: >> Good night! =) >> >> Sorry... i was wrong... >> I see that problem more serious >> >> Lets see to scheme >> >> Class 1 >> ---qdisc >> --- 10k classes >> Class 2 >> ---qdisc >> --- 10k classes >> >> All traffic

Re: [PATCH] mv643xx_eth: fix byte order when checksum offload is enabled

2008-01-19 Thread Dale Farnsworth
OK, after digesting Al Viro's comments on this, I agree with him and retract this. These multiple byte swaps sure are confusing. Byron, would you please resubmit? Thanks, -Dale On Sat, Jan 19, 2008 at 01:23:01PM -0700, Dale Farnsworth wrote: > From: Byron Bradley <[EMAIL PROTECTED]> > > The Ma

Re: [PATCH net-2.6.25] [XFRM] Remove unneeded export of xfrm_output_resume() and remove its declaration from net/xfrm.h.

2008-01-19 Thread Herbert Xu
Rami Rosen <[EMAIL PROTECTED]> wrote: > > The method xfrm_output_resume() is used only in net/xfrm/xfrm_output.c. > > This patch removes using unneeded EXPORT_SYMBOL_GPL to export it in > net/xfrm/xfrm_output.c and also removes its declaration in net/xfrm.h. This will be used ESP. Cheers, -- V

[PATCH] mv643xx_eth: fix byte order when checksum offload is enabled

2008-01-19 Thread Dale Farnsworth
From: Byron Bradley <[EMAIL PROTECTED]> The Marvell Orion system on chips have an integrated mv643xx MAC. On these little endian ARM devices mv643xx will oops when checksum offload is enabled. Swapping the byte order of the protocol and checksum solves this problem. Signed-off-by: Byron Bradley <

Re: [PATCH] mv643xx: fix byte order when checksum offload is enabled

2008-01-19 Thread Al Viro
On Sat, Jan 19, 2008 at 07:27:38PM +, Byron Bradley wrote: > case IPPROTO_UDP: > cmd_sts |= ETH_UDP_FRAME; > - desc->l4i_chk = udp_hdr(skb)->check; > + desc->l4i_chk = htons(udp_hdr(skb)->check); >

[PATCH] mv643xx: fix byte order when checksum offload is enabled

2008-01-19 Thread Byron Bradley
The Marvell Orion system on chips have an integrated mv643xx MAC. On these little endian ARM devices mv643xx will oops when checksum offload is enabled. Swapping the byte order of the protocol and checksum solves this problem. Signed-off-by: Byron Bradley <[EMAIL PROTECTED]> Cc: Dale Farnsworth <[

Re: [Bugme-new] [Bug 9773] New: pptp/ppp connection die at high speed on Athlon X2 6000+

2008-01-19 Thread Jarek Poplawski
Andrew Morton wrote, On 01/18/2008 08:48 AM: > On Thu, 17 Jan 2008 23:33:54 -0800 (PST) [EMAIL PROTECTED] wrote: > >> http://bugzilla.kernel.org/show_bug.cgi?id=9773 >> >>Summary: pptp/ppp connection die at high speed on Athlon X2 6000+ >>Product: Networking >>

Re: [PATCH] IPv4: Enable use of 240/4 address space

2008-01-19 Thread YOSHIFUJI Hideaki / 吉藤英明
In article <[EMAIL PROTECTED]> (at Sat, 19 Jan 2008 14:44:13 +0100 (CET)), Jan Engelhardt <[EMAIL PROTECTED]> says: > From 84bccef295aa9754ee662191e32ba1d64edce2ba Mon Sep 17 00:00:00 2001 > From: Jan Engelhardt <[EMAIL PROTECTED]> > Date: Fri, 18 Jan 2008 02:10:44 +0100 > Subject: [PATCH] IPv4:

Re: [PATCH][NEIGH] Fix race between neigh_parms_release and neightbl_fill_parms

2008-01-19 Thread Andrey Rahmatullin
This patch causes messages like 'unregister_netdevice: waiting for ppp0 to become free. Usage count = 1' when I try 'ifdown ppp0'. This happens in all kernel versions containing this commit and doesn't happen in 2.6.24-rc8 with this commit reverted. -- WBR, wRAR (ALT Linux Team) signature.asc D

Re: [PATCH] IPv4: Enable use of 240/4 address space

2008-01-19 Thread Jan Engelhardt
On Jan 18 2008 11:13, YOSHIFUJI Hideaki / 吉藤英明 wrote: >> -static inline bool ipv4_is_badclass(__be32 addr) >> +static inline bool ipv4_is_broadcast(__be32 addr) >> { > >I'm just afraid that people might think ipv4_is_broadcast >is for testing subnet broadcast address. > >255.255.255.255 is "limit

Re: [2.6 patch] atm/suni.c: fix section mismatch

2008-01-19 Thread Sam Ravnborg
On Sat, Jan 19, 2008 at 03:18:51PM +0200, Adrian Bunk wrote: > EXPORT_SYMBOL'ed code mustn't be __*init. > > Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> Acked-by: Sam Ravnborg <[EMAIL PROTECTED]> > > --- > --- linux-2.6/drivers/atm/suni.c.old 2008-01-19 12:16:41.0 +0200 > +++ linux-2.

Re: [2.6 patch] atm/idt77105.c: fix section mismatch

2008-01-19 Thread Sam Ravnborg
On Sat, Jan 19, 2008 at 03:18:49PM +0200, Adrian Bunk wrote: > EXPORT_SYMBOL'ed code mustn't be __*init. > > Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> Acked-by: Sam Ravnborg <[EMAIL PROTECTED]> > > --- > --- linux-2.6/drivers/atm/idt77105.c.old 2008-01-19 11:19:53.0 > +0200 > +

[2.6 patch] atm/idt77105.c: fix section mismatch

2008-01-19 Thread Adrian Bunk
EXPORT_SYMBOL'ed code mustn't be __*init. Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> --- --- linux-2.6/drivers/atm/idt77105.c.old2008-01-19 11:19:53.0 +0200 +++ linux-2.6/drivers/atm/idt77105.c2008-01-19 11:20:10.0 +0200 @@ -354,13 +354,13 @@ static const struct a

[2.6 patch] atm/suni.c: fix section mismatch

2008-01-19 Thread Adrian Bunk
EXPORT_SYMBOL'ed code mustn't be __*init. Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]> --- --- linux-2.6/drivers/atm/suni.c.old2008-01-19 12:16:41.0 +0200 +++ linux-2.6/drivers/atm/suni.c2008-01-19 12:17:23.0 +0200 @@ -275,35 +275,35 @@ static int suni_stop(struct at

[PATCH net-2.6.25] [XFRM] Remove unneeded export of xfrm_output_resume() and remove its declaration from net/xfrm.h.

2008-01-19 Thread Rami Rosen
Hi, The method xfrm_output_resume() is used only in net/xfrm/xfrm_output.c. This patch removes using unneeded EXPORT_SYMBOL_GPL to export it in net/xfrm/xfrm_output.c and also removes its declaration in net/xfrm.h. Regards, Rami Rosen Signed-off-by: Rami Rosen <[EMAIL PROTECTED]> diff --git a/

Re: [PATCH] [IPV6] ROUTE: Make sending algorithm more friendly with RFC 4861.

2008-01-19 Thread David Miller
From: YOSHIFUJI Hideaki / 吉藤英明 <[EMAIL PROTECTED]> Date: Sat, 19 Jan 2008 02:00:30 +0900 (JST) > We omit (or delay) sending NSes for known-to-unreachable routers > (in NUD_FAILED state) according to RFC 4191 (Default Router Preferences > and More-Specific Routes). > But this is not fully compatibl

Re: [PATCH 0/4] [IrDA] IrDA fixes for net-2.6.25

2008-01-19 Thread David Miller
From: [EMAIL PROTECTED] Date: Sat, 19 Jan 2008 01:02:05 +0100 > Here goes a batch of 4 IrDA patches against your latest net-2.6.25 tree. All 4 patches applied, thanks Sam. You might want to consider submitting those first two patches for 2.6.24 as they look like pure fixes. -- To unsubscribe fro