From: James Chapman <[EMAIL PROTECTED]>
Date: Sat, 05 Jan 2008 00:18:31 +
> David Miller wrote:
> > From: James Chapman <[EMAIL PROTECTED]>
> > Date: Fri, 04 Jan 2008 20:10:30 +
> >
> >> With the latest NAPI, this code has to change. But rather than remove
> >> the tx_cleaned logic comple
Hi
In few words: i have problem with bridge, that if some MAC address is not
known, even expired by age bridge will send packet as "flood".
If i am not wrong
in br_device.c
int br_dev_xmit(struct sk_buff *skb, struct net_device *dev)
...
if (dest[0] & 1)
br_flood_deliver(b
On 2008.01.05 07:10:02 +0100, Björn Steinbrink wrote:
> - nv_probe sees 00:11:22:00:00:01
> - doesn't match the vendor stuff
> - becomes 01:00:00:22:11:00
>
> Oops, that's not quite the expected thing.
Haha, I just noticed that that even is a multicast address, so you'd get
a random MAC address i
On 2008.01.04 23:43:52 +0100, Andreas Mohr wrote:
> On Fri, Jan 04, 2008 at 11:17:40AM +0100, Björn Steinbrink wrote:
> > On 2008.01.04 09:45:17 +0100, Andreas Mohr wrote:
> > > And then it needs these card I/O functions wrapped into two
> > > functions which interface with driver- and OS-related M
Roland Dreier wrote:
Any objection to merging the following for 2.6.25?
[Rolf -- I think it makes more sense to delete the overwriting of the
P_Key in ipoib_multicast.c in this patch rather than later in the
series; do you agree?]
Yes, the first patch is the logical place for it. The only r
David Miller wrote:
> From: James Chapman <[EMAIL PROTECTED]>
> Date: Fri, 04 Jan 2008 20:10:30 +
>
>> With the latest NAPI, this code has to change. But rather than remove
>> the tx_cleaned logic completely, shouldn't transmit processing be
>> included in the work_done accounting when a drive
On Fri, Jan 04, 2008 at 04:21:26PM +0100, Torsten Kaiser wrote:
> On Jan 4, 2008 2:30 PM, Jarek Poplawski <[EMAIL PROTECTED]> wrote:
...
> I'm open for any suggestions and will try to answer any questions.
I'm very glad, thanks!
> The only thing that is sadly not practical is bisecting the borken
On Fri, Jan 04, 2008 at 11:17:40AM +0100, Björn Steinbrink wrote:
> On 2008.01.04 09:45:17 +0100, Andreas Mohr wrote:
> > And then it needs these card I/O functions wrapped into two functions which
> > interface with driver- and OS-related MAC variables
> > (struct variables ALWAYS stored in usual
On Friday 04 January 2008 4:09:02 pm David Miller wrote:
> From: Paul Moore <[EMAIL PROTECTED]>
> Date: Fri, 4 Jan 2008 09:38:27 -0500
>
> > Unfortunately, it's not quite that easy at present. The only field
> > we have in the skb where we could possibly set a flag is the
> > secmark field which i
For cards that initially have the MAC address stored in reverse order,
the forcedeth driver uses a flag to signal whether the address was
already corrected, so that it is not reversed again on a subsequent
probe.
Unfortunately this flag, which is stored in a register of the card,
seems to get lost
Any objection to merging the following for 2.6.25?
[Rolf -- I think it makes more sense to delete the overwriting of the
P_Key in ipoib_multicast.c in this patch rather than later in the
series; do you agree?]
Thanks,
Roland
From: Rolf Manderscheid <[EMAIL PROTECTED]>
An IPoIB subnet on an I
On Wed, 2007-11-14 at 15:31 -0800, David Miller wrote:
> From: Ulrich Drepper <[EMAIL PROTECTED]>
> Date: Wed, 14 Nov 2007 12:59:52 -0800
>
> > Just FYI, with the current getaddrinfo code it is even more critical to
> > get to a point where I can cache network interface information and query
> >
David Miller wrote:
> Several Intel networking drivers such as e1000, e1000e
> and e100 all do this to exit NAPI polling:
>
> if ((!tx_cleaned && (work_done == 0)) ||
> !netif_running(poll_dev)) {
>
> I tried to make this use in the NAPI rework:
>
> if ((!tx_cleaned && (work
if an interrupt occurs too soon, the driver oops while trying to handle
a shortage of buffers condition (caused by no buffers having been
allocated yet).
commit a3322d3d34854edf27f7950efaa93e68f5f71ace
Author: Chas Williams - CONTRACTOR <[EMAIL PROTECTED]>
Date: Fri Jan 4 16:27:07 2008 -0500
On Jan 4, 2008 4:21 PM, Torsten Kaiser <[EMAIL PROTECTED]> wrote:
> On Jan 4, 2008 2:30 PM, Jarek Poplawski <[EMAIL PROTECTED]> wrote:
> > - above git-nfsd and git-net tests should be probably repeated with
> > -rc6-mm1 git versions: so vanilla rc6 plus both these -mm patches
> > only, and if bug t
From: James Chapman <[EMAIL PROTECTED]>
Date: Fri, 04 Jan 2008 20:10:30 +
> With the latest NAPI, this code has to change. But rather than remove
> the tx_cleaned logic completely, shouldn't transmit processing be
> included in the work_done accounting when a driver does transmit cleanup
> pro
From: Paul Moore <[EMAIL PROTECTED]>
Date: Fri, 4 Jan 2008 09:38:27 -0500
> Unfortunately, it's not quite that easy at present. The only field we
> have in the skb where we could possibly set a flag is the secmark field
> which is already taken.
Herbert Xu added a "peeked" field in net-2.6.25
Badalian Vyacheslav wrote:
> Hello all.
> Some time in dmesg i see this:
>
> [16121.400422] e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang
> [16121.400426] Tx Queue <0>
> [16121.400427] TDH <28>
> [16121.400429] TDT <28>
> [16121.400430]
Hi all,
I have a question about the status of the spiffy updates to SFQ. I
*really* like the ESFQ idea. I appears to be exactly what I'm looking
for. From what I can tell from this mailing list, SFQ is getting some
or all of the ESFQ features. Although the ESFQ web site gives detailed
i
Some recent changes completely removed accounting for the FORWARD_TSN
parameter length in the INIT and INIT-ACK chunk. This is wrong and
should be restored.
Signed-off-by: Vlad Yasevich <[EMAIL PROTECTED]>
---
net/sctp/sm_make_chunk.c |6 ++
1 files changed, 6 insertions(+), 0 deletions(
When processing an unexpected INIT chunk, we do not need to
do any preservation of the old AUTH parameters. In fact,
doing such preservations will nullify AUTH and allow connection
stealing.
Signed-off-by: Vlad Yasevich <[EMAIL PROTECTED]>
---
net/sctp/sm_statefuns.c | 22 -
The even should be called SCTP_AUTHENTICATION_INDICATION.
Signed-off-by: Vlad Yasevich <[EMAIL PROTECTED]>
---
include/net/sctp/user.h |2 +-
net/sctp/ulpevent.c |2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/net/sctp/user.h b/include/net/sctp/user.h
ind
Hi David
The following 3 paches address some issues with the AUTH implementation.
These are for 2.6.24.
Thanks
-vlad
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/majordomo-info.ht
Hello,
This comes from the Linus latest linux-2.6 tree. Randomly happened.
Can't reproduce that. More info below.
Unable to handle kernel paging request at virtual address be286000
tsk->{mm,active_mm}->context = 0eae
tsk->{mm,active_mm}->pgd = f800be0e4000
On Jan 4, 2008 2:30 PM, Jarek Poplawski <[EMAIL PROTECTED]> wrote:
> On 04-01-2008 11:23, Torsten Kaiser wrote:
> > On Jan 2, 2008 10:51 PM, Herbert Xu <[EMAIL PROTECTED]> wrote:
> >> On Wed, Jan 02, 2008 at 07:29:59PM +0100, Torsten Kaiser wrote:
> >>> Vanilla 2.6.24-rc6 seems stable. I did not se
On Thursday 03 January 2008 11:45:49 pm David Miller wrote:
> From: Paul Moore <[EMAIL PROTECTED]>
> Date: Thu, 03 Jan 2008 12:25:39 -0500
>
> > Add an inet_sys_snd_skb() LSM hook to allow the LSM to provide
> > packet level access control for all outbound packets. Using the
> > existing postroute
On Fri, Jan 04, 2008 at 03:58:31AM -0800, David Miller wrote:
> From: Nick Piggin <[EMAIL PROTECTED]>
> Date: Fri, 4 Jan 2008 12:33:52 +0100
>
> > Just for interest, the lockless pagecache actually makes
> > page->_count unstable for all pages that _have ever_ been pagecache
> > pages (since the l
On 04-01-2008 11:23, Torsten Kaiser wrote:
> On Jan 2, 2008 10:51 PM, Herbert Xu <[EMAIL PROTECTED]> wrote:
>> On Wed, Jan 02, 2008 at 07:29:59PM +0100, Torsten Kaiser wrote:
>>> Vanilla 2.6.24-rc6 seems stable. I did not see any crash or warnings.
>> OK that's great. The next step would be to try
Hi Chris,
> I have surprisingly managed to track down the USB device descriptor for the
> wired Belkin network
> adapter, and it looks as if the device class is actually 0x00 instead of
> 0xFF. I originally used
> 0xFF because that is what my 3com device used (for some reason) and so I was
> ho
Hello all.
Some time in dmesg i see this:
[16121.400422] e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang
[16121.400426] Tx Queue <0>
[16121.400427] TDH <28>
[16121.400429] TDT <28>
[16121.400430] next_to_use <28>
[16121.400431]
From: Nick Piggin <[EMAIL PROTECTED]>
Date: Fri, 4 Jan 2008 12:33:52 +0100
> Just for interest, the lockless pagecache actually makes
> page->_count unstable for all pages that _have ever_ been pagecache
> pages (since the last quiescent rcu state, anyway). Basically, it
> looks up and takes a ref
Several Intel networking drivers such as e1000, e1000e
and e100 all do this to exit NAPI polling:
if ((!tx_cleaned && (work_done == 0)) ||
!netif_running(poll_dev)) {
I tried to make this use in the NAPI rework:
if ((!tx_cleaned && (work_done < budget)) ||
On Thu, Jan 03, 2008 at 07:32:45PM -0800, David Miller wrote:
>
> Nick, I think the following changeset:
>
> commit fa4f0774d7c6cccb4d1fda76b91dd8eddcb2dd6a
>
> [CASSINI]: dont touch page_count
>
> Remove page refcount manipulations from cassini driver by using
> another fie
All the sysctl concerning the routes are moved to the network namespace
structure. A helper function is called to initialize the variables.
Because the ipv6 protocol is not yet per namespace, the variables are
accessed relatively from the network namespace.
Signed-off-by: Daniel Lezcano <[EMAIL P
The mld_max_msf protects the system with a maximum allowed multicast
source filters. Making this variable per namespace can be potentially
an problem if someone inside a namespace set it to a big value, that
will impact the whole system including other namespaces.
I don't see any benefits to have
This patch moves the icmpv6_time sysctl to the network namespace
structure. A small initialization helper function has been added.
Because the ipv6 protocol is not yet per namespace, the variable is
accessed relatively to the initial network namespace.
Signed-off-by: Daniel Lezcano <[EMAIL PROTEC
Like the ipv4 part, this patch adds an ipv6 structure in the net structure
to aggregate the different resources to make ipv6 per namespace.
Signed-off-by: Daniel Lezcano <[EMAIL PROTECTED]>
---
include/net/net_namespace.h |2 ++
include/net/netns/ipv6.h| 10 ++
2 files changed,
The ip6_frags is moved to the network namespace structure.
Because there can be multiple instances of the network namespaces,
and the ip6_frags is no longer a global static variable, a helper
function has been added to facilitate the initialization of the
variables.
Until the ipv6 protocol is not
The initialization of the sysctl for the ipv6 protocol is changed to
a network namespace subsystem. That means when a new network namespace
is created the initialization function for the sysctl will be called.
That do not change the behavior of the sysctl in case of the kernel
with the network nam
This patch makes the function ipv6_sysctl_register to return a
value. The af_inet6 init function is now able to handle an error
and catch it from the initialization of the sysctl.
Signed-off-by: Daniel Lezcano <[EMAIL PROTECTED]>
---
include/net/ipv6.h |2 +-
net/ipv6/af_inet6.c
This patch moves the bindv6only sysctl to the network namespace
structure. Until the ipv6 protocol is not per namespace, the sysctl
variable is always from the initial network namespace.
Signed-off-by: Daniel Lezcano <[EMAIL PROTECTED]>
---
include/net/ipv6.h |1 -
include/net/netns/i
Each network namespace wants its own set of sysctl value, eg. we should
not be able from a namespace to set a sysctl value for another namespace
, especially for the initial network namespace.
This patch duplicates the sysctl table when we register a new network
namespace for ipv6. The duplicated
The following patchset makes the ipv6 sysctl to handle multiple
network namespaces. Each instance of a network namespace as its own
set of sysctl values, that means the behavior of the ipv6 stack can be
different depending on the sysctl values setup in the different
network namespaces.
Changelog:
Hi,
I have surprisingly managed to track down the USB device descriptor for the
wired Belkin network
adapter, and it looks as if the device class is actually 0x00 instead of 0xFF.
I originally used
0xFF because that is what my 3com device used (for some reason) and so I was
hoping that Belkin
w
From: KOVACS Krisztian <[EMAIL PROTECTED]>
Date: Fri, 4 Jan 2008 11:25:08 +0100
> Hi,
>
> On p, jan 04, 2008 at 12:35:12 -0800, David Miller wrote:
> > #define DRV_MODULE_NAME"cassini"
> > #define PFX DRV_MODULE_NAME": "
> > -#define DRV_MODULE_VERSION "1.4"
> > -#define DRV
Hi,
On p, jan 04, 2008 at 12:35:12 -0800, David Miller wrote:
> [CASSINI]: Bump driver version and release date.
>
> Signed-off-by: David S. Miller <[EMAIL PROTECTED]>
> ---
> drivers/net/cassini.c |4 ++--
> 1 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/cass
On Jan 2, 2008 10:51 PM, Herbert Xu <[EMAIL PROTECTED]> wrote:
> On Wed, Jan 02, 2008 at 07:29:59PM +0100, Torsten Kaiser wrote:
> >
> > Vanilla 2.6.24-rc6 seems stable. I did not see any crash or warnings.
>
> OK that's great. The next step would be to try excluding specific git
> trees from mm t
On 2008.01.04 09:45:17 +0100, Andreas Mohr wrote:
> Hi,
>
> On Fri, Jan 04, 2008 at 04:43:57AM +0100, Björn Steinbrink wrote:
> > On 2008.01.03 01:42:09 +0200, Adrian Bunk wrote:
> > > [ original bug report: http://lkml.org/lkml/2008/1/2/253 ]
> > >
> > > On Wed, Jan 02, 2008 at 10:48:43PM +0100,
[ next try, first attempt was blocked because of an '@' in 'X-Sender:' line? ]
Hi,
meanwhile the Agere et1310 chip has grown to a quite popular network
chip, in laptops as well as for PCI-E cards. The release date of this chip was
already in June 2004, and still no support in mainline linux.
Th
On Fri, 2008-01-04 at 00:32 -0800, David Miller wrote:
> Over the past day I've put together the following set of bug fixes for
> the Cassini driver.
>
> At least with my setup it appears to basically work fine, not leak
> memory, and the SKB BUG messages go away too.
>
> I'll be honest and say
From: Mark McLoughlin <[EMAIL PROTECTED]>
Date: Thu, 3 Jan 2008 15:57:03 +
> When re-naming an interface, the previous secondary address
> labels get lost e.g.
>
> $> brctl addbr foo
> $> ip addr add 192.168.0.1 dev foo
> $> ip addr add 192.168.0.2 dev foo label foo:00
> $> ip addr s
From: Eric Dumazet <[EMAIL PROTECTED]>
Date: Fri, 04 Jan 2008 06:34:28 +0100
> David Miller a écrit :
> > Please use "inline" instead of "__inline__". If other stuff
> > uses __inline__ in that file, feel free to fix it up too.
>
> You are right, here is the updated version
Applied, thanks Eric
[CASSINI]: Revert 'dont touch page_count'.
This reverts changeset fa4f0774d7c6cccb4d1fda76b91dd8eddcb2dd6a
([CASSINI]: dont touch page_count) because it breaks the driver.
The local page counting added by this changeset did not account
for the asynchronous page count changes done by kfree_skb()
[CASSINI]: Fix endianness bug.
Here's proposed fix for RX checksum handling in cassini; it affects
little-endian working with half-duplex gigabit, but obviously needs
testing on big-endian too.
The problem is, we need to convert checksum to fixed-endian *before*
correcting for (unstripped) FCS.
[CASSINI]: Program parent Intel31154 bridge when necessary.
Signed-off-by: David S. Miller <[EMAIL PROTECTED]>
---
drivers/net/cassini.c | 86 +
1 files changed, 86 insertions(+), 0 deletions(-)
diff --git a/drivers/net/cassini.c b/drivers/net/c
Over the past day I've put together the following set of bug fixes for
the Cassini driver.
At least with my setup it appears to basically work fine, not leak
memory, and the SKB BUG messages go away too.
I'll be honest and say that I've devoted a couple days to this work,
and therefore I have to
[CASSINI]: Set skb->truesize properly on receive packets.
skb->truesize was not being incremented at all to
reflect the page based data added to RX SKBs.
Signed-off-by: David S. Miller <[EMAIL PROTECTED]>
---
drivers/net/cassini.c |1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff
[CASSINI]: Fix two obvious NAPI bugs.
1) close should do napi_disable() not napi_enable
2) remove unused local var 'todo'
Signed-off-by: David S. Miller <[EMAIL PROTECTED]>
---
drivers/net/cassini.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/cassini.
[CASSINI]: Bump driver version and release date.
Signed-off-by: David S. Miller <[EMAIL PROTECTED]>
---
drivers/net/cassini.c |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/cassini.c b/drivers/net/cassini.c
index c3220e4..3a9bb17 100644
--- a/drivers/net/
Hi,
On Fri, Jan 04, 2008 at 04:43:57AM +0100, Björn Steinbrink wrote:
> On 2008.01.03 01:42:09 +0200, Adrian Bunk wrote:
> > [ original bug report: http://lkml.org/lkml/2008/1/2/253 ]
> >
> > On Wed, Jan 02, 2008 at 10:48:43PM +0100, Andreas Mohr wrote:
> > > The nv_probe() function then nicely o
60 matches
Mail list logo