Re: [PATCH 1/11] ibm_newemac: Add BCM5248 and Marvell 88E1111 PHY support

2007-12-08 Thread Benjamin Herrenschmidt
On Fri, 2007-12-07 at 15:09 -0500, Jeff Garzik wrote: > Benjamin Herrenschmidt wrote: > > From: Stefan Roese <[EMAIL PROTECTED]> > > > > This patch adds BCM5248 and Marvell 88E PHY support to NEW EMAC driver. > > These PHY chips are used on PowerPC 440EPx boards. > > The PHY code is based on

Re: Bogus commit 70eba18b ("make bnx2x select ZLIB_INFLATE")?

2007-12-08 Thread Jeff Garzik
Roland Dreier wrote: Commit 70eba18b ("make bnx2x select ZLIB_INFLATE") in Linus's tree seems bogus. As far as I can tell, bnx2x is not upstream yet, and the commit in question actually adds "select ZLIB_INFLATE" to the TEHUTI config, since there is no BNX2X config option (and also I don't see a

Bogus commit 70eba18b ("make bnx2x select ZLIB_INFLATE")?

2007-12-08 Thread Roland Dreier
Commit 70eba18b ("make bnx2x select ZLIB_INFLATE") in Linus's tree seems bogus. As far as I can tell, bnx2x is not upstream yet, and the commit in question actually adds "select ZLIB_INFLATE" to the TEHUTI config, since there is no BNX2X config option (and also I don't see any reference to zlib in

Re: IPsec replay sequence number overflow behavior? (RFC4303 section 3.3.3)

2007-12-08 Thread Herbert Xu
Paul Moore <[EMAIL PROTECTED]> wrote: > > If it is a bug, I think the basic fix should be pretty simple, changing the > above xfrm_output() code to the following: > > if (x->type->flags & XFRM_TYPE_REPLAY_PROT) { > XFRM_SKB_CB(skb)->seq = ++x->replay.oseq; > + if (x->replay.o

Re: [PATCH 0/2] [IPSEC]: Reinject packet instead of calling netfilter directly on input

2007-12-08 Thread jamal
On Mon, 2007-03-12 at 07:34 -0500, jamal wrote: > The point brought up on v6 extensions needs to be addressed. I thought > about it a little - and it is valid as well for ipv4 options; they will > be processed twice. > To build up on what Patrick said, I noticed a bit still available in the > bag

Re: [PATCH net-2.6.25] qdisc: new rate limiter

2007-12-08 Thread Ben Greear
Patrick McHardy wrote: Patrick McHardy wrote: Stephen Hemminger wrote: +struct tc_rlim_qopt +{ +__u32 limit;/* fifo limit (packets) */ +__u32rate;/* bits per sec */ This seems a bit small, 512mbit is the maximum rate. Its 4gbit of course, so I guess its eno

[PATCH 3/3] [CCID3]: HC-receiver should not insert timestamps as HC-sender doesn't uses it

2007-12-08 Thread Arnaldo Carvalho de Melo
From: Gerrit Renker <[EMAIL PROTECTED]> Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> Signed-off-by: Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> --- net/dccp/ccids/ccid3.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git a/net/dccp/ccids/ccid3.c b/net/dccp/ccids/ccid3.

[PATCH 2/3] [TFRC]: The function tfrc_rx_hist_entry_delete() is not used anymore

2007-12-08 Thread Arnaldo Carvalho de Melo
From: Gerrit Renker <[EMAIL PROTECTED]> Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> Signed-off-by: Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> --- net/dccp/ccids/lib/packet_history.c |5 - 1 files changed, 0 insertions(+), 5 deletions(-) diff --git a/net/dccp/ccids/lib/packet_histo

[PATCH 1/3] [TFRC]: Whitespace cleanups

2007-12-08 Thread Arnaldo Carvalho de Melo
From: Gerrit Renker <[EMAIL PROTECTED]> Just some tidy-ups to keep git/quilt happy. Also moved up the comment "Receiver routines" above the first occurrence of RX history routines. Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> Signed-off-by: Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> --- ne

[PATCHES 0/3]: DCCP patches for 2.6.25

2007-12-08 Thread Arnaldo Carvalho de Melo
Hi David, Please consider pulling from: master.kernel.org:/pub/scm/linux/kernel/git/acme/net-2.6.25 Best Regards, - Arnaldo b/net/dccp/ccids/ccid3.c | 16 b/net/dccp/ccids/lib/loss_interval.c |2 +- b/net/dccp/ccids/lib/packet_history.c | 13

Re: [PATCH 5/8] [TFRC]: Loss interval code needs the macros/inlines that were moved

2007-12-08 Thread Arnaldo Carvalho de Melo
Em Sat, Dec 08, 2007 at 10:06:25AM +, Gerrit Renker escreveu: > This moves the inlines (which were previously declared as macros) back into > packet_history.h since > the loss detection code needs to be able to read entries from the RX history > in order to create the > relevant loss entries:

Re: [PATCH][NET]: Finish removing unused "mibalign" argument for snmp_mib_init().

2007-12-08 Thread YOSHIFUJI Hideaki / 吉藤英明
Hello. In article <[EMAIL PROTECTED]> (at Sat, 8 Dec 2007 15:55:34 -0200), Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> says: > Signed-off-by: Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> > > diff --git a/net/ipv6/af_inet6.c b/net/ipv6/af_inet6.c > index 5ab8ba7..90d2f72 100644 > --- a/net/ipv6

[PATCH][NET]: Finish removing unused "mibalign" argument for snmp_mib_init().

2007-12-08 Thread Arnaldo Carvalho de Melo
Signed-off-by: Arnaldo Carvalho de Melo <[EMAIL PROTECTED]> diff --git a/net/ipv6/af_inet6.c b/net/ipv6/af_inet6.c index 5ab8ba7..90d2f72 100644 --- a/net/ipv6/af_inet6.c +++ b/net/ipv6/af_inet6.c @@ -714,20 +714,19 @@ EXPORT_SYMBOL_GPL(ipv6_opt_accepted); static int __init init_ipv6_mibs(void)

Re: [PATCH 3/8] [TFRC/CCID3]: Remove now unused functions / function calls

2007-12-08 Thread Arnaldo Carvalho de Melo
Em Sat, Dec 08, 2007 at 10:06:23AM +, Gerrit Renker escreveu: > This removes two things which now have become redundant: > 1. The function tfrc_rx_hist_entry_delete() is no longer referenced anywhere. > 2. The CCID3 HC-receiver still inserted timestamps, but received timestamps > are not

Re: [PATCH 2/8] [TFRC]: Put RX/TX initialisation into tfrc.c

2007-12-08 Thread Arnaldo Carvalho de Melo
Em Sat, Dec 08, 2007 at 10:06:22AM +, Gerrit Renker escreveu: > This separates RX/TX initialisation and puts all packet history / loss > intervals > initialisation into tfrc.c. > The organisation is uniform: slab declaration -> {rx,tx}_init() -> > {rx,tx}_exit() NAK, you can't call a __exit

Re: [PATCH 1/8] [TFRC]: Whitespace cleanups

2007-12-08 Thread Arnaldo Carvalho de Melo
Em Sat, Dec 08, 2007 at 10:06:21AM +, Gerrit Renker escreveu: > Just some tidy-ups to keep git/quilt happy. Also moved up the > comment "Receiver routines" above the first occurrence of RX > history routines. > > Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> Thanks, applied. -- To unsubscr

[PATCH] PLIP driver: convert killed_timer_sem to completion

2007-12-08 Thread Matthias Kaehlcke
PLIP driver: convert the semaphore killed_timer_sem to a completion Signed-off-by: Matthias Kaehlcke <[EMAIL PROTECTED]> -- diff --git a/drivers/net/plip.c b/drivers/net/plip.c index 57c9866..fee3d7b 100644 --- a/drivers/net/plip.c +++ b/drivers/net/plip.c @@ -106,6 +106,7 @@ static const char v

Re: Reproducible data corruption with sendfile+vsftp - splice regression?

2007-12-08 Thread Mark Lord
Francois Romieu wrote: Holger Hoffstaette <[EMAIL PROTECTED]> : [...] Maybe turning off sendfile or NAPI just lead to random success - so far it really looks like tso on the r8169 is the common cause. TSO on the r8169 is the magic switch but the regression makes imvho more sense from a VM pov:

[Patch] Incorrect time conversion in TIPC

2007-12-08 Thread Eric Sesterhenn
hi, the timeouts in tipc/socket.c dont match if HZ is not 1000, this patch changes it to use the proper conversion functions. Signed-off-by: Eric Sesterhenn <[EMAIL PROTECTED]> --- linux-2.6.24-rc3/net/tipc/socket.c.orig 2007-12-07 20:07:11.0 +0100 +++ linux-2.6.24-rc3/net/tipc/sock

dmfe claiming incompatible device

2007-12-08 Thread Florian Lohoff
Hi, i was trying to use the debian etch installer on an Sun Netra X1 and discovered that the netinstall would not work. Cause of this was the dmfe driver claiming an tulip based network and failing to read the mac address and most likely not beeing able to drive the card. I tried an 2.6.18 and 2.6

Re: 'default' vs. 'all'

2007-12-08 Thread Herbert Xu
On Sat, Dec 08, 2007 at 12:14:11AM -0800, YOSHIFUJI Hideaki / 吉藤英明 wrote: > > One good event to propagate is the NETDEV_UP; if the dirty bit is > not set when the device is brought up, copy the default values to > the device. Yeah I already did that for IPv4 except that for backwards compatibility

Re: 'default' vs. 'all'

2007-12-08 Thread Herbert Xu
On Sat, Dec 08, 2007 at 12:04:29AM -0800, David Miller wrote: > > Herbert, Yoshifuji and I were just discussing the > sysfs device attribute issue. > > It's seems sane to me that if we had some kind of > 'dirty' bit per attribute we could propagate default > settings everywhere except where the d

[PATCH 6/8] [PATCH v2] [TFRC]: Ringbuffer to track loss interval history

2007-12-08 Thread Gerrit Renker
A ringbuffer-based implementation of loss interval history is easier to maintain, allocate, and update. Details: * access to the Loss Interval Records via macro wrappers (with safety checks); * simplified, on-demand allocation of entries (no extra memory consumption on lossless links); cache

[PATCH 8/8] [PATCH v2] [CCID3]: Interface CCID3 code with newer Loss Intervals Database

2007-12-08 Thread Gerrit Renker
This hooks up the TFRC Loss Interval database with CCID 3 packet reception. In addition, it makes the CCID-specific computation of the first loss interval (which requires access to all the guts of CCID3) local to ccid3.c. The patch also fixes an omission in the DCCP code, that of a default / fallb

[PATCH 5/8] [TFRC]: Loss interval code needs the macros/inlines that were moved

2007-12-08 Thread Gerrit Renker
This moves the inlines (which were previously declared as macros) back into packet_history.h since the loss detection code needs to be able to read entries from the RX history in order to create the relevant loss entries: it needs at least tfrc_rx_hist_loss_prev() and tfrc_rx_hist_last_rcv(), wh

[PATCH 2/8] [TFRC]: Put RX/TX initialisation into tfrc.c

2007-12-08 Thread Gerrit Renker
This separates RX/TX initialisation and puts all packet history / loss intervals initialisation into tfrc.c. The organisation is uniform: slab declaration -> {rx,tx}_init() -> {rx,tx}_exit() Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> --- net/dccp/ccids/lib/packet_history.c | 68 +

[PATCH 1/8] [TFRC]: Whitespace cleanups

2007-12-08 Thread Gerrit Renker
Just some tidy-ups to keep git/quilt happy. Also moved up the comment "Receiver routines" above the first occurrence of RX history routines. Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> --- net/dccp/ccids/ccid3.c | 16 net/dccp/ccids/lib/loss_interval.c |2

[PATCH 7/8] [TFRC]: CCID3 (and CCID4) needs to access these inlines

2007-12-08 Thread Gerrit Renker
This moves two inlines back to packet_history.h: these are not private to packet_history.c, but are needed by CCID3/4 to detect whether a new loss is indicated, or whether a loss is already pending. Signed-off-by: Gerrit Renker <[EMAIL PROTECTED]> --- net/dccp/ccids/lib/packet_history.c | 26 --

[PATCH 4/8] [TFRC]: Need separate entry_from_skb routine

2007-12-08 Thread Gerrit Renker
This again separates tfrc_rx_hist_packet() from tfrc_rx_hist_entry_from_skb(), which was the format used in the original patch submission. The reason for this is the requirement -- used by the subsequent patches -- to be able to insert a newly arrived skb in arbitrary places within the ringbuffer

[PATCH 3/8] [TFRC/CCID3]: Remove now unused functions / function calls

2007-12-08 Thread Gerrit Renker
This removes two things which now have become redundant: 1. The function tfrc_rx_hist_entry_delete() is no longer referenced anywhere. 2. The CCID3 HC-receiver still inserted timestamps, but received timestamps are not parsed/referenced/used by the HC-sender, it serves no function. Signed-of

[PATCH 0/8] [DCCP]: Updates and fixes to ensure code works with recent changes

2007-12-08 Thread Gerrit Renker
Some of the recent changes in 2.6.25 cause problems with the existing implementation (i.e. break the code). This patch set therefore provides fixes and resubmits one subsequent patch which has not been considered so far, but which is part of the tfrc_lib package. Patch #1: Performs whitespace

Re: [PATCH] [NET]: Remove unused "mibalign" argument for snmp_mib_init().

2007-12-08 Thread David Miller
From: YOSHIFUJI Hideaki / 吉藤英明 <[EMAIL PROTECTED]> Date: Sat, 08 Dec 2007 00:41:28 -0800 (PST) > Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTECTED]> Applied, thanks. -- To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo

[PATCH] [NET]: Remove unused "mibalign" argument for snmp_mib_init().

2007-12-08 Thread YOSHIFUJI Hideaki / 吉藤英明
Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTECTED]> --- diff --git a/include/net/ip.h b/include/net/ip.h index 840dd91..7f18819 100644 --- a/include/net/ip.h +++ b/include/net/ip.h @@ -169,7 +169,7 @@ DECLARE_SNMP_STAT(struct linux_mib, net_statistics); #define NET_ADD_STATS_USER(field, adnd)

Re: [PATCH 2.6.25 3/3] ipv4: last default route is a fib table property

2007-12-08 Thread David Miller
From: "Denis V. Lunev" <[EMAIL PROTECTED]> Date: Fri, 7 Dec 2007 19:11:18 +0300 > ipv4: last default route is a fib table property > > Signed-off-by: Denis V. Lunev <[EMAIL PROTECTED]> > Acked-by: Alexey Kuznetsov <[EMAIL PROTECTED]> Applied, thanks! -- To unsubscribe from this list: send the li

Re: [PATCH 2.6.25 2/3] ipv4: unify assignment of fi to fib_result

2007-12-08 Thread David Miller
From: "Denis V. Lunev" <[EMAIL PROTECTED]> Date: Fri, 7 Dec 2007 19:10:14 +0300 > ipv4: unify assignment of fi to fib_result > > Signed-off-by: Denis V. Lunev <[EMAIL PROTECTED]> > Acked-by: Alexey Kuznetsov <[EMAIL PROTECTED]> Applied, thanks. -- To unsubscribe from this list: send the line "un

Re: [PATCH 2.6.25 1/3] ipv4: no need pass pointer to a default into fib_detect_death

2007-12-08 Thread David Miller
From: "Denis V. Lunev" <[EMAIL PROTECTED]> Date: Fri, 7 Dec 2007 19:09:19 +0300 > ipv4: no need pass pointer to a default into fib_detect_death > > Signed-off-by: Denis V. Lunev <[EMAIL PROTECTED]> > Acked-by: Alexey Kuznetsov <[EMAIL PROTECTED]> Applied, thanks. -- To unsubscribe from this list

Re: [patch 2/3][IPV6]: remove ifdef in route6 for xfrm6

2007-12-08 Thread David Miller
From: Daniel Lezcano <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 14:13:27 +0100 > The following patch create the usual static inline functions to disable > the xfrm6_init and xfrm6_fini function when XFRM is off. > That's allow to remove some ifdef and make the code a little more clear. > > Signed

Re: [patch 3/3][IPV6]: route6 remove ifdef for fib_rules

2007-12-08 Thread David Miller
From: Daniel Lezcano <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 14:13:28 +0100 > The patch defines the usual static inline functions when the code is > disabled for fib6_rules. That's allow to remove some ifdef in route.c > file and make the code a little more clear. > > Signed-off-by: Daniel Lez

Re: 'default' vs. 'all'

2007-12-08 Thread YOSHIFUJI Hideaki / 吉藤英明
In article <[EMAIL PROTECTED]> (at Sat, 08 Dec 2007 00:04:29 -0800 (PST)), David Miller <[EMAIL PROTECTED]> says: > Herbert, Yoshifuji and I were just discussing the > sysfs device attribute issue. > > It's seems sane to me that if we had some kind of > 'dirty' bit per attribute we could propaga

Re: [patch 1/3][IPV6]: create route6 proc init-fini functions

2007-12-08 Thread David Miller
From: Daniel Lezcano <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 14:13:26 +0100 > Make the proc creation/destruction to be a separate function. That allows to > remove the #ifdef CONFIG_PROC_FS in the init/fini function and make them more > readable. > > Signed-off-by: Daniel Lezcano <[EMAIL PROTE

Re: [PATCH net-2.6.25 2/3]sysctl: prepare core tables to point to netns variables

2007-12-08 Thread David Miller
From: Pavel Emelyanov <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 16:10:49 +0300 > Some of ctl variables are going to be on the struct > net. Here's the way to adjust the ->data pointer on the > ctl_table-s to point on the right variable. > > Since some pointers still point on the global variable

Re: [PATCH net-2.6.25 3/3]sysctl: make sysctl_somaxconn per-namespace

2007-12-08 Thread David Miller
From: Pavel Emelyanov <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 16:12:48 +0300 > Just move the variable on the struct net and adjust > its usage. > > Others sysctls from sys.net.core table are more > difficult to virtualize (i.e. make them per-namespace), > but I'll look at them as well a bit la

Re: [PATCH net-2.6.25] qdisc: new rate limiter

2007-12-08 Thread Bill Fink
On Sat, 08 Dec 2007, Patrick McHardy wrote: > Patrick McHardy wrote: > > Stephen Hemminger wrote: > >> > >> +struct tc_rlim_qopt > >> +{ > >> +__u32 limit;/* fifo limit (packets) */ > >> +__u32rate;/* bits per sec */ > >> > > > > This seems a bit small, 512mbit is

Re: [PATCH net-2.6.25 1/3]sysctl: make the sys.net.core sysctls per-namespace

2007-12-08 Thread David Miller
From: Pavel Emelyanov <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 16:07:19 +0300 > Making them per-namespace is required for the following > two reasons: > > First, some ctl values have a per-namespace meaning. > Second, making them writable from the sub-namespace > is an isolation hole. > >

'default' vs. 'all'

2007-12-08 Thread David Miller
Herbert, Yoshifuji and I were just discussing the sysfs device attribute issue. It's seems sane to me that if we had some kind of 'dirty' bit per attribute we could propagate default settings everywhere except where the dirty bit had been set. The question is how to implement this nicely. What

Re: [PATCH net-2.6.25] Remove unused devconf macros

2007-12-08 Thread David Miller
From: Pavel Emelyanov <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 13:16:43 +0300 > The SNMP_INC_STATS_OFFSET_BH is used only by ICMP6_INC_STATS_OFFSET_BH. > The ICMP6_INC_STATS_OFFSET_BH is unused. > > Can we drop them? > > Signed-off-by: Pavel Emelyanov <[EMAIL PROTECTED]> Sure, applied to net-

Re: [PATCH][IPV4] Swap the ifa allocation with the"ipv4_devconf_setall" call

2007-12-08 Thread David Miller
From: Pavel Emelyanov <[EMAIL PROTECTED]> Date: Fri, 07 Dec 2007 12:22:57 +0300 > According to Herbert, the ipv4_devconf_setall should be called > only when the ifa is added to the device. However, failed > ifa allocation may bring things into inconsistent state. > > Move the call to ipv4_devcon