On Mon, Jan 22, 2007 at 07:52:14AM +0100, Jarek Poplawski wrote:
>
> I was so impressed by the amount of work done by Michael
> that I magnified his merit and forgot to mention the role
> of Patrick and Herbert, particularly here:
You don't need to be so modest!
While no doubt Patrick helped in
Jarek Poplawski wrote:
> On Fri, Jan 19, 2007 at 03:08:20PM +0100, Jarek Poplawski wrote:
> ...
>> You are welcome! But you probably didn't read this with
>> attention: if it works, you should thank mainly to that
>> other guy...
>>
>> Btw. I can't remember I've seen such ferocious testing
>> ever!
On Fri, Jan 19, 2007 at 03:08:20PM +0100, Jarek Poplawski wrote:
...
> You are welcome! But you probably didn't read this with
> attention: if it works, you should thank mainly to that
> other guy...
>
> Btw. I can't remember I've seen such ferocious testing
> ever!
After checking in the dictiona
On Sat, Jan 20, 2007 at 08:10:27AM +1100, Herbert Xu wrote:
> On Fri, Jan 19, 2007 at 12:06:41PM +0100, Jarek Poplawski wrote:
> >
> > [PATCH][NET] tcp_output: rare bad TCP checksum with 2.6.19
> >
> > The patch "Replace CHECKSUM_HW by CHECKSUM_PARTIAL/CHECKSUM_COMPLETE"
> > changed to unconditio
Some versions of the bcm43xx chips only support 30-bit DMA, which means
that the descriptors and buffers must be in the first 1 GB of RAM. On
the i386 and x86_64 architectures with more than 1 GB RAM, an incorrect
assignment may occur. This patch ensures that the various DMA addresses
are within th
Randy Dunlap wrote:
On Sun, 21 Jan 2007 15:07:37 -0600 Jay Cliburn wrote:
[snip]
+ value = ioread16(hw->hw_addr + REG_PCIE_CAP_LIST);
+ return ((value & 0xFF00) == 0x6C00) ? 0 : 1;
Are there defines or enums for these?
Fewer magic numbers would be nice/helpful/readable.
[snip]
On Sun, 21 Jan 2007 15:07:37 -0600 Jay Cliburn wrote:
> This patch contains auxiliary C files for the Attansic L1 gigabit ethernet
> adapter driver.
>
> Signed-off-by: Jay Cliburn <[EMAIL PROTECTED]>
> Signed-off-by: Chris Snook <[EMAIL PROTECTED]>
> ---
>
> atl1_ethtool.c | 436 ++
This patch breaks up the routines into two versions, one for legacy
descriptor versions (ver 1 and ver 2) and one for desc ver 3. This will
make the new desc functions more leaner and further reductions will be
made in next few patches.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/dr
This patch optimizes the data paths that can support hw counters. It
removes the sw counted statistics.
This is the last patch for the optimization set. Bumping up version of
driver.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/drivers/net/forcedeth.c2007-01-21 17:38:50.00
This patch introduces hw statistics for older devices that supported it.
It breaks up the counters supported into separate versions.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/drivers/net/forcedeth.c2007-01-21 17:33:59.0 -0500
+++ new/drivers/net/forcedeth.c 2007-01-
This patch optimizes the irq data paths and cleans up the code.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/drivers/net/forcedeth.c2007-01-19 11:11:35.0 -0500
+++ new/drivers/net/forcedeth.c 2007-01-19 11:13:25.0 -0500
@@ -2777,7 +2777,6 @@
A few fixes have been made based on Jeff's comments. Resending patchs 5-12.
Ayaz
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/majordomo-info.html
This patch optimizes the tx data paths and cleans up the code (removes
vlan from descr1/2 since only valid for desc3, changes to make code
easier to read, etc).
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
---
Th
This patch optimizes the rx data paths and cleans up the code.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/drivers/net/forcedeth.c2007-01-19 11:08:24.0 -0500
+++ new/drivers/net/forcedeth.c 2007-01-19 11:11:04.0 -0500
@@ -1317,9 +1317,9 @@
This patch optimizes the logic for tx limiting. It adds a flag to check
on the completion side instead of recalculating the number of empty
slots. Also, it removes the fields that were previous used for limiting
since they have no value.
Signed-Off-By: Ayaz Abdulla <[EMAIL PROTECTED]>
--- orig/d
On Sun, Jan 21, 2007 at 01:45:27PM -0800, Auke Kok wrote:
> Frederik Deweerdt wrote:
> >On Sun, Jan 21, 2007 at 09:17:41PM +0200, Andrei Popa wrote:
> >>It's the 10th resume and in /proc/interrupts eth0 appers 10 times.
> >The e100_resume() function should be calling netif_device_detach and
> >free
Frederik Deweerdt wrote:
On Sun, Jan 21, 2007 at 09:17:41PM +0200, Andrei Popa wrote:
It's the 10th resume and in /proc/interrupts eth0 appers 10 times.
The e100_resume() function should be calling netif_device_detach and
free_irq. Could you try the following (compile tested) patch?
I just f
On Thu, Jan 18, 2007 at 10:56:13PM +0100, Adrian Bunk wrote:
> This patch removes kernel 2.4 compatibility code.
Looks correct to me, thanks.
> Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
Acked-by: Samuel Ortiz <[EMAIL PROTECTED]>
> ---
>
> drivers/net/irda/vlsi_ir.c | 16 --
From: Jay Cliburn <[EMAIL PROTECTED]>
From: Chris Snook <[EMAIL PROTECTED]>
This patch contains auxiliary C files for the Attansic L1 gigabit ethernet
adapter driver.
Signed-off-by: Jay Cliburn <[EMAIL PROTECTED]>
Signed-off-by: Chris Snook <[EMAIL PROTECTED]>
---
atl1_ethtool.c | 436 +++
From: Jay Cliburn <[EMAIL PROTECTED]>
From: Chris Snook <[EMAIL PROTECTED]>
This patch contains the header files needed by the Attansic L1 gigabit
ethernet adapter driver.
Signed-off-by: Jay Cliburn <[EMAIL PROTECTED]>
Signed-off-by: Chris Snook <[EMAIL PROTECTED]>
---
atl1.h| 288 +++
From: Jay Cliburn <[EMAIL PROTECTED]>
From: Chris Snook <[EMAIL PROTECTED]>
This patch contains the build files for the Attansic L1 gigabit ethernet
adapter driver.
Signed-off-by: Jay Cliburn <[EMAIL PROTECTED]>
Signed-off-by: Chris Snook <[EMAIL PROTECTED]>
---
Kconfig | 11 ++
This is the latest submittal of the patchset providing support for the
Attansic L1 gigabit ethernet adapter. This patchset is built against
kernel version 2.6.20-rc5.
This version incorporates all comments from:
Christoph Hellwig:
http://lkml.org/lkml/2007/1/11/43
http://lkml.org/lkml/2007/1/
On Thu, Jan 11, 2007 at 10:26:27PM -0800, Andrew Morton wrote:
>...
> Changes since 2.6.20-rc3-mm1:
>...
> git-netdev-all.patch
>...
> git trees
>...
Since it's no longer used, this "#define BCM_TSO 1" can now be removed.
Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
--- linux-2.6.20-rc4-mm1/
This patch contains the following cleanups:
- proper prototypes in header files for global variables and functions
- make the following needlessly global struct static:
- auth_gss/gss_spkm3_seal.c: struct cast5_cbc_oid
- make the following needlessly global variables static:
- xprtsock.c: xprt_
After commit d3dcc077bf88806201093f86325ec656e4dbfbce,
include/linux/if_{addr,link}.h should be processed with unifdef.
Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
---
include/linux/Kbuild |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- linux-2.6.20-rc4-mm1/include/linux/K
wext-common.o is required if CONFIG_WIRELESS_EXT is set. Looks like
`CONFIG_NET_WIRELESS' is a typo.
Signed-off-by: Marcus Better <[EMAIL PROTECTED]>
--- a/net/wireless/Makefile
+++ b/net/wireless/Makefile
@@ -12,5 +12,5 @@ obj-ny :=
# this needs to be compiled in...
obj-$(CONFIG_CFG80211_WE
Evgeniy Polyakov wrote:
On Sat, Jan 20, 2007 at 05:36:03PM -0500, Rik van Riel ([EMAIL PROTECTED])
wrote:
Evgeniy Polyakov wrote:
On Fri, Jan 19, 2007 at 01:53:15PM +0100, Peter Zijlstra
([EMAIL PROTECTED]) wrote:
Even further development of such idea is to prevent such OOM condition
at all -
On 1/21/07, Thibaut VARENE <[EMAIL PROTECTED]> wrote:
On 1/11/07, Jarek Poplawski <[EMAIL PROTECTED]> wrote:
>
> PS: alas I didn't even check compiling - I had no time to
> find all compile dependencies of this driver
> ---
Hmm, I think this is guaranteed not to work. In between those lines
the l
On 1/11/07, Jarek Poplawski <[EMAIL PROTECTED]> wrote:
PS: alas I didn't even check compiling - I had no time to
find all compile dependencies of this driver
---
Signed-off-by: Jarek Poplawski <[EMAIL PROTECTED]>
---
diff -Nurp linux-2.6.20-rc4-/drivers/net/mv643xx_eth.c
linux-2.6.20-rc4/driv
Hello
In the tour of converting local definitions of boolean-type/values, I
ran into airo.c's description of ex decapsulate():
* Returns: BOOLEAN - TRUE if packet should be dropped otherwise FALSE
but returns SUCCESS (defined as 0) and ERROR (defined as -1).
Also, shouldn't those functi
30 matches
Mail list logo