Re: RFR 15 8243099: Adding ADQ support to JDK

2020-04-30 Thread Alan Bateman
On 29/04/2020 19:11, Ivanov, Vladimir A wrote: Updated version of the webrev available as http://cr.openjdk.java.net/~sviswanathan/Vladimir/8243099/webrev.03/ The tests run results for the " test/jdk/java/net test/jdk/java/nio/channels test/jdk/javax/net test/jdk/jdk/net test/jdk/sun/net" s

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Patrick Concannon
Hi, After some discussion offline, it was decided that a try-with-resources was preferred to a @BeforeTest @AfterTest for creating and closing sockets. I’ve updated the webrev to reflect this, and the new patch can be found below. http://cr.openjdk.java.net/~pconcannon/8243488/webrevs/webrev

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Chris Hegarty
> On 30 Apr 2020, at 11:40, Patrick Concannon > wrote: > > Hi, > > After some discussion offline, it was decided that a try-with-resources was > preferred to a @BeforeTest @AfterTest for creating and closing sockets. I’ve > updated the webrev to reflect this, and the new patch can be found

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Alan Bateman
On 30/04/2020 11:40, Patrick Concannon wrote: Hi, After some discussion offline, it was decided that a try-with-resources was preferred to a @BeforeTest @AfterTest for creating and closing sockets. I’ve updated the webrev to reflect this, and the new patch can be found below. http://cr.ope

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Daniel Fuchs
Hi Alan, On 30/04/2020 11:48, Alan Bateman wrote: http://cr.openjdk.java.net/~pconcannon/8243488/webrevs/webrev.02/ Another approach would be replace DSF with a simple supplier like this:     @FunctionalInterface     interface DatagramSocketSupplier {     DatagramSocket get() throws I

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Alan Bateman
On 30/04/2020 12:15, Daniel Fuchs wrote: I don't understand your comment. Maybe I'm missing something? That's exactly what DSF is isn't it? We just choose to name the method 'open' instead of 'get'. And the static `DSF of(DSF)` method is simply there to provide a type witness and avoid a cast (y

Re: RFR[8243488]: 'Add tests for set/get SendBufferSize and getReceiveBufferSize in DatagramSocket'

2020-04-30 Thread Daniel Fuchs
On 30/04/2020 12:24, Alan Bateman wrote: It's a naming issue mostly. If DSF is renamed to something like DatagramSocketSupplier then it might be a bit clearer. We have something similar in PrintSupportedOptions - I was reminded of that with the changes for ADQ that are currently under discussio

RE: RFR 15 8243099: Adding ADQ support to JDK

2020-04-30 Thread Ivanov, Vladimir A
Thanks for your comments. The Javadoc was updated to fix comments and have '@apiNote' section based on previous description. Tests PrintSupportedOptions and AfterClose updated to have minimal changes. Updated webrev available as http://cr.openjdk.java.net/~sviswanathan/Vladimir/8243099/webrev.04

RE: RFR 15 8243099: SO_INCOMING_NAPI_ID support

2020-04-30 Thread Ivanov, Vladimir A
One more update at http://cr.openjdk.java.net/~sviswanathan/Vladimir/8243099/webrev.05/ The @apiNote section was updated a little bit to concentrate on SO_INCOMING_NAPI_ID. Thanks, Vladimir -Original Message- From: Ivanov, Vladimir A Sent: Thursday, April 30, 2020 10:14 AM To: Alan Ba