Hi
perhaps there is an opportunity to do some refactoring here (... for
me a "goto " carries a code smell! )
along the lines
if (timeout) {
nread = NET_ReadWithTimeout(...);
} else {
nread = NET_Read(...);
}
the NET_ReadWithTimeout (...) function will contain a restructuring of
Hi Mark,
Thanks for the review, even i don't like "goto" , i wanted to do code
changes as less as possible(not even refactoring) and "goto" helped me
in this.
I will incorporate the review comment and send the modified webrev.
Thanks,
Vyom
On 8/30/2016 4:11 PM, Mark Sheppard wrote:
Hi