Chris Hegarty wrote:
Stuart,
Thanks for doing this. The new code looks much cleaner. Please go
ahead and push this change.
-Chris.
Looks okay to me too. One minor comment is that it might be slightly
easier to read if it were:
File tmpFile = File.createTempFile("jar_cache", null);
try {
Stuart,
Thanks for doing this. The new code looks much cleaner. Please go ahead
and push this change.
-Chris.
On 10/02/2011 21:13, Stuart Marks wrote:
Webrev is here:
http://cr.openjdk.java.net/~smarks/reviews/7018392/webrev.0/
This uses try-with-resources to close the InputStream reliably
Webrev is here:
http://cr.openjdk.java.net/~smarks/reviews/7018392/webrev.0/
This uses try-with-resources to close the InputStream reliably, and it uses
Files.copy() to avoid dealing directly with an OutputStream.
We had also discussed the circumstances when the temp file should be removed.