Re: RFR: 8254802: ThrowingPushPromisesAsStringCustom.java fails in "try throwing in GET_BODY" [v2]

2020-12-02 Thread Daniel Fuchs
> Hi, > > Please find below a fix that fixes an issue in Http2TestServerConnection - > where the > connection will be closed by the test server if the test server receives a > RESET from the client > after the stream has been closed. > > This issue has made the ThrowingPushPromisesAsStringCust

RFR: 8254802: ThrowingPushPromisesAsStringCustom.java fails in "try throwing in GET_BODY"

2020-12-02 Thread Daniel Fuchs
Hi, Please find below a fix that fixes an issue in Http2TestServerConnection - where the connection will be closed by the test server if the test server receives a RESET from the client after the stream has been closed. This issue has made the ThrowingPushPromisesAsStringCustom test fail from

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v5]

2020-12-02 Thread Daniel Fuchs
On Wed, 2 Dec 2020 16:34:17 GMT, Kartik Ohri wrote: >> Hi! >> Kindly review this patch to replace switch statements with switch >> expressions (where it makes sense) in the http client modules. The rationale >> is to improve readability of the code. >> Regards, >> Kartik > > Kartik Ohri has up

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Patrick Concannon
On Wed, 2 Dec 2020 16:28:44 GMT, Kartik Ohri wrote: >> src/java.net.http/share/classes/jdk/internal/net/http/Http1HeaderParser.java >> line 119: >> >>> 117: while (canContinueParsing(input)) { >>> 118: switch (state) { >>> 119: case INITIAL ->

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Kartik Ohri
On Wed, 2 Dec 2020 16:15:13 GMT, Chris Hegarty wrote: >> Kartik Ohri has refreshed the contents of this pull request, and previous >> commits have been removed. The incremental views will show differences >> compared to the previous content of the PR. > > I think that the actual source changes

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Patrick Concannon
On Wed, 2 Dec 2020 09:42:09 GMT, Kartik Ohri wrote: >> Hi! >> Kindly review this patch to replace switch statements with switch >> expressions (where it makes sense) in the http client modules. The rationale >> is to improve readability of the code. >> Regards, >> Kartik > > Kartik Ohri has re

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Kartik Ohri
On Wed, 2 Dec 2020 16:23:11 GMT, Daniel Fuchs wrote: >> Kartik Ohri has refreshed the contents of this pull request, and previous >> commits have been removed. The incremental views will show differences >> compared to the previous content of the PR. > > src/java.net.http/share/classes/jdk/inte

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Kartik Ohri
On Wed, 2 Dec 2020 16:26:43 GMT, Patrick Concannon wrote: >> Kartik Ohri has refreshed the contents of this pull request, and previous >> commits have been removed. The incremental views will show differences >> compared to the previous content of the PR. > > src/java.net.http/share/classes/jd

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v5]

2020-12-02 Thread Kartik Ohri
> Hi! > Kindly review this patch to replace switch statements with switch expressions > (where it makes sense) in the http client modules. The rationale is to > improve readability of the code. > Regards, > Kartik Kartik Ohri has updated the pull request incrementally with one additional commit

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Daniel Fuchs
On Wed, 2 Dec 2020 09:42:09 GMT, Kartik Ohri wrote: >> Hi! >> Kindly review this patch to replace switch statements with switch >> expressions (where it makes sense) in the http client modules. The rationale >> is to improve readability of the code. >> Regards, >> Kartik > > Kartik Ohri has re

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Chris Hegarty
On Wed, 2 Dec 2020 09:42:09 GMT, Kartik Ohri wrote: >> Hi! >> Kindly review this patch to replace switch statements with switch >> expressions (where it makes sense) in the http client modules. The rationale >> is to improve readability of the code. >> Regards, >> Kartik > > Kartik Ohri has re

Re: RFR: JDK-8257235: [PATCH] InetAddress.isReachable: Try to use an IPPROTO_ICMP socket type before attempting RAW_SOCK

2020-12-02 Thread Dalibor Topic
On Sun, 29 Nov 2020 07:54:23 GMT, Jamie Le Tual wrote: > Users have been able to send ICMP packets without the need for root > privileges or the CAP_NET_RAW capability since at least kernel 3.11. > > For some time now, if the kernel parameter net.ipv4.ping_group_range included > the gid of a

RFR: JDK-8257235: [PATCH] InetAddress.isReachable: Try to use an IPPROTO_ICMP socket type before attempting RAW_SOCK

2020-12-02 Thread Jamie Le Tual
Users have been able to send ICMP packets without the need for root privileges or the CAP_NET_RAW capability since at least kernel 3.11. For some time now, if the kernel parameter net.ipv4.ping_group_range included the gid of a user sending an icmp packet with the IPPROTO_ICMP protocol, then th

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v4]

2020-12-02 Thread Kartik Ohri
> Hi! > Kindly review this patch to replace switch statements with switch expressions > (where it makes sense) in the http client modules. The rationale is to > improve readability of the code. > Regards, > Kartik Kartik Ohri has refreshed the contents of this pull request, and previous commits

Re: RFR: JDK-8257401: Use switch expressions in jdk.internal.net.http and java.net.http [v3]

2020-12-02 Thread Kartik Ohri
> Hi! > Kindly review this patch to replace switch statements with switch expressions > (where it makes sense) in the http client modules. The rationale is to > improve readability of the code. > Regards, > Kartik Kartik Ohri has updated the pull request incrementally with one additional commit