It is written in spec, that if config doesn't support pbuffer
then the EGL_BAD_MATCH should be set.
---
src/egl/drivers/dri2/egl_dri2_fallbacks.h | 5 +
1 file changed, 5 insertions(+)
diff --git a/src/egl/drivers/dri2/egl_dri2_fallbacks.h
b/src/egl/drivers/dri2/egl_dri2_fallbacks.h
index e7
Till now window surface size on wayland was -1.
It's better to assign windows size to proper surface property.
---
src/egl/drivers/dri2/platform_wayland.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/src/egl/drivers/dri2/platform_wayland.c
b/src/egl/drivers/dri2/platfo
e was a typos)
v3: changed code with naming conventions, corrected comparision in one IF
statement, added mutex for list structure that holds information wnd-surf-dpy.
Signed-off-by: Adrian Pielech
---
Sorry for this ugly appendix that will be appended by proxy to this message.
---
src/egl
According to the EGL 1.5 spec, section 3.5.1, page 34,35
eglCreateWindowSurface should return EGL_BAD_ALLOC if there is already created
surface for given window. Similarly it is written in EGL 1.4 spec,
section 3.5.1, page 29.
Signed-off-by: Adrian Pielech
---
src/egl/main/eglapi.c | 89
According to the EGL 1.5 spec, section 3.5.1, page 34,35
eglCreateWindowSurface should return EGL_BAD_ALLOC if there is already
surface for given window. Similarly it is written in EGL 1.4 spec,
section 3.5.1, page 29.
I apologize for small mistakes on earlier message...
Signed-off-by: Adrian