Reviewed-by: Samuel Pitoiset
On 6/13/19 8:03 PM, Marek Olšák wrote:
It's only a random cleanup.
Marek
On Thu, Jun 13, 2019 at 2:57 AM Samuel Pitoiset
mailto:samuel.pitoi...@gmail.com>> wrote:
Why do you need that?
On 6/12/19 11:31 PM, Marek Olšák wrote:
> From: Marek Olšák mai
https://bugs.freedesktop.org/show_bug.cgi?id=95022
--- Comment #6 from Ilse Twigt ---
Debugging a program like this sometime takes hours and hours but with the help
of your instructions I solved all the hurdles in no time.If you are searching
homework help in Australia then click
[[https://essayo
LLVM r363339 changed llvm.amdgcn.icmp.i* to llvm.amdgcn.icmp.i64.i*.
Signed-off-by: Samuel Pitoiset
---
src/amd/common/ac_llvm_build.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/amd/common/ac_llvm_build.c b/src/amd/common/ac_llvm_build.c
index 88e89d1dfb4..b93
r-b
On Fri, Jun 14, 2019 at 11:57 AM Samuel Pitoiset
wrote:
>
> LLVM r363339 changed llvm.amdgcn.icmp.i* to llvm.amdgcn.icmp.i64.i*.
>
> Signed-off-by: Samuel Pitoiset
> ---
> src/amd/common/ac_llvm_build.c | 7 ---
> 1 file changed, 4 insertions(+), 3 deletions(-)
>
> diff --git a/src/amd/
https://bugs.freedesktop.org/show_bug.cgi?id=110709
Eric Engestrom changed:
What|Removed |Added
Status|NEW |ASSIGNED
--- Comment #3 from Eric Enge
https://bugs.freedesktop.org/show_bug.cgi?id=110921
Bug ID: 110921
Summary: virgl on OpenGL 3.3 host regressed to OpenGL 2.1
Product: Mesa
Version: git
Hardware: x86 (IA32)
OS: Linux (All)
Status: NEW
Seve
https://bugs.freedesktop.org/show_bug.cgi?id=110921
--- Comment #1 from Andrew Randrianasulu ---
Created attachment 144543
--> https://bugs.freedesktop.org/attachment.cgi?id=144543&action=edit
glxinfo from host (llvmpipe)
--
You are receiving this mail because:
You are the QA Contact for the
https://bugs.freedesktop.org/show_bug.cgi?id=110921
--- Comment #2 from Andrew Randrianasulu ---
Created attachment 144544
--> https://bugs.freedesktop.org/attachment.cgi?id=144544&action=edit
glxinfo from host (nv50)
--
You are receiving this mail because:
You are the QA Contact for the bug.
https://bugs.freedesktop.org/show_bug.cgi?id=110921
--- Comment #3 from Ilia Mirkin ---
FWIW GL_ALPHA8/16 are not valid in a core profile.
--
You are receiving this mail because:
You are the assignee for the bug.
You are the QA Contact for the bug.___
https://bugs.freedesktop.org/show_bug.cgi?id=110922
Bug ID: 110922
Summary: [regression][bisected] Android build test fails to
include libmesa_winsys_virgl_common
Product: Mesa
Version: git
Hardware: Other
O
https://bugs.freedesktop.org/show_bug.cgi?id=110709
--- Comment #4 from Sergey Kondakov ---
(In reply to Eric Engestrom from comment #3)
> We do read the bug tracker, but sometimes things slip through :)
>
> I've sent an MR with a fix here:
> https://gitlab.freedesktop.org/mesa/mesa/merge_reques
https://bugs.freedesktop.org/show_bug.cgi?id=110261
Denis changed:
What|Removed |Added
Status|NEW |NEEDINFO
--- Comment #12 from Denis ---
Jason
https://bugs.freedesktop.org/show_bug.cgi?id=110261
Danylo changed:
What|Removed |Added
CC||danylo.pilia...@gmail.com
Resolution|-
https://bugs.freedesktop.org/show_bug.cgi?id=110921
--- Comment #4 from Ilia Mirkin ---
Looks like ARB_framebuffer_sRGB is not provided for some reason by virgl.
There was recently reworked in virgl to try to be more precise, esp in ES, and
I suspect something here ended up as a casualty...
Checks if a number is one less than a power of two. Equivalently, this
checks if a number is all ones in binary. The latter definition is
helpful in the context of masks.
The function is trivial; this is *the* canonical check and is
arguably no less clean than calling util_is_power_of_two(x + 1) (
Fix android building errors in winsys/amdgpu and radv
due to 'amdgfxregs.h' not found.
Changelog:
amd/common - generated $(intermediated)/common path is added to exports
winsys/amdgpu - libmesa_amd_common static dependency is added
radv - fix libmesa_amd_common $(intermediated)/common path in incl
These names are from the replay workaround in kbase; they begin to shine
some light on the meaning of these fields. In particular, we now
understand why the "tiler_meta" field has the effect it does on
performance in certain scenes (controlling tile granularity).
Signed-off-by: Alyssa Rosenzweig
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_tiler.h | 44
1 file changed, 44 insertions(+)
create mode 100644 src/gallium/drivers/panfrost/pan_tiler.h
diff --git a/src/gallium/drivers/panfrost/pan_tiler.h
b/src/gallium/drivers/panfrost/pan_til
I'm not sure how the blob does it, but this seems to be a dead simple
test and roughly corresponds to what I've noticed from the blob, so
maybe it's good enough.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_tiler.c | 65
1 file changed, 65 insert
This explains how the polygon list is allocated, updating the headers
appropiately to sync the terminology.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_tiler.c | 86
1 file changed, 86 insertions(+)
create mode 100644 src/gallium/drivers/panfro
Following the research into Midgard's hierarchical tiling
infrastructure, we now understand (in broad stokes) the purpose of each
tiler field in the MFBD. Additionally, we understand more of the tiling
fields in the SFBD and in Bifrost's structures, although this knowledge
is still incomplete.
Upd
Midgard and Bifrost GPUs feature "hierarchical tiling", publicly
documented to varying degrees. Essentially, we're a regular tiler GPU,
but the tile size can vary (and that variance is in driver control).
This series adds some explanation how hierarchical tiling works from the
drivers' perspective
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 5 +
1 file changed, 5 insertions(+)
diff --git a/src/gallium/drivers/panfrost/pan_context.c
b/src/gallium/drivers/panfrost/pan_context.c
index a30b9e29701..d1e5b4ce647 100644
--- a/src/gallium/drivers/panfros
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 21 -
1 file changed, 16 insertions(+), 5 deletions(-)
diff --git a/src/gallium/drivers/panfrost/pan_context.c
b/src/gallium/drivers/panfrost/pan_context.c
index 0363591f79f..ecb68c990a0 100644
Quite a bit of refactoring in the main driver will be necessary to make
use of this effectively, so the implementation is incomplete.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_tiler.c | 21 +
1 file changed, 21 insertions(+)
diff --git a/src/galli
As per the notes at the beginning of pan_tiler.c, we implement a routine
to calculate the size of the polygon list header given the framebuffer
dimensions and the provided hierarchy mask.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/meson.build | 3 +-
src/gallium/drivers/
This is a bit of a hack, but it gets the point across.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 7 ++-
src/gallium/drivers/panfrost/pan_tiler.c | 14 ++
2 files changed, 20 insertions(+), 1 deletion(-)
diff --git a/src/gallium/drivers/
Just for readability.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 14 +++---
src/gallium/drivers/panfrost/pan_context.h | 3 +--
src/gallium/drivers/panfrost/pan_drm.c | 2 +-
3 files changed, 9 insertions(+), 10 deletions(-)
diff --git a/src/
On 6/14/19 9:42 AM, Alyssa Rosenzweig wrote:
> Checks if a number is one less than a power of two. Equivalently, this
> checks if a number is all ones in binary. The latter definition is
> helpful in the context of masks.
>
> The function is trivial; this is *the* canonical check and is
> arguably
https://bugs.freedesktop.org/show_bug.cgi?id=110923
Bug ID: 110923
Summary: Multiple VkSubpassDependency-entries with the same
dstSubpass not handled correctly
Product: Mesa
Version: git
Hardware: Other
OS:
This series includes misc. fixes to improve robustness for for more
complex apps.
Alyssa Rosenzweig (6):
panfrost: Identify and decode mfbd_flags
panfrost: Disable the tiler for clear-only jobs
panfrost: Improve viewport (clipping) robustness
panfrost: Flush scanout too
panfrost: Remove
On more complex apps (possibly using desktop GL specific extensions?),
our viewport code was getting wacky results for unclear reasons. Let's
be a little less wacky.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 41 ++
1 file changed, 35 in
To do so, we route some basic information through to the FBD creation
routines (currently just a binary toggle of "has draws?"). Eventually,
more refactoring will enable dynamic hierarchy mask selection, but right
now we do the most basic.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers
In some cases, Gallium can give us bad info about the texture count,
counting some NULL textures. We pass Gallium's info to the hardware
blindly, which can confuse the hardware in edge cases. This patch
adjusts accordingly.
---
src/gallium/drivers/panfrost/pan_context.c | 47 +-
https://bugs.freedesktop.org/show_bug.cgi?id=110923
Christian Forfang changed:
What|Removed |Added
CC||chris.forf...@gmail.com
--
You are
This worked around a bug in ld versions of Panfrost. Nowadays, its
presence is, at best, *creating* bugs. Let's wack it.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 4
1 file changed, 4 deletions(-)
diff --git a/src/gallium/drivers/panfrost/pan_con
Previously known as the unk3 field.
Signed-off-by: Alyssa Rosenzweig
---
.../drivers/panfrost/include/panfrost-job.h | 4 ++--
src/gallium/drivers/panfrost/pan_mfbd.c | 12 ++--
src/gallium/drivers/panfrost/pandecode/decode.c | 16 ++--
3 files changed, 22 ins
In a poorly coded app, the framebuffer can be partially drawn, an FBO
switched, switch back to the framebuffer and keep drawing, etc.
Reordering would fix this, but for now we need to just be careful about
flushing scanout too.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pa
> Except it would have to be util_is_power_of_two_or_zero because
> util_is_power_of_two(0x + 1) is false. :)
Corner cases, corner cases!
> Is there actually a 2/2 for this? We usually wouldn't land something
> like this without a caller.
The 1/2 on there was accidentally, sorry. The us
Honestly, maybe I should just retract the patch. What's the lingo for
that? :P
signature.asc
Description: PGP signature
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev
From: Marek Olšák
---
Please test and fix RADV if needed. Compressed textures may be broken.
This change contains the necessary radeonsi fixes for this addrlib.
src/amd/addrlib/inc/addrinterface.h | 12 +-
src/amd/addrlib/inc/addrtypes.h | 36 +-
src/amd/addrlib/src/addri
From: Nicolai Hähnle
This fixes piglit spec@glsl-1.50@gs-max-output.
---
src/gallium/drivers/radeonsi/si_get.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/src/gallium/drivers/radeonsi/si_get.c
b/src/gallium/drivers/radeonsi/si_get.c
index c1bddca1a66..9496817ac84 1006
Reviewed-by: Marek Olšák
Marek
On Fri, Jun 14, 2019 at 5:57 AM Samuel Pitoiset
wrote:
> LLVM r363339 changed llvm.amdgcn.icmp.i* to llvm.amdgcn.icmp.i64.i*.
>
> Signed-off-by: Samuel Pitoiset
> ---
> src/amd/common/ac_llvm_build.c | 7 ---
> 1 file changed, 4 insertions(+), 3 deletions(-
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/midgard/midgard_compile.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/src/gallium/drivers/panfrost/midgard/midgard_compile.c
b/src/gallium/drivers/panfrost/midgard/midgard_compile.c
index 7d7bda6ee12..6dbfd4ade
Exactly what it says on the tin. Decode them and implement them.
Alyssa Rosenzweig (8):
panfrost/midgard: Add swizzle_of/mask_of helpers
panfrost/midgard: Fix 3D texture masks/swizzles
panfrost: Specify 3D in texture descriptor
panfrost: Implement 3D texture resource management
panfrost:
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_context.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/src/gallium/drivers/panfrost/pan_context.c
b/src/gallium/drivers/panfrost/pan_context.c
index 4541b84754c..ec0e4ef7876 100644
--- a/src/gallium/drivers
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_resource.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/gallium/drivers/panfrost/pan_resource.c
b/src/gallium/drivers/panfrost/pan_resource.c
index 7c0d54a1f9f..81a74735592 100644
--- a/src/gallium
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/include/panfrost-job.h | 3 +--
src/gallium/drivers/panfrost/pandecode/decode.c | 6 --
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/src/gallium/drivers/panfrost/include/panfrost-job.h
b/src/gallium/drive
Signed-off-by: Alyssa Rosenzweig
---
.../drivers/panfrost/midgard/midgard_compile.c| 11 ---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/src/gallium/drivers/panfrost/midgard/midgard_compile.c
b/src/gallium/drivers/panfrost/midgard/midgard_compile.c
index d121fde
Passes dEQP-GLES3.functional.texture.format.unsized.*3d*
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_resource.c | 47 ++---
1 file changed, 42 insertions(+), 5 deletions(-)
diff --git a/src/gallium/drivers/panfrost/pan_resource.c
b/src/gallium/drivers/
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/include/panfrost-job.h | 3 +++
src/gallium/drivers/panfrost/pan_context.c | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/gallium/drivers/panfrost/include/panfrost-job.h
b/src/gallium/drivers/pa
These make manipulating vectors in the Midgard compiler easier.
Signed-off-by: Alyssa Rosenzweig
---
.../panfrost/midgard/midgard_compile.c| 36 +++
1 file changed, 30 insertions(+), 6 deletions(-)
diff --git a/src/gallium/drivers/panfrost/midgard/midgard_compile.c
b/sr
Tag to the 3D texture series. With this it passes 100% of
dEQP-GLES3.functional.texture.format.unsized.*
I plan to squash this in but don't want to resend the whole series just
for this.
Signed-off-by: Alyssa Rosenzweig
---
src/gallium/drivers/panfrost/pan_resource.c | 2 ++
1 file changed, 2 i
Am 14.06.2019 08:13, schrieb Jan Vesely:
On Thu, 2019-06-13 at 21:20 +0200, Dieter Nützel wrote:
Am 13.06.2019 07:10, schrieb Marek Olšák:
> FYI, I just pushed the new linker.
>
> Marek
Thank you very much Marek and _Nicolai_ for this GREAT stuff.
It brings back some speed after 1/8 drop with g
Fixes the following building errors and resolves Bug 110922
Fixes gallium_dri target missing symbols at linking.
external/mesa/src/gallium/winsys/virgl/drm/Android.mk:
error: libmesa_winsys_virgl (STATIC_LIBRARIES android-x86_64) missing
libmesa_winsys_virgl_common (STATIC_LIBRARIES android-x86_6
Hi,
there is a typo in the commit title, the library is
libmesa_winsys_virgl_common
I will correct it in the final commit
Mauro
On Sat, Jun 15, 2019 at 7:39 AM Mauro Rossi wrote:
> Fixes the following building errors and resolves Bug 110922
> Fixes gallium_dri target missing symbols at linking.
56 matches
Mail list logo