Hi,
On 21 February 2018 at 21:24, Jason Ekstrand wrote:
> On Wed, Feb 21, 2018 at 1:22 PM, Jason Ekstrand
> wrote:
>>> + uint32_t n = 0;
>>> + uint32_t counts[2];
>>> + uint64_t *modifiers[2];
>>> +
>>> + if (mod_reply->num_drawable_modifiers) {
>>> + counts[n] = mod_reply->num_draw
On Wed, Feb 21, 2018 at 1:22 PM, Jason Ekstrand
wrote:
> On Wed, Feb 21, 2018 at 6:05 AM, Daniel Stone
> wrote:
>
>> Adds support for multiple planes and buffer modifiers.
>>
>> v4: Rename "has_dri3_v1_1" to "has_dri3_modifiers"
>> Signed-off-by: Daniel Stone
>> ---
>> src/vulkan/wsi/wsi_commo
On Wed, Feb 21, 2018 at 6:05 AM, Daniel Stone wrote:
> Adds support for multiple planes and buffer modifiers.
>
> v4: Rename "has_dri3_v1_1" to "has_dri3_modifiers"
> Signed-off-by: Daniel Stone
> ---
> src/vulkan/wsi/wsi_common_x11.c | 185 ++
> ++
> 1 file
Adds support for multiple planes and buffer modifiers.
v4: Rename "has_dri3_v1_1" to "has_dri3_modifiers"
Signed-off-by: Daniel Stone
---
src/vulkan/wsi/wsi_common_x11.c | 185
1 file changed, 168 insertions(+), 17 deletions(-)
diff --git a/src/vulkan/ws