The best way to make this code more readable is to replace it entirely.
It's horribly overcomplicated for what is basically an open-coded hash
table. I've had various starts at that...but never quite managed to
finish. :( You could probably grab iris_program_cache.c from my iris
branch, make it w
Ping?
I'm just adding `const` to make it easier to read and understand the
code, and allow the compiler to tell us if we make a mistake and start
modifying things shouldn't.
On Tuesday, 2018-08-07 12:02:53 +0100, Eric Engestrom wrote:
> Signed-off-by: Eric Engestrom
> ---
> v2: forgot the hunk th
Signed-off-by: Eric Engestrom
---
v2: forgot the hunk that was the point of this :facepalm:
---
src/mesa/drivers/dri/i965/brw_program_cache.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/mesa/drivers/dri/i965/brw_program_cache.c
b/src/mesa/drivers/dri/i965