Kenneth Graunke writes:
> With the textureRect support and GL_CLAMP workarounds, it's grown
> sufficiently that it deserves its own function. Separating it out
> makes the original function much more readable.
This looks good.
> While we're refactoring it, tidy up a conditional. Instead of:
With the textureRect support and GL_CLAMP workarounds, it's grown
sufficiently that it deserves its own function. Separating it out
makes the original function much more readable.
While we're refactoring it, tidy up a conditional. Instead of:
if (gen < 6 && rect)
...
else if (rect)