On Mon, Jan 25, 2016 at 6:56 AM, Timothy Arceri
wrote:
> + /* If the program is made up of only a single stage assign locations if
> + * its a SSO or remove unused inputs for a fragment only program.
> + */
> + if (first == last) {
> + gl_shader *const sh = prog->_Lin
The existing code was very hard to follow and has been the source
of at least 3 bugs in the past year.
The existing code also has a bug for SSO where if we have a
multi-stage SSO for example a tes -> gs program, if we try to use
transform feedback with gs the existing code would look for the
trans