Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-23 Thread Jason Ekstrand
On Thu, Apr 23, 2015 at 10:14 AM, Emil Velikov wrote: > On 13/04/15 01:51, Matt Turner wrote: >> On Sun, Apr 12, 2015 at 6:38 PM, Jason Ekstrand wrote: >>> >>> On Apr 12, 2015 3:24 PM, "Thomas Helland" wrote: Hi, This looks correct as far as I can tell. I have some comme

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-23 Thread Emil Velikov
On 13/04/15 01:51, Matt Turner wrote: > On Sun, Apr 12, 2015 at 6:38 PM, Jason Ekstrand wrote: >> >> On Apr 12, 2015 3:24 PM, "Thomas Helland" wrote: >>> >>> Hi, >>> >>> This looks correct as far as I can tell. >>> I have some comments inline, but I don't feel strongly about >>> either of them, s

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-22 Thread Connor Abbott
On Wed, Apr 22, 2015 at 6:06 PM, Jason Ekstrand wrote: > On Wed, Apr 22, 2015 at 3:03 PM, Connor Abbott wrote: >> I think it would be better to call this "nir_vector" rather than >> "nir_array," since this is essentially a poor man's version of >> std::vector<>. Is this ok with you? > > I battled

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-22 Thread Jason Ekstrand
On Wed, Apr 22, 2015 at 3:03 PM, Connor Abbott wrote: > I think it would be better to call this "nir_vector" rather than > "nir_array," since this is essentially a poor man's version of > std::vector<>. Is this ok with you? I battled over that one for quite a while. In the end, I settled on nir_

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-22 Thread Connor Abbott
I think it would be better to call this "nir_vector" rather than "nir_array," since this is essentially a poor man's version of std::vector<>. Is this ok with you? On Fri, Apr 10, 2015 at 8:48 PM, Jason Ekstrand wrote: > --- > src/glsl/nir/nir_array.h | 96 >

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-12 Thread Matt Turner
On Sun, Apr 12, 2015 at 6:38 PM, Jason Ekstrand wrote: > > On Apr 12, 2015 3:24 PM, "Thomas Helland" wrote: >> >> Hi, >> >> This looks correct as far as I can tell. >> I have some comments inline, but I don't feel strongly about >> either of them, so do as you please. >> >> Also, maybe this is a

Re: [Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-12 Thread Jason Ekstrand
On Apr 12, 2015 3:24 PM, "Thomas Helland" wrote: > > Hi, > > This looks correct as far as I can tell. > I have some comments inline, but I don't feel strongly about > either of them, so do as you please. > > Also, maybe this is a candidate for /src/util ? Maybe. If so I'm OK leaving it here until

[Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-12 Thread Thomas Helland
Hi, This looks correct as far as I can tell. I have some comments inline, but I don't feel strongly about either of them, so do as you please. Also, maybe this is a candidate for /src/util ? 2015-04-11 2:48 GMT+02:00 Jason Ekstrand : > --- > src/glsl/nir/nir_array.h | 96 >

[Mesa-dev] [PATCH 09/12] nir: Add a simple growing array data structure

2015-04-10 Thread Jason Ekstrand
--- src/glsl/nir/nir_array.h | 96 1 file changed, 96 insertions(+) create mode 100644 src/glsl/nir/nir_array.h diff --git a/src/glsl/nir/nir_array.h b/src/glsl/nir/nir_array.h new file mode 100644 index 000..1db4e8c --- /dev/null +++ b/src/gl