Hi,
> This adds uses of alloca, without a corresponding include of alloca.h.
>
> Perhaps something like the attached is needed?
Yes, sorry!
Reviewed-by: Mathias Fröhlich
best
Mathias
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https:
On 28/03/2018 11:35, mathias.froehl...@gmx.net wrote:
Avoid using malloc in the draw path of mesa.
Since the draw_count is a user api input, fall back to malloc if
the amount of consumed stack space may get too high.
Signed-off-by: Mathias Fröhlich
---
src/mesa/vbo/vbo_context.c | 70 +++
Hi Brian,
> Can you just rename 'space' to 'prim' and rm the prim = space assignment
> below?
>
> Also, could you put a comment on this function to explain the draw_count
> and space/prim parameters, at least?
I'll try my best!
> Other than that, the series looks good.
>
> Reviewed-by: Brian
On 03/28/2018 04:35 AM, mathias.froehl...@gmx.net wrote:
From: Mathias Fröhlich
Marek,
you mean with the below patch as the 9-th change in the series?
I would like to keep that change seprarate from #3 since patch #3
just moves the already existing impelentation to the driver_functions
level
Yes, it looks good.
Marek
On Wed, Mar 28, 2018 at 6:35 AM, wrote:
> From: Mathias Fröhlich
>
>
> Marek,
>
> you mean with the below patch as the 9-th change in the series?
> I would like to keep that change seprarate from #3 since patch #3
> just moves the already existing impelentation to the
From: Mathias Fröhlich
Marek,
you mean with the below patch as the 9-th change in the series?
I would like to keep that change seprarate from #3 since patch #3
just moves the already existing impelentation to the driver_functions
level using the exactly identical implementation except calling i