On 03/23/2018 03:20 PM, Tomasz Figa wrote:
On Fri, Mar 23, 2018 at 10:15 PM, Stefan Schake wrote:
On Fri, Mar 23, 2018 at 1:02 PM, Tomasz Figa wrote:
On Fri, Mar 23, 2018 at 8:52 PM, Robert Foss wrote:
Hey Chih-Wei,
On 03/23/2018 03:43 AM, Chih-Wei Huang wrote:
2018-03-22 16:23 GMT+08
Yes, this fixes the app where I saw this issue, thanks!
Tested-by: Tapani Pälli
On 03/23/2018 10:54 PM, Ian Romanick wrote:
From: Ian Romanick
A recent commit (see below) triggered some cases where conditional
modifier propagation and dead code elimination would cause a MAD
instruction like
https://bugs.freedesktop.org/show_bug.cgi?id=105738
gloriouseggr...@gmail.com changed:
What|Removed |Added
OS|All |Linux (All)
Compone
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #17 from Timothy Arceri ---
We still need to create a piglit test for this but here is the fix for NIR
also:
https://patchwork.freedesktop.org/patch/212882/
It seems once the loop in unrolled NIR then optimises this whole shader do
When an if nesting inside anouther if is optimised away we can
end up with a loop terminator and following block that looks like
this:
if ssa_596 {
block block_5:
/* preds: block_4 */
vec1 32 ssa_601 = load_const (0x /* -nan */)
https://bugs.freedesktop.org/show_bug.cgi?id=105738
--- Comment #2 from gloriouseggr...@gmail.com ---
for clarification I am currently on an RX Vega 64, llvm 6.0.0, 4.16rc3 kernel
(tested 4.15 and had the same problem)
--
You are receiving this mail because:
You are the assignee for the bug.
You
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #16 from i...@yahoo.com ---
(In reply to Timothy Arceri from comment #15)
> Here is a fix for drivers that use GLSL IR loop unrolling. I'm still looking
> into NIR unrolling it seems there is a different bug in that pass.
>
> https:/
https://bugs.freedesktop.org/show_bug.cgi?id=105738
--- Comment #1 from gloriouseggr...@gmail.com ---
Created attachment 138351
--> https://bugs.freedesktop.org/attachment.cgi?id=138351&action=edit
warframe weird bar
--
You are receiving this mail because:
You are the QA Contact for the bug.
Y
https://bugs.freedesktop.org/show_bug.cgi?id=105738
Bug ID: 105738
Summary: commit f7ffa504a065dc2631fd38cc5fe885b277f4e7e7 causes
artifacting in radv
Product: Mesa
Version: git
Hardware: Other
OS: All
Pierre Moreau writes:
> Signed-off-by: Pierre Moreau
> ---
> src/gallium/state_trackers/clover/api/program.cpp | 23
> +-
> src/gallium/state_trackers/clover/core/program.cpp | 3 ++-
> 2 files changed, 16 insertions(+), 10 deletions(-)
>
> diff --git a/src/gallium/state_
https://bugs.freedesktop.org/show_bug.cgi?id=105737
Bug ID: 105737
Summary: st_tests_common.cpp:140:42: error: no matching
function for call to 'tgsi_get_opcode_info'
Product: Mesa
Version: git
Hardware: x86-64 (AMD64)
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #15 from Timothy Arceri ---
Here is a fix for drivers that use GLSL IR loop unrolling. I'm still looking
into NIR unrolling it seems there is a different bug in that pass.
https://patchwork.freedesktop.org/patch/212881/
--
You are
Just checking for 2 jumps is not enough to be sure we can do a
complex loop unroll. We need to make sure we also have also found
2 loop terminators.
Without this we were attempting to unroll a loop where the second
jump was nesed inside multiple ifs which loop analysis is unable
to detect as a ter
Rb
On March 25, 2018 11:11:10 Rob Clark wrote:
This is supposed to have both BASE and COMPONENT but num_indices was
inadvertantly set to 1.
Cc:
Signed-off-by: Rob Clark
---
src/compiler/nir/nir_intrinsics.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/compiler/nir/n
Signed-off-by: Samuel Pitoiset
---
src/amd/vulkan/radv_cmd_buffer.c | 7 +--
src/amd/vulkan/radv_pass.c | 12 ++--
src/amd/vulkan/radv_private.h| 1 +
3 files changed, 16 insertions(+), 4 deletions(-)
diff --git a/src/amd/vulkan/radv_cmd_buffer.c b/src/amd/vulkan/radv_cmd
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query.c
b/src/gallium/drivers/etnaviv/etnaviv_query.c
index 00f87d22cb..b076e87e78 100644
--- a/src/gal
Prep work for AMD_performance_monitor support.
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 48 +-
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 9 +
2 files changed, 56 insertions(+), 1 deletion(-)
diff --git a/src/galliu
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 42 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 7 +
2 files changed, 49 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etn
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 63 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 10
2 files changed, 73 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etna
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 45 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 5 +++
2 files changed, 50 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etnav
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 21 +
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 4
2 files changed, 25 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etnaviv/e
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 49 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 8 +
2 files changed, 57 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etn
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 28 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 6 ++
2 files changed, 34 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/et
Add needed infrastructure to use performance monitor
requests for queries.
Signed-off-by: Christian Gmeiner
---
configure.ac | 2 +-
meson.build| 2 +-
src/gallium/drivers/etnaviv/Makefile.sources | 2 +
sr
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 63 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 10
2 files changed, 73 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etna
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 35 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 6 +
2 files changed, 41 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etn
Starting with kernel 4.16 the etnaviv driver exports perfmon domains
and signals to userspace. This patch series adds support for those
queries to mesa and exposes them via amd_performance_monitor.
Passes all amd_performance_monitor piglits.
Christian Gmeiner (12):
etnaviv: add perfmon query im
Signed-off-by: Christian Gmeiner
---
src/gallium/drivers/etnaviv/etnaviv_query_pm.c | 14 ++
src/gallium/drivers/etnaviv/etnaviv_query_pm.h | 3 +++
2 files changed, 17 insertions(+)
diff --git a/src/gallium/drivers/etnaviv/etnaviv_query_pm.c
b/src/gallium/drivers/etnaviv/etnaviv_q
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #14 from almos ---
(In reply to Roland Scheidegger from comment #5)
> (In reply to almos from comment #4)
> > The problem is not loop unrolling. The problem is that userspace code can
> > hang the GPU unrecoverably, and thus bringing
From: Mathias Fröhlich
Hi,
This series pushes the inputs array down into the driver backends.
Also the draw code paths get cleaned up to use the higher level
function entry points from the driver functions struct.
And finally vbo_split* can now be moved into the tnl module.
This step is meant o
From: Mathias Fröhlich
Signed-off-by: Mathias Fröhlich
---
src/mesa/drivers/dri/i915/intel_context.c | 1 +
src/mesa/drivers/dri/i965/brw_draw.c | 4 +--
src/mesa/drivers/dri/nouveau/nouveau_context.c | 1 +
src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c | 21 -
sr
From: Mathias Fröhlich
Let the i965 backend have its own gl_vertex_array array and basically
reimplement the way _vbo_draw works.
Note that brw_draw_indirect_prims calls brw_draw_prims internally
and gets its update to Array._DrawArray by this way.
Signed-off-by: Mathias Fröhlich
---
src/mesa/
From: Mathias Fröhlich
Let the gallium backend have its own gl_vertex_array array and basically
reimplement the way _vbo_draw works.
Signed-off-by: Mathias Fröhlich
---
src/mesa/state_tracker/st_cb_feedback.c | 35 ++---
src/mesa/state_tracker/st_context.c | 9
From: Mathias Fröhlich
Signed-off-by: Mathias Fröhlich
---
src/mesa/vbo/vbo_exec_array.c| 2 --
src/mesa/vbo/vbo_primitive_restart.c | 1 -
2 files changed, 3 deletions(-)
diff --git a/src/mesa/vbo/vbo_exec_array.c b/src/mesa/vbo/vbo_exec_array.c
index 51fd434dc4..b3ce138a09 100644
---
From: Mathias Fröhlich
Remove the vbo_indirect_draw_func vbo callback and make the default
implementation use the drivers main draw callback function directly.
This will be needed with the next changes when drivers without own main
drivers DrawIndirect implementation get moved to the main drivers
From: Mathias Fröhlich
The legacy draw paths from back before 2012 contained a gl_vertex_array
array for the inputs to be used for draw. So all draw methods from legacy
drivers and evereything that goes through tnl are originally written
for this calling convention. The same goes for tools like t
From: Mathias Fröhlich
Move the files, adapt to the naming scheme in tnl, update callers
and build system.
Signed-off-by: Mathias Fröhlich
---
src/mesa/Makefile.sources | 10 +--
src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c | 4 +-
src/mesa/meson.build
From: Mathias Fröhlich
Signed-off-by: Mathias Fröhlich
---
src/mesa/drivers/common/driverfuncs.c | 2 +-
src/mesa/main/state.c | 12 ++---
src/mesa/vbo/vbo.h| 20 ---
src/mesa/vbo/vbo_context.c| 47
The driver only supports the required formats for now.
Signed-off-by: Samuel Pitoiset
---
src/amd/vulkan/radv_device.c | 35 ++-
src/amd/vulkan/radv_formats.c | 36
2 files changed, 70 insertions(+), 1 deletion(-)
diff --git
Signed-off-by: Samuel Pitoiset
---
src/amd/vulkan/radv_extensions.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/amd/vulkan/radv_extensions.py
b/src/amd/vulkan/radv_extensions.py
index 896cc62459..36f2d61d59 100644
--- a/src/amd/vulkan/radv_extensions.py
+++ b/src/amd/vulkan/radv_ext
This is supposed to have both BASE and COMPONENT but num_indices was
inadvertantly set to 1.
Cc:
Signed-off-by: Rob Clark
---
src/compiler/nir/nir_intrinsics.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/compiler/nir/nir_intrinsics.h
b/src/compiler/nir/nir_intrinsic
I threatened to do this a long time ago.. I probably *should* have done
it a long time ago when there where many fewer intrinsics. But the
system of macro/#include magic for dealing with intrinsics is a bit
annoying, and python has the nice property of optional fxn params,
making it possible to de
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/platform.cpp | 2 ++
src/gallium/state_trackers/clover/core/device.cpp | 8 +++-
2 files changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/gallium/state_trackers/clover/api/platform.cpp
Signed-off-by: Pierre Moreau
---
New in v5
src/gallium/state_trackers/clover/Makefile.am | 15 ++-
src/gallium/state_trackers/clover/Makefile.sources | 4 +
src/gallium/state_trackers/clover/meson.build | 10 +-
.../state_trackers/clover/spirv/invocation.cpp | 138 +
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
Changes in v5:
* Add a comment saying where to find llvm-spirv (Karol Herbst).
configure.ac | 18 ++
meson.build | 8
2 files changed, 26 insertions(+)
diff --git a/configure.ac b/configure.ac
index 99805e0f2
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/device.cpp | 7 +++
1 file changed, 7 insertions(+)
diff --git a/src/gallium/state_trackers/clover/api/device.cpp
b/src/gallium/state_trackers/clover/api/device.cpp
index 4e274c5005..ac6e4e0185
Signed-off-by: Pierre Moreau
---
Changes in v5:
* Use is_binary_spirv and is_valid_spirv from the SPIR-V backend;
* Drop the SPIRV-Tools and llvm-spirv dependencies on clover.
src/gallium/state_trackers/clover/api/dispatch.hpp | 4 ++
src/gallium/state_trackers/clover/api/program.cpp | 60
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/dispatch.cpp | 2 +-
src/gallium/state_trackers/clover/api/program.cpp | 8
2 files changed, 9 insertions(+), 1 deletion(-)
diff --git a/src/gallium/state_trackers/clover/api/dispatch.cpp
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/program.cpp | 7 +++
1 file changed, 7 insertions(+)
diff --git a/src/gallium/state_trackers/clover/api/program.cpp
b/src/gallium/state_trackers/clover/api/program.cpp
index 3c7e56efb9..851a212b99 100644
--- a/src/galliu
Signed-off-by: Pierre Moreau
---
.../state_trackers/clover/llvm/invocation.cpp | 29 ++
.../state_trackers/clover/llvm/invocation.hpp | 6 +
src/gallium/state_trackers/clover/meson.build | 2 +-
3 files changed, 36 insertions(+), 1 deletion(-)
diff --git
Reviewed-by: Francisco Jerez
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/platform.cpp | 4 ++--
src/gallium/state_trackers/clover/core/platform.cpp | 5 +
src/gallium/state_trackers/clover/core/platform.hpp | 2 ++
3 files changed, 9 inse
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
include/CL/cl_ext.h | 37 +
1 file changed, 37 insertions(+)
diff --git a/include/CL/cl_ext.h b/include/CL/cl_ext.h
index 5078e8f45f..5ea4968042 100644
--- a/include/CL/cl_ext.h
+++ b/include/CL/cl_ex
Reviewed-by: Francisco Jerez
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/device.cpp | 11 +--
src/gallium/state_trackers/clover/core/device.cpp | 14 ++
src/gallium/state_trackers/clover/core/device.hpp | 1 +
3 files cha
One flag that needs to be tracked is whether a library is allowed to
received mathematics optimisations or not, as the authorisation is given
when creating the library while the optimisations are specified when
creating the executable.
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
s
If creating a library, do not allow non-compiled object in it, as
executables are not allowed, and libraries would make it really hard to
enforce the "-enable-link-options" flag.
Reviewed-by: Francisco Jerez
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/c
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/program.cpp | 23 +-
src/gallium/state_trackers/clover/core/program.cpp | 3 ++-
2 files changed, 16 insertions(+), 10 deletions(-)
diff --git a/src/gallium/state_trackers/clover/api/program.cpp
b/src/g
From: Karol Herbst
Reviewed-by: Pierre Moreau
Signed-off-by: Karol Herbst
---
v5: Fix return type of clCreateCommandQueueWithProperties
v2: add more prototypes
src/gallium/state_trackers/clover/api/dispatch.cpp | 29 +++-
src/gallium/state_trackers/clover/api/dispatch.hpp | 190 +
Reviewed-by: Aaron Watry
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/core/device.cpp | 6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/src/gallium/state_trackers/clover/core/device.cpp
b/src/gallium/state_trackers/clover/c
Acked-by: Francisco Jerez
Reviewed-by: Karol Herbst
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/api/device.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/gallium/state_trackers/clover/api/device.cpp
b/src/gallium/sta
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/Makefile.am | 11 +-
src/gallium/state_trackers/clover/Makefile.sources | 4 -
src/gallium/state_trackers/clover/core/program.cpp | 13 +--
src/gallium/state_trackers/clover/meson.build |
From the OpenCL 1.2 Specification, Section 5.6.2 (about clBuildProgram):
> If program is created with clCreateProgramWithBinary, then the
> program binary must be an executable binary (not a compiled binary or
> library).
Reviewed-by: Aaron Watry
Signed-off-by: Pierre Moreau
---
src/gallium/st
Reviewed-by: Aaron Watry
Reviewed-by: Karol Herbst
Signed-off-by: Pierre Moreau
---
src/gallium/state_trackers/clover/core/device.cpp | 6 ++
src/gallium/state_trackers/clover/core/device.hpp | 1 +
2 files changed, 7 insertions(+)
diff --git a/src/gallium/state_trackers/clover/core/device
Hello,
This has only minor changes compared to the previous version, but as it
introduces a new patch, I preferred to resend the whole series, as patch
numbering would be messed up otherwise.
As is_valid_spirv will be also used by the SPIR-V backend, I moved that
function away from api/program.cp
Build mesa 7289 failed
Commit 2f181c8c18 by Rob Clark on 3/12/2018 7:00 PM:
glsl_types: vec8/vec16 support\n\nNot used in GL but 8 and 16 component vectors exist in OpenCL.\n\nSigned-off-by: Rob Clark \nReviewed-by: Timothy Arceri
Configure your noti
Cool. Thanks. Will update the patch.
-Original Message-
From: Palli, Tapani
Sent: Friday, March 23, 2018 4:59 PM
To: Lin, Johnson ; Alejandro Piñeiro
; mesa-dev@lists.freedesktop.org
Subject: Re: [Mesa-dev] [PATCH] mesa: readpixels add support for GL_HALF_FLOAT
On 03/23/2018 07:54 AM,
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #13 from Gert Wollny ---
The GLSL spec says that "negative zeros are generated as dictated by IEEE" and
that "==" returns the correct result, which I'd assume means (0.0 == -0.0) is
true.
In any case, I don't see how this is releva
On Sun, Mar 25, 2018 at 2:18 PM, Rob Clark wrote:
> On Sun, Mar 25, 2018 at 6:35 AM, Karol Herbst wrote:
>> On Sun, Mar 25, 2018 at 12:18 AM, Rob Clark wrote:
>>> On Fri, Mar 23, 2018 at 5:18 PM, Jason Ekstrand
>>> wrote:
On Fri, Mar 23, 2018 at 2:15 PM, Karol Herbst wrote:
>
> O
On Sun, Mar 25, 2018 at 6:35 AM, Karol Herbst wrote:
> On Sun, Mar 25, 2018 at 12:18 AM, Rob Clark wrote:
>> On Fri, Mar 23, 2018 at 5:18 PM, Jason Ekstrand wrote:
>>> On Fri, Mar 23, 2018 at 2:15 PM, Karol Herbst wrote:
On Fri, Mar 23, 2018 at 10:07 PM, Jason Ekstrand
wrote:
>>
On Sun, Mar 25, 2018 at 12:18 AM, Rob Clark wrote:
> On Fri, Mar 23, 2018 at 5:18 PM, Jason Ekstrand wrote:
>> On Fri, Mar 23, 2018 at 2:15 PM, Karol Herbst wrote:
>>>
>>> On Fri, Mar 23, 2018 at 10:07 PM, Jason Ekstrand
>>> wrote:
>>> > +list
>>> >
>>> > On Fri, Mar 23, 2018 at 1:45 PM, Karol
https://bugs.freedesktop.org/show_bug.cgi?id=105670
--- Comment #12 from i...@yahoo.com ---
(In reply to Gert Wollny from comment #11)
> The if statement can be be true because
> which means at this point R3.w can be zero.
But that's the point in my initial question.
When R3.w=0.0, will "if(+0.
On Wed, Mar 21, 2018 at 05:09:17PM +, Eric Engestrom wrote:
> Cc: Maxin B. John
> Cc: Khem Raj
> Suggested-by: Jon Turney
> Signed-off-by: Eric Engestrom
> ---
> configure.ac| 1 +
> meson.build | 2 +-
> src/util/u_endian.h | 2 +-
> 3 files changed, 3 insertions(+), 2 del
71 matches
Mail list logo