On Fri, Aug 26, 2016 at 11:03 PM, Timothy Arceri
wrote:
> V2: Do a "depth first search" to convert to LCSSA
>
> V3: Small comment fixup
>
> V4: Rebase, adapt to removal of function overloads
>
> V5: Rebase, adapt to relocation of nir to compiler/nir
> Still need to adapt to potential if-uses
>
On Sat, 2016-08-27 at 07:52 -0700, Jason Ekstrand wrote:
> Hey Timothy,
> > > Thanks for working on this! Looks like you're making pretty good
progress. I'm going to try and give the series a hard look some time
next week.
Thanks that would be great. I'll try to get an new series out tomorrow
wi
On Sat, 2016-08-27 at 14:08 +0200, Thomas Helland wrote:
> 2016-08-27 8:03 GMT+02:00 Timothy Arceri m>:
> >
> > This pass detects induction variables and calculates the
> > trip count of loops to be used for loop unrolling.
> >
> > I've removed support for float induction values for now, for the
On Sat, 2016-08-27 at 16:06 +0200, Thomas Helland wrote:
> 2016-08-27 8:03 GMT+02:00 Timothy Arceri m>:
> >
> > We generate these in each optimisation pass, counting them
> > as progress would cause the loop to run forever.
>
> These are just some random thoughts that I thought I'd share.
> It m
On Aug 27, 2016 5:51 PM, "Mauro Rossi" wrote:
>
> Hi Emil, Jason, Tapani,
>
> this weekend I had planned to check mesa-dev with marshmallow-x86 and
> nougat-x86,builds,
> so here you can find the port to android of commit
> bebc1a1d995e33f173ea207848bcddd81f6dd19a
>
> Built successfully and tested
Hi Emil, Jason, Tapani,
this weekend I had planned to check mesa-dev with marshmallow-x86 and
nougat-x86,builds,
so here you can find the port to android of commit
bebc1a1d995e33f173ea207848bcddd81f6dd19a
Built successfully and tested on Sandybridge.
Added also the same formatted patch as attachm
On Sat, Aug 27, 2016 at 8:01 PM, Ilia Mirkin wrote:
> Experimentally, this is required for glxgears and others to display the
> proper colors.
>
> Signed-off-by: Ilia Mirkin
> ---
> src/mesa/drivers/dri/nouveau/nv20_state_frag.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --
Experimentally, this is required for glxgears and others to display the
proper colors.
Signed-off-by: Ilia Mirkin
---
src/mesa/drivers/dri/nouveau/nv20_state_frag.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/mesa/drivers/dri/nouveau/nv20_state_frag.c
b/src/mesa/driv
NV34 and possibly other NV3x hardware has the capability of exposing the
NV25 graph class. This allows forcing nouveau_vieux to be used instead
of the gallium driver, primarily for testing purposes. (Among other
things, NV2x only ever came as AGP or inside an Xbox, never PCI/PCIe).
Signed-off-by:
This is identical to OES_texture_cube_map_array support. dEQP has tests
which use this extension. Also it is part of AEP.
Signed-off-by: Ilia Mirkin
---
src/compiler/glsl/builtin_functions.cpp | 2 ++
src/compiler/glsl/builtin_types.cpp | 2 ++
src/compiler/glsl/glsl_lexer.ll |
Signed-off-by: Ilia Mirkin
---
docs/features.txt | 4 ++--
docs/relnotes/12.1.0.html | 4 ++--
src/mesa/state_tracker/st_extensions.c | 14 ++
3 files changed, 18 insertions(+), 4 deletions(-)
diff --git a/docs/features.txt b/docs/features.txt
inde
https://bugs.freedesktop.org/show_bug.cgi?id=95346
Alexander Tsoy changed:
What|Removed |Added
URL|http://www.memonic.com/user |
|/pharmacy/id/1Fzdh
This extension should just be available whenever ES 3.1 is available.
With the new extension verification infrastructure, it will only be
enable-able on a #version 310 es shader, rendering the original reason
for having a separate enable moot.
Signed-off-by: Ilia Mirkin
---
src/mesa/drivers/dri/
Signed-off-by: Jordan Justen
Acked-by: Kenneth Graunke
---
docs/features.txt| 2 +-
src/mesa/drivers/dri/i965/intel_extensions.c | 3 ++-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/docs/features.txt b/docs/features.txt
index 26e8ff7..218fa6c 100644
Am 25.08.2016 11:09, schrieb Michel Dänzer:
On 24/08/16 06:35 AM, Eric Anholt wrote:
Michel Dänzer writes:
On 20/08/16 04:42 AM, Eric Anholt wrote:
Michel Dänzer writes:
From: Michel Dänzer
Always use 3 buffers when flipping. With only 2 buffers, we have to
wait
for a flip to complete (
On Sat, 2016-08-27 at 12:05 -0400, Rhys Kidd wrote:
> As reported by Clang, TGSI_OPCODE_DFMA (defined magic number 118) is
> currently initialized twice for Cayman and Evergreen.
> When Jan Vesely added double precision FMA opcode it did make sense
> to locate it immediately after TGSI_OPCODE_DMAD,
On Fri, 2016-08-26 at 17:25 +0100, Eric Engestrom wrote:
> On Fri, Aug 26, 2016 at 04:21:14PM +0200, Kai Wasserbäch wrote:
> >
> > Hey Eric,
> > Eric Engestrom wrote on 26.08.2016 15:49:
> > >
> > > On Fri, Aug 26, 2016 at 03:14:57PM +0200, Kai Wasserbäch wrote:
> > > >
> > > > Brian Paul wrote
Having run Mesa through Clang on Eric Anholt's Travis harness, these small
code clean ups improve readability of TGSI code in r600g and may avoid
future problems.
Series also can be found at:
https://github.com/Echelon9/mesa/tree/fix/r600g-cleanup-tgsi-opcodes
I don't have the hardware to test th
As reported by Clang, TGSI_OPCODE_DFMA (defined magic number 118) is
currently initialized twice for Cayman and Evergreen.
When Jan Vesely added double precision FMA opcode it did make sense
to locate it immediately after TGSI_OPCODE_DMAD, although this is
out of order.
This change cleans up the
Small code clean up that removes magic numbers where a TGSI
opcode has been defined.
No functional change expected as each opcode is unsupported on
the respective hardware.
Signed-off-by: Rhys Kidd
---
src/gallium/drivers/r600/r600_shader.c | 14 +++---
src/gallium/include/pipe/p_sh
From: Rhys Kidd
Noticed this error in a debug message whilst reviewing
https://bugs.freedesktop.org/show_bug.cgi?id=97477
This patch doesn't go towards fixing that bug, but at
least may clarify future debug output.
Signed-off-by: Rhys Kidd
---
I don't have the hardware to actually test this, b
Hey Timothy,
Thanks for working on this! Looks like you're making pretty good
progress. I'm going to try and give the series a hard look some time next
week.
On Aug 26, 2016 11:03 PM, "Timothy Arceri"
wrote:
> This series does the equivalent of the simple unroll in GLSL IR. The
> main differe
https://bugs.freedesktop.org/show_bug.cgi?id=95346
Nelson changed:
What|Removed |Added
URL||http://www.memonic.com/user
|
2016-08-27 8:03 GMT+02:00 Timothy Arceri :
> We generate these in each optimisation pass, counting them
> as progress would cause the loop to run forever.
These are just some random thoughts that I thought I'd share.
It might not make sense at all, and it might be answered in the
patch series, but
This patch is:
Reviewed-by: Thomas Helland
2016-08-27 8:03 GMT+02:00 Timothy Arceri :
> This will be used by the loop unroll and lcssa passes.
> ---
> src/compiler/nir/nir.h | 8
> 1 file changed, 8 insertions(+)
>
> diff --git a/src/compiler/nir/nir.h b/src/compiler/nir/nir.h
> index
https://bugs.freedesktop.org/show_bug.cgi?id=97260
--- Comment #32 from Clésio Luiz ---
Padoka updated (mesa 12.1~git1600826212300.cf7be70~x~padoka0), so I made a test
with kernels 4.7.2 and 4.8 RC3. The problem persist.
The package xserver-xorg-video-ati from his PPA is from 08/24 though.
--
2016-08-27 8:03 GMT+02:00 Timothy Arceri :
> This pass detects induction variables and calculates the
> trip count of loops to be used for loop unrolling.
>
> I've removed support for float induction values for now, for the
> simple reason that they don't appear in my shader-db collection,
> and so
On Sat, Aug 27, 2016 at 4:12 AM, Ilia Mirkin wrote:
> On Fri, Aug 26, 2016 at 3:01 PM, Ryan Houdek wrote:
>> Most of the Tegra devices (K1 and above) provide desktop GL, except for the
>> Nexus devices which cut out that functionality.
>> Not sure how front buffers differ there, never checked.
>>
V2: Rebase onto the adaption of new hashing functions
Signed-off-by: Thomas Helland
---
src/compiler/glsl/ast_to_hir.cpp | 25 ++---
1 file changed, 14 insertions(+), 11 deletions(-)
diff --git a/src/compiler/glsl/ast_to_hir.cpp b/src/compiler/glsl/ast_to_hir.cpp
index 58136
Hey Michael,
Michael Schellenberger wrote on 26.08.2016 20:19:
> Am 26.08.2016 um 15:23 schrieb Kai Wasserbäch:
>> [...]
>> diff --git a/src/gallium/drivers/nouveau/nv30/nv30_texture.c
>> b/src/gallium/drivers/nouveau/nv30/nv30_texture.c
>> index 4f4f87e..e5d3db3 100644
>> --- a/src/gallium/driver
Hey Samuel,
Samuel Pitoiset wrote on 26.08.2016 20:22:
> On 08/26/2016 04:17 PM, Kai Wasserbäch wrote:
>> Hey Samuel,
>> Samuel Pitoiset wrote on 26.08.2016 15:54:
>>> On 08/26/2016 01:58 PM, Kai Wasserbäch wrote:
[...]
diff --git a/src/gallium/drivers/nouveau/nv30/nv30_texture.c
b/s
Signed-off-by: Kai Wasserbäch
---
src/gallium/auxiliary/cso_cache/cso_context.c | 2 +-
src/gallium/auxiliary/cso_cache/cso_context.h | 2 +-
src/gallium/auxiliary/draw/draw_context.c | 4 ++--
src/gallium/auxiliary/draw/draw_context.h | 4 ++--
src/gallium/auxiliary/draw/
Signed-off-by: Kai Wasserbäch
---
src/gallium/drivers/nouveau/nvc0/nvc0_state.c | 2 +-
src/gallium/drivers/radeonsi/si_descriptors.c | 8 +---
src/gallium/drivers/softpipe/sp_state_image.c | 2 +-
src/gallium/drivers/trace/tr_context.c| 2 +-
src/gallium/include/pipe/p_context.h
v1 → v2:
- Fixed indentation (noted by Brian Paul)
- Removed second assert from nouveau's switch statements (suggested by
Brian Paul)
Reviewed-by: Samuel Pitoiset
Signed-off-by: Kai Wasserbäch
---
src/gallium/auxiliary/cso_cache/cso_context.c | 7 ---
src/gallium/auxiliary/cso_cac
Signed-off-by: Kai Wasserbäch
---
src/gallium/auxiliary/cso_cache/cso_context.c | 3 ++-
src/gallium/auxiliary/cso_cache/cso_context.h | 3 ++-
src/gallium/drivers/ddebug/dd_context.c | 3 ++-
src/gallium/drivers/ilo/ilo_state.c | 2 +-
src/gallium/drivers/nouveau/nvc0/nvc0_state.
Hey everybody,
here is the complete series to switch from "unsigned shader" to
"enum pipe_shader_type" in the functions defined in p_context.h.
Please review and – if this series gets accepted – commit it for me, since I
do not have access for that.
Patch 1 already carries the R-b by Samuel.
All
When originally conceived the kernel context was just a plain wrapper
around the logical HW context. Since then it has evolved into a much
grander partitioning of driver state between different clients, it is
the basis for resource tracking and accountability and has an identical
role to the GL con
37 matches
Mail list logo