[Mesa-dev] [PATCH] mesa/st: add support for dynamic ubo selection

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- Brian reviewed the first bits of this, but it turns out I had to change src_register as well. Also I realized that instead of doing the UADD I could just index2D to 1 in order to generate something like 6: MOV TEMP[0], CONST[ADDR[1].x+1][ADDR[0].x] So... that's

Re: [Mesa-dev] [PATCH V2] glsl: remove unnecessary check

2014-07-19 Thread Ian Romanick
On 07/19/2014 03:24 AM, Timothy Arceri wrote: > On Sat, 2014-07-19 at 14:20 +1000, Timothy Arceri wrote: >> On Sat, 2014-07-19 at 12:25 +1000, Timothy Arceri wrote: >>> This code does nothing useful as the next recursive call on the array >>> element >>> will override any null values if the elemen

Re: [Mesa-dev] [PATCH 04/14] i965/gen7: Don't allocate hiz miptree structure

2014-07-19 Thread Jordan Justen
On Fri, Jul 18, 2014 at 1:58 AM, Pohjolainen, Topi wrote: > On Tue, Jul 15, 2014 at 06:32:12PM -0700, Jordan Justen wrote: >> We now skip allocating a hiz miptree for gen7. Instead, we calculate >> the required hiz buffer parameters and allocate a bo directly. >> >> Signed-off-by: Jordan Justen >

Re: [Mesa-dev] [PATCH 1/4] i965: Silence many unused parameter warnings

2014-07-19 Thread Matt Turner
On Sat, Jul 19, 2014 at 3:03 PM, Ian Romanick wrote: > On 07/15/2014 11:18 AM, Matt Turner wrote: >> You could just drop the brw from the function declaration, and avoid >> the (void)brw. That might be nicer. > > Unfortunately, that .h file is included from C files, and you can only > do that in C

Re: [Mesa-dev] [PATCH 1/4] i965: Silence many unused parameter warnings

2014-07-19 Thread Ian Romanick
On 07/15/2014 11:18 AM, Matt Turner wrote: > On Tue, Jul 15, 2014 at 10:56 AM, Ian Romanick wrote: >> From: Ian Romanick >> >> brw_inst.h: In function 'brw_inst_set_src1_vstride': >> brw_inst.h:118:76: warning: unused parameter 'brw' [-Wunused-parameter] >> >> Signed-off-by: Ian Romanick >> ---

[Mesa-dev] [Bug 79949] [DRI3] GTK+ Programs Not Updating Correctly

2014-07-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=79949 ava1ar changed: What|Removed |Added CC||m...@ava1ar.info -- You are receiving this mai

[Mesa-dev] [PATCH 2/3] r600g/compute: Allow compute_memory_defrag to defragment between resources

2014-07-19 Thread Bruno Jiménez
This will be used in the following patch to avoid duplicated code --- src/gallium/drivers/r600/compute_memory_pool.c | 11 ++- src/gallium/drivers/r600/compute_memory_pool.h | 1 + 2 files changed, 7 insertions(+), 5 deletions(-) diff --git a/src/gallium/drivers/r600/compute_memory_pool.

[Mesa-dev] [PATCH 0/3] r600g/compute: Implement grow+defrag for compute_memory_pool

2014-07-19 Thread Bruno Jiménez
Hi, This series is a follow up for the 'Adding support for defragmenting compute_memory_pool' series. It also sits on top of the patch I sent here: http://lists.freedesktop.org/archives/mesa-dev/2014-July/062923.html It modifies the function 'compute_memory_grow_pool' so it can defrag the pool at

[Mesa-dev] [PATCH 3/3] r600g/compute: Defrag the pool at the same time as we grow it

2014-07-19 Thread Bruno Jiménez
This allows us two things: we now need less item copies when we have to defrag+grow the pool (to just one copy per item) and, even in the case where we don't need to defrag the pool, we reduce the data copied to just the useful data that the items use. Note: The fallback path is a bit ugly now, bu

[Mesa-dev] [PATCH 1/3] r600g/compute: Allow compute_memory_move_item to move items between resources

2014-07-19 Thread Bruno Jiménez
--- src/gallium/drivers/r600/compute_memory_pool.c | 43 ++ src/gallium/drivers/r600/compute_memory_pool.h | 1 + 2 files changed, 25 insertions(+), 19 deletions(-) diff --git a/src/gallium/drivers/r600/compute_memory_pool.c b/src/gallium/drivers/r600/compute_memory_pool

Re: [Mesa-dev] [PATCH] gbm: Replace GBM_DRIVERS_PATH with LIBGL_DRIVERS_PATH

2014-07-19 Thread Kenneth Graunke
On Saturday, July 19, 2014 01:50:39 PM Emil Velikov wrote: > On 18/07/14 17:27, Kenneth Graunke wrote: > > On Friday, July 18, 2014 07:41:57 AM Dylan Baker wrote: > >> Currently mesa searches for two different environment variables, > >> LIBGL_DRIVERS_PATH and GBM_DRIVERS_PATH. The first is used fo

Re: [Mesa-dev] State of llvmpipe geometry shaders?

2014-07-19 Thread Paul
Brian Paul vmware.com> writes: > > On 07/11/2014 01:47 AM, Florian Link wrote: > > Hi everyone, > > > > I read a post from 2012 that MESA supports geometry shaders. I tried a > > current MESA 10.2.x release, but MESA GL_VERSION returns OpenGL version > > 3.0 (not 3.2) and the > > GL_ARB_geometry

[Mesa-dev] [PATCH 1/5] gallium: add tessellation shader types

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- src/gallium/auxiliary/tgsi/tgsi_info.c | 4 src/gallium/auxiliary/tgsi/tgsi_strings.c | 4 +++- src/gallium/auxiliary/tgsi/tgsi_strings.h | 2 +- src/gallium/include/pipe/p_defines.h | 6 -- src/gallium/include/pipe/p_shader_tokens.h | 4 +++- 5

[Mesa-dev] [PATCH 3/5] gallium: add new semantics for tessellation

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- An alternative to having TESSOUTER/INNER be separate is to create a single TESSFACTOR semantic with index 0 being the outer, and index 1 being the inner. I'm pretty ambivalent on the issue though. src/gallium/auxiliary/tgsi/tgsi_strings.c | 4 src/gallium/d

[Mesa-dev] [PATCH 2/5] gallium: add new PATCHES primitive type

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- src/gallium/auxiliary/tgsi/tgsi_strings.c | 3 ++- src/gallium/include/pipe/p_defines.h | 3 ++- 2 files changed, 4 insertions(+), 2 deletions(-) diff --git a/src/gallium/auxiliary/tgsi/tgsi_strings.c b/src/gallium/auxiliary/tgsi/tgsi_strings.c index be5534c.

[Mesa-dev] [PATCH 4/5] gallium: add interfaces for controlling tess program state

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- There are no docs on any of these shader states. I didn't want to create them as part of this change, since this is just a copy of whatever fs/vs/gs are doing. src/gallium/include/pipe/p_context.h | 10 ++ 1 file changed, 10 insertions(+) diff --git a/src

[Mesa-dev] [PATCH 5/5] gallium: add tessellation shader properties

2014-07-19 Thread Ilia Mirkin
Signed-off-by: Ilia Mirkin --- Please double-check my docs on what these things mean... I'm definitely weak on all the details, I just know that value X must be stuffed into card method Y and everything works :) I had an initial version that also fed the patch size to each of TCS and TES, but I

[Mesa-dev] [PATCH 0/5] gallium: add tessellation basics

2014-07-19 Thread Ilia Mirkin
This just adds the names of things, extends lists, adds a few function entrypoints. It's unlikely that this is everything that will need to be done to the gallium, interface, but I can't imagine a tessellation implementation without these things. So I thought I'd send it out before starting to poli

[Mesa-dev] [Bug 78773] Doom3 BFG doesnt start

2014-07-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=78773 --- Comment #9 from Jonathan Gray --- The latest RBDOOM-3-BFG git at the time of writing (485edfebc146c6c60fe4e918d7bb7b18e1e87f1b) seems to work fine with Mesa 10.2.3 on OpenBSD/amd64 with ivybridge mobile/HD4000 without needing to set any addi

Re: [Mesa-dev] [PATCH 0/2] Make a llvmpipe context basically thread safe.

2014-07-19 Thread Mathias Fröhlich
Hi Jose, Thanks for reviewing! On Thursday, July 17, 2014 16:01:50 Jose Fonseca wrote: > For patch 1 I'd prefer that instead of keeping a global list of > contexts, these are passed by the caller as argument to gallivm_create() > . It will be a more invasive change, but it will be cleaner. A

Re: [Mesa-dev] [PATCH] gbm: Replace GBM_DRIVERS_PATH with LIBGL_DRIVERS_PATH

2014-07-19 Thread Emil Velikov
On 18/07/14 17:27, Kenneth Graunke wrote: > On Friday, July 18, 2014 07:41:57 AM Dylan Baker wrote: >> Currently mesa searches for two different environment variables, >> LIBGL_DRIVERS_PATH and GBM_DRIVERS_PATH. The first is used for search >> for DRI drivers in every case except GBM, and the latte

Re: [Mesa-dev] [PATCH V2] glsl: remove unnecessary check

2014-07-19 Thread Timothy Arceri
On Sat, 2014-07-19 at 14:20 +1000, Timothy Arceri wrote: > On Sat, 2014-07-19 at 12:25 +1000, Timothy Arceri wrote: > > This code does nothing useful as the next recursive call on the array > > element > > will override any null values if the element is a record anyway. The code is > > also not do

[Mesa-dev] [Bug 77449] Tracker bug for all bugs related to Steam titles

2014-07-19 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=77449 Bug 77449 depends on bug 79373, which changed state. Bug 79373 Summary: Non-const initializers for matrix and vector constructors https://bugs.freedesktop.org/show_bug.cgi?id=79373 What|Removed |Added -