Making all in builtin_compiler
gmake[4]: Entering directory `/opt/mesa/src/glsl/builtin_compiler'
CXX glsl_lexer.lo
glsl_lexer.cpp: In function 'int yy_get_next_buffer(yyscan_t)':
glsl_lexer.cpp:3076:3: warning: comparison between signed and unsigned
integer expressions [-Wsign-compare]
C
On Sun, May 5, 2013 at 8:53 PM, Chad Versace
wrote:
> On 05/04/2013 03:20 PM, Matt Turner wrote:
>>
>> On Sat, May 4, 2013 at 12:14 AM, Matt Turner wrote:
>>>
>>> On Fri, May 3, 2013 at 10:42 PM, Chad Versace
>>> wrote:
+32% on GLBenchmark 2.5 Egypt Offscreen DXT1. Tested on Harris Bea
On 05/04/2013 03:20 PM, Matt Turner wrote:
On Sat, May 4, 2013 at 12:14 AM, Matt Turner wrote:
On Fri, May 3, 2013 at 10:42 PM, Chad Versace
wrote:
+32% on GLBenchmark 2.5 Egypt Offscreen DXT1. Tested on Harris Beach GT3 with
Android.
Please please please, someone run Piglit on this series.
On 05/03/2013 04:07 PM, Ian Romanick wrote:
From: Ian Romanick
Lower ir_binop_vector_extract with a constant index to a swizzle. This
is exactly like ir_dereference_array of a vector with a constant index.
v2: Convert tabs to spaces. Suggested by Eric.
v3: Correctly call convert_vector_extr
On 05/03/2013 04:07 PM, Ian Romanick wrote:
From: Ian Romanick
The new opcode is used to get a single field from a vector. The field
index may not be constant. This will eventually replace
ir_dereference_array of vectors. This is similar to the extractelement
instruction in LLVM IR.
http://
Fixes "Missing break in switch" defect reported by Coverity.
Signed-off-by: Vinson Lee
---
src/gallium/drivers/ilo/shader/toy_tgsi.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/gallium/drivers/ilo/shader/toy_tgsi.c
b/src/gallium/drivers/ilo/shader/toy_tgsi.c
index c2b1da5..046c646 1
It should be TGSI_TYPE_UNSIGNED, not TGSI_TYPE_FLOAT.
Fixed also gallivm not_emit_cpu() to use uint build context.
Signed-off-by: Chia-I Wu
---
src/gallium/auxiliary/gallivm/lp_bld_tgsi_action.c |2 +-
src/gallium/auxiliary/tgsi/tgsi_info.c |1 +
2 files changed, 2 insertion
Call tgsi_opcode_infer_type() from tgsi_opcode_infer_src_type().
Signed-off-by: Chia-I Wu
---
src/gallium/auxiliary/tgsi/tgsi_info.c | 44 +++-
1 file changed, 9 insertions(+), 35 deletions(-)
diff --git a/src/gallium/auxiliary/tgsi/tgsi_info.c
b/src/gallium/auxil
Move the body of tgsi_opcode_infer_dst_type() to a new helper function,
tgsi_opcode_infer_type(), and call the helper function from
tgsi_opcode_infer_dst_type(). The diff looks complicated simply because the
code is moved around.
A following commit will make tgsi_opcode_infer_src_type() call
tgsi
Reorder opcodes by their assigned numbers. This makes it easier to see the
differences between tgsi_opcode_infer_src_type() and
tgsi_opcode_infer_dst_type().
Signed-off-by: Chia-I Wu
---
src/gallium/auxiliary/tgsi/tgsi_info.c | 48
1 file changed, 24 insertion
Hi,
The first three patches of this series move the code around such that
tgsi_opcode_infer_src_type() and tgsi_opcode_infer_dst_type() both call a
helper function. The idea is that most opcodes should expect the same data
type for their src and dst operands so most code can be shared. No functi
Tom,
The series
Reviewed-by: mathias.froehl...@web.de
Greetings
Mathias
___
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/mesa-dev
Hi,
Sorry for these late response. I am in the middle of moving to a new
appartements coordinating work in the new one and so on.
It might even be that I do have no good network access for a few days ...
On Wednesday, May 01, 2013 17:56:33 Tom Stellard wrote:
> Thanks for pointing this out, I'l
https://bugs.freedesktop.org/show_bug.cgi?id=63435
--- Comment #3 from post+...@ralfj.de ---
Current master (b42fe195) still exhibits this problem, which effectively
renders full-screen EGL applications using v-sync unusable (no matter whether
they use OpenGL or OpenGLES). The erroneous behaviour
14 matches
Mail list logo