On Thu, 2007-04-05 at 00:20 -0500, Chris Lattner wrote:
>
> Changes in directory llvm/include/llvm/ADT:
>
> APSInt.h added (r1.1)
> ---
> Log message:
>
> Add a helper class (APSInt) which can represent an APInt along with sign
> information. This is useful when a value does have a sign associa
Changes in directory llvm-stacker:
Makefile.common.in updated: 1.4 -> 1.5
---
Log message:
Make this compile again by abandoning partially completed makefile work.
---
Diffs of the changes: (+1 -1)
Makefile.common.in |2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm-s
Changes in directory llvm-stacker/lib/compiler:
Makefile updated: 1.12 -> 1.13
---
Log message:
Make this compile again by abandoning partially completed makefile work.
---
Diffs of the changes: (+0 -1)
Makefile |1 -
1 files changed, 1 deletion(-)
Index: llvm-stacker/lib/compiler/Ma
On Apr 5, 2007, at 8:40 AM, Reid Spencer wrote:
>> Add a helper class (APSInt) which can represent an APInt along
>> with sign
>> information. This is useful when a value does have a sign
>> associated with
>> it. This shouldn't be used generally in LLVM for mid-level
>> optimizer stuff.
>
Changes in directory llvm/test/CodeGen/Generic:
switch-lower-feature-2.ll updated: 1.1 -> 1.2
---
Log message:
Fix test
---
Diffs of the changes: (+2 -0)
switch-lower-feature-2.ll |2 ++
1 files changed, 2 insertions(+)
Index: llvm/test/CodeGen/Generic/switch-lower-feature-2.ll
diff
Revision: 125745
Author: dpatel
Date: 2007-04-05 09:48:13 -0700 (Thu, 05 Apr 2007)
Log Message:
---
Improve Packed structure support by used
Packed StructType.
Original version of this patch was written by
Andrew Lenharth. Later this patch was updated by
Duncan Sands. I updated pac
Changes in directory llvm/tools/llvm-ld:
Optimize.cpp updated: 1.18 -> 1.19
---
Log message:
run a late dce pass to clean up extra cruft.
---
Diffs of the changes: (+1 -0)
Optimize.cpp |1 +
1 files changed, 1 insertion(+)
Index: llvm/tools/llvm-ld/Optimize.cpp
diff -u llvm/tools/llv
Changes in directory llvm/test/CFrontend:
2007-04-05-PackedBitFields-2.c added (r1.1)
2007-04-05-PackedBitFields.c added (r1.1)
2007-04-05-PackedStruct.c added (r1.1)
2007-04-05-UnPackedStruct.c added (r1.1)
---
Log message:
New tests for Packed structs.
---
Diffs of the changes: (+66 -0)
>
> New tests for Packed structs.
Woot, thanks Devang, Duncan and Andrew! :)
-Chris
>
> ---
> Diffs of the changes: (+66 -0)
>
> 2007-04-05-PackedBitFields-2.c | 16
> 2007-04-05-PackedBitFields.c | 16
> 2007-04-05-PackedStruct.c | 18 +++
Changes in directory llvm/test/C++Frontend:
2007-04-05-PackedBitFields-1.cpp added (r1.1)
2007-04-05-PackedBitFieldsOverlap-2.cpp added (r1.1)
2007-04-05-PackedBitFieldsOverlap.cpp added (r1.1)
2007-04-05-PackedBitFieldsSmall.cpp added (r1.1)
2007-04-05-StructPackedFieldUnpacked.cpp added (r1.1)
Changes in directory llvm-www:
DevMtgMay2007.html updated: 1.46 -> 1.47
---
Log message:
update, the mtg will be in a room at the Cupertino Inn.
---
Diffs of the changes: (+7 -7)
DevMtgMay2007.html | 14 +++---
1 files changed, 7 insertions(+), 7 deletions(-)
Index: llvm-www/De
Changes in directory llvm-www:
DevMtgMay2007.html updated: 1.47 -> 1.48
---
Log message:
Minor updates, linkify the location
---
Diffs of the changes: (+7 -6)
DevMtgMay2007.html | 13 +++--
1 files changed, 7 insertions(+), 6 deletions(-)
Index: llvm-www/DevMtgMay2007.html
diff
Changes in directory llvm/test/CFrontend:
2007-04-05-PadBeforeZeroLengthField.c added (r1.1)
---
Log message:
testcase for padding before zero-length fields.
---
Diffs of the changes: (+9 -0)
2007-04-05-PadBeforeZeroLengthField.c |9 +
1 files changed, 9 insertions(+)
Index:
Revision: 125748
Author: johannes
Date: 2007-04-05 12:09:17 -0700 (Thu, 05 Apr 2007)
Log Message:
---
Handle padding before zero-length fields. Handle consecutive
zero-length fields as the comment indicates they should be.
Modified Paths:
--
apple-local/branches/llv
Changes in directory llvm-www:
DevMtgMay2007.html updated: 1.48 -> 1.49
---
Log message:
Add Scott Michel's talk.
---
Diffs of the changes: (+3 -1)
DevMtgMay2007.html |4 +++-
1 files changed, 3 insertions(+), 1 deletion(-)
Index: llvm-www/DevMtgMay2007.html
diff -u llvm-www/DevMtgMa
Changes in directory llvm/lib/Transforms/IPO:
GlobalOpt.cpp updated: 1.99 -> 1.100
---
Log message:
Fix Transforms/GlobalOpt/2007-04-05-Crash.ll
---
Diffs of the changes: (+1 -1)
GlobalOpt.cpp |2 +-
1 files changed, 1 insertion(+), 1 deletion(-)
Index: llvm/lib/Transforms/IPO/Global
Changes in directory llvm/test/Transforms/GlobalOpt:
2007-04-05-Crash.ll added (r1.1)
---
Log message:
new testcase that crashes globalopt
---
Diffs of the changes: (+34 -0)
2007-04-05-Crash.ll | 34 ++
1 files changed, 34 insertions(+)
Index: llvm/tes
Changes in directory llvm/include/llvm/Support:
CommandLine.h updated: 1.58 -> 1.59
---
Log message:
remove the dead removeArgument method, rename Options to OptionsMap.
---
Diffs of the changes: (+0 -1)
CommandLine.h |1 -
1 files changed, 1 deletion(-)
Index: llvm/include/llvm/Supp
Changes in directory llvm/lib/Support:
CommandLine.cpp updated: 1.82 -> 1.83
---
Log message:
remove the dead removeArgument method, rename Options to OptionsMap.
---
Diffs of the changes: (+30 -61)
CommandLine.cpp | 91 ++--
1 files ch
Changes in directory llvm/include/llvm/Support:
CommandLine.h updated: 1.59 -> 1.60
---
Log message:
eliminate a virtual method
---
Diffs of the changes: (+39 -42)
CommandLine.h | 81 +++---
1 files changed, 39 insertions(+), 42 deletio
Huh? What is the DCE pass doing that the global-dce isn't?
Chris Lattner wrote:
>
> Changes in directory llvm/tools/llvm-ld:
>
> Optimize.cpp updated: 1.18 -> 1.19
> ---
> Log message:
>
> run a late dce pass to clean up extra cruft.
>
>
> ---
> Diffs of the changes: (+1 -0)
>
> Optimize.c
Changes in directory llvm/test/CodeGen/Generic:
bit-intrinsics.ll updated: 1.1 -> 1.2
---
Log message:
XFAIL this test for now. It will be a while before I can implement this
intrinsic properly in SDISel.
---
Diffs of the changes: (+1 -0)
bit-intrinsics.ll |1 +
1 files changed, 1 inse
On Thu, 5 Apr 2007, Nick Lewycky wrote:
> Huh? What is the DCE pass doing that the global-dce isn't?
globaldce deletes globals and functions, not code within functions.
-Chris
> Chris Lattner wrote:
>>
>> Changes in directory llvm/tools/llvm-ld:
>>
>> Optimize.cpp updated: 1.18 -> 1.19
>> ---
>
Changes in directory llvm-www:
InTheNews.html updated: 1.14 -> 1.15
---
Log message:
Add CliffHacks: Experimenting with LLVM.
---
Diffs of the changes: (+3 -1)
InTheNews.html |4 +++-
1 files changed, 3 insertions(+), 1 deletion(-)
Index: llvm-www/InTheNews.html
diff -u llvm-www/InTh
Changes in directory llvm-www:
InTheNews.html updated: 1.15 -> 1.16
---
Log message:
Use sections. Add section for bloggers.
---
Diffs of the changes: (+30 -13)
InTheNews.html | 43 ++-
1 files changed, 30 insertions(+), 13 deletions(-)
Index: ll
Changes in directory llvm/lib/VMCore:
Type.cpp updated: 1.177 -> 1.178
---
Log message:
For PR1209: http://llvm.org/PR1209 :
Implement Type class's ContainedTys without using a std::vector.
---
Diffs of the changes: (+63 -17)
Type.cpp | 80
Changes in directory llvm/include/llvm:
DerivedTypes.h updated: 1.89 -> 1.90
Type.h updated: 1.105 -> 1.106
---
Log message:
For PR1209: http://llvm.org/PR1209 :
Implement Type class's ContainedTys without using a std::vector.
---
Diffs of the changes: (+50 -30)
DerivedTypes.h | 27 +
Changes in directory llvm-www:
InTheNews.html updated: 1.16 -> 1.17
---
Log message:
Add more blogs.
---
Diffs of the changes: (+6 -12)
InTheNews.html | 18 ++
1 files changed, 6 insertions(+), 12 deletions(-)
Index: llvm-www/InTheNews.html
diff -u llvm-www/InTheNews.ht
Changes in directory llvm-www:
SVNMigration.html updated: 1.4 -> 1.5
---
Log message:
Update status about SVN Migration.
---
Diffs of the changes: (+8 -1)
SVNMigration.html |9 -
1 files changed, 8 insertions(+), 1 deletion(-)
Index: llvm-www/SVNMigration.html
diff -u llvm-ww
Changes in directory llvm-www:
SVNMigration.html updated: 1.5 -> 1.6
---
Log message:
The Adaptive repository won't be migrated.
---
Diffs of the changes: (+1 -2)
SVNMigration.html |3 +--
1 files changed, 1 insertion(+), 2 deletions(-)
Index: llvm-www/SVNMigration.html
diff -u llvm-
Changes in directory llvm-www:
Users.html updated: 1.3 -> 1.4
---
Log message:
Yes it is silly, but we can't talk about "unreleased products"
---
Diffs of the changes: (+2 -2)
Users.html |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
Index: llvm-www/Users.html
diff -u llvm
Changes in directory llvm-www:
Users.html updated: 1.4 -> 1.5
---
Log message:
contrary to popular believe, llvm.org is not vikram's research group web page.
---
Diffs of the changes: (+2 -2)
Users.html |4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
Index: llvm-www/Users.h
Changes in directory llvm-www:
Users.html updated: 1.5 -> 1.6
---
Log message:
comment this out for now
---
Diffs of the changes: (+3 -4)
Users.html |7 +++
1 files changed, 3 insertions(+), 4 deletions(-)
Index: llvm-www/Users.html
diff -u llvm-www/Users.html:1.5 llvm-www/Users.
Changes in directory llvm-www:
DevMtgMay2007.html updated: 1.49 -> 1.50
---
Log message:
no comma
---
Diffs of the changes: (+10 -10)
DevMtgMay2007.html | 20 ++--
1 files changed, 10 insertions(+), 10 deletions(-)
Index: llvm-www/DevMtgMay2007.html
diff -u llvm-www/Dev
Changes in directory llvm-www:
InTheNews.html updated: 1.17 -> 1.18
---
Log message:
Remove the obviously wrong articles for now.
---
Diffs of the changes: (+7 -7)
InTheNews.html | 14 +++---
1 files changed, 7 insertions(+), 7 deletions(-)
Index: llvm-www/InTheNews.html
diff -
Changes in directory llvm-test/External/Nurbs:
Makefile updated: 1.1 -> 1.2
---
Log message:
After changing this from an i/o bound app to a cpu bound app, we need to
increase the problem size :)
---
Diffs of the changes: (+1 -1)
Makefile |2 +-
1 files changed, 1 insertion(+), 1 delet
36 matches
Mail list logo