[Lldb-commits] [PATCH] D139158: [LLDB][LoongArch] Make software single stepping work

2022-12-07 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Instruction/LoongArch/EmulateInstructionLoongArch.h:58 + uint32_t reg_num) override; + lldb::addr_t ReadPC(bool *success); + bool WritePC(lldb::addr_t pc);

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Fix build errors

2022-10-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel created this revision. seehearfeel added reviewers: SixWeining, wangleiat, xen0n, xry111, MaskRay. Herald added a subscriber: StephenFan. Herald added a project: All. seehearfeel requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. W

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Fix build errors

2022-10-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 470059. seehearfeel added a comment. Use git diff -U99 to generate the patch so that we can get more context suggested by Weining. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D136578/new/ https://reviews.llvm.org/D136578 Files: lldb/sou

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Add minimal LoongArch support

2022-10-24 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel marked an inline comment as done. seehearfeel added a comment. In D136578#3878476 , @xen0n wrote: > Hi, I've edited the summary and patch title for you. It's generally not > necessary to add //that// much "politeness" when most of it is obvio

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Add minimal LoongArch support

2022-10-24 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Process/Utility/RegisterInfoPOSIX_loongarch64.h:26 +public: + enum { GPRegSet = 0, FPRegSet }; + tschuett wrote: > Firstly, I prefer `ènum class`. Second, it is unused? Now, GPRegSet and FPRegSe

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Add minimal LoongArch support

2022-10-24 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_loongarch64.h:24 + +class NativeRegisterContextLinux_loongarch64 : public NativeRegisterContextLinux { +public: SixWeining wrote: > Pls limit the columns

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Add minimal LoongArch support

2022-10-24 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 470345. seehearfeel edited the summary of this revision. seehearfeel set the repository for this revision to rG LLVM Github Monorepo. seehearfeel added a comment. Remove GPRegSet and FPRegSet definitions which are not used in this commit. Use git clang-for

[Lldb-commits] [PATCH] D136578: [LLDB] [LoongArch] Add minimal LoongArch support

2022-10-25 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a comment. In D136578#3881955 , @DavidSpickett wrote: > This LGTM from the lldb side. OK, thank you. > Feel free to upload a series of patches in future if you want. You don't have > to do one at a time, just update the whole stack a

[Lldb-commits] [PATCH] D136362: [LLDB][RISCV] Add RV64C instruction support for EmulateInstructionRISCV

2022-10-27 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a comment. After commit 05ae747a5353811f93f5814f24d2335e6229d78a ("[LLDB][RISCV] Add RV64C instruction support for EmulateInstructionRISCV"), build failed when "ninja check-lldb" on my local machine: [1/3]

[Lldb-commits] [PATCH] D136362: [LLDB][RISCV] Add RV64C instruction support for EmulateInstructionRISCV

2022-10-27 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a comment. In D136362#3888328 , @Emmmer wrote: > In D136362#3887927 , @seehearfeel > wrote: > >> After commit 05ae747a5353811f93f5814f24d2335e6229d78a >>

[Lldb-commits] [PATCH] D136362: [LLDB][RISCV] Add RV64C instruction support for EmulateInstructionRISCV

2022-10-28 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a subscriber: SixWeining. seehearfeel added a comment. In D136362#3890970 , @DavidSpickett wrote: > Can you give us: > > - the full cmake command you used to configure the project git clone https://github.com/llvm/llvm-project.git

[Lldb-commits] [PATCH] D136362: [LLDB][RISCV] Add RV64C instruction support for EmulateInstructionRISCV

2022-10-30 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a comment. I can reproduce this issue on x86_64 used with the latest gcc. (1) Install Fedora36 https://download.fedoraproject.org/pub/fedora/linux/releases/36/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-36-1.5.iso $ uname -a Linux fedora 5.17.5-300.fc36.x86_64 #1 SMP

[Lldb-commits] [PATCH] D137057: [LLDB][LoongArch] Add LoongArch ArchSpec and subtype detection

2022-10-31 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel created this revision. seehearfeel added reviewers: SixWeining, wangleiat, xen0n, xry111, MaskRay, DavidSpickett. Herald added subscribers: StephenFan, emaste. Herald added a project: All. seehearfeel requested review of this revision. Herald added a project: LLDB. Herald added a subsc

[Lldb-commits] [PATCH] D137057: [LLDB][LoongArch] Add LoongArch ArchSpec and subtype detection

2022-10-31 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Utility/ArchSpec.cpp:223 +{eByteOrderLittle, 4, 1, 4, llvm::Triple::loongarch32, + ArchSpec::eCore_loongarch32, "loongarch32"}, SixWeining wrote: > xen0n wrote: > > `min_opcode_byte_size` should

[Lldb-commits] [PATCH] D137057: [LLDB][LoongArch] Add LoongArch ArchSpec and subtype detection

2022-10-31 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added a comment. In D137057#3895926 , @DavidSpickett wrote: > Looks good to me. Thanks for your review. Let me update the diff to do some small modifications. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://revi

[Lldb-commits] [PATCH] D137057: [LLDB][LoongArch] Add LoongArch ArchSpec and subtype detection

2022-10-31 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 471973. seehearfeel added a comment. (1) Rename LOONGARCHSubType to LoongArchSubType (2) Define min_opcode_byte_size as 4 for LoongArch CHANGES SINCE LAST ACTION https://reviews.llvm.org/D137057/new/ https://reviews.llvm.org/D137057 Files: lldb/inc

[Lldb-commits] [PATCH] D137312: [LLDB] [LoongArch] Add loongarch64 case in ComputeHostArchitectureSupport()

2022-11-02 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel created this revision. seehearfeel added reviewers: SixWeining, wangleiat, xen0n, xry111, MaskRay, DavidSpickett. Herald added a subscriber: StephenFan. Herald added a project: All. seehearfeel requested review of this revision. Herald added a project: LLDB. Herald added a subscriber:

[Lldb-commits] [PATCH] D137519: [LLDB][LoongArch] Add LoongArch software breakpoint trap code

2022-11-06 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel created this revision. seehearfeel added reviewers: SixWeining, wangleiat, xen0n, xry111, MaskRay, DavidSpickett. Herald added a subscriber: StephenFan. Herald added a project: All. seehearfeel requested review of this revision. Herald added a project: LLDB. Herald added a subscriber:

[Lldb-commits] [PATCH] D137519: [LLDB] Add LoongArch software breakpoint trap opcode

2022-11-06 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 473542. seehearfeel retitled this revision from "[LLDB] Add LoongArch software breakpoint trap opcode" to " [LLDB] Add LoongArch software breakpoint trap opcode". seehearfeel edited the summary of this revision. seehearfeel added a comment. Use "break 0x

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-21 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel created this revision. seehearfeel added reviewers: SixWeining, wangleiat, xen0n, xry111, MaskRay, DavidSpickett. Herald added a subscriber: StephenFan. Herald added a project: All. seehearfeel requested review of this revision. Herald added a project: LLDB. Herald added a subscriber:

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_loongarch64.cpp:27 +// NT_PRSTATUS and NT_FPREGSET definition +#include + SixWeining wrote: > [[ https://llvm.org/docs/CodingStandards.html#include-style

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_loongarch64.cpp:221 + + uint8_t *src = const_cast(data_sp->GetBytes()); + if (src == nullptr) { DavidSpickett wrote: > seehearfeel wrote: > > DavidSpick

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 477650. seehearfeel added a comment. (1) Put elf.h before sys/uio.h (2) Remove unnecessary indent (3) Remove const cast of data_sp->GetBytes() (4) Return k_num_register_sets in GetRegisterSetCount() (5) Add register name alias CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel added inline comments. Comment at: lldb/source/Plugins/Process/Utility/RegisterInfos_loongarch64.h:21 +#define GPR_OFFSET(idx) ((idx)*8 + 0) +#define FPR_OFFSET(idx) ((idx)*8 + sizeof(RegisterInfoPOSIX_loongarch64::GPR)) +#define FCC_OFFSET(idx) ((idx)*1 + 32 * 8 + s

[Lldb-commits] [PATCH] D138407: [LLDB] Add LoongArch register definitions and operations

2022-11-23 Thread Tiezhu Yang via Phabricator via lldb-commits
seehearfeel updated this revision to Diff 477690. seehearfeel added a comment. (1) define *_OFFSET in RegisterInfoPOSIX_loongarch64.cpp (2) remove the alias u0 for r21, use fp and s9 for r22 CHANGES SINCE LAST ACTION https://reviews.llvm.org/D138407/new/ https://reviews.llvm.org/D138407 File