[Lldb-commits] [PATCH] D104413: Fixed use of -o and -k in LLDB under Windows when statically compiled with vcruntime.

2021-09-07 Thread Levon Ter-Grigoryan via Phabricator via lldb-commits
PatriosTheGreat updated this revision to Diff 371002. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104413/new/ https://reviews.llvm.org/D104413 Files: lldb/bindings/interface/SBDebugger.i lldb/include/lldb/API/SBDebugger.h lldb/include/lldb/Core/Debugger.h lldb/source/API/SBDebu

[Lldb-commits] [PATCH] D108078: [lldb] Support gdbserver signals

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 371011. mgorny marked an inline comment as done. mgorny added a comment. Rebased. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108078/new/ https://reviews.llvm.org/D108078 Files: lldb/packages/Python/lldbsuite/test/tools/lldb-server/gdbremote_tes

[Lldb-commits] [PATCH] D108061: [lldb] Add support for shared library load when executable called through ld.

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: lldb/source/Plugins/DynamicLoader/POSIX-DYLD/DYLDRendezvous.cpp:571-579 + + // ld.so saves empty file name for the executable file in the link map. + // When argv[0] is ld.so, we need to be update executable path. + if (file_path.empt

[Lldb-commits] [PATCH] D109326: [lldb] [Process/FreeBSD] Support SaveCore() using PT_COREDUMP

2021-09-07 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski accepted this revision. krytarowski added a comment. This revision is now accepted and ready to land. Looks good CHANGES SINCE LAST ACTION https://reviews.llvm.org/D109326/new/ https://reviews.llvm.org/D109326 ___ lldb-commits mailing l

[Lldb-commits] [PATCH] D107717: [LLVM][CMake][NFC] Resolve FIXME: Rename LLVM_CMAKE_PATH to LLVM_CMAKE_DIR throughout the project

2021-09-07 Thread Mark de Wever via Phabricator via lldb-commits
Mordante added a comment. Since @ldionne approved this patch it's good to land. If you don't have commit access, can you provide "Your name" , then somebody can commit the change for you. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107717/new/ https://reviews.llvm.org/D107717 _

[Lldb-commits] [PATCH] D107717: [LLVM][CMake][NFC] Resolve FIXME: Rename LLVM_CMAKE_PATH to LLVM_CMAKE_DIR throughout the project

2021-09-07 Thread Alf via Phabricator via lldb-commits
gAlfonso-bit updated this revision to Diff 370957. gAlfonso-bit added a comment. Rebase to Main @ldionne CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107717/new/ https://reviews.llvm.org/D107717 Files: clang/CMakeLists.txt clang/lib/Basic/CMakeLists.txt compiler-rt/cmake/Modules

[Lldb-commits] [PATCH] D109345: MemoryBuffer: Migrate to Expected/llvm::Error from ErrorOr/std::error_code

2021-09-07 Thread Thomas Preud'homme via Phabricator via lldb-commits
thopre added a comment. Is there no way to split this patch further? It's going to be hard finding someone who can review something so big. If there's no way to split it in incremental changes, you could perhaps split per subsystem only for review and refer to this diff for CI as well as when l

[Lldb-commits] [PATCH] D107701: [lldb] [test] Skip Expr/nodefaultlib.cpp test if LD_PRELOAD Is used

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. What does the preloaded library do ? Is it actually necessary for the (other) tests to run? I'm wondering if we shouldn't strip the variable from the environment instead... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D1077

[Lldb-commits] [PATCH] D108739: [LLDB] AArch64 SVE restore SVE registers after expression

2021-09-07 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added inline comments. Comment at: lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.cpp:451 Status NativeRegisterContextLinux_arm64::ReadAllRegisterValues( lldb::DataBufferSP &data_sp) { omjavaid wrote: > DavidSpickett wro

[Lldb-commits] [PATCH] D108739: [LLDB] AArch64 SVE restore SVE registers after expression

2021-09-07 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added a comment. Hopefully in the future we can get some kind of smarter container for this register data in future but this looks good for now with a few extra comments for the logic of it. (and so we know where to make changes later) CHANGES SINCE LAST ACTION https://reviews.

[Lldb-commits] [PATCH] D107809: [lldb] Add new commands and tests for getting file perms & exists

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I was thinking this would be more useful in the SB form (and indeed we have SBPlatform::GetFilePermissions) already, though I suppose making it available through the command line does not hurt either.. Comment at: lldb/source/Plugins/Process/gdb-remot

[Lldb-commits] [PATCH] D107811: [lldb] [gdb-remote] Add fallbacks for vFile:mode and vFile:exists

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. It seems useful to note that these are only approximations, as they will fail for unreadable files, even though normally these operations should succeed. However, I think it is the best we can do given the limited set of supported operations (i.e., lack of stat(2) syscal

[Lldb-commits] [PATCH] D107821: [lldb] [gdb-server] Add tests for more vFile packets

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Instead of the tempfile thingies I'd probably just use fixed files names in the build directory -- it's specific to a single test, automatically cleaned on each run and it's where all of our o

[Lldb-commits] [PATCH] D107840: [lldb] [gdb-server] Implement the vFile:fstat packet

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added inline comments. This revision is now accepted and ready to land. Comment at: lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerCommon.cpp:776 + + std::array data; + DataEncoder encoder{data.data(), data.size(), lldb

[Lldb-commits] [PATCH] D107931: [lldb] [gdb-remote] Implement vRun packet

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. I like this. I am saddened to see that neither method supports setting a "fake" argv[0], but that's not a problem of this patch,,, CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107931

[Lldb-commits] [PATCH] D108018: [lldb] [gdb-remote] Support QEnvironment fallback to hex-encoded

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. cool Comment at: lldb/test/API/tools/lldb-server/main.cpp:332 + const char *value = getenv(arg.c_str()); + printf("%s\n", value ? value : "__unset__"); } else

[Lldb-commits] [PATCH] D108148: [lldb] [gdb-remote] Use standardized GDB errno values

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I think this would be a good use case for a llvm-style `.def` file. It would provide a central place listing all the known constants, and one could use it to generate the enum definition and both of the conversion functions (by defining a suitable macro). CHANGES SINCE

[Lldb-commits] [PATCH] D108548: [lldb] Support "eflags" register name in generic reg fallback

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. seems reasonable CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108548/new/ https://reviews.llvm.org/D108548 ___ lldb-commits mailing list

[Lldb-commits] [PATCH] D107701: [lldb] [test] Skip Expr/nodefaultlib.cpp test if LD_PRELOAD Is used

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In D107701#2986378 , @labath wrote: > What does the preloaded library do ? Is it actually necessary for the (other) > tests to run? I'm wondering if we shouldn't strip the variable from the > environment instead... It detects ac

[Lldb-commits] [PATCH] D109231: [lldb] Improve error handling around GetRngListData()

2021-09-07 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added inline comments. Herald added a subscriber: JDevlieghere. Comment at: lldb/source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp:522 +entry->getContribution(llvm::DW_SECT_RNGLISTS)) { + Offset = contribution->Offset; return DWARFDataExtractor(data, co

[Lldb-commits] [PATCH] D106226: [lldb] Improve error message when "lldb attach" fails

2021-09-07 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added a comment. Maybe I can help a little with the error code approach/add on. lldb communicates to lldb-server using gdb-remote packets, you can enable logging of these with `log enable gdb-remote packets`. If you're running on the same machine, lldb will start an lldb-server in

[Lldb-commits] [lldb] 4da5a44 - [lldb] Update crashlog.py to accept multiple results from mdfind

2021-09-07 Thread Jonas Devlieghere via lldb-commits
Author: Jonas Devlieghere Date: 2021-09-07T08:36:58-07:00 New Revision: 4da5a446f818cd979868d830eced9770a886a5b6 URL: https://github.com/llvm/llvm-project/commit/4da5a446f818cd979868d830eced9770a886a5b6 DIFF: https://github.com/llvm/llvm-project/commit/4da5a446f818cd979868d830eced9770a886a5b6.d

[Lldb-commits] [PATCH] D109263: [lldb] Update crashlog.py to accept multiple results from mdfind

2021-09-07 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG4da5a446f818: [lldb] Update crashlog.py to accept multiple results from mdfind (authored by JDevlieghere). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[Lldb-commits] [PATCH] D104413: Fixed use of -o and -k in LLDB under Windows when statically compiled with vcruntime.

2021-09-07 Thread Levon Ter-Grigoryan via Phabricator via lldb-commits
PatriosTheGreat marked 2 inline comments as done. PatriosTheGreat added a comment. Sorry for delay from my side also CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104413/new/ https://reviews.llvm.org/D104413 ___ lldb-commits mailing list lldb

[Lldb-commits] [lldb] a97efde - [lldb] Add missing newline to stderr output on failed attach

2021-09-07 Thread David Spickett via lldb-commits
Author: David Spickett Date: 2021-09-07T15:49:07Z New Revision: a97efde54e6ccbd1b56ec1ae1b7899988ac240a0 URL: https://github.com/llvm/llvm-project/commit/a97efde54e6ccbd1b56ec1ae1b7899988ac240a0 DIFF: https://github.com/llvm/llvm-project/commit/a97efde54e6ccbd1b56ec1ae1b7899988ac240a0.diff LOG

Re: [Lldb-commits] [lldb] 5f6f33d - [lldb/Plugins] Move member template specialization out of class

2021-09-07 Thread Shafik Yaghmour via lldb-commits
This may actually be a gcc bug: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85282 Not much we can do now but worth knowing in case it is fixed. > On Sep 3, 2021, at 3:19 PM, Med Ismail Bennani via lldb-commits > wrote: > > > Author: Med

[Lldb-commits] [PATCH] D109004: [lldb] Catch all exceptions when checking if simulator exists

2021-09-07 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added a comment. What do you think about putting the ` json.loads(sim_devices_str)['devices']` into the decorator, so we know that xcodebuild has an SDK *and* the simulator has devices available? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.or

[Lldb-commits] [PATCH] D107811: [lldb] [gdb-remote] Add fallbacks for vFile:mode and vFile:exists

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In D107811#2986430 , @labath wrote: > It seems useful to note that these are only approximations, as they will fail > for unreadable files, even though normally these operations should succeed. > However, I think it is the best w

[Lldb-commits] [PATCH] D107809: [lldb] Add new commands and tests for getting file perms & exists

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added inline comments. Comment at: lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerCommon.cpp:661-664 +if (mode != llvm::sys::fs::perms_not_known) + response.Printf("F%x", mode); +else + response.Printf("F-1,%x", (int)Status(ec).GetErr

[Lldb-commits] [PATCH] D108018: [lldb] [gdb-remote] Support QEnvironment fallback to hex-encoded

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added inline comments. Comment at: lldb/test/API/tools/lldb-server/main.cpp:332 + const char *value = getenv(arg.c_str()); + printf("%s\n", value ? value : "__unset__"); } else { labath wrote: > Printing a quoted this in the case of a null p

[Lldb-commits] [PATCH] D108148: [lldb] [gdb-remote] Use standardized GDB errno values

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In D108148#2986602 , @labath wrote: > I think this would be a good use case for a llvm-style `.def` file. It would > provide a central place listing all the known constants, and one could use it > to generate the enum definition

[Lldb-commits] [lldb] ea04bf3 - [lldb] Alphabetize some CMake files a bit better

2021-09-07 Thread Nico Weber via lldb-commits
Author: Nico Weber Date: 2021-09-07T13:19:00-04:00 New Revision: ea04bf302cf8f32bef62208e123d9d0cb99fa55c URL: https://github.com/llvm/llvm-project/commit/ea04bf302cf8f32bef62208e123d9d0cb99fa55c DIFF: https://github.com/llvm/llvm-project/commit/ea04bf302cf8f32bef62208e123d9d0cb99fa55c.diff LO

[Lldb-commits] [PATCH] D109367: [lldb] Alphabetize some CMake files a bit better

2021-09-07 Thread Nico Weber via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGea04bf302cf8: [lldb] Alphabetize some CMake files a bit better (authored by thakis). Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Repository: rG LLVM Github Monorepo CHANGES S

[Lldb-commits] [PATCH] D108148: [lldb] [gdb-remote] Use standardized GDB errno values

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Nah, tablegen is overkill. I was thinking of something similar to (but simpler than) `include/llvm/BinaryFormat/Dwarf.def`. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108148/new/ https://reviews.llvm.org/D108148 __

[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 371134. mgorny added a comment. The test requires building with X86 target. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108554/new/ https://reviews.llvm.org/D108554 Files: lldb/source/Host/common/NativeRegisterContext.cpp lldb/source/Target/Re

[Lldb-commits] [PATCH] D108018: [lldb] [gdb-remote] Support QEnvironment fallback to hex-encoded

2021-09-07 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: lldb/test/API/tools/lldb-server/main.cpp:332 + const char *value = getenv(arg.c_str()); + printf("%s\n", value ? value : "__unset__"); } else { mgorny wrote: > labath wrote: > > Printing a quoted this in th

[Lldb-commits] [PATCH] D109272: [lldb] [gdb-remote] Try using for remote arch unconditionally

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 371136. mgorny added a comment. Require respective targets for tests, and tests for the generic AArch64 aliases that already work. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D109272/new/ https://reviews.llvm.org/D109272 Files: lldb/source/Plugi

[Lldb-commits] [PATCH] D106226: [lldb] Improve error message when "lldb attach" fails

2021-09-07 Thread Jim Ingham via Phabricator via lldb-commits
jingham requested changes to this revision. jingham added a comment. This revision now requires changes to proceed. This seems like a good idea, but the functionality belongs in the Linux Platform, not in the Target.cpp. We try really hard to keep platform specific details out of the generic fi

[Lldb-commits] [PATCH] D108148: [lldb] [gdb-remote] Use standardized GDB errno values

2021-09-07 Thread Michał Górny via Phabricator via lldb-commits
mgorny added a comment. In D108148#2987460 , @labath wrote: > Nah, tablegen is overkill. I was thinking of something similar to (but > simpler than) `include/llvm/BinaryFormat/Dwarf.def`. Yeah, that looks easier. You got me scared there for a sec! CHA

[Lldb-commits] [PATCH] D109185: [gn build] Add build files for LLDB

2021-09-07 Thread Nico Weber via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGcfe02847496b: [gn build] Add build files for LLDB (authored by thakis). Herald added a project: LLDB. Herald added a subscriber: lldb-commits. Chang

[Lldb-commits] [PATCH] D109384: [lldb] Delete IRExecutionUnit::SearchSpec

2021-09-07 Thread Alex Langford via Phabricator via lldb-commits
bulbazord created this revision. bulbazord added reviewers: clayborg, jingham, teemperor, JDevlieghere. bulbazord requested review of this revision. Herald added a project: LLDB. IRExecutionUnit::SearchSpec is a struct that encapsulates information needed to look for a symbol. Specifically, it is

[Lldb-commits] [PATCH] D109384: [lldb] Delete IRExecutionUnit::SearchSpec

2021-09-07 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. Looks fine to me. I will let others that specialize more in the expression evaluator accept this., though it would be good to verify this code looks the same in the Swift branches Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.

[Lldb-commits] [PATCH] D108944: [LLDB][GUI] Add source file searcher

2021-09-07 Thread Greg Clayton via Phabricator via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Sorry for the delay, yes this looks good. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108944/new/ https://reviews.llvm.org/D108944 __

[Lldb-commits] [PATCH] D109101: [lldb] Add an option to specify a VFS overlay

2021-09-07 Thread Jim Ingham via Phabricator via lldb-commits
jingham accepted this revision. jingham added a comment. This revision is now accepted and ready to land. LGTM Comment at: lldb/source/API/SBDebugger.cpp:878 // call the target triple version. - error = m_opaque_sp->GetTargetList().CreateTarget(*m_opaque_sp, filena

[Lldb-commits] [PATCH] D109384: [lldb] Delete IRExecutionUnit::SearchSpec

2021-09-07 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D109384/new/ https://reviews.llvm.org/D109384 ___