[Lldb-commits] [PATCH] D108554: [lldb] Support querying registers via generic names without alt_names

2021-09-05 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 370785. mgorny added a comment. Preserve the prior (probably accidental) behavior of generic names taking precedence over later registers with the same name (e.g. generic `sp` alias taking precedence over 16-bit `sp` pseudo-register). CHANGES SINCE LAST ACT

[Lldb-commits] [PATCH] D108831: [lldb] [gdb-remote] Add x86_64 pseudo-registers when using gdbserver

2021-09-05 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 370786. mgorny added a comment. Restore the `sp` test. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108831/new/ https://reviews.llvm.org/D108831 Files: lldb/source/Plugins/Process/gdb-remote/CMakeLists.txt lldb/source/Plugins/Process/gdb-remote

[Lldb-commits] [PATCH] D109281: [lldb] [gdb-remote] Extend x86 pseudo-regs to i386

2021-09-05 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 370787. mgorny added a comment. Add `sp` test. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D109281/new/ https://reviews.llvm.org/D109281 Files: lldb/source/Plugins/Process/gdb-remote/CMakeLists.txt lldb/source/Plugins/Process/gdb-remote/GDBRemo

[Lldb-commits] [PATCH] D107717: [LLVM][CMake][NFC] Resolve FIXME: Rename LLVM_CMAKE_PATH to LLVM_CMAKE_DIR throughout the project

2021-09-05 Thread Alf via Phabricator via lldb-commits
gAlfonso-bit added a comment. @ldionne update? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107717/new/ https://reviews.llvm.org/D107717 ___ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinf

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-09-05 Thread David Blaikie via Phabricator via lldb-commits
dblaikie added a comment. In D97786#2974202 , @pfaffe wrote: > In D97786#2973868 , @dblaikie wrote: > >> This doesn't solve all use cases/it's not a terribly general purpose >> situation - using -fdebug-prefix-map/

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-09-05 Thread Philip Pfaffe via Phabricator via lldb-commits
pfaffe added a comment. In D97786#2974879 , @dblaikie wrote: > Not fixable? Not sure I follow. In the case of cwd-relative (old behavior) > you can fix the behavior by changing where you invoke the debugger from, and > in the case of exe-relative you can

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-09-05 Thread David Blaikie via Phabricator via lldb-commits
dblaikie added a comment. In D97786#2976549 , @pfaffe wrote: > In D97786#2974879 , @dblaikie wrote: > >> Not fixable? Not sure I follow. In the case of cwd-relative (old behavior) >> you can fix the behavior by cha

Re: [Lldb-commits] New feature suggestion: Tacking variable update

2021-09-05 Thread Jyothi Krishna V S via lldb-commits
Thanks a lot Jim. Our motivation was from the idea that the user might not be knowing which variable might be causing the issue and might need multiple runs to finally zero upon the problem. Another one is if the variable in question is updated inside a loop. here we need not track all updates, ju

[Lldb-commits] [PATCH] D97786: LLDB: Use path relative to binary, not relative to debugger CWD, for finding .dwo files.

2021-09-05 Thread Philip Pfaffe via Phabricator via lldb-commits
pfaffe added a comment. In D97786#2973868 , @dblaikie wrote: > This doesn't solve all use cases/it's not a terribly general purpose > situation - using -fdebug-prefix-map/-fdebug-compilation-dir requires > knowledge of these limitations/how to use these

[Lldb-commits] [PATCH] D101285: [lldb] [llgs server] Support creating core dumps on NetBSD

2021-09-05 Thread Michał Górny via Phabricator via lldb-commits
mgorny updated this revision to Diff 370823. mgorny added a comment. Rebased. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D101285/new/ https://reviews.llvm.org/D101285 Files: lldb/include/lldb/Host/common/NativeProcessProtocol.h lldb/include/lldb/Utility/StringExtractorGDBRemote.h