labath added a comment.
I am not sure what do you mean by "translating paths" in the VFS. If you mean
something like "return a `FILE *` for `/whatever/my_reproducer/vfs/bin/ls` when
I ask for `/bin/ls`", then I think that's a good idea, as it's most likely to
work with all of our existing code
aleksandr.urakov added a comment.
This commit breaks the Windows build.
Repository:
rL LLVM
https://reviews.llvm.org/D53915
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
Author: aleksandr.urakov
Date: Fri Nov 2 01:47:33 2018
New Revision: 345956
URL: http://llvm.org/viewvc/llvm-project?rev=345956&view=rev
Log:
[Windows] Fix Windows build after be053dd5a384a03da5a77552686900ddc7bfc178
Modified:
lldb/trunk/source/Host/windows/FileSystem.cpp
lldb/trunk/sour
aleksandr.urakov added a comment.
It's ok, I was able to fix it myself. Here is the commit: r345956
Repository:
rL LLVM
https://reviews.llvm.org/D53915
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailma
aleksandr.urakov added a comment.
Thank you!
https://reviews.llvm.org/D53368
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
Author: aleksandr.urakov
Date: Fri Nov 2 01:54:35 2018
New Revision: 345957
URL: http://llvm.org/viewvc/llvm-project?rev=345957&view=rev
Log:
[Symbol] Search symbols with name and type in a symbol file
Summary:
This patch adds possibility of searching a public symbol with name and type in a
symb
This revision was automatically updated to reflect the committed changes.
Closed by commit rLLDB345957: [Symbol] Search symbols with name and type in a
symbol file (authored by aleksandr.urakov, committed by ).
Repository:
rLLDB LLDB
https://reviews.llvm.org/D53368
Files:
include/lldb/Symbo
Author: grimar
Date: Fri Nov 2 02:03:25 2018
New Revision: 345958
URL: http://llvm.org/viewvc/llvm-project?rev=345958&view=rev
Log:
[LLDB] - Add support for DW_FORM_rnglistx and relative DW_RLE_* entries.
This adds support for DW_RLE_base_addressx, DW_RLE_startx_endx,
DW_RLE_startx_length, DW_FO
This revision was automatically updated to reflect the committed changes.
Closed by commit rL345958: [LLDB] - Add support for DW_FORM_rnglistx and
relative DW_RLE_* entries. (authored by grimar, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D53929?vs=172121&id=172323#toc
Re
aleksandr.urakov created this revision.
aleksandr.urakov added reviewers: zturner, stella.stamenova.
aleksandr.urakov added a project: LLDB.
Herald added subscribers: lldb-commits, teemperor.
This patch fixes the NativePDB tests to make them work from x86 command line
too.
Repository:
rLLDB L
zturner added a subscriber: aleksandr.urakov.
zturner added a comment.
Lgtm
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54031
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commi
Lgtm
On Fri, Nov 2, 2018 at 3:03 AM Aleksandr Urakov via Phabricator <
revi...@reviews.llvm.org> wrote:
> aleksandr.urakov created this revision.
> aleksandr.urakov added reviewers: zturner, stella.stamenova.
> aleksandr.urakov added a project: LLDB.
> Herald added subscribers: lldb-commits, teemp
aleksandr.urakov added a comment.
Thanks!
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54031
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
Author: aleksandr.urakov
Date: Fri Nov 2 07:15:29 2018
New Revision: 345974
URL: http://llvm.org/viewvc/llvm-project?rev=345974&view=rev
Log:
[NativePDB] Make tests work on x86 too
Summary:
This patch fixes the NativePDB tests to make them work from x86 command line too
Reviewers: zturner, stel
This revision was not accepted when it landed; it landed in state "Needs
Review".
This revision was automatically updated to reflect the committed changes.
Closed by commit rL345974: [NativePDB] Make tests work on x86 too (authored by
aleksandr.urakov, committed by ).
Herald added a subscriber: l
JDevlieghere added a comment.
In https://reviews.llvm.org/D54020#1285201, @labath wrote:
> I am not sure what do you mean by "translating paths" in the VFS. If you mean
> something like "return a `FILE *` for `/whatever/my_reproducer/vfs/bin/ls`
> when I ask for `/bin/ls`", then I think that's
JDevlieghere added inline comments.
Comment at: source/Host/common/FileSystem.cpp:253
+static int GetOpenFlags(uint32_t options) {
+ const bool read = options & File::OpenOptions::eOpenOptionRead;
+ const bool write = options & File::OpenOptions::eOpenOptionWrite;
-
JDevlieghere updated this revision to Diff 172382.
JDevlieghere marked 3 inline comments as done.
JDevlieghere added a comment.
Address Pavel's feedback:
- Un-const open functions.
- Remove `::Empty()` again as it was redundant with `operator bool()`.
- Rename `OpenFile` to just `Open`. We might
aprantl updated this revision to Diff 172388.
aprantl added a comment.
Herald added subscribers: kbarton, nemanjai.
Version that only overrides GetNumChildren to avoid creating dynamic clang
types.
https://reviews.llvm.org/D53530
Files:
include/lldb/Symbol/ClangASTContext.h
include/lldb/Sy
aprantl added a comment.
Fair point. So here's a version that only overrides GetNumChildren(). I'll
leave the type summary for a follow-up patch.
https://reviews.llvm.org/D53530
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists
aprantl updated this revision to Diff 172390.
aprantl added a comment.
Fix a bug in the testcase.
https://reviews.llvm.org/D53530
Files:
include/lldb/Symbol/ClangASTContext.h
include/lldb/Symbol/CompilerType.h
include/lldb/Symbol/GoASTContext.h
include/lldb/Symbol/JavaASTContext.h
inc
Author: jdevlieghere
Date: Fri Nov 2 10:34:16 2018
New Revision: 346002
URL: http://llvm.org/viewvc/llvm-project?rev=346002&view=rev
Log:
[FileSystme] Move ::open abstraction into FileSystem.
This moves the abstraction around ::open into the FileSystem, as is
already the case for ::fopen.
Modif
Author: jdevlieghere
Date: Fri Nov 2 10:34:17 2018
New Revision: 346003
URL: http://llvm.org/viewvc/llvm-project?rev=346003&view=rev
Log:
[FileSystem] Remove `SetFileSystem` method.
This is no longer relevant with the new way we initialize the
FileSystem.
Modified:
lldb/trunk/include/lldb/H
Author: zturner
Date: Fri Nov 2 10:49:01 2018
New Revision: 346008
URL: http://llvm.org/viewvc/llvm-project?rev=346008&view=rev
Log:
Refactor the lit configuration files
A year or so ago, I re-wrote most of the lit infrastructure in LLVM so
that it wasn't so boilerplate-y. I added lots of common
This revision was automatically updated to reflect the committed changes.
Closed by commit rLLDB346008: Refactor the lit configuration files (authored by
zturner, committed by ).
Herald added subscribers: teemperor, abidh.
Changed prior to commit:
https://reviews.llvm.org/D54009?vs=172254&id=17
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
In https://reviews.llvm.org/D54020#1285539, @JDevlieghere wrote:
> In https://reviews.llvm.org/D54020#1285201, @labath wrote:
>
> > I am not sure what do you mean by "translating paths" in the
Author: zturner
Date: Fri Nov 2 12:55:15 2018
New Revision: 346035
URL: http://llvm.org/viewvc/llvm-project?rev=346035&view=rev
Log:
Fix a bug in the lit test suite generation.
I'm not sure why this has to be CMAKE_CURRENT_SOURCE_DIR, but
it causes all kinds of strange cmake generation errors wh
JDevlieghere added a comment.
In https://reviews.llvm.org/D54020#1285799, @labath wrote:
> Ok, I think we're on the same page here. What I was wondering is that given
> this lack of generality (this operation would only be supported on
> `DiskBackedFilesystem`, and not all other kinds of file s
teemperor added a comment.
This looks nice, just added some minor comments below. Otherwise LGTM after
Davide's point is addressed.
Comment at: include/lldb/Symbol/ClangASTContext.h:909
clang::EnumConstantDecl *AddEnumerationValueToEnumerationType(
- lldb::opaque_compi
zturner added a comment.
This function is called in `SymbolFile/NativePDB` as well.
https://reviews.llvm.org/D54003
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
JDevlieghere added a comment.
Hi Zachary, looks like this broke GreenDragon:
http://green.lab.llvm.org/green/view/LLDB/job/lldb-cmake/12087/console
Can you have a look please?
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54009
___
lldb-comm
davide added a comment.
This broke MacOS. I'm going to revert this. To reproduce, just run `ninja
check-lldb` with your patches.
Please let me know if you need other informations.
Repository:
rLLDB LLDB
https://reviews.llvm.org/D53368
___
lldb-c
Author: davide
Date: Fri Nov 2 14:59:14 2018
New Revision: 346045
URL: http://llvm.org/viewvc/llvm-project?rev=346045&view=rev
Log:
Revert "[Symbol] Search symbols with name and type in a symbol file"
It broke MacOS buildbots.
Modified:
lldb/trunk/include/lldb/Symbol/SymbolFile.h
lldb/t
zturner created this revision.
zturner added reviewers: aleksandr.urakov, labath, lemo.
Herald added subscribers: erik.pilkington, mgorny.
Previously we were not able to accurately represent tag record types with clang
record decls. The primary reason for this is that for type information PDB
o
Fix incoming, sorry about that.
On Fri, Nov 2, 2018 at 2:57 PM Jonas Devlieghere via Phabricator <
revi...@reviews.llvm.org> wrote:
> JDevlieghere added a comment.
>
> Hi Zachary, looks like this broke GreenDragon:
> http://green.lab.llvm.org/green/view/LLDB/job/lldb-cmake/12087/console
>
> Can y
Author: zturner
Date: Fri Nov 2 15:02:09 2018
New Revision: 346046
URL: http://llvm.org/viewvc/llvm-project?rev=346046&view=rev
Log:
Fix the lit test suite.
This change was accidentally missed from the original changeset.
Modified:
lldb/trunk/lit/lit.site.cfg.py.in
Modified: lldb/trunk/lit
zturner added a subscriber: stella.stamenova.
zturner added a comment.
Fix incoming, sorry about that.
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54009
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/
This revision was automatically updated to reflect the committed changes.
Closed by commit rL346049: [FileSystem] Open File instances through the
FileSystem. (authored by JDevlieghere, committed by ).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://reviews.llvm.org/D54
This revision was automatically updated to reflect the committed changes.
Closed by commit rLLDB346049: [FileSystem] Open File instances through the
FileSystem. (authored by JDevlieghere, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D54020?vs=172382&id=172448#toc
Repositor
Author: jdevlieghere
Date: Fri Nov 2 15:34:51 2018
New Revision: 346049
URL: http://llvm.org/viewvc/llvm-project?rev=346049&view=rev
Log:
[FileSystem] Open File instances through the FileSystem.
This patch modifies how we open File instances in LLDB. Rather than
passing a path or FileSpec to the
jingham created this revision.
jingham added a reviewer: aprantl.
Herald added a subscriber: lldb-commits.
Sometimes you want to make sure that the target doesn't run at all when running
an expression, and you'd rather the expression fail if it would have run the
target. You can do this with th
aprantl accepted this revision.
aprantl added a comment.
This revision is now accepted and ready to land.
This is great! Why not just call it `--jit`?
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54056
___
lldb-commits mailing list
lldb-commi
jasonmolenda added a comment.
To me --jit sounds like an imperative (i.e. don't use the IR interpreter, jit
and execute this expression), whereas --allow-jit seems closer to the behavior
here.
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54056
aprantl added a comment.
Ah, I didn't realize that the behavior is to always try to interpret first.
Repository:
rLLDB LLDB
https://reviews.llvm.org/D54056
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/ma
JDevlieghere created this revision.
JDevlieghere added reviewers: davide, zturner, labath, tberghammer.
JDevlieghere added a project: LLDB.
Herald added a subscriber: mgorny.
In January Davide sent an e-mail to the mailing list to suggest removing
support for Go and Java. The plan was to have som
lemo accepted this revision.
lemo added a comment.
This revision is now accepted and ready to land.
nice!
Comment at: lldb/source/Plugins/SymbolFile/NativePDB/MangledAST.cpp:80
+
+ lldb::AccessType access =
+ (ttn->Tag == TagKind::Class) ? lldb::eAccessPrivate :
lldb::eA
jingham added a comment.
--jit wouldn't describe what the flag actually does. Currently allow-jit and
the SB Setting I added for it set the execution policy to
eExecutionPolicyWhenNeeded, not eExecutionPolicyAlways. So this really does
just allow the JIT to be used, it doesn't force it.
If w
Author: jingham
Date: Fri Nov 2 16:42:40 2018
New Revision: 346053
URL: http://llvm.org/viewvc/llvm-project?rev=346053&view=rev
Log:
Add an SBExpressionOptions setting mirroring the "exec" command's --allow-jit.
Differential Revision: https://reviews.llvm.org/D54056
Added:
lldb/trunk/pack
This revision was automatically updated to reflect the committed changes.
Closed by commit rL346053: Add an SBExpressionOptions setting mirroring the
"exec" command's --allow-jit. (authored by jingham, committed by
).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://re
zturner added a comment.
In https://reviews.llvm.org/D54053#1286272, @lemo wrote:
> nice!
AFAIU this is just the "default" access of the class. I should probably
investigate why it's needed in the first place, since it can be deduced from
the tag type.
https://reviews.llvm.org/D54053
__
Author: zturner
Date: Fri Nov 2 17:06:37 2018
New Revision: 346057
URL: http://llvm.org/viewvc/llvm-project?rev=346057&view=rev
Log:
Make sure to have lit load the configured site config first.
For the lldb unit test suite, we forgot to add the mapping from
site config to main config, so when it
Author: zturner
Date: Fri Nov 2 17:07:03 2018
New Revision: 346058
URL: http://llvm.org/viewvc/llvm-project?rev=346058&view=rev
Log:
Fix some windows-specific fallout from the FileSpec change.
Modified:
lldb/trunk/source/Host/windows/Host.cpp
lldb/trunk/unittests/SymbolFile/PDB/SymbolFil
teemperor added a comment.
Minor detail: The revision title only mentions Java, but this revision removes
both Go and Java.
Did anyone actually went through with Jim's proposal and posted this proposal
to some Go mailing list or so?
https://reviews.llvm.org/D54059
_
aleksandr.urakov added a comment.
Thanks for catching that! Unfortunately, I have no access to MacOS, can you
provide some more info about failure, please?
Repository:
rLLDB LLDB
https://reviews.llvm.org/D53368
___
lldb-commits mailing list
lldb
davide added a comment.
In https://reviews.llvm.org/D53368#1286361, @aleksandr.urakov wrote:
> Thanks for catching that! Unfortunately, I have no access to MacOS, can you
> provide some more info about failure, please?
Unfortunately the bot logs are gone. When I originally looked at them they
aleksandr.urakov added a comment.
I'm not sure, but have an assumption. Here is the first green build of the
green-dragon-24: http://green.lab.llvm.org/green/job/lldb-cmake/12090/ It
became green after three changes, one of them is your revert of my commit,
while another is Zachary's "Fix the l
56 matches
Mail list logo