[Lldb-commits] [PATCH] D55584: Simplify boolean expressions

2018-12-11 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik added a comment. I find the `static_cast` to be a bit too clever, I don't think it helps readability. This is also too large to digest in a way I would feel satisfied that I did not miss anything. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D55584/new

[Lldb-commits] [PATCH] D55584: Simplify boolean expressions

2018-12-11 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added a comment. This one is probably less controversial than D55574 :-) Comment at: include/lldb/Target/ThreadPlanTracer.h:46 TracingStarted(); -else if (old_value == true && value == false) +else if (old_value && !valu