[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Dave Lee via Phabricator via lldb-commits
kastiglione updated this revision to Diff 494783. kastiglione added a comment. Add a couple tests Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143282/new/ https://reviews.llvm.org/D143282 Files: lldb/bindings/interface/SBBreakpoint.i lldb/bin

[Lldb-commits] [PATCH] D143308: [lldb/Plugins] Fix method dispatch bug when using multiple scripted processes

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 494779. mib added a comment. Fix test failure CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143308/new/ https://reviews.llvm.org/D143308 Files: lldb/include/lldb/Interpreter/ScriptInterpreter.h lldb/include/lldb/Interpreter/ScriptedInterface.h ll

[Lldb-commits] [PATCH] D143308: [lldb/Plugins] Fix method dispatch bug when using multiple scripted processes

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added reviewers: JDevlieghere, bulbazord. mib added a project: LLDB. Herald added a project: All. mib requested review of this revision. Herald added a subscriber: lldb-commits. This patch should address a bug when a user have multiple scripted processes in the same

[Lldb-commits] [PATCH] D133129: [lldb] Add boilerplate for debugger interrupts

2023-02-03 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere abandoned this revision. JDevlieghere added a comment. Jim is working on another way to tackle this. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D133129/new/ https://reviews.llvm.org/D133129 ___ lldb-commits mailing list lldb-co

[Lldb-commits] [PATCH] D142926: [lldb][RFC] Replace SB swig interfaces with API headers

2023-02-03 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: lldb/bindings/interface/SBAddressDocstrings.i:1-2 +%feature("docstring", +"A section + offset based address class. + bulbazord wrote: > mib wrote: > > kastiglione wrote: > > > How much of these header docs are speci

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGc19280330474: [lldb] Add a way to get a scripted process implementation from the SBAPI (authored by mib). Repository: rG LLVM Github Monorepo CHA

[Lldb-commits] [lldb] c192803 - [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Med Ismail Bennani via lldb-commits
Author: Med Ismail Bennani Date: 2023-02-03T12:29:01-08:00 New Revision: c1928033047409f977b26ffc938d59188f1ced97 URL: https://github.com/llvm/llvm-project/commit/c1928033047409f977b26ffc938d59188f1ced97 DIFF: https://github.com/llvm/llvm-project/commit/c1928033047409f977b26ffc938d59188f1ced97.

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 494704. mib edited the summary of this revision. mib added a comment. Address @JDevlieghere feedback: - Rename API to `GetScriptedImplementation` - Add test for non scripted process plugins CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143236/new/ http

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Jim Ingham via Phabricator via lldb-commits
jingham accepted this revision. jingham added a comment. This revision is now accepted and ready to land. LGTM if Jonas is also happy. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143236/new/ https://reviews.llvm.org/D143236 ___ lldb-commits

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. I'd call it `GetScriptedImplementation()` to make it clear this isn't going to give you the underlying `lldb_private` class or anything like that. What happens in Python when you don't have a scripted implementation? Is the resu

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib updated this revision to Diff 494695. mib added a comment. Address @jingham comment. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143236/new/ https://reviews.llvm.org/D143236 Files: lldb/bindings/interface/SBProcess.i lldb/bindings/python/python-typemaps.swig lldb/include/ll

[Lldb-commits] [PATCH] D142926: [lldb][RFC] Replace SB swig interfaces with API headers

2023-02-03 Thread Alex Langford via Phabricator via lldb-commits
bulbazord added a comment. In D142926#4102287 , @labath wrote: > I like this. > > I'm not sure what it would take, but I think it'd be nice if the > de-swig-ification was not specific to the framework build. Ideally, I'd make > it controlled by a separa

[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Alex Langford via Phabricator via lldb-commits
bulbazord added a comment. A simple test would be what you did in your commit summary, trying to get `thread.frame[-1]` and verifying that it's the correct frame. LGTM with a test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143282/new/ https://

[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib added a comment. In D143282#4103165 , @kastiglione wrote: > I wondered what to do about tests. Should I pick one of these to test? Just > doesn't seem worth tests for each… Yeah, that sounds good to me :) Repository: rG LLVM Github Monorepo CHA

[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Dave Lee via Phabricator via lldb-commits
kastiglione added a comment. I wondered what to do about tests. Should I pick one of these to test? Just doesn't seem worth tests for each… Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143282/new/ https://reviews.llvm.org/D143282

[Lldb-commits] [PATCH] D143236: [lldb] Add a way to get a scripted process implementation from the SBAPI

2023-02-03 Thread Jim Ingham via Phabricator via lldb-commits
jingham requested changes to this revision. jingham added inline comments. This revision now requires changes to proceed. Comment at: lldb/bindings/python/python-typemaps.swig:57 +%typemap(out) void* { + $result = nullptr; Won't this make every out void * clai

[Lldb-commits] [PATCH] D143127: [LLDB] Fix assertion failure by removing `CopyType` in `std::coroutine_handle` pretty printer

2023-02-03 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl accepted this revision. aprantl added a comment. > Well.. I don't believe we have any ASTImporter calls in any of the other > pretty printers, so I think this change is good. And if it causes some other > issues, then maybe we need to look at solving them in some other way... Okay I gue

[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib accepted this revision. mib added a comment. This revision is now accepted and ready to land. This is nice although I wish there was a built way to do it. LGTM with a test :) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143282/new/ https://rev

[Lldb-commits] [PATCH] D142926: [lldb][RFC] Replace SB swig interfaces with API headers

2023-02-03 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib added inline comments. Comment at: lldb/bindings/interface/SBAddressDocstrings.i:1-2 +%feature("docstring", +"A section + offset based address class. + kastiglione wrote: > How much of these header docs are specific to the API, but not specific to > Swig bin

[Lldb-commits] [PATCH] D142926: [lldb][RFC] Replace SB swig interfaces with API headers

2023-02-03 Thread Dave Lee via Phabricator via lldb-commits
kastiglione added inline comments. Comment at: lldb/bindings/interface/SBAddressDocstrings.i:1-2 +%feature("docstring", +"A section + offset based address class. + How much of these header docs are specific to the API, but not specific to Swig bindings? Should/c

[Lldb-commits] [PATCH] D143282: [lldb] Accept negative indexes in __getitem__

2023-02-03 Thread Dave Lee via Phabricator via lldb-commits
kastiglione created this revision. kastiglione added reviewers: JDevlieghere, mib, bulbazord. Herald added a subscriber: arphaman. Herald added a project: All. kastiglione requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. To the Python bindin

[Lldb-commits] [PATCH] D140999: [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Sam Elliott via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG8c712296fb75: [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h (authored by lenary). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D140999/new/

[Lldb-commits] [lldb] 8c71229 - [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Archibald Elliott via lldb-commits
Author: Archibald Elliott Date: 2023-02-03T17:34:01Z New Revision: 8c712296fb75ff73db08f92444b35c438c01a405 URL: https://github.com/llvm/llvm-project/commit/8c712296fb75ff73db08f92444b35c438c01a405 DIFF: https://github.com/llvm/llvm-project/commit/8c712296fb75ff73db08f92444b35c438c01a405.diff

[Lldb-commits] [PATCH] D138618: [LLDB] Enable 64 bit debug/type offset

2023-02-03 Thread Alexander Yermolovich via Phabricator via lldb-commits
ayermolo added a comment. In D138618#4102275 , @labath wrote: > In D138618#4094933 , @clayborg > wrote: > >>> - My main source of frustration was that my concern is getting >>> overlooked/ignored (not necessaril

[Lldb-commits] [lldb] 2e70da2 - [lldb] Enable arm64 target for entry values test

2023-02-03 Thread Felipe de Azevedo Piovezan via lldb-commits
Author: Felipe de Azevedo Piovezan Date: 2023-02-03T09:52:20-05:00 New Revision: 2e70da2e431a4979af9742553172d48d0b453e29 URL: https://github.com/llvm/llvm-project/commit/2e70da2e431a4979af9742553172d48d0b453e29 DIFF: https://github.com/llvm/llvm-project/commit/2e70da2e431a4979af9742553172d48d0

[Lldb-commits] [PATCH] D143265: [lldb] Enable arm64 target for entry values test

2023-02-03 Thread Felipe de Azevedo Piovezan via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG2e70da2e431a: [lldb] Enable arm64 target for entry values test (authored by fdeazeve). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D143265/new/ https://rev

[Lldb-commits] [PATCH] D143265: [lldb] Enable arm64 target for entry values test

2023-02-03 Thread Felipe de Azevedo Piovezan via Phabricator via lldb-commits
fdeazeve created this revision. fdeazeve added a reviewer: Michael137. Herald added subscribers: omjavaid, kristof.beyls. Herald added a project: All. fdeazeve requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This test is supposed to work in

[Lldb-commits] [PATCH] D140999: [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Sam Elliott via Phabricator via lldb-commits
lenary added a comment. Most recent diff was to clang-format the patch, which has removed some duplicate includes. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D140999/new/ https://reviews.llvm.org/D140999

[Lldb-commits] [PATCH] D140999: [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Sam Elliott via Phabricator via lldb-commits
lenary updated this revision to Diff 494600. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D140999/new/ https://reviews.llvm.org/D140999 Files: clang/lib/Basic/Targets/AArch64.cpp clang/lib/Basic/Targets/AArch64.h clang/lib/CodeGen/CGBuiltin.cp

[Lldb-commits] [PATCH] D140999: [NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Sam Elliott via Phabricator via lldb-commits
lenary retitled this revision from "[NFC][TargetParser] Deprecate llvm/Support/AArch64TargetParser.h" to "[NFC][TargetParser] Remove llvm/Support/AArch64TargetParser.h". lenary edited the summary of this revision. lenary updated this revision to Diff 494596. Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D140999: [NFC][TargetParser] Deprecate llvm/Support/AArch64TargetParser.h

2023-02-03 Thread Sam Elliott via Phabricator via lldb-commits
lenary added a comment. In D140999#4030131 , @MaskRay wrote: > I don't think it is necessary to deprecate the old header then delete it > after 16.0.0 is branched. > llvm/Support/AArch64TargetParser.h has very few open-source out-of-tree uses. > Perhaps

[Lldb-commits] [PATCH] D143127: [LLDB] Fix assertion failure by removing `CopyType` in `std::coroutine_handle` pretty printer

2023-02-03 Thread Adrian Vogelsgesang via Phabricator via lldb-commits
avogelsgesang added a comment. Agree, other pretty-printers also don't use `ASTImporter`. I think the call was still needed originally in https://github.com/llvm/llvm-project/commit/01f4c305fae9ff2f165ce0f635a90f8e2292308c, because the promise_type was combined with newly created AST types whic

[Lldb-commits] [PATCH] D142926: [lldb][RFC] Replace SB swig interfaces with API headers

2023-02-03 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I like this. I'm not sure what it would take, but I think it'd be nice if the de-swig-ification was not specific to the framework build. Ideally, I'd make it controlled by a separate cmake variable, (autodetected to on if the relevant tool is found, but also overridable

[Lldb-commits] [PATCH] D142309: [LLDB][NFC] Fix a incorrect use of shared_ptr in RenderScriptRuntime.cpp

2023-02-03 Thread Pavel Labath via Phabricator via lldb-commits
labath added a subscriber: srhines. labath added a comment. In D142309#4075745 , @JDevlieghere wrote: > LGTM, but I wonder when we'll be able to get rid of RenderScript completely > (CC @labath) I am not going to stand in your way. I usually redirect t

[Lldb-commits] [PATCH] D138618: [LLDB] Enable 64 bit debug/type offset

2023-02-03 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D138618#4094933 , @clayborg wrote: >> - My main source of frustration was that my concern is getting >> overlooked/ignored (not necessarily your fault -- I've been told I am not >> always sufficiently clear). I think that is s

[Lldb-commits] [PATCH] D143127: [LLDB] Fix assertion failure by removing `CopyType` in `std::coroutine_handle` pretty printer

2023-02-03 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Well.. I don't believe we have any ASTImporter calls in any of the other pretty printers, so I think this change is good. And if it causes some other issues, then maybe we need to look at solv

[Lldb-commits] [PATCH] D142309: [LLDB][NFC] Fix a incorrect use of shared_ptr in RenderScriptRuntime.cpp

2023-02-03 Thread Shivam Gupta via Phabricator via lldb-commits
xgupta added a comment. In D142309#4075745 , @JDevlieghere wrote: > LGTM, but I wonder when we'll be able to get rid of RenderScript completely > (CC @labath) @JDevlieghere, Shall I commit the changes after running check-lldb? Repository: rG LLVM G

[Lldb-commits] [PATCH] D142341: [LLDB][NFC] Fix valobj_sp null pointer checks in lldb/source/Plugins/Language/

2023-02-03 Thread Shivam Gupta via Phabricator via lldb-commits
xgupta added a comment. gentle ping for review. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D142341/new/ https://reviews.llvm.org/D142341 ___ lldb-commits mailing list lldb-commits@lists.llvm.org https:

[Lldb-commits] [PATCH] D143215: Separate Process::GetWatchpointSupportInfo into two methods to get the two separate pieces of information

2023-02-03 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added a reviewer: DavidSpickett. DavidSpickett added a comment. I like removing a return by ref and being explicit about what info is wanted where. So say the stub reports the "watchpoints received" but not the number of slots. Does lldb just send the watchpoint set packets and re