[Lldb-commits] [PATCH] D101361: [LLDB] Support AArch64/Linux watchpoint on tagged addresses

2021-06-30 Thread Muhammad Omair Javaid via Phabricator via lldb-commits
omjavaid updated this revision to Diff 355735. omjavaid added a comment. This update makes native register context changes restricted to Linux/Arm64. Also tweeks test case a little bit. PS: This test may fail on QEMU. There is QEMU bug that reports wrong watchpoint hit address in case top byte

[Lldb-commits] [PATCH] D105166: Fix expression evaluation result expansion in lldb-vscode

2021-06-30 Thread jeffrey tan via Phabricator via lldb-commits
yinghuitan added inline comments. Comment at: lldb/tools/lldb-vscode/VSCode.cpp:531 +void Variables::Clear() { + locals.Clear(); clayborg wrote: > I am not sure. I like to call it Clear() in cause we will need to call it from other scenario beyond process co

[Lldb-commits] [PATCH] D104395: [LLDB][GUI] Add initial forms support

2021-06-30 Thread Omar Emara via Phabricator via lldb-commits
OmarEmaraDev added a comment. Full example: F17684763: 20210630-220202.mp4 <https://reviews.llvm.org/F17684763> Example API definition for the above example: class TestFormDelegate : public FormDelegate { public: TestFormDelegate() { m_text_field = AddTextField("Text

[Lldb-commits] [PATCH] D104395: [LLDB][GUI] Add initial forms support

2021-06-30 Thread Omar Emara via Phabricator via lldb-commits
OmarEmaraDev updated this revision to Diff 355672. OmarEmaraDev added a comment. This revision is now accepted and ready to land. - Add contextual scrolling support. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104395/new/ https://reviews.llvm.org

[Lldb-commits] [PATCH] D105215: [lldb] Remove CPlusPlusLanguage from Mangled

2021-06-30 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. In D105215#2850821 , @bulbazord wrote: > I kind of feel that `Language::GetDemangledFunctionNameWithoutArguments` may > be a bit too specific for a generalized language plugins. I think it may be > worth it to make `Mangled` an

[Lldb-commits] [PATCH] D105215: [lldb] Remove CPlusPlusLanguage from Mangled

2021-06-30 Thread Alex Langford via Phabricator via lldb-commits
bulbazord added a comment. Herald added a subscriber: JDevlieghere. I kind of feel that `Language::GetDemangledFunctionNameWithoutArguments` may be a bit too specific for a generalized language plugins. I think it may be worth it to make `Mangled` an interface that language plugins can implement

[Lldb-commits] [PATCH] D105215: [lldb] Remove CPlusPlusLanguage from Mangled

2021-06-30 Thread Alex Langford via Phabricator via lldb-commits
bulbazord created this revision. bulbazord added reviewers: teemperor, jingham. bulbazord requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. The only remaining plugin dependency in Mangled is CPlusPlusLanguage which it uses to extract informat

[Lldb-commits] [PATCH] D93479: [lldb] Simplify the is_finalized logic in process and make it thread safe.

2021-06-30 Thread Adam Brouwers-Harries via Phabricator via lldb-commits
aharries-upmem added a comment. > ! In D93479#2850445 , @jingham wrote: > Don't hesitate to reach out for questions, explanations, "what the heck"-s > once you get back to this. Thanks Jim, that's very kind of you! Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D100261: [lldb] [gdb-remote server] Support selecting process via Hg

2021-06-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. I'm probably not the most qualified to sign off on this, but the review has stalled and I don't see anything obviously wrong here so LGTM. Comment at: lldb/sour

[Lldb-commits] [PATCH] D100262: [lldb] [gdb-remote client] Support switching PID along with TID

2021-06-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added inline comments. Comment at: lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.h:337 - llvm::Optional SendSetCurrentThreadPacket(uint64_t tid, char type); + llvm::Optional> + SendSetCurrentThreadPacket(uint64_t tid, uint64_t pid, char ty

[Lldb-commits] [PATCH] D93479: [lldb] Simplify the is_finalized logic in process and make it thread safe.

2021-06-30 Thread Jim Ingham via Phabricator via lldb-commits
jingham added a comment. In D93479#2850104 , @aharries-upmem wrote: > In D93479#2841049 , @jingham wrote: > >> Huh... I fear you are going to have to debug this further on your end. I >> can't see anything else

[Lldb-commits] [PATCH] D104826: Replace SVE_PT* macros in NativeRegisterContextLinux_arm64.{cpp, h} with their equivalent defintions in LinuxPTraceDefines_arm64sve.h

2021-06-30 Thread Caroline Tice via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG05915400b7f9: [lldb] Replace SVE_PT* macros in NativeRegisterContextLinux_arm64.{cpp,h} with… (authored by cmtice). Herald added a project: LLDB. Her

[Lldb-commits] [lldb] 0591540 - [lldb] Replace SVE_PT* macros in NativeRegisterContextLinux_arm64.{cpp, h} with their equivalent defintions in LinuxPTraceDefines_arm64sve.h

2021-06-30 Thread Caroline Tice via lldb-commits
Author: Caroline Tice Date: 2021-06-30T09:26:20-07:00 New Revision: 05915400b7f9933b95686116f2dc1370e7f96cfb URL: https://github.com/llvm/llvm-project/commit/05915400b7f9933b95686116f2dc1370e7f96cfb DIFF: https://github.com/llvm/llvm-project/commit/05915400b7f9933b95686116f2dc1370e7f96cfb.diff

[Lldb-commits] [PATCH] D93479: [lldb] Simplify the is_finalized logic in process and make it thread safe.

2021-06-30 Thread Adam Brouwers-Harries via Phabricator via lldb-commits
aharries-upmem added a comment. In D93479#2841049 , @jingham wrote: > Huh... I fear you are going to have to debug this further on your end. I > can't see anything else suspect in this patch. Agreed. Sadly I need to prioritise another task in the short

[Lldb-commits] [PATCH] D103744: [lldb][docs] Remove mention of subversion. NFC.

2021-06-30 Thread Shivam Gupta via Phabricator via lldb-commits
xgupta added a comment. seems you forget to commit it, @brucem :) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D103744/new/ https://reviews.llvm.org/D103744 ___ lldb-commits mailing list lldb-commits@lis

[Lldb-commits] [PATCH] D105183: [lldb] Add "memory tag write" --end-addr option

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added a subscriber: dang. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. The default mode of "memory tag write" is to calculate the range from the start address and the number of ta

[Lldb-commits] [PATCH] D105182: [lldb] Add "memory tag write" command

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This adds a new command for writing memory tags. It is based on the existing "memory write" command. Syntax: memory tag write [ [...]] (wh

[Lldb-commits] [PATCH] D105181: [lldb][AArch64] Add memory tag writing to lldb

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added subscribers: danielkiss, kristof.beyls. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This adds memory tag writing to Process and the GDB remote code. Supporting work for the

[Lldb-commits] [PATCH] D105180: [lldb][AArch64] Add memory tag writing to lldb-server

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added subscribers: danielkiss, kristof.beyls. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. This is implemented using the QMemTags packet, as specified by GDB in: https://sourcewar

[Lldb-commits] [PATCH] D105179: [lldb][AArch64] Add tag repeat and unpack to memory tag manager

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added subscribers: danielkiss, kristof.beyls. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. PackTags is used by to compress tags to go in the QMemTags packet and be passed to ptrac

[Lldb-commits] [PATCH] D105178: [lldb][AArch64] Annotate synchronous tag faults

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett added reviewers: omjavaid, pcc. DavidSpickett added a subscriber: pcc. DavidSpickett added a comment. Herald added a subscriber: JDevlieghere. @pcc This makes use of the kernel changes you did, let me know if I have anything wrong. Note that the situation where you can't read the a

[Lldb-commits] [PATCH] D105178: [lldb][AArch64] Annotate synchronous tag faults

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett created this revision. Herald added subscribers: danielkiss, kristof.beyls. DavidSpickett requested review of this revision. Herald added a project: LLDB. Herald added a subscriber: lldb-commits. In the latest Linux kernels synchronous tag faults include the tag bits in their address

[Lldb-commits] [PATCH] D104914: [lldb] Correct format of qMemTags type field

2021-06-30 Thread David Spickett via Phabricator via lldb-commits
DavidSpickett updated this revision to Diff 355486. DavidSpickett added a comment. - Remove redundant check on type value - Explain how we check the target has MTE Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104914/new/ https://reviews.llvm.org/D

[Lldb-commits] [PATCH] D105134: [jenkins] Update script to use cross-project lit test suite

2021-06-30 Thread James Henderson via Phabricator via lldb-commits
jhenderson accepted this revision. jhenderson added a comment. Looks good, with the exception of my inline comment. Comment at: zorg/jenkins/build.py:619 run_cmd(conf.lldbbuilddir(), ['/usr/bin/env', 'TERM=vt100', NINJA, '-v', - 'check-debu

[Lldb-commits] [PATCH] D105134: [jenkins] Update script to use cross-project lit test suite

2021-06-30 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. LGTM! Repository: rZORG LLVM Github Zorg CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105134/new/ https://reviews.llvm.org/D105134 ___ lldb-commits mailing list lldb-commi

[Lldb-commits] [PATCH] D105134: [jenkins] Update script to use cross-project lit test suite

2021-06-30 Thread Med Ismail Bennani via Phabricator via lldb-commits
mib created this revision. mib added reviewers: JDevlieghere, teemperor, jhenderson. mib added projects: Zorg, LLDB. Herald added a subscriber: mgorny. Herald added a reviewer: gkistanova. mib requested review of this revision. To reflect changes announced in https://lists.llvm.org/pipermail/llvm

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Martin Storsjö via Phabricator via lldb-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG3eed57e7ef7d: [ADT] Rename StringRef case insensitive methods for clarity (authored by mstorsjo). Changed prior to commit: https://reviews.llvm.or

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D104819#2839263 , @dexonsmith wrote: > LGTM, once @MaskRay is happy. I have a couple of minor comments inline too. > > (I also see that there are some clang-format suggestions in the unit tests; > not sure any of them are ac

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Duncan P. N. Exon Smith via Phabricator via lldb-commits
dexonsmith added a comment. In D104819#2839315 , @mstorsjo wrote: > In D104819#2839263 , @dexonsmith > wrote: > >> Just be sure to clang-format when you do the mechanical changes in the >> follow up patches.) >

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Chris Lattner via Phabricator via lldb-commits
lattner accepted this revision. lattner added a comment. Thank you! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D104819/new/ https://reviews.llvm.org/D104819 ___ lldb-commits mailing list lldb-commits@l

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Duncan P. N. Exon Smith via Phabricator via lldb-commits
dexonsmith accepted this revision. dexonsmith added a comment. This revision is now accepted and ready to land. LGTM, once @MaskRay is happy. I have a couple of minor comments inline too. (I also see that there are some clang-format suggestions in the unit tests; not sure any of them are actuall

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo updated this revision to Diff 354178. mstorsjo added a comment. Reduced this patch only to updating of the StringRef class itself and its unit test, removing the mechanical changes. Removed superfluous method name duplication in doxygen comments. Repository: rG LLVM Github Monorepo

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Fangrui Song via Phabricator via lldb-commits
MaskRay added inline comments. Comment at: llvm/include/llvm/ADT/StringRef.h:192 -/// equals_lower - Check for string equality, ignoring case. +/// equals_insensitive - Check for string equality, ignoring case. LLVM_NODISCARD https://llvm.org/docs/

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Martin Storsjö via Phabricator via lldb-commits
mstorsjo added a comment. In D104819#2837421 , @dexonsmith wrote: > Given how large this is, would it be reasonable to split this up a bit more? > > What I might do if this were my patch: get a review of the API change + the > manual changes in one patc

[Lldb-commits] [PATCH] D104819: [ADT] Rename StringRef case insensitive methods for clarity

2021-06-30 Thread Duncan P. N. Exon Smith via Phabricator via lldb-commits
dexonsmith added a comment. Given how large this is, would it be reasonable to split this up a bit more? What I might do if this were my patch: get a review of the API change + the manual changes in one patch (assuming there aren't many manual changes), then land the remaining mechanical change