Author: adrian
Date: Thu May 24 17:29:01 2018
New Revision: 333248
URL: http://llvm.org/viewvc/llvm-project?rev=333248&view=rev
Log:
HostInfoMacOSX: Support finding the clang resource directory within CLTools.
rdar://problem/40537961
Modified:
lldb/trunk/source/Host/macosx/HostInfoMacOSX.mm
Author: jingham
Date: Thu May 24 16:33:27 2018
New Revision: 333238
URL: http://llvm.org/viewvc/llvm-project?rev=333238&view=rev
Log:
Add DWARFBaseDie.{h,cpp} to the Xcode build.
This should unbreak the green dragon bot builds.
Modified:
lldb/trunk/lldb.xcodeproj/project.pbxproj
Modified: l
clayborg added a comment.
In https://reviews.llvm.org/D46810#570, @jankratochvil wrote:
> In https://reviews.llvm.org/D46810#1098110, @clayborg wrote:
>
> > So this problem exists both in the LLDB and LLVM DWARF parsers. I am not
> > sure this fix is safe. I would rather fix this by fixing D
clayborg added a comment.
Be sure to not pass through any experimental settings.
Repository:
rL LLVM
https://reviews.llvm.org/D47302
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-com
clayborg added a comment.
In https://reviews.llvm.org/D47302#569, @polyakov.alex wrote:
> In https://reviews.llvm.org/D47302#497, @clayborg wrote:
>
> > no. Create a new SBTargetSettings class. SBTarget will hand one out for
> > global and for target instance settings, Add all settings a
clayborg added a comment.
A better solution here would be to have two functions: one for parsing the Unit
DIE only and one for parsing all DIEs:
class DWARFUnit {
void ExtractUnitDIEIfNeeded();
size_t ExtractDIEsIfNeeded();
}
Then the code becomes much simpler, we don't need the "m_
jankratochvil added a comment.
In https://reviews.llvm.org/D46810#1098110, @clayborg wrote:
> So this problem exists both in the LLDB and LLVM DWARF parsers. I am not sure
> this fix is safe. I would rather fix this by fixing DWARFDIE class to "do the
> right thing". We should be able to teach
polyakov.alex added a comment.
In https://reviews.llvm.org/D47302#497, @clayborg wrote:
> no. Create a new SBTargetSettings class. SBTarget will hand one out for
> global and for target instance settings, Add all settings accessors to
> SBTargetSettings class
What is a difference between
jankratochvil updated this revision to Diff 148480.
https://reviews.llvm.org/D46810
Files:
source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp
source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.h
source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp
source/Plugins/SymbolFile/DWARF/DWARFUnit.
This revision was not accepted when it landed; it landed in state "Needs
Review".
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333224: Use DWARFBaseDIE as a compile-time protection
(authored by jankratochvil, committed by ).
Herald added a subscribe
Author: jankratochvil
Date: Thu May 24 13:51:13 2018
New Revision: 333224
URL: http://llvm.org/viewvc/llvm-project?rev=333224&view=rev
Log:
Use DWARFBaseDIE as a compile-time protection
As suggested by Pavel Labath in D46810 DWARFUnit::GetUnitDIEOnly() returning
a pointer to m_first_die should no
jankratochvil updated this revision to Diff 148474.
jankratochvil retitled this revision from "2/3: Use DWARFBasicDIE as
compile-time protection" to "2/3: Use DWARFBaseDIE as compile-time protection".
https://reviews.llvm.org/D47276
Files:
source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cp
clayborg added a comment.
Rename to DWARFBaseDIE and this is good to go.
https://reviews.llvm.org/D47276
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
This revision was not accepted when it landed; it landed in state "Needs
Revision".
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333222: DWARFDIE split out to DWARFBaseDIE (authored by
jankratochvil, committed by ).
Herald added a subscriber: llvm-c
Author: jankratochvil
Date: Thu May 24 13:44:48 2018
New Revision: 333222
URL: http://llvm.org/viewvc/llvm-project?rev=333222&view=rev
Log:
DWARFDIE split out to DWARFBaseDIE
This new DWARFBaseDIE is going to be used for DWARFUnit::GetUnitDIEOnly() as
other DIEs are unavailable that time so the c
labath accepted this revision.
labath added a comment.
This revision is now accepted and ready to land.
Fine by me.
https://reviews.llvm.org/D47342
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listi
clayborg added a comment.
no. Create a new SBTargetSettings class. SBTarget will hand one out for global
and for target instance settings, Add all settings accessors to
SBTargetSettings class
Repository:
rL LLVM
https://reviews.llvm.org/D47302
clayborg added a comment.
Looks good to me. Pavel, you ok with the file location?
https://reviews.llvm.org/D47342
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
xiaobai added a comment.
In https://reviews.llvm.org/D47278#1110777, @labath wrote:
> From a layering perspective, it makes sense for SystemInitializerFull to live
> in the outermost layer, as it's the thing which makes sure liblldb pulls in
> all required components. Since it is only included
polyakov.alex added a comment.
In https://reviews.llvm.org/D47302#377, @clayborg wrote:
> In https://reviews.llvm.org/D47302#372, @polyakov.alex wrote:
>
> > In https://reviews.llvm.org/D47302#351, @clayborg wrote:
> >
> > > In https://reviews.llvm.org/D47302#249, @polyakov.alex w
xiaobai created this revision.
xiaobai added reviewers: labath, clayborg.
It seems to me that files in include/lldb/API/ are headers that should
be exposed to liblldb users. Because SystemInitializerFull.h exposes details of
lldb_private, I think having it there is not the right thing to do. Since
clayborg requested changes to this revision.
clayborg added a comment.
This revision now requires changes to proceed.
ok, just rename DWARFFirstDIE to DWARFBaseDIE and this is good to go.
https://reviews.llvm.org/D47275
___
lldb-commits mailing list
labath added a comment.
Yes, Base is fine. Thank you.
https://reviews.llvm.org/D47275
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
clayborg added a comment.
In https://reviews.llvm.org/D47302#372, @polyakov.alex wrote:
> In https://reviews.llvm.org/D47302#351, @clayborg wrote:
>
> > In https://reviews.llvm.org/D47302#249, @polyakov.alex wrote:
> >
> > > In https://reviews.llvm.org/D47302#078, @clayborg wrote:
polyakov.alex added a comment.
In https://reviews.llvm.org/D47302#351, @clayborg wrote:
> In https://reviews.llvm.org/D47302#249, @polyakov.alex wrote:
>
> > In https://reviews.llvm.org/D47302#078, @clayborg wrote:
> >
> > > It might make sense to create a new SBTargetSettings class t
clayborg added a comment.
In https://reviews.llvm.org/D47275#285, @labath wrote:
> In https://reviews.llvm.org/D47275#254, @clayborg wrote:
>
> > In https://reviews.llvm.org/D47275#1110772, @labath wrote:
> >
> > > I don't think a name like `DWARFUnitDIE` is a good one bacause it would
>
clayborg added a comment.
In https://reviews.llvm.org/D47302#249, @polyakov.alex wrote:
> In https://reviews.llvm.org/D47302#078, @clayborg wrote:
>
> > It might make sense to create a new SBTargetSettings class that has
> > accessors. Then we can have to accessors on SBTarget:
> >
> >
labath added a comment.
In https://reviews.llvm.org/D47275#254, @clayborg wrote:
> In https://reviews.llvm.org/D47275#1110772, @labath wrote:
>
> > I don't think a name like `DWARFUnitDIE` is a good one bacause it would
> > make a weird `is-a` relationship (a DWARFDIE represetning a DW_TAG_v
clayborg added a comment.
In https://reviews.llvm.org/D47275#1110772, @labath wrote:
> I don't think a name like `DWARFUnitDIE` is a good one bacause it would make
> a weird `is-a` relationship (a DWARFDIE represetning a DW_TAG_variable is
> certainly **not** a "unit DIE" yet you could assign i
polyakov.alex added a comment.
In https://reviews.llvm.org/D47302#078, @clayborg wrote:
> It might make sense to create a new SBTargetSettings class that has
> accessors. Then we can have to accessors on SBTarget:
>
> class SBTarget {
> static SBTargetSettings GetGlobalSettings();
>
clayborg added a comment.
The main reason for the split up in SBTargetSettings is we have both global
settings and the target specific settings. If you modify the global settings,
you are modifying the target settings for all future targets. As they get
created, they will copy the global settin
Author: jingham
Date: Thu May 24 10:06:48 2018
New Revision: 333208
URL: http://llvm.org/viewvc/llvm-project?rev=333208&view=rev
Log:
pc's should be printed in hex...
Modified:
lldb/trunk/source/Target/ThreadPlanStepOverBreakpoint.cpp
Modified: lldb/trunk/source/Target/ThreadPlanStepOverBrea
Author: jingham
Date: Thu May 24 10:06:11 2018
New Revision: 333207
URL: http://llvm.org/viewvc/llvm-project?rev=333207&view=rev
Log:
Add SystemInitializerLLGS to the lldb-server target.
This should unbreak the xcode build.
Modified:
lldb/trunk/lldb.xcodeproj/project.pbxproj
Modified: lldb/
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333205: [lldb-mi] Add possibility to set breakpoints without
selecting a target. (authored by adrian, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D46588?vs=148323&id=148436#toc
Re
Author: adrian
Date: Thu May 24 09:45:59 2018
New Revision: 333205
URL: http://llvm.org/viewvc/llvm-project?rev=333205&view=rev
Log:
[lldb-mi] Add possibility to set breakpoints without selecting a target.
Now it's possible to set breakpoints before selecting a target, they
will be set to the dum
labath added a comment.
In https://reviews.llvm.org/D47275#215, @clayborg wrote:
> I like DWARFFirstDIE. Pavel should ok this too.
I said what I think of DWARFFirstDIE. I'd like to hear from you what you think
about the is-a issue I mentioned.
https://reviews.llvm.org/D47275
_
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
I like DWARFFirstDIE. Pavel should ok this too.
https://reviews.llvm.org/D47275
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
htt
> On May 23, 2018, at 7:21 PM, Zachary Turner wrote:
>
>
> On Wed, May 23, 2018 at 7:04 PM Jim Ingham via Phabricator
> wrote:
> jingham added a comment.
>
> I worry when concerns of layering which seem a little artificial to me would
> make us add a shadow class for something that is alre
clayborg added a comment.
It might make sense to create a new SBTargetSettings class that has accessors.
Then we can have to accessors on SBTarget:
class SBTarget {
static SBTargetSettings GetGlobalSettings();
SBTargetSettings GetSettings();
};
This allows us to expose settings in a
Author: labath
Date: Thu May 24 06:12:07 2018
New Revision: 333183
URL: http://llvm.org/viewvc/llvm-project?rev=333183&view=rev
Log:
Fix windows/mac builds broken by r333182.
I should've known that something was wrong when only one of my plugins
was prefixed by the lldb_private namespace.
Modifi
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333182: Move ObjectFile initialization out of
SystemInitializerCommon (authored by labath, committed by ).
Herald added a subscriber: llvm-commits.
Repository:
rL LLVM
https://reviews.llvm.org/D47250
Author: labath
Date: Thu May 24 05:44:18 2018
New Revision: 333182
URL: http://llvm.org/viewvc/llvm-project?rev=333182&view=rev
Log:
Move ObjectFile initialization out of SystemInitializerCommon
Summary:
For lldb-server, it is sufficient to parse only the native object file
format for its target
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333178: DWARF: Move indexing code from DWARFUnit to
ManualDWARFIndex (authored by labath, committed by ).
Herald added a subscriber: llvm-commits.
Repository:
rL LLVM
https://reviews.llvm.org/D47253
F
Author: labath
Date: Thu May 24 05:12:49 2018
New Revision: 333178
URL: http://llvm.org/viewvc/llvm-project?rev=333178&view=rev
Log:
DWARF: Move indexing code from DWARFUnit to ManualDWARFIndex
Summary:
I think this makes sense for several reasons:
- better separation of concerns: DWARFUnit's job
This revision was automatically updated to reflect the committed changes.
Closed by commit rL333173: Add PPC64le support information (authored by labath,
committed by ).
Herald added a subscriber: llvm-commits.
Repository:
rL LLVM
https://reviews.llvm.org/D47285
Files:
lldb/trunk/www/featur
Author: labath
Date: Thu May 24 04:17:02 2018
New Revision: 333173
URL: http://llvm.org/viewvc/llvm-project?rev=333173&view=rev
Log:
Add PPC64le support information
Summary: Add PPC64le support information on LLDB site
Reviewers: clayborg
Reviewed By: clayborg
Subscribers: labath, lldb-commits
labath added a comment.
Looks like we missed each other, but all I said about DWARFUnitDIE applies to
DWARFFirstDIE as well. I doesn't have to be called "basic" die, but the reason
I proposed that name is that it does not sound weird when you say that any die
"is a" basic die. Other possibility
labath added a comment.
From a layering perspective, it makes sense for SystemInitializerFull to live
in the outermost layer, as it's the thing which makes sure liblldb pulls in all
required components. Since it is only included from files in `source/API`
(which is as it should be), maybe we co
labath added a reviewer: aprantl.
labath added a comment.
I don't think a name like `DWARFUnitDIE` is a good one bacause it would make a
weird `is-a` relationship (a DWARFDIE represetning a DW_TAG_variable is
certainly **not** a "unit DIE" yet you could assign it to a `DWARFUnitDIE&`).
We coul
jankratochvil updated this revision to Diff 148362.
https://reviews.llvm.org/D47276
Files:
source/Plugins/SymbolFile/DWARF/DWARFDebugInfoEntry.cpp
source/Plugins/SymbolFile/DWARF/DWARFUnit.cpp
source/Plugins/SymbolFile/DWARF/DWARFUnit.h
source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.cpp
jankratochvil updated this revision to Diff 148360.
https://reviews.llvm.org/D47275
Files:
source/Plugins/SymbolFile/DWARF/CMakeLists.txt
source/Plugins/SymbolFile/DWARF/DWARFDIE.cpp
source/Plugins/SymbolFile/DWARF/DWARFDIE.h
source/Plugins/SymbolFile/DWARF/DWARFFirstDIE.cpp
source/Plug
jankratochvil marked 5 inline comments as done.
jankratochvil added a comment.
In https://reviews.llvm.org/D47275#1110065, @clayborg wrote:
> Marked things that don't belong in DWARFBasicDIE.
OK, sorry, thanks for reviewing it.
> Also DWARFBasicDIE doesn't really explain what it actually is. M
52 matches
Mail list logo