[Lldb-commits] [lldb] r284674 - Added a decorator for the macOS version and switched over testcases that used platform.release

2016-10-19 Thread Sean Callanan via lldb-commits
Author: spyffe Date: Wed Oct 19 19:03:39 2016 New Revision: 284674 URL: http://llvm.org/viewvc/llvm-project?rev=284674&view=rev Log: Added a decorator for the macOS version and switched over testcases that used platform.release Modified: lldb/trunk/packages/Python/lldbsuite/test/decorators.p

Re: [Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
Actually ignore that last comment , the behavior is the same as before, but linux will still behave differently than other platforms On Wed, Oct 19, 2016 at 3:17 PM Zachary Turner wrote: > zturner added a comment. > > Incidentally, this patch actually makes all platforms behave consistently > whe

[Lldb-commits] [lldb] r284666 - Add lldb register definitions for w0-w28, s0-s31, and d0-d31 to

2016-10-19 Thread Jason Molenda via lldb-commits
Author: jmolenda Date: Wed Oct 19 18:38:38 2016 New Revision: 284666 URL: http://llvm.org/viewvc/llvm-project?rev=284666&view=rev Log: Add lldb register definitions for w0-w28, s0-s31, and d0-d31 to RegisterInfos_arm64.h. These register definitions include the offset into the register context, wh

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. Incidentally, this patch actually makes all platforms behave consistently when the `Write` overload with offset is used with `O_APPEND`, so there's probably some value in having that consistency. https://reviews.llvm.org/D25783 __

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. In https://reviews.llvm.org/D25783#574860, @labath wrote: > > This can happen with any number of bytes and at any time. `write`, `read`, > > and all other related functions will return a non-negative value indicating > > the number of bytes successfully read/written, w

[Lldb-commits] [PATCH] D25792: Don't set a software stepping breakpoint at 0 on arm.

2016-10-19 Thread Pavel Labath via lldb-commits
labath requested changes to this revision. labath added a comment. This revision now requires changes to proceed. I envisioned a bit different solution to this problem. The issue does not happen only when the inferior jumps to a literal 0x0 address, but for any address that is not mapped into me

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. > This can happen with any number of bytes and at any time. `write`, `read`, > and all other related functions will return a non-negative value indicating > the number of bytes successfully read/written, which will be less than the > number requested. Except if fd refe

[Lldb-commits] [PATCH] D25792: Don't set a software stepping breakpoint at 0 on arm.

2016-10-19 Thread Jim Ingham via lldb-commits
jingham added a comment. Not commenting on the substance of the change (though it seems sensible to me.) The inclusion of the .gitignore was probably accidental, but in any case, try not to gang unrelated changes together like this. Thanks! https://reviews.llvm.org/D25792

[Lldb-commits] [PATCH] D25792: Don't set a software stepping breakpoint at 0 on arm.

2016-10-19 Thread Jason Majors via lldb-commits
jmajors created this revision. jmajors added a reviewer: labath. jmajors added a subscriber: lldb-commits. Herald added subscribers: srhines, danalbert, tberghammer, rengolin, aemerson. Added a test for the next_pc being zero before setting a software breakpoint in arm32. Reenabled the crash durin

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Greg Clayton via lldb-commits
clayborg accepted this revision. clayborg added a comment. This revision is now accepted and ready to land. Ok, the lseek calls make sense then. https://reviews.llvm.org/D25783 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.l

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added inline comments. Comment at: source/Host/common/File.cpp:405 -if (bytes_read == 0) { - if (::feof(m_stream)) -error.SetErrorString("feof"); - else if (::ferror(m_stream)) -error.SetErrorString("ferror"); - num_bytes = 0; -} e

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. Also you are right that I misspoke about the append case. But still, I just think that if writing to the same file from multiple processes is something we care about, we should support it "for real" instead of just pretending to. That means some kind of cross-process

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Greg Clayton via lldb-commits
clayborg requested changes to this revision. clayborg added a comment. This revision now requires changes to proceed. Just a few questions on why we are calling lseek in the read and write functions. See inlined comments. Comment at: source/Host/common/File.cpp:405 -if (

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. In https://reviews.llvm.org/D25783#574699, @labath wrote: > In https://reviews.llvm.org/D25783#574684, @zturner wrote: > > > There are many other problems with this code if we want to deal with > > atomicity. For example, the whole point of this patch was to handle shor

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. In https://reviews.llvm.org/D25783#574684, @zturner wrote: > There are many other problems with this code if we want to deal with > atomicity. For example, the whole point of this patch was to handle short > reads and writes. Well, if you have a short read or a write,

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. Also, for the record, if you specify the threadsafe logging option, it already does put this in a mutex, so there should be no issue. https://reviews.llvm.org/D25783 ___ lldb-commits mailing list lldb-commits@lists.llvm.org

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner added a comment. In https://reviews.llvm.org/D25783#574679, @labath wrote: > I am not sure the "append" thing is actually a "fix". I consider it more like > a feature of the append mode. It's also nice that it guarantees atomicity of > writes even if two processes are writing to the sam

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. I am not sure the "append" thing is actually a "fix". I consider it more like a feature of the append mode. It's also nice that it guarantees atomicity of writes even if two processes are writing to the same file (very useful for logging, although I'm not sure if that go

[Lldb-commits] [PATCH] D25783: [Host] handle short reads and writes

2016-10-19 Thread Zachary Turner via lldb-commits
zturner created this revision. zturner added reviewers: clayborg, beanz, EugeneBi. zturner added a subscriber: lldb-commits. The original motivation for this came from https://reviews.llvm.org/D25712, in which Eugene pointed out that `File::Read()` does not correctly handle short reads. However

[Lldb-commits] [PATCH] D25726: Improve the libstdc++ smart pointer formatters

2016-10-19 Thread Enrico Granata via lldb-commits
granata.enrico added a comment. I see you already got a bunch of feedback on specific items. The overall idea looks good to me. I'll try to delve a little deeper in the code ASAP (I was out for a couple days and have some backlog...), but should be good to go assuming you address the feedback y

[Lldb-commits] [PATCH] D25734: Add data formatter for libstdc++ unique_ptr

2016-10-19 Thread Enrico Granata via lldb-commits
granata.enrico added a comment. I see you already got a bunch of feedback on specific items. The overall idea looks good to me. I'll try to delve a little deeper in the code ASAP (I was out for a couple days and have some backlog...), but should be good to go assuming you address the feedback y

Re: [Lldb-commits] [PATCH] D25734: Add data formatter for libstdc++ unique_ptr

2016-10-19 Thread Jim Ingham via lldb-commits
> On Oct 19, 2016, at 10:38 AM, Jim Ingham via lldb-commits > wrote: > > >> On Oct 19, 2016, at 6:35 AM, Pavel Labath via lldb-commits >> wrote: >> >> >> >> Comment at: source/Plugins/Language/CPlusPlus/LibStdcppUniquePointer.cpp:110 >> + if (name == ConstString("ptr") ||

Re: [Lldb-commits] [PATCH] D25734: Add data formatter for libstdc++ unique_ptr

2016-10-19 Thread Jim Ingham via lldb-commits
> On Oct 19, 2016, at 6:35 AM, Pavel Labath via lldb-commits > wrote: > > > > Comment at: source/Plugins/Language/CPlusPlus/LibStdcppUniquePointer.cpp:110 > + if (name == ConstString("ptr") || name == ConstString("pointer")) return 2; > + return UINT32_MAX; > +} > --

Re: [Lldb-commits] [PATCH] D25057: Fix ARM/AArch64 Step-Over watchpoint issue remove provision for duplicate watchpoints

2016-10-19 Thread Jim Ingham via lldb-commits
> On Oct 4, 2016, at 9:28 AM, Pavel Labath via lldb-commits > wrote: > > Also, apparently lldb has a bug, where it mishandles the case where you do a > (user-level) single step over an instruction triggering a watchpoint. That > would be pretty important to fix as well. Do you have a referen

[Lldb-commits] [PATCH] D25756: FreeBSD ARM support for software single step.

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a reviewer: emaste. labath added a comment. No, I'm saying someone *should*. :P Ed looked into that at some point but, I don't think get got too far with it. Adding @emaste, who should probably review this. Repository: rL LLVM https://reviews.llvm.org/D25756

[Lldb-commits] [PATCH] D25756: FreeBSD ARM support for software single step.

2016-10-19 Thread Dmitry Mikulin via lldb-commits
dmikulin added a comment. Are you saying someone is working on switching FreeBSD to lldb-server debugging? Can I get my hands on this patch? Repository: rL LLVM https://reviews.llvm.org/D25756 ___ lldb-commits mailing list lldb-commits@lists.llv

Re: [Lldb-commits] [PATCH] D25681: [PseudoTerminal] Fix PseudoTerminal MSVC release crash

2016-10-19 Thread Zachary Turner via lldb-commits
It will return true in this case. Should it be returning false to indicate failure? On Tue, Oct 18, 2016 at 11:26 PM Carlo Kok wrote: > fwiw this looks good to me, a much better fix than I had. but it'z > zturner who objected to my approach. > > On 2016-10-17 17:51, Rudy Pons via lldb-commits wro

Re: [Lldb-commits] [lldb] r284601 - Simplify GetGlobalProperties functions of Thread/Process/Target

2016-10-19 Thread Pavel Labath via lldb-commits
I'll put that on my list. :) On 19 October 2016 at 16:36, Zachary Turner wrote: > This was using call_once because msvc didn't support function local static > thread safe initialization. But it does now in msvc 2015. > > Can you fix HostInfoBase `g_flags` while you're at it? > > On Wed, Oct 19, 2

Re: [Lldb-commits] [lldb] r284601 - Simplify GetGlobalProperties functions of Thread/Process/Target

2016-10-19 Thread Zachary Turner via lldb-commits
This was using call_once because msvc didn't support function local static thread safe initialization. But it does now in msvc 2015. Can you fix HostInfoBase `g_flags` while you're at it? On Wed, Oct 19, 2016 at 8:21 AM Pavel Labath via lldb-commits < lldb-commits@lists.llvm.org> wrote: > Author:

[Lldb-commits] [PATCH] D17710: Simplify GetGlobalProperties functions of Thread/Process/Target

2016-10-19 Thread Pavel Labath via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL284601: Simplify GetGlobalProperties functions of Thread/Process/Target (authored by labath). Changed prior to commit: https://reviews.llvm.org/D17710?vs=49356&id=75157#toc Repository: rL LLVM https

[Lldb-commits] [PATCH] D25677: Minidump plugin: redesign the x86_64 register context

2016-10-19 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Looks much better, thanks. :) https://reviews.llvm.org/D25677 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi

[Lldb-commits] [lldb] r284601 - Simplify GetGlobalProperties functions of Thread/Process/Target

2016-10-19 Thread Pavel Labath via lldb-commits
Author: labath Date: Wed Oct 19 10:12:45 2016 New Revision: 284601 URL: http://llvm.org/viewvc/llvm-project?rev=284601&view=rev Log: Simplify GetGlobalProperties functions of Thread/Process/Target Summary: "Initialization of function-local statics is guaranteed to occur only once even when calle

[Lldb-commits] [PATCH] D25677: Minidump plugin: redesign the x86_64 register context

2016-10-19 Thread Dimitar Vlahovski via lldb-commits
dvlahovski updated this revision to Diff 75154. dvlahovski marked an inline comment as done. dvlahovski added a comment. Simplified writeRegister function s/uint128_struct/Uint128/ https://reviews.llvm.org/D25677 Files: source/Plugins/Process/minidump/RegisterContextMinidump_x86_64.cpp sou

[Lldb-commits] [PATCH] D25393: Remove IntervalTimer class

2016-10-19 Thread Pavel Labath via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL284599: Remove IntervalTimer class (authored by labath). Changed prior to commit: https://reviews.llvm.org/D25393?vs=74015&id=75153#toc Repository: rL LLVM https://reviews.llvm.org/D25393 Files: l

[Lldb-commits] [lldb] r284599 - Remove IntervalTimer class

2016-10-19 Thread Pavel Labath via lldb-commits
Author: labath Date: Wed Oct 19 10:01:22 2016 New Revision: 284599 URL: http://llvm.org/viewvc/llvm-project?rev=284599&view=rev Log: Remove IntervalTimer class Summary: it was added back in 2013, but there are no uses of it. I started refactoring it, but then it occured to me it would better to d

[Lldb-commits] [PATCH] D25569: Minidump plugin: functions parsing memory structures and filtering module list

2016-10-19 Thread Dimitar Vlahovski via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL284593: Minidump plugin: functions parsing memory structures and filtering module list (authored by dvlahovski). Changed prior to commit: https://reviews.llvm.org/D25569?vs=74824&id=75147#toc Repositor

[Lldb-commits] [lldb] r284593 - Minidump plugin: functions parsing memory structures and filtering module list

2016-10-19 Thread Dimitar Vlahovski via lldb-commits
Author: dvlahovski Date: Wed Oct 19 09:14:18 2016 New Revision: 284593 URL: http://llvm.org/viewvc/llvm-project?rev=284593&view=rev Log: Minidump plugin: functions parsing memory structures and filtering module list Summary: Now the Minidump parser can parse the: 1) MemoryInfoList - containing re

[Lldb-commits] [PATCH] D25677: Minidump plugin: redesign the x86_64 register context

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. Just a couple of cleanups and then I think we're ready. Comment at: source/Plugins/Process/minidump/RegisterContextMinidump_x86_64.cpp:78 + if ((context_flags & ControlFlag) == ControlFlag) { +writeRegister(&context->cs, getDestRegister(result_base

[Lldb-commits] [PATCH] D25734: Add data formatter for libstdc++ unique_ptr

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. Looks fine with the usual comments. :) Comment at: packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-stl/libstdcpp/unique_ptr/Makefile:5 + +CXXFLAGS := -O0 +USE_LIBSTDCPP := 1 Same comments as the previous pat

[Lldb-commits] [PATCH] D25733: Add data formatter for libstdc++ tuple

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. Just minor nits from my side. Comment at: packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-stl/libstdcpp/tuple/Makefile:5 + +CXXFLAGS := -O0 +USE_LIBSTDCPP := 1 I don't think this is necessary.

[Lldb-commits] [lldb] r284584 - [cmake] Use LLVM_CMAKE_PATH for GetSVN script

2016-10-19 Thread Michal Gorny via lldb-commits
Author: mgorny Date: Wed Oct 19 07:54:28 2016 New Revision: 284584 URL: http://llvm.org/viewvc/llvm-project?rev=284584&view=rev Log: [cmake] Use LLVM_CMAKE_PATH for GetSVN script Use the LLVM_CMAKE_PATH variable to locate the GetSVN.cmake script. The variable was already available in stand-alone

[Lldb-commits] [PATCH] D25668: [cmake] Respect LLVM_CMAKE_PATH in stand-alone builds for GetSVN.cmake

2016-10-19 Thread Michał Górny via lldb-commits
mgorny abandoned this revision. mgorny added a comment. Now handled as a followup of https://reviews.llvm.org/D25724. https://reviews.llvm.org/D25668 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/lis

[Lldb-commits] [PATCH] D25057: Fix ARM/AArch64 Step-Over watchpoint issue remove provision for duplicate watchpoints

2016-10-19 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. LGTM, thanks. BTW, it looks like the linux kernel is about to grow support for proper byte-range watchpoints http://lists.infradead.org/pipermail/linux-arm-kernel/2016-October/461036.html.

Re: [Lldb-commits] [lldb] r284565 - Revert back to the state before r284550

2016-10-19 Thread Pavel Labath via lldb-commits
Hi, Let me know if you need help with this. I can give the patch a dry run when you have the next version ready. pl On 19 October 2016 at 03:44, Chris Bieneman via lldb-commits wrote: > Author: cbieneman > Date: Tue Oct 18 21:44:20 2016 > New Revision: 284565 > > URL: http://llvm.org/viewvc/llv

[Lldb-commits] [PATCH] D25756: FreeBSD ARM support for software single step.

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. I'd love to see freebsd switch to lldb-server based debugging. Then we could make sure this code is actually reused instead of copied around (e.g. we are right now preparing a patch to improve this, which you could have gotten for free if the code was shared). Reposit

Re: [Lldb-commits] [PATCH] debugserver: Disable four-char-constants and format-pedantic warnings

2016-10-19 Thread Pavel Labath via lldb-commits
On 19 October 2016 at 00:20, Justin Bogner wrote: > Pavel Labath writes: >> Thanks for the patch. Could you submit the patch through phabricator >> and add Greg Clayton as a reviewer. > > Maybe later. I don't have time to fight with phabricator today. > >> That said, my

[Lldb-commits] [PATCH] D25745: [CMake] Rename lldb-launcher to darwin-debug

2016-10-19 Thread Pavel Labath via lldb-commits
labath accepted this revision. labath added a reviewer: labath. labath added a comment. I have no idea what this executable does, but I am pretty sure we don't use it. PS: there are some mentions of this in the `scripts/Python/finishSwigPythonLLDB.py` script. Does that need an update? https://

[Lldb-commits] [PATCH] D25726: Improve the libstdc++ smart pointer formatters

2016-10-19 Thread Pavel Labath via lldb-commits
labath added a comment. Looks good from my side. Enrico, do you want to have a look at this? A couple tiny comments below. Also, be sure to properly reformat and reorder the headers. Comment at: packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-stl