Re: [PATCH V2] tty: serial: Add const to struct uart_ops declarations

2015-04-07 Thread Vineet Gupta
art.c| 2 +- drivers/tty/serial/arc_uart.c | 2 +- Acked-by: Vineet Gupta <mailto:vgu...@synopsys.com> # for arc_uart Th, -Vineet ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [RFC][PATCH 0/4] perf: Enable symbolic event names

2015-05-02 Thread Vineet Gupta
On Friday 01 May 2015 12:35 PM, Sukadev Bhattiprolu wrote: > Implement ability to specify Power PMU events by their symbolic event > names rather than raw codes. This approach pulls tables of the Power7 > and Power8 PMU events into the perf source tree and uses these tables > to create aliases for

Re: [RFC][PATCH 4/4] perf: Create aliases for PMU events

2015-05-02 Thread Vineet Gupta
On Friday 01 May 2015 12:35 PM, Sukadev Bhattiprolu wrote: > Using the tables of Power7 and Power8 events, create aliases for the > Power PMU events. This would allow us to specify all Power events by > name rather than by raw code: > > $ /tmp/perf stat -e PM_1PLUS_PPC_CMPL sleep 1 > >

Re: [PATCH 08/44] kernel: Move pm_power_off to common code

2014-10-09 Thread Vineet Gupta
) { - /* FIXME :: power off ??? */ + do_kernel_poweroff(); machine_halt(); } - -void (*pm_power_off) (void) = NULL; -EXPORT_SYMBOL(pm_power_off); Acked-by: Vineet Gupta <mailto:vgu...@synopsys.com> Thx, -Vineet ___ Linuxp

Re: [PATCH] of: Specify initrd location using 64-bit

2013-06-20 Thread Vineet Gupta
Hi Santosh, On 06/21/2013 06:22 AM, Santosh Shilimkar wrote: > Cc: Vineet Gupta > Cc: Russell King > Cc: Catalin Marinas > Cc: Will Deacon > Cc: Mark Salter > Cc: Aurelien Jacquiot > Cc: James Hogan > Cc: Michal Simek > Cc: Ralf Baechle > Cc: Jonas Bonn

Re: [PATCH v2] of: Specify initrd location using 64-bit

2013-07-01 Thread Vineet Gupta
; https://lkml.org/lkml/2012/9/13/544 > > Cc: Grant Likely > Cc: Rob Herring > Cc: Geert Uytterhoeven > Cc: Sebastian Andrzej Siewior > Cc: Jean-Christophe PLAGNIOL-VILLARD > Cc: Vineet Gupta > Cc: Russell King > Cc: Catalin Marinas > Cc: Will Deacon > Cc: Mark

Re: [PATCH 19/31] arc: handle page-less SG entries

2015-08-12 Thread Vineet Gupta
On Wednesday 12 August 2015 12:39 PM, Christoph Hellwig wrote: > Make all cache invalidation conditional on sg_has_page() and use > sg_phys to get the physical address directly. > > Signed-off-by: Christoph Hellwig With a minor nit below. Acked-by: Vineet Gupta > --- > ar

Re: [PATCH v3] arch: Kconfig: Let all architectures set endian explicitly

2014-08-14 Thread Vineet Gupta
On Thursday 14 August 2014 09:55 AM, Chen Gang wrote: > Normal architectures: > > - Big endian: avr32, frv, m68k, openrisc, parisc, s390, sparc > > - Little endian: alpha, blackfin, cris, hexagon, ia64, metag, mn10300, > score, unicore32, x86 > > - Choose in config time: arc, a

Re: [PATCH v3] arch: Kconfig: Let all architectures set endian explicitly

2014-08-14 Thread Vineet Gupta
On Thursday 14 August 2014 03:22 PM, Chen Gang wrote: > For many individual modules may need check CPU_LITTLE_ENDIAN or > CPU_BIG_ENDIAN, which is an architecture's attribute. > > Or they have to list many architectures which they support, which they > don't support. And still, it is not precise. >

Re: [PATCH 00/14] entry: preempt_schedule_irq() callers scrub

2019-03-12 Thread Vineet Gupta
On 3/11/19 3:47 PM, Valentin Schneider wrote: > Hi, > > This is the continuation of [1] where I'm hunting down > preempt_schedule_irq() callers because of [2]. > > I told myself the best way to get this moving forward wouldn't be to write > doc about it, but to go write some fixes and get some di

Re: [PATCH v2 1/5] arch/arc: unwind.c: replace swap function with built-in one

2019-04-01 Thread Vineet Gupta
ple byte copies swap is implemented > without them, an "optimized" custom swap function is now > a waste of time as well as code. > > Signed-off-by: Andrey Abramov > Reviewed by: George Spelvin > Acked-by: Vineet Gupta Thx, -Vineet

Re: [PATCH V8] mm/debug: Add tests validating architecture page table helpers

2019-11-05 Thread Vineet Gupta
Hi Anshuman, On 11/4/19 4:00 PM, Anshuman Khandual wrote: > On 10/28/2019 10:59 AM, Anshuman Khandual wrote: >> This adds tests which will validate architecture page table helpers and >> other accessors in their compliance with expected generic MM semantics. >> This will help various architectures

Re: [PATCH V8] mm/debug: Add tests validating architecture page table helpers

2019-11-06 Thread Vineet Gupta
On 11/5/19 7:03 PM, Anshuman Khandual wrote: > But should not pfn_pmd() be encapsulated inside HAVE_ARCH_TRANSPARENT_HUGEPAGE > at the minimum (but I would say it should be available always, nonetheless) > when > the platform subscribes to THP irrespective of whether THP is enabled or not. For AR

Re: [PATCH V8] mm/debug: Add tests validating architecture page table helpers

2019-11-07 Thread Vineet Gupta
On 11/6/19 8:44 PM, Anshuman Khandual wrote: > >> >>> */ >>> -#ifdef CONFIG_TRANSPARENT_HUGEPAGE >>> +#ifdef CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE >>> #include >>> #endif >> This in wrong.  CONFIG_HAVE_ARCH_TRANSPARENT_HUGEPAGE is a just a glue >> toggle, >> used only in Kconfig files (and no

Re: [PATCH V8] mm/debug: Add tests validating architecture page table helpers

2019-11-11 Thread Vineet Gupta
On 11/7/19 8:27 PM, Anshuman Khandual wrote: > > On 11/08/2019 12:35 AM, Vineet Gupta wrote: >> On 11/6/19 8:44 PM, Anshuman Khandual wrote: >>>>> */ >>>>> -#ifdef CONFIG_TRANSPARENT_HUGEPAGE >>>>> +#ifdef CONFIG_HAVE_ARCH_TRANSPARENT_H

Re: [PATCH v2 17/20] mm: free_area_init: allow defining max_zone_pfn in descending order

2020-05-05 Thread Vineet Gupta
On 5/5/20 6:18 AM, Guenter Roeck wrote: > On 5/4/20 8:39 AM, Mike Rapoport wrote: >> On Sun, May 03, 2020 at 11:43:00AM -0700, Guenter Roeck wrote: >>> On Sun, May 03, 2020 at 10:41:38AM -0700, Guenter Roeck wrote: Hi, On Wed, Apr 29, 2020 at 03:11:23PM +0300, Mike Rapoport wrote: >>

Re: [PATCH V12] mm/debug: Add tests validating architecture page table helpers

2020-01-28 Thread Vineet Gupta
On 1/27/20 7:33 PM, Qian Cai wrote: > >>> What’s the value of this block of new code? It only supports x86 and arm64 >>> which are supposed to be good now. >> We have been over the usefulness of this code many times before as the patch >> is >> already in it's V12. Currently it is enabled on arm64

Re: [PATCH 13/21] arc: dma-mapping: skip invalidating before bidirectional DMA

2023-04-01 Thread Vineet Gupta
iewed-by: Vineet Gupta Shahab can you give this a spin on hsdk - run glibc testsuite over ssh and make sure nothing strange happens. Thx, -Vineet

Re: [PATCH v3 4/4] arc: Use generic dump_stack_print_cmdline() implementation

2022-10-09 Thread Vineet Gupta
On 8/8/22 06:09, Helge Deller wrote: The process program name and command line is now shown in generic code in dump_stack_print_info(), so drop the arc-specific implementation. Signed-off-by: Helge Deller But that info printing was added back in 2018 by e36df28f532f882. I don't think arc is u

Re: [PATCH RFC 0/3] mm/gup: consistently call it GUP-fast

2024-03-27 Thread Vineet Gupta
+CC Alexey On 3/27/24 09:22, Arnd Bergmann wrote: > On Wed, Mar 27, 2024, at 16:39, David Hildenbrand wrote: >> On 27.03.24 16:21, Peter Xu wrote: >>> On Wed, Mar 27, 2024 at 02:05:35PM +0100, David Hildenbrand wrote: >>> >>> I'm not sure what config you tried there; as I am doing some build tests

Re: [PATCH RFC 0/3] mm/gup: consistently call it GUP-fast

2024-03-28 Thread Vineet Gupta
On 3/28/24 00:15, Mike Rapoport wrote: > On Thu, Mar 28, 2024 at 07:09:13AM +0100, Arnd Bergmann wrote: >> On Thu, Mar 28, 2024, at 06:51, Vineet Gupta wrote: >>> On 3/27/24 09:22, Arnd Bergmann wrote: >>>> On Wed, Mar 27, 2024, at 16:39, David Hildenbrand wrote:

Re: [PATCH v2] mm: Move mem_init_print_info() into mm_init()

2021-03-17 Thread Vineet Gupta
On 3/16/21 6:52 PM, Kefeng Wang wrote: > mem_init_print_info() is called in mem_init() on each architecture, > and pass NULL argument, so using void argument and move it into mm_init(). > > Acked-by: Dave Hansen > Signed-off-by: Kefeng Wang Acked-by: Vineet Gupta Thx, -Vineet

Re: [PATCH 1/2] mm: Fix struct page layout on 32-bit systems

2021-04-19 Thread Vineet Gupta
Hi Matthew, On 4/16/21 7:45 PM, Matthew Wilcox wrote: > Replacement patch to fix compiler warning. > > From: "Matthew Wilcox (Oracle)" > Date: Fri, 16 Apr 2021 16:34:55 -0400 > Subject: [PATCH 1/2] mm: Fix struct page layout on 32-bit systems > To: bro...@redhat.com > Cc: linux-ker...@vger.kernel

Re: [PATCH 1/2] mm: Fix struct page layout on 32-bit systems

2021-04-20 Thread Vineet Gupta
On 4/20/21 12:07 AM, Arnd Bergmann wrote: > On Tue, Apr 20, 2021 at 5:10 AM Matthew Wilcox wrote: >> On Tue, Apr 20, 2021 at 02:48:17AM +0000, Vineet Gupta wrote: >>>> 32-bit architectures which expect 8-byte alignment for 8-byte integers >>>> and need 64-bit D

Re: [PATCH v2 00/13] Unify asm/unaligned.h around struct helper

2021-05-14 Thread Vineet Gupta
On 5/14/21 10:32 AM, Linus Torvalds wrote: > On Fri, May 14, 2021 at 3:02 AM Arnd Bergmann wrote: >> I've included this version in the asm-generic tree for 5.14 already, >> addressing the few issues that were pointed out in the RFC. If there >> are any remaining problems, I hope those can be addre

Re: [PATCH v2 00/13] Unify asm/unaligned.h around struct helper

2021-05-14 Thread Vineet Gupta
On 5/14/21 12:22 PM, Linus Torvalds wrote: > On Fri, May 14, 2021 at 11:52 AM Vineet Gupta > wrote: >> Wasn't the new zlib code slated for 5.14. I don't see it in your master yet > You're right, I never actually committed it, since it was specific to > ARC and

Re: [PATCH v2 3/9] arc: remove support for DISCONTIGMEM

2021-06-04 Thread Vineet Gupta
7;d still like to give this a spin on hardware - considering highmem on ARC has tendency to go sideways ;-) Can you please share a branch ! Acked-by: Vineet Gupta Thx, -Vineet > --- > arch/arc/Kconfig | 13 > arch/arc/include/asm/mmzone.h | 40 -

Re: [PATCH v2 2/9] arc: update comment about HIGHMEM implementation

2021-06-04 Thread Vineet Gupta
On 6/3/21 11:49 PM, Mike Rapoport wrote: > From: Mike Rapoport > > Arc does not use DISCONTIGMEM to implement high memory, update the comment > describing how high memory works to reflect this. > > Signed-off-by: Mike Rapoport Acked-by: Vineet Gupta Thx, -Vineet > --- &

Re: [PATCH 2/3] trace: refactor TRACE_IRQFLAGS_SUPPORT in Kconfig

2021-07-31 Thread Vineet Gupta
On 7/30/21 10:22 PM, Masahiro Yamada wrote: > Make architectures select TRACE_IRQFLAGS_SUPPORT instead of > having many defines. > > Signed-off-by: Masahiro Yamada > --- > > arch/arc/Kconfig | 4 +--- > [snip..] Acked-by: Vineet Gupta    #arch/arc

Re: [PATCH -next] trap: Cleanup trap_init()

2021-08-12 Thread Vineet Gupta
On 8/12/21 5:36 AM, Kefeng Wang wrote: There are some empty trap_init() in different ARCHs, introduce a new weak trap_init() function to cleanup them. Cc: Vineet Gupta Cc: Russell King Cc: Yoshinori Sato Cc: Ley Foon Tan Cc: Jonas Bonn Cc: Stefan Kristiansson Cc: Stafford Horne Cc: James E.J

Re: [RFC PATCH 10/13] mm: Introduce first class virtual address spaces

2017-03-13 Thread Vineet Gupta
+CC Ingo, tglx Hi Till, On 03/13/2017 03:14 PM, Till Smejkal wrote: > Introduce a different type of address spaces which are first class citizens > in the OS. That means that the kernel now handles two types of AS, those > which are closely coupled with a process and those which aren't. While the

Re: [PATCH 09/67] arc: remove CONFIG_ARC_PLAT_NEEDS_PHYS_TO_DMA

2018-01-05 Thread Vineet Gupta
On 12/29/2017 12:25 AM, Christoph Hellwig wrote: We always use the stub definitions, so remove the unused other code. Signed-off-by: Christoph Hellwig Acked-by: Vineet Gupta FWIW, it was removed and reintroduced as one of the customers wanted it, which is not relevant now ! Thx, -Vineet

Re: [PATCH] fix double ;;s in code

2018-02-19 Thread Vineet Gupta
On 02/17/2018 01:19 PM, Pavel Machek wrote: Fix double ;;'s in code. Signed-off-by: Pavel Machek diff --git a/arch/arc/kernel/setup.c b/arch/arc/kernel/setup.c index 9d27331..ec12fe1 100644 --- a/arch/arc/kernel/setup.c +++ b/arch/arc/kernel/setup.c @@ -373,7 +373,7 @@ static void arc_chk_core_

Re: [PATCH 0/3] move __HAVE_ARCH_PTE_SPECIAL in Kconfig

2018-04-09 Thread Vineet Gupta
On 04/09/2018 06:57 AM, Laurent Dufour wrote: The per architecture __HAVE_ARCH_PTE_SPECIAL is defined statically in the per architecture header files. This doesn't allow to make other configuration dependent on it. So I understand this series has more "readability" value and I'm fine with this

Re: [PATCH v4 43/44] dma-mapping: Remove dma_get_attr

2016-06-12 Thread Vineet Gupta
On Friday 10 June 2016 03:44 PM, Krzysztof Kozlowski wrote: > After switching DMA attributes to unsigned long it is easier to just > compare the bits. > > Signed-off-by: Krzysztof Kozlowski > [for avr32] > Acked-by: Hans-Christian Noren Egtvedt Acked-by: Vineet Gupt

Re: [PATCH] devpts: remove DEVPTS_MULTIPLE_INSTANCES from all configs

2016-06-20 Thread Vineet Gupta
On Monday 20 June 2016 02:44 PM, Alexandru Moise wrote: > As each mount of devpts is now an independent filesystem, > the DEVPTS_MULTIPLE_INSTANCES config option no longer exists. > So remove it. > > Signed-off-by: Alexandru Moise <00moses.alexande...@gmail.com> For arch/

[PATCH] atomic64: No need for CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE

2016-09-08 Thread Vineet Gupta
S. Miller" Cc: Chris Metcalf Cc: Thomas Gleixner Cc: Ingo Molnar Cc: "H. Peter Anvin" Cc: x...@kernel.org Cc: Andrew Morton Cc: Vineet Gupta Cc: Zhaoxiu Zeng Cc: Linus Walleij Cc: Matthew Wilcox Cc: Alexander Potapenko Cc: Andrey Ryabinin Cc: Herbert Xu Cc: Ming Lin

Re: [PATCH] atomic64: No need for CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE

2016-09-08 Thread Vineet Gupta
On 09/08/2016 11:19 AM, Peter Zijlstra wrote: > On Thu, Sep 08, 2016 at 09:28:18AM -0700, Vineet Gupta wrote: >> This came to light when implementing native 64-bit atomics for ARCv2. >> >> The atomic64 self-test code uses CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIV

[PATCH v2 2/2] atomic64: No need for CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE

2016-09-12 Thread Vineet Gupta
: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Michael Ellerman Cc: Martin Schwidefsky Cc: Heiko Carstens Cc: "David S. Miller" Cc: Chris Metcalf Cc: Thomas Gleixner Cc: Ingo Molnar Cc: "H. Peter Anvin" Cc: x...@kernel.org Cc: Andrew Morton Cc: Vineet Gupta Cc: Zhaox

[PATCH v3 2/2] atomic64: No need for CONFIG_ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE

2016-09-12 Thread Vineet Gupta
: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Michael Ellerman Cc: Martin Schwidefsky Cc: Heiko Carstens Cc: "David S. Miller" Cc: Chris Metcalf Cc: Thomas Gleixner Cc: Ingo Molnar Cc: "H. Peter Anvin" Cc: x...@kernel.org Cc: Andrew Morton Cc: Vineet Gupta Cc: Zhaox

Re: [PATCH v3] mm: Avoid unnecessary page fault retires on shared memory types

2022-05-25 Thread Vineet Gupta
v3: - Rebase to akpm/mm-unstable - Copy arch maintainers --- arch/arc/mm/fault.c | 4 Acked-by: Vineet Gupta Thx, -Vineet

Re: [PATCH RESEND v9 1/5] arc: dts: Harmonize EHCI/OHCI DT nodes name

2022-06-24 Thread Vineet Gupta
On 6/24/22 07:16, Serge Semin wrote: In accordance with the Generic EHCI/OHCI bindings the corresponding node name is suppose to comply with the Generic USB HCD DT schema, which requires the USB nodes to have the name acceptable by the regexp: "^usb(@.*)?" . Make sure the "generic-ehci" and "g