Re: [PATCH 31/44] arm: Register with kernel poweroff handler

2014-10-07 Thread Nicolas Ferre
s the system or puts the CPU in sleep mode, > select a priority of 0 to indicate that the poweroff handler is one of last > resort. If the poweroff handler powers off the system, select a priority > of 128. > > Cc: Russell King > Cc: Andrew Victor > Cc: Nicolas Ferre &g

Re: [PATCH 36/51] DMA-API: usb: use dma_set_coherent_mask()

2013-09-23 Thread Nicolas Ferre
the correct API. Signed-off-by: Russell King --- drivers/usb/chipidea/ci_hdrc_imx.c |5 +++-- drivers/usb/dwc3/dwc3-exynos.c |5 +++-- drivers/usb/gadget/lpc32xx_udc.c |4 +++- drivers/usb/host/ehci-atmel.c |5 +++-- For Atmel driver: Acked-by: Nicolas Ferre

Re: [PATCH 37/51] DMA-API: usb: use new dma_coerce_mask_and_coherent()

2013-09-23 Thread Nicolas Ferre
On 20/09/2013 00:02, Russell King : Signed-off-by: Russell King --- drivers/usb/chipidea/ci_hdrc_imx.c |4 +--- drivers/usb/dwc3/dwc3-exynos.c |4 +--- drivers/usb/host/ehci-atmel.c |4 +--- For Atmel driver: Acked-by: Nicolas Ferre [..] diff --git a/drivers/usb

Re: [PATCH v3 24/25] irq_domain: remove "hint" when allocating irq numbers

2012-02-07 Thread Nicolas Ferre
c. > > This patch removes it. Grant, While trying your patch series in conjunction with Rob one, I do not find this patch in your irqdomain/next branch (and a couple of others). Can you tell me if this v3 series is available as a git tree? Than

Re: [PATCH 119/493] usb: remove use of __devexit_p

2012-11-20 Thread Nicolas Ferre
i-atmel.c| 2 +- > drivers/usb/host/ohci-at91.c | 2 +- For Atmel: Acked-by: Nicolas Ferre [..] > diff --git a/drivers/usb/c67x00/c67x00-drv.c b/drivers/usb/c67x00/c67x00-drv.c > index 6f3b6e2..855d538 100644 > --- a/drivers/usb/c67x00/c67x00-drv.c > +++ b/drive

Re: [PATCH 161/493] tty: remove use of __devinit

2012-11-20 Thread Nicolas Ferre
drivers/tty/serial/atmel_serial.c | 6 +++--- Acked-by: Nicolas Ferre > diff --git a/drivers/tty/cyclades.c b/drivers/tty/cyclades.c > index 0244acf..444b544 100644 > --- a/drivers/tty/cyclades.c > +++ b/drivers/tty/cyclades.c

Re: [PATCH v3 24/25] irq_domain: remove "hint" when allocating irq numbers

2012-02-15 Thread Nicolas Ferre
On 02/07/2012 07:07 PM, Nicolas Ferre : > On 01/27/2012 10:36 PM, Grant Likely : >> The 'hint' used to try and line up irq numbers with hw irq numbers is >> rather a hack and not very useful. Now that /proc/interrupts also outputs >> the hwirq number, it is even

Re: [PATCH v3 25/25] irq_domain: mostly eliminate slow-path revmap lookups

2012-02-15 Thread Nicolas Ferre
+ return irq_data ? irq_data->irq : irq_find_mapping_slow(domain, hwirq); > } > > /** > @@ -585,14 +594,11 @@ unsigned int irq_linear_revmap(struct irq_domain > *domain, > if (unlikely(hwirq >= domain->revmap_data.linear.size)) > return irq_find_mapping(domain, hwirq); Ditto here. And same whith previous one in same function. Check in irq_radix_revmap_lookup() there is the same issue on the "WARN_ON_ONCE" path... > > - /* Check if revmap was allocated */ > revmap = domain->revmap_data.linear.revmap; > - if (unlikely(revmap == NULL)) > - return irq_find_mapping(domain, hwirq); > > /* Fill up revmap with slow path if no mapping found */ > if (unlikely(!revmap[hwirq])) > - revmap[hwirq] = irq_find_mapping(domain, hwirq); > + revmap[hwirq] = irq_find_mapping_slow(domain, hwirq); > > return revmap[hwirq]; > } Bye, -- Nicolas Ferre ___ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev

Re: [PATCH v2 0/9] DMA engine cookie handling cleanups

2012-03-13 Thread Nicolas Ferre
l, the diffstat looks like this: > > arch/arm/include/asm/hardware/iop_adma.h |2 - > drivers/dma/amba-pl08x.c | 38 - > drivers/dma/at_hdmac.c | 48 > drivers/dma/at_hdmac_regs.h |2 - For at_hdmac Atmel D

Re: [PATCH] net: Use of_property_read_bool() for boolean properties

2023-03-13 Thread Nicolas Ferre
reading properties. Convert reading boolean properties to to of_property_read_bool(). Signed-off-by: Rob Herring --- drivers/net/can/cc770/cc770_platform.c | 12 ++-- drivers/net/ethernet/cadence/macb_main.c| 2 +- Acked-by: Nicolas Ferre drivers/net/ethernet

Re: [PATCH 64/64] i2c: reword i2c_algorithm in drivers according to newest specification

2024-03-22 Thread Nicolas Ferre
rivers/i2c/busses/i2c-at91-master.c | 2 +- drivers/i2c/busses/i2c-at91-slave.c| 8 [..] Acked-by: Nicolas Ferre # for at91 Probably file names themselves will need some care, in a second time. Thanks. Regards, Nicolas [..] -- 2.43.0

Re: [PATCH] watchdog: add SPDX identifiers for watchdog subsystem

2018-02-20 Thread Nicolas Ferre
-by: Nicolas Ferre Thanks, best regards, -- Nicolas Ferre

Re: [PATCH] usb: Convert pr_warning to pr_warn

2016-09-28 Thread Nicolas Ferre
rs/usb/gadget/function/u_serial.c | 4 ++-- > drivers/usb/gadget/udc/at91_udc.h | 2 +- > drivers/usb/gadget/udc/atmel_usba_udc.c | 4 ++-- For AT91 and Atmel parts: Acked-by: Nicolas Ferre Thanks > drivers/usb/gadget/udc/fsl_usb2_udc.h | 2 +- > drivers/usb/gadget/

Re: [PATCH 2/3] ARM: dts: at91: usb_a9g20: fix rtc node

2017-09-15 Thread Nicolas Ferre
On 15/09/2017 at 04:00, Alexandre Belloni wrote: > The rv3029 compatible is missing its vendor string, add it. > Also fix the node name to be a proper generic name. > > Signed-off-by: Alexandre Belloni Acked-by: Nicolas Ferre > --- > arch/arm/boot/dts/usb_a9g20_common.dtsi

Re: [PATCH 11/20] irqchip/atmel-aic: convert to of_property_for_each_u32_new()

2024-07-03 Thread Nicolas Ferre
On 03/07/2024 at 12:36, Luca Ceresoli wrote: Simplify code using of_property_for_each_u32_new() as the two additional parameters in of_property_for_each_u32() are not used here. Signed-off-by: Luca Ceresoli Acked-by: Nicolas Ferre --- drivers/irqchip/irq-atmel-aic-common.c | 4 +--- 1