+++ Petr Mladek [09/03/16 15:01 +0100]:
LivePatch framework deserves some documentation, definitely.
This is an attempt to provide some basic info. I hope that
it will be useful for both LivePatch producers and also
potential developers of the framework itself.
Signed-off-by: Petr Mladek
---
T
+++ Miroslav Benes [13/04/16 15:01 +0200]:
On Wed, 13 Apr 2016, Michael Ellerman wrote:
This series adds live patching support for powerpc (ppc64le only ATM).
It's unchanged since the version I posted on March 24, with the exception that
I've dropped the first patch, which was a testing-only p
+++ Miroslav Benes [14/04/16 15:28 +0200]:
On Wed, 13 Apr 2016, Jessica Yu wrote:
+++ Miroslav Benes [13/04/16 15:01 +0200]:
> On Wed, 13 Apr 2016, Michael Ellerman wrote:
>
> > This series adds live patching support for powerpc (ppc64le only ATM).
> >
> > It's
Nice work Petr. I read through it and didn't notice any other
additional issues. With Chris', Balbir's and Josh's comments taken
into account:
Acked-by: Jessica Yu
___
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
http
+++ Miroslav Benes [26/01/16 15:14 +0100]:
[ Jessica added to CC list so she is aware that there are plans to
implement livepatch on ppc64le ]
On Tue, 26 Jan 2016, Torsten Duwe wrote:
On Tue, Jan 26, 2016 at 11:50:25AM +0100, Miroslav Benes wrote:
> > + */
> > +int klp_write_module_reloc(stru
can select it
and be able to use mod_check_sig() without having to depend on either
CONFIG_MODULE_SIG or CONFIG_MODULES.
Signed-off-by: Thiago Jung Bauermann
Reviewed-by: Mimi Zohar
Cc: Jessica Yu
---
include/linux/module.h | 3 --
include/linux/module_signature.h | 44
asm/module.lds.h, which is included from
scripts/module.lds.S.
scripts/module.lds is fine because 'make clean' keeps all the
build artifacts under scripts/.
You can add arch-specific sections in .
Signed-off-by: Masahiro Yamada
Tested-by: Jessica Yu
Acked-by: Will Deacon
Acked-by: Jessica Yu
Thanks for working on this!
+++ Christoph Hellwig [02/02/21 13:13 +0100]:
Hi all,
this series removes support for long term unused export types and
cleans up various loose ends in the module loader.
Changes since v2:
- clean up klp_find_object_symbol a bit
- remove the now unused module_assert_mutex helper
Changes since
+++ Nicholas Piggin [11/06/21 19:39 +1000]:
The elf_check_arch() function is used to test usermode binaries, but
kernel modules may have more specific requirements. powerpc would like
to test for ABI version compatibility.
Add an arch-overridable function elf_check_module_arch() that defaults
to
+++ Nicholas Piggin [15/06/21 12:05 +1000]:
Excerpts from Jessica Yu's message of June 14, 2021 10:06 pm:
+++ Nicholas Piggin [11/06/21 19:39 +1000]:
The elf_check_arch() function is used to test usermode binaries, but
kernel modules may have more specific requirements. powerpc would like
to te
+++ Jarkko Sakkinen [14/07/20 12:45 +0300]:
Rename module_alloc() to text_alloc() and module_memfree() to
text_memfree(), and move them to kernel/text.c, which is unconditionally
compiled to the kernel proper. This allows kprobes, ftrace and bpf to
allocate space for executable code without requi
+++ Jarkko Sakkinen [24/07/20 10:36 +0300]:
On Thu, Jul 23, 2020 at 03:42:09PM +0300, Ard Biesheuvel wrote:
On Thu, 23 Jul 2020 at 04:52, Jarkko Sakkinen
wrote:
>
> On Thu, Jul 16, 2020 at 06:49:09PM +0200, Christophe Leroy wrote:
> > Jarkko Sakkinen a écrit :
> >
> > > Rename module_alloc() t
+++ Christoph Hellwig [21/01/21 08:49 +0100]:
To uncouple the livepatch code from module loader internals move a
slightly refactored version of klp_find_object_module to module.c
This allows to mark find_module static and removes one of the last
users of module_mutex outside of module.c.
Signed-
+++ Miroslav Benes [29/01/21 16:29 +0100]:
On Thu, 28 Jan 2021, Christoph Hellwig wrote:
Allow for a RCU-sched critical section around find_module, following
the lower level find_module_all helper, and switch the two callers
outside of module.c to use such a RCU-sched critical section instead
o
+++ Christoph Hellwig [02/02/21 13:13 +0100]:
Hi all,
this series removes support for long term unused export types and
cleans up various loose ends in the module loader.
Changes since v2:
- clean up klp_find_object_symbol a bit
- remove the now unused module_assert_mutex helper
Changes since
Acked-by: Geert Uytterhoeven
---
arch/m68k/mm/cache.c | 4
kernel/module.c | 8
2 files changed, 4 insertions(+), 8 deletions(-)
Thanks for cleaning this up. For module.c:
Acked-by: Jessica Yu
+++ Segher Boessenkool [15/06/21 07:50 -0500]:
On Tue, Jun 15, 2021 at 02:17:40PM +0200, Jessica Yu wrote:
+int __weak elf_check_module_arch(Elf_Ehdr *hdr)
+{
+ return 1;
+}
But is this a good idea? It isn't useful to be able to attempt to load
a module not compiled for
ow :D)
This can go through the powerpc tree. Will you do another respin
of this patch? And yes, feel free to take my SOB for this one -
Signed-off-by: Jessica Yu
Thanks!
Jessica
+++ Michael Ellerman [16/06/21 12:37 +1000]:
Jessica Yu writes:
+++ Nicholas Piggin [15/06/21 12:05 +1000]:
Excerpts from Jessica Yu's message of June 14, 2021 10:06 pm:
+++ Nicholas Piggin [11/06/21 19:39 +1000]:
The elf_check_arch() function is used to test usermode binaries, but
k
profile-kernel'
insmod: ERROR: could not insert module autofs4-pg.ko: Invalid module format
Signed-off-by: Michael Ellerman
Looks good to me:
Acked-by: Jessica Yu
---
arch/powerpc/include/asm/module.h | 4
1 file changed, 4 insertions(+)
diff --git a/arch/powerpc/include/asm/m
+++ Ard Biesheuvel [24/01/17 16:16 +]:
This v4 is a followup to [0] 'modversions: redefine kcrctab entries as
relative CRC pointers', but since relative CRC pointers do not work in
modules, and are actually only needed by powerpc with CONFIG_RELOCATABLE=y,
I have made it a Kconfig selectable
+++ Jessica Yu [02/02/17 22:54 -0500]:
+++ Ard Biesheuvel [24/01/17 16:16 +]:
This v4 is a followup to [0] 'modversions: redefine kcrctab entries as
relative CRC pointers', but since relative CRC pointers do not work in
modules, and are actually only needed by po
+++ Steven Rostedt [02/03/17 13:11 -0500]:
Can I get an Ack from a module maintainer?
Acked-by: Jessica Yu
Thanks!
Jessica
On Wed, 1 Mar 2017 14:04:53 -0800
David Daney wrote:
For powerpc the __jump_table section in modules is not aligned, this
causes a WARN_ON() splat when loading a
+++ David Daney [02/03/17 11:24 -0800]:
On 03/02/2017 10:26 AM, Jessica Yu wrote:
+++ Steven Rostedt [02/03/17 13:11 -0500]:
Can I get an Ack from a module maintainer?
Acked-by: Jessica Yu
Thanks!
Jessica
Thanks Jessica,
Can you also add scripts/module-common.lds to MAINTAINERS so
+++ Josh Poimboeuf [28/04/16 15:44 -0500]:
[snip]
diff --git a/Documentation/livepatch/livepatch.txt
b/Documentation/livepatch/livepatch.txt
index 6c43f6e..bee86d0 100644
--- a/Documentation/livepatch/livepatch.txt
+++ b/Documentation/livepatch/livepatch.txt
@@ -72,7 +72,8 @@ example, they add
25 matches
Mail list logo