Re: [PATCH 03/30] blk-mq: add the blk_mq_alloc_disk APIs

2021-06-02 Thread Chaitanya Kulkarni
itialization calls and respective error handling in each blk-mq based drivers. Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 15/30] blk-mq: remove blk_mq_init_sq_queue

2021-06-02 Thread Chaitanya Kulkarni
On 6/1/21 23:55, Christoph Hellwig wrote: > All users are gone now. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 18/30] loop: use blk_mq_alloc_disk and blk_cleanup_disk

2021-06-02 Thread Chaitanya Kulkarni
On 6/1/21 23:56, Christoph Hellwig wrote: > Use blk_mq_alloc_disk and blk_cleanup_disk to simplify the gendisk and > request_queue allocation. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 20/30] nullb: use blk_mq_alloc_disk

2021-06-02 Thread Chaitanya Kulkarni
On 6/1/21 23:56, Christoph Hellwig wrote: > Use blk_mq_alloc_disk and blk_cleanup_disk to simplify the gendisk and > request_queue allocation. > > Signed-off-by: Christoph Hellwig > --- > drivers/block/null_blk/main.c | 11 +-- > 1 file changed, 5 insertions(+), 6 deletions(-) > > diff --

Re: [PATCH 03/16] bvec: fix the include guards for bvec.h

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:06, Christoph Hellwig wrote: > Fix the include guards to match the file naming. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 01/16] mm: use kmap_local_page in memzero_page

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:06, Christoph Hellwig wrote: > No need for kmap_atomic here. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 04/16] bvec: add a bvec_kmap_local helper

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:06, Christoph Hellwig wrote: > Add a helper to call kmap_local_page on a bvec. There is no need for > an unmap helper given that kunmap_local accept any address in the mapped > page. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 06/16] block: use memzero_page in zero_fill_bio

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:07, Christoph Hellwig wrote: > Use memzero_bvec to zero each segment in the bio instead of manually > mapping and zeroing the data. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 05/16] bvec: add memcpy_{from,to}_bvec and memzero_bvec helper

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:07, Christoph Hellwig wrote: > Add helpers to perform common memory operation on a bvec. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 12/16] block: use memcpy_to_bvec in copy_to_high_bio_irq

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:08, Christoph Hellwig wrote: > Use memcpy_to_bvec instead of opencoding the logic. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 13/16] block: use memcpy_from_bvec in bio_copy_kern_endio_read

2021-06-08 Thread Chaitanya Kulkarni
On 6/8/21 09:09, Christoph Hellwig wrote: > Use memcpy_from_bvec instead of open coding the logic. > > Signed-off-by: Christoph Hellwig Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 02/13] nvme-multipath: add error handling support for add_disk()

2021-10-18 Thread Chaitanya Kulkarni
; Signed-off-by: Luis Chamberlain Looks good. Reviewed-by: Chaitanya Kulkarni

Re: [PATCH 02/26] sd: remove sd_is_zoned

2024-06-17 Thread Chaitanya Kulkarni
inecke > Reviewed-by: Johannes Thumshirn Looks good. Reviewed-by: Chaitanya Kulkarni -ck

Re: [PATCH 09/26] virtio_blk: remove virtblk_update_cache_mode

2024-06-17 Thread Chaitanya Kulkarni
sche > Reviewed-by: Stefan Hajnoczi > Reviewed-by: Damien Le Moal > Reviewed-by: Hannes Reinecke > Reviewed-by: Johannes Thumshirn Looks good. Reviewed-by: Chaitanya Kulkarni -ck

Re: [PATCH 11/26] block: freeze the queue in queue_attr_store

2024-06-17 Thread Chaitanya Kulkarni
ristoph Hellwig > Reviewed-by: Bart Van Assche > Reviewed-by: Damien Le Moal > Reviewed-by: Hannes Reinecke Looks good. Reviewed-by: Chaitanya Kulkarni -ck

Re: [PATCH 12/26] block: remove blk_flush_policy

2024-06-17 Thread Chaitanya Kulkarni
Looks good. Reviewed-by: Chaitanya Kulkarni -ck

Re: [PATCH] checkpatch: Add kmap and kmap_atomic to the deprecated list

2022-08-13 Thread Chaitanya Kulkarni
io know if you plan on tacking one of the conversions so we can mark it > off the list. > > [1] > https://docs.google.com/spreadsheets/d/1i_ckZ10p90bH_CkxD2bYNi05S2Qz84E2OFPv8zq__0w/edit#gid=1679714357 > Looks good. Reviewed-by: Chaitanya Kulkarni