Re: [PATCH v2] selftests/powerpc: Remove the path after initialization.

2024-11-17 Thread Michael Ellerman
On Mon, 30 Sep 2024 09:27:57 +0800, zhangjiao2 wrote: > If there were no anamolies noted, then we can > simply remove the log file and return. > > Applied to powerpc/next. [1/1] selftests/powerpc: Remove the path after initialization. https://git.kernel.org/powerpc/c/7ca93aa9204b706e4afcd

Re: [PATCH v7 00/17] powerpc: Core ftrace rework, support for ftrace direct and bpf trampolines

2024-11-17 Thread Michael Ellerman
On Wed, 30 Oct 2024 12:38:33 +0530, Hari Bathini wrote: > This is v7 of the series posted here: > https://lore.kernel.org/all/20241018173632.277333-1-hbath...@linux.ibm.com/ > > This series reworks core ftrace support on powerpc to have the function > profiling sequence moved out of line. This ena

Re: [PATCH 11/13] powerpc/irq: use seq_put_decimal_ull_width() for decimal values

2024-11-17 Thread Michael Ellerman
On Sat, 09 Nov 2024 00:23:27 +0800, David Wang wrote: > Performance improvement for reading /proc/interrupts on arch powerpc > > Applied to powerpc/next. [11/13] powerpc/irq: use seq_put_decimal_ull_width() for decimal values https://git.kernel.org/powerpc/c/5b881c1f83792f5db421124171b

Re: [PATCH] powerpc-km82xx.c: replace of_node_put with __free improves cleanup

2024-11-17 Thread Michael Ellerman
On Tue, 09 Jul 2024 10:35:53 -0400, David Hunter wrote: > The use of the __free function allows the cleanup to be based on scope > instead of on another function called later. This makes the cleanup > automatic and less susceptible to errors later. > > This code was compiled without errors or warn

Re: [PATCH] powerpc/ep8248e: Use %pa to format resource_size_t

2024-11-17 Thread Michael Ellerman
On Mon, 14 Oct 2024 11:55:03 +0100, Simon Horman wrote: > The correct format string for resource_size_t is %pa which > acts on the address of the variable to be formatted [1]. > > [1] > https://elixir.bootlin.com/linux/v6.11.3/source/Documentation/core-api/printk-formats.rst#L229 > > Introduced

Re: [PATCH] powerpc/ps3: Mark ps3_setup_uhc_device() __init

2024-11-17 Thread Michael Ellerman
On Wed, 06 Nov 2024 14:26:25 +0100, Geert Uytterhoeven wrote: > ps3_setup_uhc_device() is only called from ps3_setup_ehci_device() and > ps3_setup_ohci_device(), which are both marked __init. Hence replace > the former's __ref marker by __init. > > Note that before commit bd721ea73e1f9655 ("treew

Re: [PATCH] powerpc: Add __must_check to set_memory_...()

2024-11-17 Thread Michael Ellerman
On Sat, 07 Sep 2024 17:40:41 +0200, Christophe Leroy wrote: > After the following powerpc commits, all calls to set_memory_...() > functions check returned value. > - Commit 8f17bd2f4196 ("powerpc: Handle error in mark_rodata_ro() and > mark_initmem_nx()") > - Commit f7f18e30b468 ("powerpc/kprobes:

Re: [PATCH v2] powerpc/xive: Use cpumask_intersects()

2024-11-17 Thread Michael Ellerman
On Thu, 26 Sep 2024 12:26:22 +0300, Costa Shulyupin wrote: > Replace `cpumask_any_and(a, b) >= nr_cpu_ids` > with the more readable `!cpumask_intersects(a, b)`. > > Comparison between cpumask_any_and() and cpumask_intersects() > > The cpumask_any_and() function expands using FIND_FIRST_BIT(), > r

Re: [PATCH] powermac: Use of_property_match_string() in pmac_has_backlight_type()

2024-11-17 Thread Michael Ellerman
On Fri, 11 Oct 2024 18:18:42 +0200, Markus Elfring wrote: > Replace an of_get_property() call by of_property_match_string() > so that this function implementation can be simplified. > > Applied to powerpc/next. [1/1] powermac: Use of_property_match_string() in pmac_has_backlight_type() ht

Re: [PATCH] MAINTAINERS: powerpc: Mark Maddy as "M"

2024-11-17 Thread Michael Ellerman
On Fri, 15 Nov 2024 15:54:42 +1100, Michael Ellerman wrote: > Mark Maddy as a co-maintainer, so that he can get a kernel.org account > and help manage the powerpc tree on kernel.org. > > Applied to powerpc/next. [1/1] MAINTAINERS: powerpc: Mark Maddy as "M" https://git.kernel.org/powerpc/

Re: [PATCH] powerpc: remove dead config options for MPC85xx platform support

2024-11-17 Thread Michael Ellerman
On Fri, 27 Sep 2024 11:52:03 +0200, Lukas Bulwahn wrote: > Commit 384e338a9187 ("powerpc: drop MPC8540_ADS and MPC8560_ADS platform > support") and commit b751ed04bc5e ("powerpc: drop MPC85xx_CDS platform > support") removes the platform support for MPC8540_ADS, MPC8560_ADS and > MPC85xx_CDS in the

Re: [PATCH] powerpc/ftrace: Fix ftrace bug with KASAN=y

2024-11-17 Thread Michael Ellerman
On Thu, 07 Nov 2024 22:16:30 +1100, Michael Ellerman wrote: > Booting a KASAN=y kernel with the recently added ftrace out-of-line > support causes a warning at boot: > > [ cut here ] > Stub index overflow (1729 > 1728) > WARNING: CPU: 0 PID: 0 at arch/powerpc/kernel/t

Re: [PATCH] cpufreq: maple: Remove maple driver

2024-11-17 Thread Michael Ellerman
On Tue, 12 Nov 2024 19:51:48 +1100, Michael Ellerman wrote: > This driver is no longer buildable since the PPC_MAPLE platform was > removed, see commit 62f8f307c80e ("powerpc/64: Remove maple platform"). > > Remove the driver. > > Note that the comment in the driver says it supports "SMU & 970FX

Re: [PATCH] macintosh: Use common error handling code in via_pmu_led_init()

2024-11-17 Thread Michael Ellerman
On Thu, 03 Oct 2024 21:15:45 +0200, Markus Elfring wrote: > Add a jump target so that a bit of exception handling can be better reused > at the end of this function implementation. > > This issue was detected by using the Coccinelle software. > > Applied to powerpc/next. [1/1] macintosh: Use c

Re: (subset) [PATCH 00/35] Reorganize kerneldoc parameter names

2024-11-17 Thread Michael Ellerman
On Mon, 30 Sep 2024 13:20:46 +0200, Julia Lawall wrote: > Reorganize kerneldoc parameter names to match the parameter > order in the function header. > > The misordered cases were identified using the following > Coccinelle semantic patch: > > // > @initialize:ocaml@ > @@ > > [...] Applied to

Re: [PATCH] powerpc: cell: Use for_each_of_range() iterator

2024-11-17 Thread Michael Ellerman
On Wed, 06 Nov 2024 15:26:46 -0600, Rob Herring (Arm) wrote: > Simplify the cell_iommu_get_fixed_address() dma-ranges parsing to use the > for_each_of_range() iterator. > > Applied to powerpc/next. [1/1] powerpc: cell: Use for_each_of_range() iterator https://git.kernel.org/powerpc/c/f3ef

Re: [PATCH] powerpc: 44x: Use for_each_of_range() iterator

2024-11-17 Thread Michael Ellerman
On Wed, 06 Nov 2024 15:26:39 -0600, Rob Herring (Arm) wrote: > Simplify the ppc44x PCI dma-ranges parsing to use the for_each_of_range() > iterator. > > Applied to powerpc/next. [1/1] powerpc: 44x: Use for_each_of_range() iterator https://git.kernel.org/powerpc/c/817a763a07f2407ca43b2134d

Re: [PATCH] powerpc/Makefile: Allow overriding CPP

2024-11-17 Thread Michael Ellerman
On Thu, 07 Nov 2024 22:26:46 +1100, Michael Ellerman wrote: > Unlike all other arches, powerpc doesn't allow the user to override CPP, > because it sets it unconditionally in the arch Makefile. This can lead > to strange build failures. > > Instead add the required flags to KBUILD_CPPFLAGS, which

Re: [PATCH] powerpc/sstep: make emulate_vsx_load and emulate_vsx_store static

2024-11-17 Thread Michael Ellerman
On Tue, 01 Oct 2024 15:03:49 +0200, Michal Suchanek wrote: > These functions are not used outside of sstep.c > > Applied to powerpc/next. [1/1] powerpc/sstep: make emulate_vsx_load and emulate_vsx_store static https://git.kernel.org/powerpc/c/a26c4dbb3d9c1821cb0fc11cb2dbc32d5bf3463b chee

Re: [PATCH] powerpc/vdso: Drop -mstack-protector-guard flags in 32-bit files with clang

2024-11-17 Thread Michael Ellerman
On Wed, 30 Oct 2024 11:41:37 -0700, Nathan Chancellor wrote: > Under certain conditions, the 64-bit '-mstack-protector-guard' flags may > end up in the 32-bit vDSO flags, resulting in build failures due to the > structure of clang's argument parsing of the stack protector options, > which validates

Re: [PATCH v2 1/2] powerpc/fadump: allocate memory for additional parameters early

2024-11-17 Thread Michael Ellerman
On Thu, 07 Nov 2024 11:28:16 +0530, Sourabh Jain wrote: > Memory for passing additional parameters to fadump capture kernel > is allocated during subsys_initcall level, using memblock. But > as slab is already available by this time, allocation happens via > the buddy allocator. This may work for r

Re: [PATCH] powerpc/cell: Remove dead extern declaration for spu_priv1_beat_ops

2024-11-17 Thread Michael Ellerman
On Tue, 12 Nov 2024 22:48:05 +1100, Michael Ellerman wrote: > spu_priv1_beat_ops were removed in commit bf4981a00636 ("powerpc: Remove > the celleb support"), remove the unneeded extern. > > Applied to powerpc/next. [1/1] powerpc/cell: Remove dead extern declaration for spu_priv1_beat_ops

Re: [RFC PATCH 01/10] powerpc/chrp: Remove CHRP support

2024-11-17 Thread Gerhard Pircher
Am 14.11.24 um 14:11 schrieb Michael Ellerman: CHRP (Common Hardware Reference Platform) was a standard developed by IBM & Apple for PowerPC-based systems. The standard was used in the development of some machines but never gained wide spread adoption. The Linux CHRP code only supports a handfu

Re: [PATCH] powerpc/vdso: Remove unused clockmode asm offsets

2024-11-17 Thread Thomas Weißschuh
Hi Michael, On Sun, Nov 17, 2024 at 11:09:57PM +1100, Michael Ellerman wrote: > On Wed, 13 Nov 2024 09:06:58 +0100, Thomas Weißschuh wrote: > > These offsets are not used anymore, delete them. > > > > > > Applied to powerpc/next. > > [1/1] powerpc/vdso: Remove unused clockmode asm offsets >

Re: [RFC PATCH 01/10] powerpc/chrp: Remove CHRP support

2024-11-17 Thread Michael Ellerman
Gerhard Pircher writes: > Am 14.11.24 um 14:11 schrieb Michael Ellerman: >> CHRP (Common Hardware Reference Platform) was a standard developed by >> IBM & Apple for PowerPC-based systems. >> >> The standard was used in the development of some machines but never >> gained wide spread adoption. >> >

[PATCH] macintosh: Fix spelling mistake "toogle" to "toggle"

2024-11-17 Thread Zhu Jun
There is a spelling mistake, Please fix it. Signed-off-by: Zhu Jun --- drivers/macintosh/adbhid.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/macintosh/adbhid.c b/drivers/macintosh/adbhid.c index b2fe7a3dc471..943a7123786a 100644 --- a/drivers/macintosh/adbhid.c +

[powerpc:topic/ppc-kvm] BUILD SUCCESS 590d2f9347f7974d7954400e5d937672fd844a8b

2024-11-17 Thread kernel test robot
figclang-20 arc nsimosci_hs_defconfiggcc-13.2.0 arc nsimosci_hs_smp_defconfigclang-20 arc randconfig-001-20241117clang-20 arc randconfig-002-20241117clang-20 arm allmodconfigclang-20

[powerpc:next] BUILD SUCCESS ba6d8efb1bd7318f173846a8f5730a54c93f3ff5

2024-11-17 Thread kernel test robot
tree/branch: https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git next branch HEAD: ba6d8efb1bd7318f173846a8f5730a54c93f3ff5 Merge branch 'topic/ppc-kvm' into next elapsed time: 802m configs tested: 122 configs skipped: 2 The following configs have been built successfully. More c

Re: [PATCH v2] powerpc/kvm: Fix typo in the kvm functions

2024-11-17 Thread Michael Ellerman
On Thu, 14 Nov 2024 14:20:20 +0530, Kajol Jain wrote: > Fix typo in the following kvm function names from: > > kmvhv_counters_tracepoint_regfunc -> kvmhv_counters_tracepoint_regfunc > kmvhv_counters_tracepoint_unregfunc -> kvmhv_counters_tracepoint_unregfunc > > Applied to powerpc/topic/ppc-kvm

Re: [PATCH 0/3] Fix doorbell emulation for nested KVM guests in V1 API

2024-11-17 Thread Michael Ellerman
On Sat, 09 Nov 2024 12:02:54 +0530, Gautam Menghani wrote: > Doorbell emulation for nested KVM guests in V1 API is broken because of > 2 reasons: > 1. L0 presenting H_EMUL_ASSIST to L1 instead of H_FAC_UNAVAIL > 2. Broken plumbing for passing around doorbell state. > > Fix the trap passed to L1 an

Re: [PATCH] KVM: PPC: Book3S HV: Add Power11 capability support for Nested PAPR guests

2024-11-17 Thread Michael Ellerman
On Mon, 28 Oct 2024 15:46:22 +0530, Amit Machhiwal wrote: > The Power11 architected and raw mode support in Linux was merged via [1] > and the corresponding support in QEMU is pending in [2], which is > currently in its V6. > > Currently, booting a KVM guest inside a pseries LPAR (Logical Partitio

Re: (subset) [PATCH 00/17] replace call_rcu by kfree_rcu for simple kmem_cache_free callback

2024-11-17 Thread Michael Ellerman
On Sun, 13 Oct 2024 22:16:47 +0200, Julia Lawall wrote: > Since SLOB was removed and since > commit 6c6c47b063b5 ("mm, slab: call kvfree_rcu_barrier() from > kmem_cache_destroy()"), > it is not necessary to use call_rcu when the callback only performs > kmem_cache_free. Use kfree_rcu() directly. >

Re: [PATCH v3] KVM: PPC: Book3S HV: Mask off LPCR_MER for a vCPU before running it to avoid spurious interrupts

2024-11-17 Thread Michael Ellerman
Gautam Menghani writes: > Running a L2 vCPU (see [1] for terminology) with LPCR_MER bit set and no > pending interrupts results in that L2 vCPU getting an infinite flood of > spurious interrupts. The 'if check' in kvmhv_run_single_vcpu() sets the > LPCR_MER bit if there are pending interrupts. Ap

Re: [RFC PATCH 08/10] macintosh: Remove ADB_MACIO

2024-11-17 Thread Michael Ellerman
Christophe Leroy writes: > Le 14/11/2024 à 14:11, Michael Ellerman a écrit : >> The macio-adb driver depends on PPC_CHRP, which has been removed, remove >> the driver also. >> >> Signed-off-by: Michael Ellerman >> --- >> drivers/macintosh/Kconfig | 9 -- >> drivers/macintosh/Makefile

Re: [PATCH v2 2/2] PCI/AER: Report fatal errors of RCiEP and EP if link recoverd

2024-11-17 Thread Shuai Xue
在 2024/11/16 20:44, Shuai Xue 写道: 在 2024/11/16 04:20, Bowman, Terry 写道: Hi Shuai, On 11/12/2024 7:54 AM, Shuai Xue wrote: The AER driver has historically avoided reading the configuration space of an endpoint or RCiEP that reported a fatal error, considering the link to that device unrel

[PATCH 02/11] lib/crc-t10dif: add support for arch overrides

2024-11-17 Thread Eric Biggers
From: Eric Biggers Following what was done for CRC32, add support for architecture-specific override of the CRC-T10DIF library. This will allow the CRC-T10DIF library functions to access architecture-optimized code directly. Signed-off-by: Eric Biggers --- include/linux/crc-t10dif.h | 12

Re: [PATCH v2] arch/powerpc/pseries: Fix KVM guest detection for disabling hardlockup detector

2024-11-17 Thread Michael Ellerman
On Fri, 08 Nov 2024 15:18:37 +0530, Gautam Menghani wrote: > As per the kernel documentation[1], hardlockup detector should be > disabled in KVM guests as it may give false positives. On PPC, hardlockup > detector is enabled inside KVM guests because disable_hardlockup_detector() > is marked as ear

Re: [PATCH v2] powerpc/xmon: symbol lookup length fixed

2024-11-17 Thread Michael Ellerman
On Fri, 25 Oct 2024 00:42:33 +0530, Mukesh Kumar Chaurasiya wrote: > Currently this cannot lookup symbol beyond 64 characters in some cases > like "ls", "lp" and "t" > > Fix this by using KSYM_NAME_LEN instead of fixed 64 characters > > Applied to powerpc/next. [1/1] powerpc/xmon: symbol looku

Re: [PATCH 1/5] selftests/powerpc: Lower run time of count_stcx_fail test

2024-11-17 Thread Michael Ellerman
On Thu, 07 Nov 2024 00:04:49 +1100, Michael Ellerman wrote: > The count_stcx_fail test runs for close to or just over 2 minutes, which > means it sometimes times out. > > That's overkill for a test that just demonstrates some PMU counters > are working. Drop the 64 billion instruction case, to low

Re: [PATCH] powerpc: Use str_enabled_disabled() helper function

2024-11-17 Thread Michael Ellerman
On Sun, 27 Oct 2024 23:22:17 +0100, Thorsten Blum wrote: > Remove hard-coded strings by using the str_enabled_disabled() helper > function. > > Applied to powerpc/next. [1/1] powerpc: Use str_enabled_disabled() helper function https://git.kernel.org/powerpc/c/19e0a70e6c3c1bf800b8ce9eb4586

Re: [PATCH v1] ps3: Correct some typos in comments

2024-11-17 Thread Michael Ellerman
On Mon, 30 Sep 2024 10:32:34 +0800, Shen Lichuan wrote: > Fixed some confusing typos that were currently identified with codespell, > the details are as follows: > > -in the code comments: > drivers/ps3/ps3-lpm.c:94: rigths ==> rights > drivers/ps3/ps3-sys-manager.c:365: acnowledge ==> acknowledge

Re: [PATCH] powerpc/kexec: Fix the return of uninitialized variable

2024-11-17 Thread Michael Ellerman
On Mon, 30 Sep 2024 15:56:28 +0800, Zhang Zekun wrote: > The of_property_read_u64() can fail and remain the variable uninitialized, > which will then be used. Return error if we failed to read the property. > > Applied to powerpc/next. [1/1] powerpc/kexec: Fix the return of uninitialized variab

Re: [PATCH] powerpc/vdso: Remove unused clockmode asm offsets

2024-11-17 Thread Michael Ellerman
On Wed, 13 Nov 2024 09:06:58 +0100, Thomas Weißschuh wrote: > These offsets are not used anymore, delete them. > > Applied to powerpc/next. [1/1] powerpc/vdso: Remove unused clockmode asm offsets https://git.kernel.org/powerpc/c/d7a82238cb8c77d4ed8cc97cd556c5f3e64bc749 cheers

Re: [PATCH][next] powerpc/ps3: replace open-coded sysfs_emit function

2024-11-17 Thread Michael Ellerman
On Sat, 19 Oct 2024 15:13:49 +1300, Paulo Miguel Almeida wrote: > sysfs_emit() helper function should be used when formatting the value > to be returned to user space. > > This patch replaces open-coded sysfs_emit() in sysfs .show() callbacks > > Applied to powerpc/next. [1/1] powerpc/ps3: rep

Re: [PATCH] powerpc/modules: start/end_opd are only needed for ABI v1

2024-11-17 Thread Michael Ellerman
On Mon, 12 Aug 2024 16:33:12 +1000, Michael Ellerman wrote: > The start_opd/end_opd members of struct mod_arch_specific are only > needed for kernels built using ELF ABI v1. Guard them with an ifdef to > save a little bit of space on ELF ABI v2 kernels. > > Applied to powerpc/next. [1/1] powerp