Re: [PATCH 6/7] powerpc/entry: factout irqentry-state

2024-10-15 Thread Thomas Gleixner
On Sat, Oct 12 2024 at 11:56, Luming Yu wrote: > To have lowlevel paca.h include high level entry-common.h cause > include file dependency mess. Split irqentry-state.h to have > the irqentry_state.h can be included in low level paca.h What's the rationale for this? > Signed-off-by: Luming Yu >

Re: [PATCH 0/2] net: ethernet: freescale: Use %pa to format resource_size_t

2024-10-15 Thread Simon Horman
On Tue, Oct 15, 2024 at 07:24:48AM +, Daniel Machon wrote: > > Hi, > > > > This short series addersses the formatting of variables of > > type resource_size_t in freescale drivers. > > > > The correct format string for resource_size_t is %pa which > > acts on the address of the variable to be

Re: [RFC PATCH v3 4/4] sched+mm: Use hazard pointers to track lazy active mm existence

2024-10-15 Thread Mathieu Desnoyers
On 2024-10-14 04:27, kernel test robot wrote: Hello, kernel test robot noticed "WARNING:at_kernel/hazptr.c:#hazptr_scan" on: commit: c1508707268498a6fd3ca5853ad65f9482c12374 ("[RFC PATCH v3 4/4] sched+mm: Use hazard pointers to track lazy active mm existence") url: https://github.com/intel-

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Dave Martin
On Tue, Oct 15, 2024 at 12:41:16PM +0100, Will Deacon wrote: > On Tue, Oct 15, 2024 at 10:59:11AM +0100, Joey Gouly wrote: > > On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > > > Kevin, Joey, > > > > > > On Wed, Oct 09, 2024 at 03:43:01PM +0100, Will Deacon wrote: > > > > On Tue, Se

Re: [PATCH 00/17] replace call_rcu by kfree_rcu for simple kmem_cache_free callback

2024-10-15 Thread patchwork-bot+netdevbpf
Hello: This series was applied to netdev/net-next.git (main) by Simon Wunderlich : On Sun, 13 Oct 2024 22:16:47 +0200 you wrote: > Since SLOB was removed and since > commit 6c6c47b063b5 ("mm, slab: call kvfree_rcu_barrier() from > kmem_cache_destroy()"), > it is not necessary to use call_rcu whe

[PATCH v3 04/22] powerpc/cell: Switch to irq_get_nr_irqs()

2024-10-15 Thread Bart Van Assche
Use the irq_get_nr_irqs() function instead of the global variable 'nr_irqs'. Prepare for changing 'nr_irqs' from an exported global variable into a variable with file scope. Cc: linuxppc-dev@lists.ozlabs.org Signed-off-by: Bart Van Assche --- arch/powerpc/platforms/cell/axon_msi.c | 2 +- 1 file

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Joey Gouly
On Tue, Oct 15, 2024 at 12:41:16PM +0100, Will Deacon wrote: > On Tue, Oct 15, 2024 at 10:59:11AM +0100, Joey Gouly wrote: > > On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > > > Kevin, Joey, > > > > > > On Wed, Oct 09, 2024 at 03:43:01PM +0100, Will Deacon wrote: > > > > On Tue, Se

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Mark Brown
On Tue, Oct 15, 2024 at 01:25:29PM +0100, Joey Gouly wrote: > On Tue, Oct 15, 2024 at 12:41:16PM +0100, Will Deacon wrote: > > if (system_supports_poe() && err == 0 && user->poe_offset) { > > ... > > which gives the wrong impression that the POR is somehow optional, even > > if th

Re: [RFC PATCH v1 01/57] mm: Add macros ahead of supporting boot-time page size selection

2024-10-15 Thread Ryan Roberts
On 15/10/2024 04:04, Pingfan Liu wrote: > On Mon, Oct 14, 2024 at 10:07 PM Ryan Roberts wrote: >> >> On 14/10/2024 14:54, Pingfan Liu wrote: >>> Hello Ryan, >>> >>> On Mon, Oct 14, 2024 at 11:58:08AM +0100, Ryan Roberts wrote: arm64 can support multiple base page sizes. Instead of selecting a

Re: drivers/nx: Invalid wait context issue when rebooting

2024-10-15 Thread Vishal Chourasia
On Mon, Oct 14, 2024 at 05:54:44PM +0530, Ritesh Harjani wrote: > Vishal Chourasia writes: > > > On Fri, Oct 11, 2024 at 09:37:27PM +1100, Michael Ellerman wrote: > >> > >> I don't see why of_reconfig_notifier_unregister() needs to be called > >> with the devdata_mutext held, but I haven't looke

Re: [RFC v3 3/3] fadump: Move fadump_cma_init to setup_arch() after initmem_init()

2024-10-15 Thread Madhavan Srinivasan
On 10/11/24 8:30 PM, Ritesh Harjani (IBM) wrote: > During early init CMA_MIN_ALIGNMENT_BYTES can be PAGE_SIZE, > since pageblock_order is still zero and it gets initialized > later during initmem_init() e.g. > setup_arch() -> initmem_init() -> sparse_init() -> set_pageblock_order() > > One such

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Joey Gouly
On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > Kevin, Joey, > > On Wed, Oct 09, 2024 at 03:43:01PM +0100, Will Deacon wrote: > > On Tue, Sep 24, 2024 at 01:27:58PM +0200, Kevin Brodsky wrote: > > > On 22/08/2024 17:11, Joey Gouly wrote: > > > > @@ -1178,6 +1237,9 @@ static void set

Re: [PATCH] x86/uaccess: Avoid barrier_nospec() in copy_from_user()

2024-10-15 Thread Borislav Petkov
On Mon, Oct 14, 2024 at 04:39:26PM +0100, Andrew Cooper wrote: > But, I expect it will malfunction on newer hardware when > CONFIG_X86_5LEVEL=n, because it causes Linux to explicitly ignore the > LA57 bit.  That can be fixed by changing how CONFIG_X86_5LEVEL works. https://lore.kernel.org/all/8073

Re: [RFC RESEND v2 02/13] powerpc: mm: Fix kfence page fault reporting

2024-10-15 Thread IBM
Christophe Leroy writes: > Le 15/10/2024 à 03:33, Ritesh Harjani (IBM) a écrit : >> copy_from_kernel_nofault() can be called when doing read of /proc/kcore. >> /proc/kcore can have some unmapped kfence objects which when read via >> copy_from_kernel_nofault() can cause page faults. Since *_nofaul

[v2 PATCH 2/2] crypto/nx: Fix invalid wait context during kexec reboot

2024-10-15 Thread Vishal Chourasia
nx842_remove() call of_reconfig_notifier_unregister while holding the devdata_spinlock. This could lead to an invalid wait context error during kexec reboot, as of_reconfig_notifier_unregister tries to acquire a read-write semaphore (check logs) while holding a spinlock. Move the of_reconfig_notif

[v2 PATCH 1/2] crypto/nx: Rename devdata_mutex to devdata_spinlock

2024-10-15 Thread Vishal Chourasia
Rename devdata_mutex to devdata_spinlock to accurately reflect its implementation as a spinlock. [1] v1 https://lore.kernel.org/all/zwyqd-w5hehrn...@linux.ibm.com Signed-off-by: Vishal Chourasia --- drivers/crypto/nx/nx-common-pseries.c | 34 +-- 1 file changed, 17 inser

[PATCH] KVM: PPC: Book3S HV: Reset LPCR_MER before running a vCPU to avoid spurious interrupts

2024-10-15 Thread Gautam Menghani
Reset LPCR_MER bit before running a vCPU to ensure that it is not set if there are no pending interrupts. Running a vCPU with LPCR_MER bit set and no pending interrupts results in L2 vCPU getting an infinite flood of spurious interrupts. The 'if check' in kvmhv_run_single_vcpu() sets the LPCR_MER b

Re: [PATCH 0/2] net: ethernet: freescale: Use %pa to format resource_size_t

2024-10-15 Thread Daniel Machon
> Hi, > > This short series addersses the formatting of variables of > type resource_size_t in freescale drivers. > > The correct format string for resource_size_t is %pa which > acts on the address of the variable to be formatted [1]. > > [1] > https://elixir.bootlin.com/linux/v6.11.3/source/D

Re: [PATCH v5 6/8] x86/module: perpare module loading for ROX allocations of text

2024-10-15 Thread Nathan Chancellor
On Fri, Oct 11, 2024 at 03:58:04PM +0300, Mike Rapoport wrote: > I overlooked how cfi_*_callers routines update addr. > This patch should fix it: Thanks, can confirm. My boot is working again and LKDTM's CFI_FORWARD_PROTO test properly fails. > diff --git a/arch/x86/kernel/alternative.c b/arch/x8

Re: [RFC v3 2/3] fadump: Reserve page-aligned boot_memory_size during fadump_reserve_mem

2024-10-15 Thread Madhavan Srinivasan
On 10/11/24 8:30 PM, Ritesh Harjani (IBM) wrote: > This patch refactors all CMA related initialization and alignment code > to within fadump_cma_init() which gets called in the end. This also means > that we keep [reserve_dump_area_start, boot_memory_size] page aligned > during fadump_reserve_me

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Mark Brown
On Tue, Oct 15, 2024 at 10:59:11AM +0100, Joey Gouly wrote: > On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > > Looking a little more at this, I think we have quite a weird behaviour > > on arm64 as it stands. It looks like we rely on the signal frame to hold > > the original POR_EL

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Will Deacon
On Tue, Oct 15, 2024 at 10:59:11AM +0100, Joey Gouly wrote: > On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > > Kevin, Joey, > > > > On Wed, Oct 09, 2024 at 03:43:01PM +0100, Will Deacon wrote: > > > On Tue, Sep 24, 2024 at 01:27:58PM +0200, Kevin Brodsky wrote: > > > > On 22/08/202

Re: [PATCH 1/7] powerpc/entry: convert to common and generic entry

2024-10-15 Thread Christophe Leroy
Le 12/10/2024 à 05:56, Luming Yu a écrit : convert powerpc entry code in syscall and fault to use syscall_work and irqentry_state as well as common calls implemented in generic entry infrastructure. Signed-off-by: Luming Yu --- arch/powerpc/Kconfig | 1 + arch/powerpc/in

Re: [PATCH v5 19/30] arm64: add POE signal support

2024-10-15 Thread Catalin Marinas
On Tue, Oct 15, 2024 at 12:41:16PM +0100, Will Deacon wrote: > On Tue, Oct 15, 2024 at 10:59:11AM +0100, Joey Gouly wrote: > > On Mon, Oct 14, 2024 at 06:10:23PM +0100, Will Deacon wrote: > > > Looking a little more at this, I think we have quite a weird behaviour > > > on arm64 as it stands. It lo

Re: [PATCH 00/17] replace call_rcu by kfree_rcu for simple kmem_cache_free callback

2024-10-15 Thread patchwork-bot+netdevbpf
Hello: This series was applied to netdev/net-next.git (main) by Jakub Kicinski : On Sun, 13 Oct 2024 22:16:47 +0200 you wrote: > Since SLOB was removed and since > commit 6c6c47b063b5 ("mm, slab: call kvfree_rcu_barrier() from > kmem_cache_destroy()"), > it is not necessary to use call_rcu when

Re: [PATCH 0/2] net: ethernet: freescale: Use %pa to format resource_size_t

2024-10-15 Thread patchwork-bot+netdevbpf
Hello: This series was applied to netdev/net-next.git (main) by Jakub Kicinski : On Mon, 14 Oct 2024 11:48:06 +0100 you wrote: > Hi, > > This short series addersses the formatting of variables of > type resource_size_t in freescale drivers. > > The correct format string for resource_size_t is %

Re: [PATCH] tools/perf/tests/shell/base_probe: Enhance print_overall_results to print summary information

2024-10-15 Thread Athira Rajeev
> On 14 Oct 2024, at 9:10 PM, Athira Rajeev wrote: > > Currently print_overall_results prints the number of > fails in the summary, example from base_probe tests in > testsuite_probe: > > ## [ FAIL ] ## perf_probe :: test_invalid_options SUMMARY :: > 11 failures found > > test_invalid_option

Re: [PATCH v6 2/4] arch_topology: Support SMT control for OF based system

2024-10-15 Thread kernel test robot
-rc3 next-20241015] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in https://git-scm.com/docs/git-format-patch#_base_tree_information] url: https://github.com/intel-lab-lkp/linux/commits/Yicon

Re: [PATCH] tools/perf/tests/base_probe: Fix check for the count of existing probes in test_adding_kernel

2024-10-15 Thread Athira Rajeev
> On 14 Oct 2024, at 9:09 PM, Athira Rajeev wrote: > > perftool-testsuite_probe fails in test_adding_kernel as below: > Regexp not found: "probe:inode_permission_11" > -- [ FAIL ] -- perf_probe :: test_adding_kernel :: force-adding probes :: > second probe adding (with force) (output regexp pa

Re: [PATCH v6 2/4] arch_topology: Support SMT control for OF based system

2024-10-15 Thread kernel test robot
-rc3 next-20241015] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in https://git-scm.com/docs/git-format-patch#_base_tree_information] url: https://github.com/intel-lab-lkp/linux/commits/Yicon

[PATCH v6 2/5] modules: Support extended MODVERSIONS info

2024-10-15 Thread Matthew Maurer
Adds a new format for MODVERSIONS which stores each field in a separate ELF section. This initially adds support for variable length names, but could later be used to add additional fields to MODVERSIONS in a backwards compatible way if needed. Any new fields will be ignored by old user tooling, un

Re: [PATCH v5 14/16] modules: Support extended MODVERSIONS info

2024-10-15 Thread Matthew Maurer
So, the basic things I can think of to test here are: 1. The kernel can still load the previous MODVERSIONS format 2. The kernel can load the new MODVERSIONS format 3. If we artificially tweak a CRC in the previous format, it will fail to load. 4. If we artificially tweak a CRC in the new format,

Re: [PATCH v3 04/22] powerpc/cell: Switch to irq_get_nr_irqs()

2024-10-15 Thread Michael Ellerman
Bart Van Assche writes: > Use the irq_get_nr_irqs() function instead of the global variable > 'nr_irqs'. Prepare for changing 'nr_irqs' from an exported global > variable into a variable with file scope. > > Cc: linuxppc-dev@lists.ozlabs.org > Signed-off-by: Bart Van Assche > --- > arch/powerpc/

Re: [PATCH v5 7/8] execmem: add support for cache of large ROX pages

2024-10-15 Thread Luis Chamberlain
On Tue, Oct 15, 2024 at 08:54:29AM +0300, Mike Rapoport wrote: > On Mon, Oct 14, 2024 at 09:09:49PM -0700, Luis Chamberlain wrote: > > Mike, please run this with kmemleak enabled and running, and also try to get > > tools/testing/selftests/kmod/kmod.sh to pass. > > There was an issue with kmemleak

Re: [PATCH] tpm: ibmvtpm: Set TPM_OPS_AUTO_STARTUP flag on driver

2024-10-15 Thread Jarkko Sakkinen
On Wed Oct 16, 2024 at 12:15 AM EEST, Jarkko Sakkinen wrote: > On Mon Oct 14, 2024 at 5:16 PM EEST, Stefan Berger wrote: > > Set the TPM_OPS_AUTO_STARTUP on the driver so that the ibmvtpm driver now > > uses tpm2_auto_startup and tpm1_auto_startup like many other drivers do. > > Remove tpm_get_time

Re: [PATCH] tpm: ibmvtpm: Set TPM_OPS_AUTO_STARTUP flag on driver

2024-10-15 Thread Jarkko Sakkinen
On Mon Oct 14, 2024 at 5:16 PM EEST, Stefan Berger wrote: > Set the TPM_OPS_AUTO_STARTUP on the driver so that the ibmvtpm driver now > uses tpm2_auto_startup and tpm1_auto_startup like many other drivers do. > Remove tpm_get_timeouts, tpm2_get_cc_attrs_tbl, and tpm2_sessions_init > calls from it s