Re: [PATCH v3] KVM: PPC: Book3S HV: Fix L2 guest reboot failure due to empty 'arch_compat'

2024-02-06 Thread Michael Ellerman
Hi Amit, One comment below ... Amit Machhiwal writes: > Currently, rebooting a pseries nested qemu-kvm guest (L2) results in > below error as L1 qemu sends PVR value 'arch_compat' == 0 via > ppc_set_compat ioctl. This triggers a condition failure in > kvmppc_set_arch_compat() resulting in an EIN

[powerpc:fixes-test] BUILD SUCCESS 4a7aee96200ad281a5cc4cf5c7a2e2a49d2b97b0

2024-02-06 Thread kernel test robot
-001-20240206 gcc arc randconfig-002-20240206 gcc arc tb10x_defconfig gcc arm allmodconfig gcc arm allnoconfig clang arm allyesconfig gcc arm

[PATCH 0/4] PCI: Consolidate TLP Log reading and printing

2024-02-06 Thread Ilpo Järvinen
This series consolidates AER & DPC TLP Log handling code. Helpers are added for reading and printing the TLP Log and the format is made to include E-E Prefixes in both cases (previously only one DPC RP PIO displayed the E-E Prefixes). I'd appreciate if people familiar with ixgbe could check the er

[PATCH 1/4] PCI/AER: Cleanup register variable

2024-02-06 Thread Ilpo Järvinen
Use u32 for PCIe Capability register variable and name it aercc (Advanced Error Capabilities and Control register, PCIe r6.1 sec 7.8.4.7) instead of temp. Signed-off-by: Ilpo Järvinen --- drivers/pci/pcie/aer.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/pci

[PATCH 2/4] PCI: Generalize TLP Header Log reading

2024-02-06 Thread Ilpo Järvinen
Both AER and DPC RP PIO provide TLP Header Log registers (PCIe r6.1 secs 7.8.4 & 7.9.14) to convey error diagnostics but the struct is named after AER as the struct aer_header_log_regs. Also, not all places that handle TLP Header Log use the struct and the struct members are named individually. Ge

[PATCH 3/4] PCI: Add TLP Prefix reading into pcie_read_tlp_log()

2024-02-06 Thread Ilpo Järvinen
pcie_read_tlp_log() handles only 4 TLP Header Log DWORDs but TLP Prefix Log (PCIe r6.1 secs 7.8.4.12 & 7.9.14.13) may also be present. Generalize pcie_read_tlp_log() and struct pcie_tlp_log to handle also TLP Prefix Log. The layout of relevant registers in AER and DPC Capability is not identical b

[PATCH 4/4] PCI: Create helper to print TLP Header and Prefix Log

2024-02-06 Thread Ilpo Järvinen
Add pcie_print_tlp_log() helper to print TLP Header and Prefix Log. Print End-End Prefixes only if they are non-zero. Consolidate the few places which currently print TLP using custom formatting. Signed-off-by: Ilpo Järvinen --- drivers/net/ethernet/intel/ixgbe/ixgbe_main.c | 4 +-- drivers/pc

[PATCH v3 4/6] bitmap: Introduce bitmap_off()

2024-02-06 Thread Herve Codina
The bitmap_onto() function translates one bitmap relative to another but no function are present to perform the reverse translation. Introduce bitmap_off() to fill this hole. Signed-off-by: Herve Codina --- include/linux/bitmap.h | 3 +++ lib/bitmap.c | 42 +++

[PATCH v3 3/6] bitmap: Make bitmap_onto() available to users

2024-02-06 Thread Herve Codina
Currently the bitmap_onto() is available only for CONFIG_NUMA=y case, while some users may benefit out of it and being independent to NUMA code. Make it available to users by moving out of ifdeffery and exporting for modules. Signed-off-by: Herve Codina --- lib/bitmap.c | 3 ++- 1 file changed,

[PATCH v3 0/6] Add support for QMC HDLC

2024-02-06 Thread Herve Codina
Hi, This series introduces the QMC HDLC support. Patches were previously sent as part of a full feature series and were previously reviewed in that context: "Add support for QMC HDLC, framer infrastructure and PEF2256 framer" [1] In order to ease the merge, the full feature series has been split

[PATCH v3 5/6] net: wan: fsl_qmc_hdlc: Add runtime timeslots changes support

2024-02-06 Thread Herve Codina
QMC channels support runtime timeslots changes but nothing is done at the QMC HDLC driver to handle these changes. Use existing IFACE ioctl in order to configure the timeslots to use. Signed-off-by: Herve Codina Reviewed-by: Christophe Leroy Acked-by: Jakub Kicinski --- drivers/net/wan/fsl_qm

[PATCH v3 2/6] MAINTAINERS: Add the Freescale QMC HDLC driver entry

2024-02-06 Thread Herve Codina
After contributing the driver, add myself as the maintainer for the Freescale QMC HDLC driver. Signed-off-by: Herve Codina --- MAINTAINERS | 7 +++ 1 file changed, 7 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index 8d1052fa6a69..15cd3a8e5866 100644 --- a/MAINTAINERS +++ b/MAINTAIN

[PATCH v3 1/6] net: wan: Add support for QMC HDLC

2024-02-06 Thread Herve Codina
The QMC HDLC driver provides support for HDLC using the QMC (QUICC Multichannel Controller) to transfer the HDLC data. Signed-off-by: Herve Codina Reviewed-by: Christophe Leroy Acked-by: Jakub Kicinski --- drivers/net/wan/Kconfig| 12 + drivers/net/wan/Makefile | 1 + drivers/

[PATCH v3 6/6] net: wan: fsl_qmc_hdlc: Add framer support

2024-02-06 Thread Herve Codina
Add framer support in the fsl_qmc_hdlc driver in order to be able to signal carrier changes to the network stack based on the framer status Also use this framer to provide information related to the E1/T1 line interface on IF_GET_IFACE and configure the line interface according to IF_IFACE_{E1,T1}

[revert commit 9f079dda1433] [mainline] [6.8.0-rc3] [NVME] OOPS kernel crash while booting

2024-02-06 Thread Tasmiya Nalatwad
Greetings, [revert commit 9f079dda1433] [mainline] [6.8.0-rc3] [NVME] OOPS kernel crash while booting to kernel Reverting below commit fixes the problem commit 9f079dda14339ee87d864306a9dc8c6b4e4da40b     nvme: allow passthru cmd error logging --- Traces --- [   15.639835] BUG: Kernel NULL

Re: [PATCH v2 1/4] PCI/AER: Store more information in aer_err_info

2024-02-06 Thread Wang, Qingshun
On Mon, Feb 05, 2024 at 05:12:31PM -0600, Bjorn Helgaas wrote: > On Thu, Jan 25, 2024 at 02:27:59PM +0800, Wang, Qingshun wrote: > > When Advisory Non-Fatal errors are raised, both correctable and > > uncorrectable error statuses will be set. The current kernel code cannot > > store both statuses a

Re: [PATCH v2 2/4] PCI/AER: Handle Advisory Non-Fatal properly

2024-02-06 Thread Wang, Qingshun
On Mon, Feb 05, 2024 at 05:26:16PM -0600, Bjorn Helgaas wrote: > In the subject, "properly" really doesn't convey information. I think > this patch does two things: > > - Prints error bits that might be ANFE > - Clears UNCOR_STATUS bits that were previously not cleared > > Maybe the subject

Re: [PATCH v2 1/4] PCI/AER: Store more information in aer_err_info

2024-02-06 Thread Bjorn Helgaas
On Wed, Feb 07, 2024 at 12:41:41AM +0800, Wang, Qingshun wrote: > On Mon, Feb 05, 2024 at 05:12:31PM -0600, Bjorn Helgaas wrote: > > On Thu, Jan 25, 2024 at 02:27:59PM +0800, Wang, Qingshun wrote: > > > When Advisory Non-Fatal errors are raised, both correctable and > > > uncorrectable error status

Re: [revert commit 9f079dda1433] [mainline] [6.8.0-rc3] [NVME] OOPS kernel crash while booting

2024-02-06 Thread Keith Busch
On Tue, Feb 06, 2024 at 10:05:20PM +0530, Tasmiya Nalatwad wrote: > Greetings, > > [revert commit 9f079dda1433] [mainline] [6.8.0-rc3] [NVME] OOPS kernel crash > while booting to kernel > > Reverting below commit fixes the problem > > commit 9f079dda14339ee87d864306a9dc8c6b4e4da40b >     nvme: a

Re: [PATCH] perf/pmu-events/powerpc: Update json mapfile with Power11 PVR

2024-02-06 Thread Namhyung Kim
On Mon, 29 Jan 2024 17:38:55 +0530, Madhavan Srinivasan wrote: > Update the Power11 PVR to json mapfile to enable > json events. Power11 is PowerISA v3.1 compliant > and support Power10 events. > > Applied to perf-tools-next, thanks! Best regards, -- Namhyung Kim

Re: [PATCH 1/5] sched/vtime: remove confusing arch_vtime_task_switch() declaration

2024-02-06 Thread Frederic Weisbecker
Le Sun, Jan 28, 2024 at 08:58:50PM +0100, Alexander Gordeev a écrit : > Callback arch_vtime_task_switch() is only defined when > CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is selected. Yet, the > function prototype forward declaration is present for > CONFIG_VIRT_CPU_ACCOUNTING_GEN variant. Remove it. > >

Re: [PATCH v2 2/4] eventfd: simplify eventfd_signal()

2024-02-06 Thread Stefan Hajnoczi
vhost and VIRTIO-related parts: Reviewed-by: Stefan Hajnoczi On Wed, 22 Nov 2023 at 07:50, Christian Brauner wrote: > > Ever since the evenfd type was introduced back in 2007 in commit > e1ad7468c77d ("signal/timer/event: eventfd core") the eventfd_signal() > function only ever passed 1 as a va

Re: [PATCH 2/5] sched/vtime: get rid of generic vtime_task_switch() implementation

2024-02-06 Thread Frederic Weisbecker
Le Sun, Jan 28, 2024 at 08:58:51PM +0100, Alexander Gordeev a écrit : > The generic vtime_task_switch() implementation gets built only > if __ARCH_HAS_VTIME_TASK_SWITCH is not defined, but requires an > architecture to implement arch_vtime_task_switch() callback at > the same time, which is confusi

Re: [PATCH 3/5] s390/vtime: remove unused __ARCH_HAS_VTIME_TASK_SWITCH leftover

2024-02-06 Thread Frederic Weisbecker
Le Sun, Jan 28, 2024 at 08:58:52PM +0100, Alexander Gordeev a écrit : > __ARCH_HAS_VTIME_TASK_SWITCH macro is not used anymore. > > Signed-off-by: Alexander Gordeev Reviewed-by: Frederic Weisbecker > --- > arch/s390/include/asm/vtime.h | 2 -- > 1 file changed, 2 deletions(-) > > diff --git

Re: [PATCH 5/5] sched/vtime: do not include header

2024-02-06 Thread Frederic Weisbecker
Le Sun, Jan 28, 2024 at 08:58:54PM +0100, Alexander Gordeev a écrit : > There is no architecture-specific code or data left > that generic needs to know about. > Thus, avoid the inclusion of header. > > Signed-off-by: Alexander Gordeev Reviewed-by: Frederic Weisbecker

Re: [PATCH v2 1/2] powerpc: Add Power11 architected and raw mode

2024-02-06 Thread Michael Ellerman
Madhavan Srinivasan writes: > On 2/5/24 2:13 PM, Aneesh Kumar K.V wrote: >> Madhavan Srinivasan writes: >> >>> reg.h is updated with Power11 pvr. pvr_mask value of 0x0F07 >>> means we are arch v3.1 compliant. ... >>> diff --git a/arch/powerpc/kernel/cpu_setup_power.c >>> b/arch/powerpc/kerne

[PATCH] drivers/ps3: select VIDEO to provide cmdline functions

2024-02-06 Thread Randy Dunlap
When VIDEO is not set, there is a build error. Fix that by selecting VIDEO for PS3_PS3AV. ERROR: modpost: ".video_get_options" [drivers/ps3/ps3av_mod.ko] undefined! Fixes: dae7fbf43fd0 ("driver/ps3: Include for mode parsing") Signed-off-by: Randy Dunlap Cc: Michael Ellerman Cc: Nicholas Piggin

[PATCH 2/2] powerpc/pseries: Set CPU_FTR_DBELL according to ibm,pi-features

2024-02-06 Thread Nicholas Piggin
PAPR will define a new ibm,pi-features bit which says that doorbells should not be used even on architectures where they exist. This could be because they are emulated and slower than using the interrupt controller directly for IPIs. Wire this bit into the pi-features parser to clear CPU_FTR_DBELL

[PATCH 1/2] powerpc/pseries: Add a clear modifier to ibm,pa/pi-features parser

2024-02-06 Thread Nicholas Piggin
When a new ibm,pa/pi-features bit is introduced that is intended to apply to existing systems and features, it may have an "inverted" meaning (i.e., bit clear => feature available; bit set => unavailable). Depending on the nature of the feature, this may give the best backward compatibility result

Re: Re: [PATCH v3] KVM: PPC: Book3S HV: Fix L2 guest reboot failure due to empty 'arch_compat'

2024-02-06 Thread Amit Machhiwal
Hi Michael, Thanks for looking into the patch and your comments. On 2024/02/06 09:09 PM, Michael Ellerman wrote: > Hi Amit, > > One comment below ... > > Amit Machhiwal writes: > > Currently, rebooting a pseries nested qemu-kvm guest (L2) results in > > below error as L1 qemu sends PVR value '

[PATCH v4] KVM: PPC: Book3S HV: Fix L2 guest reboot failure due to empty 'arch_compat'

2024-02-06 Thread Amit Machhiwal
Currently, rebooting a pseries nested qemu-kvm guest (L2) results in below error as L1 qemu sends PVR value 'arch_compat' == 0 via ppc_set_compat ioctl. This triggers a condition failure in kvmppc_set_arch_compat() resulting in an EINVAL. qemu-system-ppc64: Unable to set CPU compatibility mode in

[PATCH v4 5/5] sched: rename SD_SHARE_PKG_RESOURCES to SD_SHARE_LLC

2024-02-06 Thread alexs
From: Alex Shi SD_CLUSTER shares the CPU resources like llc tags or l2 cache, that's easy confuse with SD_SHARE_PKG_RESOURCES. So let's specifical point what the latter shares: LLC. That would reduce some confusing. Suggested-by: Valentin Schneider Signed-off-by: Alex Shi To: linux-ker...@vger

Re: [PATCH] drivers/ps3: select VIDEO to provide cmdline functions

2024-02-06 Thread Geoff Levand
Hi, On 2/7/24 12:37, Randy Dunlap wrote: > When VIDEO is not set, there is a build error. Fix that by selecting > VIDEO for PS3_PS3AV. > > ERROR: modpost: ".video_get_options" [drivers/ps3/ps3av_mod.ko] undefined! > > Fixes: dae7fbf43fd0 ("driver/ps3: Include for mode parsing") > Signed-off-by:

Re: [revert commit 9f079dda1433] [mainline] [6.8.0-rc3] [NVME] OOPS kernel crash while booting

2024-02-06 Thread Tasmiya Nalatwad
Thanks Keith for the patch. I have tested the patch without reverting old commits. The patch fixes the issue. Tested-by: Tasmiya Nalatwad On 2/6/24 23:22, Keith Busch wrote: On Tue, Feb 06, 2024 at 10:05:20PM +0530, Tasmiya Nalatwad wrote: Greetings, [revert commit 9f079dda1433] [mainline]

Re: [kvm-unit-tests PATCH v2 2/9] arch-run: Clean up temporary files properly

2024-02-06 Thread Thomas Huth
On 02/02/2024 07.57, Nicholas Piggin wrote: Migration files weren't being removed when tests were interrupted. This improves the situation. Signed-off-by: Nicholas Piggin --- scripts/arch-run.bash | 12 +++- 1 file changed, 7 insertions(+), 5 deletions(-) diff --git a/scripts/arch-r