Commit ddb5cdbafaaa ("kbuild: generate KSYMTAB entries by modpost")
deprecated , which is now a wrapper of .
Replace #include with #include .
After all the lines are converted, and
will be removed.
Signed-off-by: Masahiro Yamada
---
arch/powerpc/kernel/epapr_hcalls.S | 2 +-
arch/pow
There is no EXPORT_SYMBOL line there, hence #include
is unneeded.
Signed-off-by: Masahiro Yamada
---
arch/powerpc/kernel/entry_32.S | 1 -
arch/powerpc/kernel/head_40x.S | 1 -
arch/powerpc/kernel/head_44x.S | 1 -
arch/powerpc/kernel/head_64.S
All *.S files under arch/powerpc/ have been converted to include
instead of .
Remove .
Signed-off-by: Masahiro Yamada
---
arch/powerpc/include/asm/Kbuild | 1 -
1 file changed, 1 deletion(-)
diff --git a/arch/powerpc/include/asm/Kbuild b/arch/powerpc/include/asm/Kbuild
index 419319c4963c..61
On Fri, Aug 04, 2023 at 03:30:20PM +0200, Christophe Leroy wrote:
> cpm_dpxxx() macros are now always referring to cpm_muram_xxx() fonctions
nit: fonctions -> functions
Thanks Christophe,
This minor nit notwithstanding, this series looks good to me.
I'll send a reviewed-by tag for the whole seri
On Fri, Aug 04, 2023 at 03:30:10PM +0200, Christophe Leroy wrote:
> Over the years, platform and driver initialisation have evolved into
> more generic ways, and driver or platform specific stuff has gone
> away, leaving stale objects behind.
>
> This series aims at cleaning all that up for fs_ene
On Fri, Aug 04, 2023 at 04:05:09PM +, Christophe Leroy wrote:
> Hello,
>
> Le 20/07/2023 à 12:17, zhangyongle...@208suo.com a écrit :
> > [Vous ne recevez pas souvent de courriers de zhangyongle...@208suo.com.
> > D?couvrez pourquoi ceci est important ?
> > https://aka.ms/LearnAboutSenderIde
From: "Dr. David Alan Gilbert"
PowerPC has a 'btext' font used for the console which is almost identical
to the shared font_sun8x16, so use it rather than duplicating the data.
They were actually identical until about a decade ago when
commit bcfbeecea11c ("drivers: console: font_: Change a g
A nested-HV API for PAPR has been developed based on the KVM-specific
nested-HV API that is upstream in Linux/KVM and QEMU. The PAPR API had
to break compatibility to accommodate implementation in other
hypervisors and partitioning firmware. The existing KVM-specific API
will be known as the Nested
There are already some getter and setter functions used for accessing
vcpu register state, e.g. kvmppc_get_pc(). There are also more
complicated examples that are generated by macros like
kvmppc_get_sprg0() which are generated by the SHARED_SPRNG_WRAPPER()
macro.
In the new PAPR "Nestedv2" API for
More "wrapper" style accessor generating macros will be introduced for
the nestedv2 guest support. Rename the existing macros with more
descriptive names now so there is a consistent naming convention.
Signed-off-by: Jordan Niethe
---
v3:
- New to series
---
arch/powerpc/include/asm/kvm_ppc.h
The PAPR "Nestedv2" guest API introduces the concept of a Guest State
Buffer for communication about L2 guests between L1 and L0 hosts.
In the new API, the L0 manages the L2 on behalf of the L1. This means
that if the L1 needs to change L2 state (e.g. GPRs, SPRs, partition
table...), it must reque
The LPID register is 32 bits long. The host keeps the lpids for each
guest in an unsigned word struct kvm_arch. Currently, LPIDs are already
limited by mmu_lpid_bits and KVM_MAX_NESTED_GUESTS_SHIFT.
The nestedv2 API returns a 64 bit "Guest ID" to be used be the L1 host
for each L2 guest. This valu
A series of hcalls have been added to the PAPR which allow a regular
guest partition to create and manage guest partitions of its own. KVM
already had an interface that allowed this on powernv platforms. This
existing interface will now be called "nestedv1". The newly added PAPR
interface will be c
From: Michael Neuling
Document support for nested KVM on POWER using the existing API as well
as the new PAPR API. This includes the new HCALL interface and how it
used by KVM.
Signed-off-by: Michael Neuling
Signed-off-by: Jordan Niethe
---
v2:
- Separated into individual patch
v3:
- Fix t
On 2023/8/6 11:55, Hugh Dickins wrote:
On Thu, 3 Aug 2023, Qi Zheng wrote:
On 2023/7/12 12:42, Hugh Dickins wrote:
Bring collapse_and_free_pmd() back into collapse_pte_mapped_thp().
It does need mmap_read_lock(), but it does not need mmap_write_lock(),
nor vma_start_write() nor i_mmap lock n
PCI core add pci_find_next_dvsec_capability() to query the next DVSEC.
We can use that core API to simplify the code. Also remove the unused
macros.
Signed-off-by: Xiongfeng Wang
---
arch/powerpc/platforms/powernv/ocxl.c | 20 ++--
drivers/misc/ocxl/config.c| 21 +
Some devices may have several DVSEC(Designated Vendor-Specific Extended
Capability) entries with the same DVSEC ID. Add
pci_find_next_dvsec_capability() to find them all.
Signed-off-by: Xiongfeng Wang
---
drivers/pci/pci.c | 37 +
include/linux/pci.h | 2 ++
Some devices may have several DVSEC(Designated Vendor-Specific Extended
Capability) entries with the same DVSEC ID. Introduce
pci_find_next_dvsec_capability() to simplify the code.
Xiongfeng Wang (2):
PCI: Add pci_find_next_dvsec_capability to find next designated VSEC
ocxl: use pci_find_next_
On Fri, 2023-08-04 at 15:56 +0800, Xiongfeng Wang wrote:
> PCI core add pci_find_vsec_capability() to query VSEC. We can use
> that
> core API to simplify the code.
>
> The only logical change is that pci_find_vsec_capability check the
> Vendor ID before finding the VSEC.
>
> PCI spec rev 5.0 say
On Mon, 2023-08-07 at 11:18 +0800, Xiongfeng Wang wrote:
> Some devices may have several DVSEC(Designated Vendor-Specific
> Extended
> Capability) entries with the same DVSEC ID. Add
> pci_find_next_dvsec_capability() to find them all.
>
> Signed-off-by: Xiongfeng Wang
>
Reviewed-by: Andrew Don
Testcase "Parsing of all PMU events from sysfs" parse events for
all PMUs, and not just cpu. In case of powerpc, the PowerVM
environment supports events from hv_24x7 and hv_gpci PMU which
is of example format like below:
- hv_24x7/CPM_ADJUNCT_INST,domain=?,core=?/
- hv_gpci/event,partition_id=?/
The test "BPF prologue generation" fails as below:
Writing event: p:perf_bpf_probe/func _text+10423200 f_mode=+20(%gpr3):x32
offset=%gpr4:s64 orig=%gpr5:s32
In map_prologue, ntevs=1
mapping[0]=0
libbpf: prog 'bpf_func__null_lseek': BPF program load failed: Permission
denied
libbpf
On Mon, 2023-08-07 at 11:18 +0800, Xiongfeng Wang wrote:
> PCI core add pci_find_next_dvsec_capability() to query the next
> DVSEC.
> We can use that core API to simplify the code. Also remove the unused
> macros.
>
> Signed-off-by: Xiongfeng Wang
Reviewed-by: Andrew Donnellan
--
Andrew Donn
On Thu, Aug 03, 2023 at 12:52:50PM +0530, Athira Rajeev wrote:
>
>
> > On 03-Aug-2023, at 8:33 AM, Aditya Gupta wrote:
> >
> > Hi Arnaldo,
> > I am working on a patch for 'perf version --has', and will send a patch next
>
> Hi Aditya,
>
> I believe, it will be “perf build —has” option. And no
> On 07-Aug-2023, at 10:22 AM, Athira Rajeev
> wrote:
>
> The test "BPF prologue generation" fails as below:
>
> Writing event: p:perf_bpf_probe/func _text+10423200 f_mode=+20(%gpr3):x32
> offset=%gpr4:s64 orig=%gpr5:s32
> In map_prologue, ntevs=1
> mapping[0]=0
> libbpf: prog 'bpf_
> On 07-Aug-2023, at 10:20 AM, Athira Rajeev
> wrote:
>
> Testcase "Parsing of all PMU events from sysfs" parse events for
> all PMUs, and not just cpu. In case of powerpc, the PowerVM
> environment supports events from hv_24x7 and hv_gpci PMU which
> is of example format like below:
>
> - h
rtas_generic_errno() function will convert the generic rtas return codes
into errno. Also, #define descriptive names for rtas return codes and use
it instead of numeric values.
Signed-off-by: Mahesh Salgaonkar
---
(no changes since v7)
Change in V7:
- Until v6 there was only one patch with subj
When certain PHB HW failure causes pHyp to recover PHB, it marks the PE
state as temporarily unavailable until recovery is complete. This also
triggers an EEH handler in Linux which needs to notify drivers, and perform
recovery. But before notifying the driver about the PCI error it uses
get_adapte
28 matches
Mail list logo