When a PCI error is encountered 6th time in an hour we
set the channel state to perm_failure and notify the
driver about the permanent failure.
However, after upstream commit 38ddc011478e ("powerpc/eeh:
Make permanently failed devices non-actionable"), EEH handler
stops calling any routine once th
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
From: Nicholas Piggin
[ Upstream commit c28548012ee2bac55772ef7685138bd1124b80c3 ]
Interrupt entry sets the soft mask to IRQS_ALL_DISABLED to match the
hard irq disabled state. So when should_hard_irq_enable() returns true
because we want PMI interrupts in irq handlers, MSR[EE] is enabled but
PM
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
From: Sathvika Vasireddy
[ Upstream commit 8afffce6aa3bddc940ac1909627ff1e772b6cbf1 ]
objtool throws the following warning:
arch/powerpc/kernel/head_85xx.o: warning: objtool: .head.text+0x1a6c:
unannotated intra-function call
Fix the warning by annotating KernelSPE symbol with SYM_FUNC_STAR
From: Sathvika Vasireddy
[ Upstream commit fe6de81b610e5d0b9d2231acff2de74a35482e7d ]
objtool throws the following warning:
arch/powerpc/kvm/booke.o: warning: objtool: kvmppc_fill_pt_regs+0x30:
unannotated intra-function call
Fix the warning by setting the value of 'nip' using the _THIS_IP_
yes, it is more about sort the list using .data and .compatible. key
much better if it we keep this as suggested by Frank,
static const struct of_device_id ls_pcie_ep_of_match[] = {
+ { .compatible = "fsl,ls1028a-pcie-ep", .data = &ls1_ep_drvdata },
{ .compatible = "fsl,ls1046a-pc
In fb_get_options(), always duplicate the returned option string and
transfer ownership of the memory to the function's caller.
Until now, only the global option string got duplicated and transferred
to the caller; the per-driver options were owned by fb_get_options().
In the end, it was impossibl
The kernel's video= option sets the initial video mode. It is shared
by fbdev and DRM, but located within the fbdev code. Move it to
drivers/video/ and adapt callers. Allows DRM (and others) to use the
option without depending on fbdev.
While at it, fix the interface of the lookup functions. This
Fix Daniel's email address. No functional changes.
Signed-off-by: Thomas Zimmermann
Cc: Daniel Vetter
---
drivers/video/fbdev/core/fb_cmdline.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/video/fbdev/core/fb_cmdline.c
b/drivers/video/fbdev/core/fb_cmdline.c
inde
Include in ps3av.c to get video_get_options() and
avoid the dependency on . The replaced function
fb_get_options() is just a tiny wrapper around video_get_opions(). No
functional changes.
Signed-off-by: Thomas Zimmermann
---
drivers/ps3/ps3av.c | 18 ++
1 file changed, 6 inserti
Get the kernel's global video= parameter with fb_get_option(). Done
to unexport the internal fbdev state fb_mode_config. No functional
changes.
Signed-off-by: Thomas Zimmermann
---
drivers/ps3/ps3av.c | 11 +--
1 file changed, 9 insertions(+), 2 deletions(-)
diff --git a/drivers/ps3/ps3
Move the lookup of the option string into an internal helper. No
functional changes.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/core/fb_cmdline.c | 60 ---
1 file changed, 36 insertions(+), 24 deletions(-)
diff --git a/drivers/video/fbdev/core/fb_cmdline.c
Handle the command-line parameter video= in video/cmdline.c. Implement
the fbdev helper fb_get_options() on top. Will allows to handle the
kernel parameter in DRM without fbdev dependencies.
Note that __video_get_options() has the meaning of its return value
inverted compared to fb_get_options().
Ignore the per-driver video options if no driver name has been
specified to fb_get_option(). Return the global options in this
case.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/core/fb_cmdline.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/video/
There are no external users of fb_mode_option. Unexport the variable
and declare it static.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/core/fb_cmdline.c | 4 +---
include/linux/fb.h| 1 -
2 files changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/vide
Get the kernel's global video= parameter with fb_get_option(). Done
to unexport the internal fbdev state fb_mode_config. No functional
changes.
Signed-off-by: Thomas Zimmermann
---
drivers/video/fbdev/core/modedb.c | 8 ++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/drive
Do not claim that there's a default mode in the video= option parser.
if no option string has been given, the parser does nothing.
Signed-off-by: Thomas Zimmermann
---
drivers/gpu/drm/drm_modes.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/drm_modes.c b/
Include in drm_connector.c to get video_get_options()
and avoid the dependency on . The replaced function
fb_get_options() is just a tiny wrapper around video_get_opions(). No
functional changes.
Include to get fwnode_handle_put(), which had been
provided via .
Signed-off-by: Thomas Zimmermann
Correct many spelling errors in Documentation/ as reported by codespell.
Maintainers of specific kernel subsystems are only Cc-ed on their
respective patches, not the entire series.
These patches are based on linux-next-20230209.
[PATCH 01/24] Documentation: arm: correct spelling
[PATCH 02
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> Do not imply that some of the generic headers may be always included.
> Instead, include explicitly what we are direct user of.
>
> While at it, split out the GPIO group of headers.
>
> Signed-off-by: Andy Shevchenko
Reviewed-by: Linus Wal
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> The struct fwnode_handle pointer is used in both branches of ifdeffery,
> no need to have a copy of the same in each of them, just make it global.
>
> Signed-off-by: Andy Shevchenko
Reviewed-by: Linus Walleij
Yours,
Linus Walleij
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> For better maintenance group the forward declarations together.
>
> Signed-off-by: Andy Shevchenko
Reviewed-by: Linus Walleij
Yours,
Linus Walleij
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> Do not imply that some of the generic headers may be always included.
> Instead, include explicitly what we are direct user of.
>
> While at it, drop unused linux/gpio.h and split out the GPIO group of
> headers.
>
> Signed-off-by: Andy Shev
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> Do not imply that some of the generic headers may be always included.
> Instead, include explicitly what we are direct user of.
>
> While at it, split out the GPIO group of headers.
>
> Signed-off-by: Andy Shevchenko
Reviewed-by: Linus Wal
On Wed, Feb 8, 2023 at 6:34 PM Andy Shevchenko
wrote:
> There is a few things done:
> - include only the headers we are direct user of
> - when pointer is in use, provide a forward declaration
> - add missing headers
> - group generic headers and subsystem headers
> - sort each group alphabetical
On Wed, Feb 8, 2023 at 6:39 PM Krzysztof Kozlowski
wrote:
> On 08/02/2023 18:33, Andy Shevchenko wrote:
> > From: Linus Walleij
> >
> > The file s3c64xx.c is including despite using no
> > symbols from the file, however it needs it to implicitly bring in
> > of_have_populated_dt() so include e
On 2/8/23 11:03 PM, Andy Shevchenko wrote:
> From: Linus Walleij
>
> The test driver uses the gpiod consumer API so include the right
> header. This may cause a problem with
> struct of_device_id being implcitly pulled in by the legacy
> header so include
> explicitly as well.
>
> While at it
From: Xiaowei Bao
Add PCIe EP mode support for ls1028a.
Signed-off-by: Xiaowei Bao
Signed-off-by: Hou Zhiqiang
Signed-off-by: Frank Li
Acked-by: Roy Zang
---
Change from v2 to v3
order by .compatible
Change from v2 to v2
Added
Signed-off-by: Frank Li
Acked-by: Roy Zang
All other patc
>
> Caution: EXT Email
>
> yes, it is more about sort the list using .data and .compatible. key
>
> much better if it we keep this as suggested by Frank,
>
> static const struct of_device_id ls_pcie_ep_of_match[] = {
> + { .compatible = "fsl,ls1028a-pcie-ep", .data = &ls1_ep_drvdata },
On 2/7/23 9:14 AM, Nathan Lynch wrote:
>
> (cc'ing a few possibly interested people)
>
> Brian King writes:
>> While testing fixes to the hvcs hotplug code, kmemleak was reporting
>> potential memory leaks. This was tracked down to the struct device_node
>> object associated with the hvcs device
Brian King writes:
> On 2/7/23 9:14 AM, Nathan Lynch wrote:
>> Brian King writes:
>>> While testing fixes to the hvcs hotplug code, kmemleak was reporting
>>> potential memory leaks. This was tracked down to the struct device_node
>>> object associated with the hvcs device. Looking at the leaked
On 2/9/23 11:11 AM, Nathan Lynch wrote:
> Brian King writes:
>> On 2/7/23 9:14 AM, Nathan Lynch wrote:
>>> Brian King writes:
While testing fixes to the hvcs hotplug code, kmemleak was reporting
potential memory leaks. This was tracked down to the struct device_node
object associat
> On 9 Feb 2023, at 10:14 am, Rohan McLure wrote:
>
>
>
>> On 8 Feb 2023, at 11:23 pm, Christophe Leroy
>> wrote:
>>
>>
>>
>> Le 08/02/2023 à 04:21, Rohan McLure a écrit :
>>> KCSAN instruments calls to atomic builtins, and will in turn call these
>>> builtins itself. As such, architect
On Thu, 2023-02-09 at 07:15 +, Christophe Leroy wrote:
> > +static inline int patch_uint(u32 *addr, unsigned int val)
> > +{
> > + return patch_instruction(addr, ppc_inst(val));
>
> Would it make more sense that patch_instruction() calls patch_uint()
> instead of the reverse ?
>
That'
Geoff Levand writes:
> On 1/16/23 23:26, Christophe Leroy wrote:
>> Le 16/01/2023 à 21:08, Geoff Levand a écrit :
>>>
>>> As mentioned, I'd really like to keep PS3 included in ppc64_defconfig. My
>>> original patch that basically just ignores the call to
>>> mmu_hash_ops.updateboltedpp allows tha
On Wed, Feb 08, 2023 at 07:33:33PM +0200, Andy Shevchenko wrote:
> From: Arnd Bergmann
>
> gpio_set_debounce() only has a single user, which is trivially
> converted to gpiod_set_debounce().
>
> Signed-off-by: Arnd Bergmann
> Reviewed-by: Linus Walleij
> Reviewed-by: Andy Shevchenko
> Signed-
-a016
x86_64 rhel-8.3-syz
x86_64 rhel-8.3-kunit
i386 randconfig-a005
x86_64 rhel-8.3-kvm
arc randconfig-r043-20230209
arm randconfig-r046-20230209
x86_64
Hi all,
After merging the powerpc tree, today's linux-next build (powerpc64
allnoconfig) failed like this:
arch/powerpc/kernel/setup_64.c: In function 'early_setup':
arch/powerpc/kernel/setup_64.c:400:34: error: 'struct thread_info' has no
member named 'cpu'
400 | task_thread_info(curr
David Hildenbrand writes:
> We already implemented support for 64bit book3s in commit bff9beaa2e80
> ("powerpc/pgtable: support __HAVE_ARCH_PTE_SWP_EXCLUSIVE for book3s")
>
> Let's support __HAVE_ARCH_PTE_SWP_EXCLUSIVE also in 32bit by reusing yet
> unused LSB 2 / MSB 29. There seems to be no real
Nathan Lynch writes:
> Michael Ellerman writes:
>> Nathan Lynch via B4 Submission Endpoint
>> writes:
>>> From: Nathan Lynch
>>>
>>> Some code that runs early in boot calls RTAS functions that can return
>>> -2 or 990x statuses, which mean the caller should retry. An example is
>>> pSeries_cmo
Nathan Lynch writes:
> Michael Ellerman writes:
>> Nathan Lynch via B4 Submission Endpoint
>> writes:
...
>>> +struct rtas_work_area * __ref rtas_work_area_alloc(size_t size)
>>> +{
>>> + struct rtas_work_area *area;
>>> + unsigned long addr;
>>> +
>>> + might_sleep();
>>> +
>>> + WARN_O
50 matches
Mail list logo