Replacing kmalloc/kfree/dma_map_single/dma_unmap_single()
with dma_alloc_coherent/dma_free_coherent() helps to reduce
code size, and simplify the code, and coherent DMA will not
clear the cache every time.
Signed-off-by: Cai Huoqing
---
v1->v2: Remove extra change in Kconfig
drivers/net/etherne
Commit b56cd05c55a1 ("x86/mm: Rename is_kernel_text to __is_kernel_text"),
add '__' prefix not to get in conflict with existing is_kernel_text() in
.
We will add __is_kernel_text() for the basic kernel text range check in the
next patch, so use private is_x86_32_kernel_text() naming for x86 specia
After commit 4ba66a976072 ("arch: remove blackfin port"),
no need arch-specific text/data check.
Cc: Arnd Bergmann
Signed-off-by: Kefeng Wang
---
include/asm-generic/sections.h | 16
include/linux/kallsyms.h | 3 +--
kernel/locking/lockdep.c | 3 ---
3 files chang
The is_kernel_inittext/is_kernel_text/is_kernel function should not
include the end address(the labels _einittext, _etext and _end) when
check the address range, the issue exists since Linux v2.6.12.
Cc: Arnd Bergmann
Cc: Sergey Senozhatsky
Cc: Petr Mladek
Reviewed-by: Petr Mladek
Reviewed-by:
There are three head files(kallsyms.h, kernel.h and sections.h) which
include the kernel sections range check, let's make some cleanup and
unify them.
1. cleanup arch specific text/data check and fix address boundary check
in kallsyms.h
2. make all the basic/core kernel range check function int
Directly use is_kernel() helper in kernel_or_module_addr().
Cc: Andrey Ryabinin
Cc: Alexander Potapenko
Cc: Andrey Konovalov
Cc: Dmitry Vyukov
Signed-off-by: Kefeng Wang
---
mm/kasan/report.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mm/kasan/report.c b/mm/kasan/rep
The core_kernel_text() should check the gate area, as it is part
of kernel text range.
Cc: Steven Rostedt
Signed-off-by: Kefeng Wang
---
kernel/extable.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/kernel/extable.c b/kernel/extable.c
index 98ca627ac5ef..0ba383d850ff 10
Use is_kernel_text() and is_kernel_inittext() helper to simplify code,
also drop etext, _stext, _sinittext, _einittext declaration which
already declared in section.h.
Cc: Michael Ellerman
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: linuxppc-dev@lists.ozlabs.org
Signed-off-by: Kefeng Wang
An internal __is_kernel() helper which only check the kernel address ranges,
and an internal __is_kernel_text() helper which only check text section ranges.
Signed-off-by: Kefeng Wang
---
include/asm-generic/sections.h | 29 +
include/linux/kallsyms.h | 4 ++--
Move core_kernel_data() into sections.h and rename it to
is_kernel_core_data(), also make it return bool value, then
update all the callers.
Cc: Arnd Bergmann
Cc: Steven Rostedt
Cc: Ingo Molnar
Cc: "David S. Miller"
Signed-off-by: Kefeng Wang
---
include/asm-generic/sections.h | 16 +
The is_kernel_inittext() and init_kernel_text() are with same
functionality, let's just keep is_kernel_inittext() and move
it into sections.h, then update all the callers.
Cc: Ingo Molnar
Cc: Thomas Gleixner
Cc: Arnd Bergmann
Cc: x...@kernel.org
Signed-off-by: Kefeng Wang
---
arch/x86/kernel/
On 2021/9/26 10:51, Xiaoming Ni wrote:
When CONFIG_SMP=y, timebase synchronization is required when the second
kernel is started.
arch/powerpc/kernel/smp.c:
int __cpu_up(unsigned int cpu, struct task_struct *tidle)
{
...
if (smp_ops->give_
Hi Sven,
Thanks a lot for your nice explanation of the history of the PASemi i2c
driver.
We are using Nemo boards with 64-bit dual-core PWRficient PA6T-1682M
CPUs (A-EON AmigaOne X1000). [1]
The RC2 of kernel 5.15 works without any problems on our Nemo boards. [2]
Could you please post all
Hi,
This series adds support for the I2C controller found on Apple Silicon Macs
which has quite a bit of history:
Apple bought P.A. Semi in 2008 and it looks like a part of its legacy continues
to live on in the M1. This controller has actually been used since at least the
iPhone 4S and hasn't ch
Some later revisions after the original PASemi I2C controller introduce
what likely is an enable bit to the CTL register. Without setting it the
actual i2c transmission is never started.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi-core.c | 8
drivers/i2c/busses/i2c-pasem
Split out common reset call to its own function so that we
can later add support for selecting the clock frequency
and an additional enable bit found in newer revisions.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi-core.c | 15 +--
1 file changed, 9 insertions(+), 6 de
Split off the PCI driver so that we can reuse common code for the
platform driver.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/Makefile | 1 +
.../{i2c-pasemi.c => i2c-pasemi-core.c} | 88 +
drivers/i2c/busses/i2c-pasemi-core.h | 19
dr
With all the previous preparations we can now finally add
the platform driver to support the PASemi-based controllers
in Apple SoCs. This does not work on the M1 yet but should
work on the early iPhones already.
Signed-off-by: Sven Peter
---
MAINTAINERS | 1 +
drivers
Split off common probing code that will be used by both the PCI and the
platform device.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi.c | 39 +
1 file changed, 25 insertions(+), 14 deletions(-)
diff --git a/drivers/i2c/busses/i2c-pasemi.c b/drivers
Using managed device resources means there's nothing left to be done in
pasemi_smb_pci_remove and also allows to remove base and size from
struct pasemi_smbus.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi-core.c | 10 +++
drivers/i2c/busses/i2c-pasemi-core.h | 2 --
drivers/i
In preparation for splitting this driver up into a platform_driver
and a pci_driver, replace outl/inl usage with ioport_map and
ioread32/iowrite32.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi.c | 16 +---
1 file changed, 13 insertions(+), 3 deletions(-)
diff --git a/
Prepare to create a platform driver by removing all usages of pci_dev we
can.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/i2c/busses/i2c-pasemi.c b/drivers/i2c/busses/i2c-pasemi.c
index dd3
The Apple I2C controller is based on the PASemi I2C controller.
It is present on Apple SoCs such as the M1.
Signed-off-by: Sven Peter
---
.../devicetree/bindings/i2c/apple,i2c.yaml| 61 +++
MAINTAINERS | 1 +
2 files changed, 62 insertions(+
Right now the bus frequency has always been hardcoded as
100 KHz with the specific reference clock used in the PASemi
PCI controllers. Make this configurable to prepare for the
platform driver.
Signed-off-by: Sven Peter
---
drivers/i2c/busses/i2c-pasemi-core.c | 8 +++-
drivers/i2c/busses/i2
Hi Sven,
I can't apply your patch 5 (i2c: pasemi: Split pci driver to its own
file). [1]
Error message:
patching file b/drivers/i2c/busses/i2c-pasemi-core.c (renamed from
a/drivers/i2c/busses/i2c-pasemi.c)
Hunk #3 FAILED at 344.
1 out of 3 hunks FAILED -- saving rejects to file
b/drivers/i
On Tue, 21 Sep 2021, Stephen Kitt wrote:
> This has served its purpose and is no longer used. All usercopy
> violations appear to have been handled by now, any remaining
> instances (or new bugs) will cause copies to be rejected.
>
> This isn't a direct revert of commit 2d891fbc3bb6 ("usercopy: A
Get rid of warning:
arch/powerpc/kernel/eeh.c:774: warning: expecting prototype for
eeh_set_pe_freset(). Prototype was for eeh_set_dev_freset() instead
Signed-off-by: Kai Song
---
arch/powerpc/kernel/eeh.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/powerpc/kern
Hi,
Le 25/09/2021 à 11:49, cp a écrit :
hi
I am new to this list. Hope this is the right place to ask.
I am working with a PPC405GP board, and as far as I understand, the
support for ppc40x platforms like Acadia and Walnut were dropped with
kernel 5.8.0, so this seems like a pretty straightforw
28 matches
Mail list logo