This series reworks how EEH devices are initialised. This mainly affects
pseries since it moves the "early" EEH probe out of shared code and into
pseries platform code. The goal here is to make the platform
dependencies more explicit and to allow PowerNV to implement its own
pci_dev <-> eeh_dev map
Move creating the EEH specific sysfs files into eeh_add_device_late()
rather than being open-coded all over the place. Calling the function is
generally done immediately after calling eeh_add_device_late() anyway. The
two cases where it's not done there (OF based PCI probing and the pseries
VFs) do
On pseries and PowerNV pcibios_bus_add_device() calls eeh_add_device_late()
so there's no need to do a separate tree traversal to bind the eeh_dev and
pci_dev together setting up the PHB at boot. As a result we can remove
eeh_add_device_tree_late().
Signed-off-by: Oliver O'Halloran
---
arch/powe
The pci hotplug helper (pci_hp_add_devices()) calls
eeh_add_device_tree_early() to scan the device-tree for new PCI devices and
do the early EEH probe before the device is scanned. This early probe is a
no-op in a lot of cases because:
a) The early init is only required to satisfy a PAPR requireme
This check for a missing PHB has existing in various forms since the
initial PPC64 port was upstreamed in 2002. The idea seems to be that we
need to guard against creating pci-specific data structures for the non-pci
children of a PCI device tree node (e.g. USB devices). However, we only
create pci
The eeh_ops->probe() function is called from two different contexts:
1. On pseries, where set set EEH_PROBE_MODE_DEVTREE, it's called in
eeh_add_device_early() which is supposed to run before we create
a pci_dev.
2. On PowerNV, where we set EEH_PROBE_MODE_DEV, it's called in
eeh_device_a
With the EEH early probe now being pseries specific there's no need for
eeh_ops->probe() to take a pci_dn. Instead, we can make it take a pci_dev
and use the probe function to map a pci_dev to an eeh_dev. This allows
the platform to implement it's own method for finding (or creating) an
eeh_dev for
On Mon, Feb 03, 2020 at 07:21:52AM +0100, Christophe Leroy wrote:
> Le 03/02/2020 à 02:00, Patchwork a écrit :
> >The following patch (submitted by you) has been updated in Patchwork:
> >
> > * linuxppc-dev: powerpc/nohash: Don't flush all TLBs when flushing one
> > page
> > - http://patchw
Hi Christophe,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on next-20200130]
[cannot apply to powerpc/next tip/timers/vdso mpe/next v5.5 v5.5-rc7 v5.5-rc6
v5.5]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system. BTW, w
On Mon, Feb 3, 2020 at 12:28 PM kbuild test robot wrote:
>
> If you fix the issue, kindly add following tag
> Reported-by: kbuild test robot
>
> All errors (new ones prefixed by >>):
>
> >> arch/powerpc/kernel/vdso32/vgettimeofday.c:26:1: error: unknown type name
> >> 'time_t'; did you mean 'kti
On Tue, 3 Dec 2019 14:46:34 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> Tally up the LPC memory on an OpenCAPI link & allow it to be mapped
>
> Signed-off-by: Alastair D'Silva
Hi Alastair,
A few trivial comments inline.
Jonathan
> ---
> drivers/misc/ocxl/core.c | 1
On Tue, 3 Dec 2019 14:46:35 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> Add functions to map/unmap LPC memory
>
> Signed-off-by: Alastair D'Silva
> ---
> drivers/misc/ocxl/config.c| 4 +++
> drivers/misc/ocxl/core.c | 50 +++
> dri
On Tue, 3 Dec 2019 14:46:36 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> This patch retrieves the serial number of the card and makes it available
> to consumers of the ocxl driver via the ocxl_fn struct.
>
> Signed-off-by: Alastair D'Silva
> Acked-by: Frederic Barrat
> Acked-b
On Tue, 3 Dec 2019 14:46:38 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> This driver exposes LPC memory on OpenCAPI SCM cards
> as an NVDIMM, allowing the existing nvram infrastructure
> to be used.
>
> Namespace metadata is stored on the media itself, so
> scm_reserve_metadata()
On Tue, 3 Dec 2019 14:46:40 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> This patch reads timeouts & firmware version from the controller, and
> uses those timeouts to wait for the controller to report that it is ready
> before handing the memory over to libnvdimm.
>
> Signed-off
On Tue, 3 Dec 2019 14:46:41 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> This patch requests the metadata required to issue admin commands, as well
> as some helper functions to construct and check the completion of the
> commands.
>
> Signed-off-by: Alastair D'Silva
A few triv
On Tue, 3 Dec 2019 14:46:42 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> Similar to the previous patch, this adds support for near storage commands.
>
> Signed-off-by: Alastair D'Silva
> ---
> drivers/nvdimm/ocxl/scm.c | 6 +
> drivers/nvdimm/ocxl/scm_internal.c |
On Tue, 3 Dec 2019 14:46:52 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> The near storage command 'Secure Erase' overwrites all data on the
> media.
>
> This patch hooks it up to the security function 'overwrite'.
>
> Signed-off-by: Alastair D'Silva
A few things to tidy up in
On Tue, 3 Dec 2019 14:46:50 +1100
Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> The heartbeat admin command is a simple admin command that exercises
> the communication mechanisms within the controller.
>
> This patch issues a heartbeat command to the card during init to ensure
> we can
Le 02/02/2020 à 12:26, Qian Cai a écrit :
On Jan 30, 2020, at 9:13 AM, Christophe Leroy wrote:
config DEBUG_VM_PGTABLE
bool "Debug arch page table for semantics compliance" if
ARCH_HAS_DEBUG_VM_PGTABLE || EXPERT
depends on MMU
default 'n' if !ARCH_HAS_DEBUG_VM_PGTABLE
def
On Mon, 2020-02-03 at 16:14 +0100, Christophe Leroy wrote:
>
> Le 02/02/2020 à 12:26, Qian Cai a écrit :
> >
> >
> > > On Jan 30, 2020, at 9:13 AM, Christophe Leroy
> > > wrote:
> > >
> > > config DEBUG_VM_PGTABLE
> > > bool "Debug arch page table for semantics compliance" if
> > > ARCH_
This test triggers a TM Bad Thing by raising a signal in transactional state
and forcing a pagefault to happen in kernelspace when the kernel signal
handling code first touches the user signal stack.
This is inspired by the test tm-signal-context-force-tm but uses userfaultfd to
make the test dete
After a treclaim, we expect to be in non-transactional state. If we don't
immediately clear the current thread's MSR[TS] and we get preempted, then
tm_recheckpoint_new_task() will recheckpoint and we get rescheduled in
suspended transaction state.
When handling a signal caught in transactional sta
The test case tm-signal-context-force-tm expects a segfault to happen on
returning from signal handler, and then does a setcontext() to run the test
again. However, the test doesn't always segfault, causing the test to run a
single time.
This patch fixes the test by putting it within a loop and ju
_tlbia() is a function used only on 603/603e core, ie on CPUs which
don't have a hash table.
_tlbia() uses the tlbia macro which implements a loop of 1024 tlbie.
On the 603/603e core, flushing the entire TLB requires no more than
32 tlbie.
Replace tlbia by a loop of 32 tlbie.
Signed-off-by: Chr
On Mon, 2020-02-03 at 16:47 +, Christophe Leroy wrote:
> CAUTION: This email originated from outside of the organization. Do not click
> links or open attachments unless you recognize the sender and know the
> content is safe.
>
>
> _tlbia() is a function used only on 603/603e core, ie on C
Dan Williams writes:
> Kill this definition that was introduced in commit 41e94a851304 ("add
> devm_memremap_pages") add never used.
>
Reviewed-by: Aneesh Kumar K.V
> Cc: Christoph Hellwig
> Signed-off-by: Dan Williams
> ---
> include/linux/io.h |2 --
> 1 file changed, 2 deletions(-)
>
Dan Williams writes:
> The "sub-section memory hotplug" facility allows memremap_pages() users
> like libnvdimm to compensate for hardware platforms like x86 that have a
> section size larger than their hardware memory mapping granularity. The
> compensation that sub-section support affords is b
Dan Williams writes:
> The pmem driver on PowerPC crashes with the following signature when
> instantiating misaligned namespaces that map their capacity via
> memremap_pages().
>
> BUG: Unable to handle kernel data access at 0xc00100040600
> Faulting instruction address: 0xc0
Dan Williams writes:
> The NDD_ALIASING flag is used to indicate where pmem capacity might
> alias with blk capacity and require labeling. It is also used to
> indicate whether the DIMM supports labeling. Separate this latter
> capability into its own flag so that the NDD_ALIASING flag is scoped
Dan Williams writes:
> The align attribute applies an alignment constraint for namespace
> creation in a region. Whereas the 'align' attribute of a namespace
> applied alignment padding via an info block, the 'align' attribute
> applies alignment constraints to the free space allocation.
>
> The
Le 03/02/2020 à 17:57, Joakim Tjernlund a écrit :
On Mon, 2020-02-03 at 16:47 +, Christophe Leroy wrote:
CAUTION: This email originated from outside of the organization. Do not click
links or open attachments unless you recognize the sender and know the content
is safe.
_tlbia() is a
The only missing configuration option preventing us from using
multi_v7_defconfig with the Raspberry Pi 4 is ARM_LPAE. It's needed as
the PCIe controller found on the SoC depends on 64bit addressing, yet
can't be included as not all v7 boards support LPAE.
Introduce multi_v7_lpae_defconfig, built
This series introduces a new configuration target,
multi_v7_lpae_defconfig, built by merging the config fragment
lpae.config with mult_v7_defconfig. Ultimately needed in order for
Raspberry Pi 4's PCIe bus to work on arm builds, but which may benefit
other boards out there.
---
Changes since RFC:
So far this function was only used locally in powerpc, some other
architectures might benefit from it. Move it into
scripts/Makefile.defconf.
Signed-off-by: Nicolas Saenz Julienne
---
arch/powerpc/Makefile| 12 +---
scripts/Makefile.defconf | 15 +++
2 files changed, 16 i
On Thu, Jan 30, 2020 at 10:09:32AM -0600, Fontenot, Nathan wrote:
> On 1/29/2020 12:10 PM, Scott Cheloha wrote:
> > On Tue, Jan 28, 2020 at 05:56:55PM -0600, Nathan Lynch wrote:
> >> Scott Cheloha writes:
> >>> LMB lookup is currently an O(n) linear search. This scales poorly when
> >>> there are
On Sun, 2 Feb 2020 16:02:18 +0100, Christian Zigotzky wrote:
> On 02 February 2020 at 09:19 am, Christophe Leroy wrote:
> > Hello,
> >
> > Le 02/02/2020 à 01:08, Christian Zigotzky a écrit :
> >> Hello,
> >>
> >> We regularly compile and test Linux kernels every day during the
> >> merge window.
On Fri, 31 Jan 2020 10:18:34 +0100 David Hildenbrand wrote:
> On 31.01.20 05:40, Andrew Morton wrote:
> > On Tue, 3 Dec 2019 14:36:38 +0100 Oscar Salvador wrote:
> >
> >> On Mon, Dec 02, 2019 at 10:09:51AM +0100, David Hildenbrand wrote:
> >>> @Michal, @Oscar, can some of you at least have a pa
202
x86_64 randconfig-a003-20200202
i386 randconfig-a001-20200202
i386 randconfig-a002-20200202
i386 randconfig-a003-20200202
x86_64 randconfig-a001-20200203
x86_64 randconfig-a002-202
Some architectures like powerpc64 have the capability to separate
read access and write access protection.
For get_user() and copy_from_user(), powerpc64 only open read access.
For put_user() and copy_to_user(), powerpc64 only open write access.
But when using unsafe_get_user() or unsafe_put_user()
When opening user access to only perform reads, only open read access.
When opening user access to only perform writes, only open write
access.
Signed-off-by: Christophe Leroy
---
fs/readdir.c| 12 ++--
kernel/compat.c | 12 ++--
kernel/exit.c | 12 +
When i915_gem_execbuffer2_ioctl() is using user_access_begin(),
that's only to perform unsafe_put_user() so use
user_write_access_begin() in order to only open write access.
Signed-off-by: Christophe Leroy
---
drivers/gpu/drm/i915/gem/i915_gem_execbuffer.c | 11 ++-
1 file changed, 6 ins
Add support for selective read or write user access with
user_read_access_begin/end and user_write_access_begin/end.
Signed-off-by: Christophe Leroy
---
arch/powerpc/include/asm/book3s/32/kup.h | 4 ++--
arch/powerpc/include/asm/kup.h | 14 +-
arch/powerpc/include/asm/uacc
Gautham R Shenoy wrote:
Hi Naveen,
On Thu, Dec 05, 2019 at 10:23:58PM +0530, Naveen N. Rao wrote:
>diff --git a/arch/powerpc/kernel/sysfs.c b/arch/powerpc/kernel/sysfs.c
>index 80a676d..42ade55 100644
>--- a/arch/powerpc/kernel/sysfs.c
>+++ b/arch/powerpc/kernel/sysfs.c
>@@ -1044,6 +1044,36 @@
44 matches
Mail list logo