[PATCH v10 09/18] powerpc/powernv: Extend PCI bridge resources

2016-05-20 Thread Gavin Shan
The PCI slots are associated with root port or downstream ports of the PCIe switch connected to root port. When adapter is hot added to the PCI slot, it usually requests more IO or memory resource from the directly connected parent bridge (port) and update the bridge's windows accordingly. The reso

[PATCH v10 16/18] powerpc/powernv: Introduce pnv_pci_get_slot_id()

2016-05-20 Thread Gavin Shan
This introduces pnv_pci_get_slot_id() to get the hotpluggable PCI slot ID from the corresponding device node. It will be used by hotplug driver. Requested-by: Andrew Donnellan Signed-off-by: Gavin Shan --- arch/powerpc/include/asm/pnv-pci.h | 2 ++ arch/powerpc/platforms/powernv/pci.c | 38 +

[PATCH v10 04/18] powerpc/powernv: Move pnv_pci_ioda_setup_opal_tce_kill() around

2016-05-20 Thread Gavin Shan
pnv_pci_ioda_setup_opal_tce_kill() called by pnv_ioda_setup_dma() to remap the TCE kill regiter. What's done in pnv_ioda_setup_dma() will be covered in pcibios_setup_bridge() which is invoked on each PCI bridge. It means we will possibly remap the TCE kill register for multiple times and it's unnec

[PATCH v10 17/18] powerpc/powernv: Functions to get/set PCI slot state

2016-05-20 Thread Gavin Shan
This exports 4 functions, which base on the corresponding OPAL APIs to get/set PCI slot status. Those functions are going to be used by PowerNV PCI hotplug driver: pnv_pci_get_device_tree()opal_get_device_tree() pnv_pci_get_presence_state() opal_pci_get_presence_state() pnv_pci_get_po

[PATCH v10 10/18] powerpc/powernv: Make pnv_ioda_deconfigure_pe() visible

2016-05-20 Thread Gavin Shan
pnv_ioda_deconfigure_pe() is visible only when CONFIG_PCI_IOV is enabled. The function will be used to tear down PE's associated mapping in PCI hotplug path that doesn't depend on CONFIG_PCI_IOV. This makes pnv_ioda_deconfigure_pe() visible and not depend on CONFIG_PCI_IOV. Signed-off-by: Gavin S

[PATCH v10 14/18] powerpc/powernv: Support PCI slot ID

2016-05-20 Thread Gavin Shan
The reset and poll functionality from (OPAL) firmware supports PHB and PCI slot at same time. They are identified by ID. This supports PCI slot ID by: * Rename the argument name for opal_pci_reset() and opal_pci_poll() accordingly * Rename pnv_eeh_phb_poll() to pnv_eeh_poll() and adjust

[GIT PULL] Please pull powerpc/linux.git powerpc-4.7-1 tag

2016-05-20 Thread Michael Ellerman
Hi Linus, Please pull powerpc updates for 4.7: The following changes since commit bf16200689118d19de1b8d2a3c314fc21f5dc7bb: Linux 4.6-rc3 (2016-04-10 17:58:30 -0700) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git tags/powerpc-4.7-1

Re: [kernel-hardening] [PATCH v8 2/4] GCC plugin infrastructure

2016-05-20 Thread Michael Ellerman
On Thu, 2016-05-19 at 10:24 +0200, PaX Team wrote: > On 19 May 2016 at 16:22, Michael Ellerman wrote: > > On Wed, 2016-05-18 at 12:33 +0200, Emese Revfy wrote: > > > Did you test the plugins with all gcc versions (4.5-6)? > > > > What's the concern about gcc versions? Just not breaking the build o

Re: [RFC PATCH 2/3] arch/powerpc : optprobes for powerpc core

2016-05-20 Thread Masami Hiramatsu
On Thu, 19 May 2016 13:19:42 +0530 Anju T wrote: > >> +void arch_unoptimize_kprobes(struct list_head *oplist, > >> + struct list_head *done_list) > >> +{ > >> + struct optimized_kprobe *op; > >> + struct optimized_kprobe *tmp; > >> + > >> + list_for_each_entry_safe(op, tm

Re: [RFC PATCH] Increase in idle power with schedutil

2016-05-20 Thread Shilpasri G Bhat
Hi, On 05/19/2016 05:10 PM, Peter Zijlstra wrote: > On Wed, May 18, 2016 at 11:11:51PM +0200, Rafael J. Wysocki wrote: >> On Wed, May 18, 2016 at 2:53 PM, Shilpasri G Bhat >> wrote: >>> This patch adds driver callback for fast_switch and below observations >>> on schedutil governor are done with

Re: [RFC PATCH v2 2/3] arch/powerpc : optprobes for powerpc core

2016-05-20 Thread Masami Hiramatsu
Hi Anju, Please see my comments below, On Thu, 19 May 2016 20:40:39 +0530 Anju T wrote: > ppc_get_optinsn_slot() and ppc_free_optinsn_slot() are > geared towards the allocation and freeing of memory from > the area reserved for detour buffer. > > Signed-off-by: Anju T > --- > arch/powerpc/k

Re: [RFC PATCH v2 05/18] sched: add task flag for preempt IRQ tracking

2016-05-20 Thread Josh Poimboeuf
On Thu, May 19, 2016 at 04:39:51PM -0700, Andy Lutomirski wrote: > On Thu, May 19, 2016 at 4:15 PM, Josh Poimboeuf wrote: > > Note this example is with today's unwinder. It could be made smarter to > > get the RIP from the pt_regs so the '?' could be removed from > > copy_page_to_iter(). > > > >

Re: [RFC PATCH v2 05/18] sched: add task flag for preempt IRQ tracking

2016-05-20 Thread Andy Lutomirski
On Fri, May 20, 2016 at 7:05 AM, Josh Poimboeuf wrote: > On Thu, May 19, 2016 at 04:39:51PM -0700, Andy Lutomirski wrote: >> On Thu, May 19, 2016 at 4:15 PM, Josh Poimboeuf wrote: >> > Note this example is with today's unwinder. It could be made smarter to >> > get the RIP from the pt_regs so th

Re: [RFC PATCH v2 05/18] sched: add task flag for preempt IRQ tracking

2016-05-20 Thread Josh Poimboeuf
On Fri, May 20, 2016 at 08:41:00AM -0700, Andy Lutomirski wrote: > On Fri, May 20, 2016 at 7:05 AM, Josh Poimboeuf wrote: > > On Thu, May 19, 2016 at 04:39:51PM -0700, Andy Lutomirski wrote: > >> On Thu, May 19, 2016 at 4:15 PM, Josh Poimboeuf > >> wrote: > >> > Note this example is with today's

Re: [RFC PATCH v2 05/18] sched: add task flag for preempt IRQ tracking

2016-05-20 Thread Andy Lutomirski
On Fri, May 20, 2016 at 9:41 AM, Josh Poimboeuf wrote: > On Fri, May 20, 2016 at 08:41:00AM -0700, Andy Lutomirski wrote: >> On Fri, May 20, 2016 at 7:05 AM, Josh Poimboeuf wrote: >> > On Thu, May 19, 2016 at 04:39:51PM -0700, Andy Lutomirski wrote: >> >> On Thu, May 19, 2016 at 4:15 PM, Josh Poi

Re: [RFC PATCH v2 05/18] sched: add task flag for preempt IRQ tracking

2016-05-20 Thread Josh Poimboeuf
On Fri, May 20, 2016 at 09:59:38AM -0700, Andy Lutomirski wrote: > On Fri, May 20, 2016 at 9:41 AM, Josh Poimboeuf wrote: > > On Fri, May 20, 2016 at 08:41:00AM -0700, Andy Lutomirski wrote: > >> On Fri, May 20, 2016 at 7:05 AM, Josh Poimboeuf > >> wrote: > >> > On Thu, May 19, 2016 at 04:39:51P

[PATCH v2 2/4] powerpc: add explicit #include for jump label

2016-05-20 Thread Jason Baron
The stringify_in_c() macro may not be included. Make the dependency explicit. Cc: Benjamin Herrenschmidt Cc: Paul Mackerras Cc: Michael Ellerman Cc: linuxppc-dev@lists.ozlabs.org Signed-off-by: Jason Baron --- arch/powerpc/include/asm/jump_label.h | 1 + 1 file changed, 1 insertion(+) diff -

Re: [PATCH] ps3_gelic: use kmemdup

2016-05-20 Thread David Miller
From: Muhammad Falak R Wani Date: Thu, 19 May 2016 19:24:41 +0530 > Use kmemdup when some other buffer is immediately copied into allocated > region. It replaces call to allocation followed by memcpy, by a single > call to kmemdup. > > Signed-off-by: Muhammad Falak R Wani Applied.